
Application Manual

EthoVision® XT
Version 18
 



Information in this document is subject to change without notice and 
does not represent a commitment on the part of Noldus Information 
Technology BV. The software described in this document is furnished 
under a license agreement. The software may be used or copied only in 
accordance with the terms of the agreement.

Copyright © 2025 Noldus Information Technology BV. All rights 
reserved. No part of this publication may be reproduced, transmitted, 
transcribed, stored in a retrieval system, or translated into any other 
language in whole or in part, in any form or by any means, without the 
written permission of Noldus Information Technology BV.

EthoVision is a registered trademark of Noldus Information Technology 
BV.

January 6, 2025

For EthoVision XT 18

Noldus Information Technology BV

International headquarters

Wageningen, The Netherlands

Telephone: +31-317-473300

E-mail: contact@noldus.com

For addresses of our other offices and support, please see our web site 
www.noldus.com

https://www.noldus.com
contact@noldus.com


Contents

1 General Information  14

Setting up the experiment in EthoVision XT ..........................  15
create the experiment — 15
experiment settings — 15
arena settings — 15
trial control settings — 17
detection settings — 17
trial list — 19
protocols on the web featuring ethovision xt — 20

Acquire the data ......................................................................  21
protocol — 21
acquire the tracks — 21

Analyze the data ....................................................................  24
data preparation — 24
visualize the data — 25
calculate the statistics — 26
export the results — 27

2 The Open Field Test  28

Introduction ...........................................................................  29
the open field for rodents — 29
the open field for zebrafish — 30

Physical setup..........................................................................  33
 Contents 3



4

The Open Field experiment in EthoVision XT .........................  35
experiment settings — 35
manual scoring settings — 35
arena settings — 36
trial control settings — 38
detection settings — 39

Acquiring data .........................................................................  41
protocol — 41
score behaviors manually — 42

Data Analysis..........................................................................  43
analysis profiles — 43
analysis per zone — 43
time variation of behavior — 44
zone crossings — 44
freezing behavior — 45
stretch-attend — 45
rat or mouse behavior recognition — 45
comparing groups — 46
visualizing data — 46

3 The Morris Water Maze Test  48

Introduction ...........................................................................  49
the morris water maze test — 49
the sample experiment — 50
references — 50

Physical setup..........................................................................  51

The Morris water maze test in EthoVision XT.........................  52
arena settings — 52
trial control settings — 54
detection settings — 55
trial list — 56

Acquiring data ........................................................................  58
protocol — 58

Data Analysis..........................................................................  59
Contents



data preparation — 59
analysis profiles — 59
swim patterns — 60
gallagher’s proximity score — 62

4 The Novel Object Recognition Test  65

Introduction ...........................................................................  66
the novel object recognition test — 66
the sample experiment — 67
references — 67

Physical setup.........................................................................  68

The NOR test in EthoVision XT ...............................................  69
experiment settings — 69
manual scoring settings — 69
arena settings — 70
trial control settings — 72
detection settings — 73
trial list — 74

Acquiring data ........................................................................  76
protocol — 76
score behaviors manually — 76

Data Analysis..........................................................................  78
data preparation — 78
selecting data — 78
analysis profiles — 79
exploratory behavior — 80
heatmaps — 81

5 The Elevated Plus Maze Test  82

Introduction ...........................................................................  83
the elevated plus maze test — 83
the sample experiment — 85
 Contents 5



6

references — 85

Physical setup.........................................................................  87

The Elevated Plus maze experiment in EthoVision XT ..........  92
experiment settings — 92
manual scoring settings — 92
arena settings — 94
trial control settings — 96
detection settings — 96
trial list — 97

Acquiring data ......................................................................  100
protocol — 100
score behaviors manually — 100

Data analysis .........................................................................  101
data preparation — 101
selecting data — 101
visualizing data — 103
analysis profiles — 104

6 The Sociability Cage Test  107

Introduction .......................................................................... 108
the sociability test (three-chamber paradigm) — 108
references — 109

The Sociability test in EthoVision XT .....................................  111
experiment settings — 111
manual scoring settings — 111
arena settings — 112
detection settings — 112
trial list — 113

Acquiring data ........................................................................ 114
protocol — 114
score behaviors manually — 115

Data analysis .......................................................................... 116
data preparation — 116
Contents



analysis profiles — 116
visualizing data — 118

7 The Social Interaction Test  119

Introduction ..........................................................................  120
measuring social interactions — 120
the sample experiment — 121
references — 121

Physical setup........................................................................  123
lighting conditions — 123
marked vs. unmarked subjects — 123

The Social Interaction test in EthoVision XT.........................  125
create an experiment — 125
experiment settings — 125
manual scoring settings — 126
trial control settings — 126
detection settings — 127
trial list — 131

Carrying out your trials .......................................................... 133
protocol — 133

Data analysis .........................................................................  136
data preparation — 136
analysis profiles — 137
social interaction in detail — 138
statistics and charts — 139
visualizing data — 139

8 The Radial Arm Maze Test  140

Introduction ........................................................................... 141
the radial arm maze test — 141
references — 142

Physical setup........................................................................  143
 Contents 7



8

The Radial Arm Maze test in EthoVision XT..........................  144
experiment settings — 144
arena settings — 145
trial control settings — 146
detection settings — 150
trial list — 151

Acquiring data .......................................................................  152
protocol — 152

Data analysis .........................................................................  154
data preparation — 154
analysis profiles — 155
testing working memory — 155
testing reference memory — 156
integrated visualization — 157
heatmaps — 158
calculating statistics — 158

9 The Porsolt Forced Swim Test  159

Introduction .......................................................................... 160
the porsolt forced swim test — 160
the sample experiment — 161
references — 161

Physical setup........................................................................  162

The Porsolt Forced Swim test in EthoVision XT ....................  164
experiment settings — 164
manual scoring settings — 164
arena settings — 165
trial control settings — 166
detection settings — 167
trial list — 168

Acquiring data .......................................................................  170
protocol — 170
score behaviors manually — 170
determining mobility thresholds — 171
Contents



determining activity thresholds — 172

Data analysis .......................................................................... 173
data preparation — 173
integrated visualization — 174
analysis profile — 175

10 The Fear Conditioning Test  179

Introduction .......................................................................... 180
principle of operation — 180
changes relative to previous ethovision xt versions — 181
if you have the “old” fcs setup — 182
for general information — 183

Physical setup........................................................................  184
one-cubicle configuration — 184
four-cubicle configuration — 190
camera settings — 195
upgrade your fcs system — 200
update the cubicle firmware — 204

The Fear Conditioning experiment in EthoVision XT...........  207
prerequisites — 207
create an ethovision xt experiment — 207
experiment settings — 208
com port communication — 210
arena settings: define the arenas — 212
arena settings: declare the fcs devices — 212
examples of arena-hardware mapping — 215
test the fcs devices — 218
trial control settings — 221
detection settings — 225
troubleshooting — 228

Acquire the data ...................................................................  230
things to check first — 230
acquire data — 231

Analyze the data ...................................................................  232
 Contents 9



10
basic steps — 232
analyze events — 232
analyze intervals — 233

Technical specifications ........................................................ 236
infrared top light and controller — 236

11 Other Conditioning Tests  238

Introduction .......................................................................... 239

Physical setup........................................................................  241

A conditioning test in EthoVision XT .................................... 242
experiment settings — 242
arena settings — 243
trial control settings — 245
detection settings — 251
trial list — 251

Pre-Pulse Inhibition of the startle response (PPI).................  253
introduction — 253
connection scheme — 253

Data analysis .........................................................................  255
data preparation — 255
data selection — 256
analysis profiles — 257
integrated visualization — 259

12 The RotaRod Test  261

Introduction .......................................................................... 262
the rotarod test — 262
references — 263

Physical setup.......................................................................  264

The Rotarod test in EthoVision XT ........................................ 265
experiment settings — 265
Contents



arena settings — 265
detection settings — 267

Acquiring data ......................................................................  268

Data analysis ........................................................................  269

13 The Y-maze Test  270

Introduction ..........................................................................  271
the y-maze — 271
spontaneous alternation — 272
delayed alternation — 273
references — 274

The Y-maze test in EthoVision XT .........................................  275
experiment settings — 275
arena settings — 275
trial control settings — 277
detection settings — 278
trial list — 278

Acquiring data ....................................................................... 279
protocols — 279

Data analysis .........................................................................  281
analysis profiles — 281
alternation behavior — 281
visualizing data — 284

14 Optogenetics Experiments  286

Introduction .......................................................................... 287
optogenetics and ethovision xt — 287
examples — 287
references — 288

Physical setup.......................................................................  289
components (example) — 289
 Contents 11



12
basic setup — 291
advanced setup (with pulser) — 293
measure the led light output — 296

Optogenetics experiments in EthoVision XT ........................ 297
experiment settings — 297
arena settings — 298
trial control settings — 299
detection settings — 304

Using the Pulser .................................................................... 305
pulse sequences — 305
configure the com port for each pulser — 308
program the prizmatix pulser/pulserplus within ethovision xt 
— 310
program the prizmatix pulser/pulserplus with the prizmatix 
software — 317

Advanced applications ..........................................................  318
differential stimulation depending on zone — 318
multiple simultaneous stimulations in one arena — 322
simultaneous stimulations in two or more arenas — 326

Data Analysis......................................................................... 330
simple data selection — 330
advanced data selection — 331
calculating statistics — 333
integrated visualization — 333

Installing the Prizmatix Pulser..............................................  335
software installation — 335
driver update — 335

15 Experiments with Calcium Imaging  338

Introduction .......................................................................... 339
ethovision xt and calcium imaging — 339
ethovision xt and optogenetic stimulation — 339
nvista vs nvoke — 340
ethovision xt license needed — 340
Contents



application examples — 340
references — 341

Physical setup........................................................................ 342
hardware components — 342
connection schemes — 343
notes — 345

Basic settings........................................................................  346
ethovision xt: experiment settings — 346
ethovision xt: arena settings — 346
inscopix devices — 347

Program control of devices in EthoVision XT.......................  349
trial control settings — 349
example 1 - image recording (nvista) — 349
example 2 - manual video recording, triggered og-led 
stimulation — 351
example 3 - triggered video recording and led stimulation — 
353

Detection settings .................................................................  355
general — 355
detect immobility — 355
remove the effect of the microscope cable — 356

Aligning data .........................................................................  358
sync signal — 358
using the tcap signal — 358
using a ttl signal — 359
mark ethovision events on the calcium imaging timeline — 361

Data analysis in EthoVision XT ............................................. 362
define a simple event — 362
analyze intervals (global) — 363
analyze specific intervals — 364
export the raw data — 365
align ethovision xt and inscopix data — 366
 Contents 13



14
Chapter 1
General Information

Setting up the experiment in EthoVision XT............... 15

Acquire the data ........................................................... 21

Analyze the data.......................................................... 24

For more manuals, from the Windows Start menu choose Apps > 
Noldus > EthoVision XT 18 Other Documentation. 
  General Information



Setting up the experiment in 
EthoVision XT

create the experiment

1. Start EthoVision XT and choose File > New from template.

2. In the Select a template option window, select Apply a pre-defined 
template. Next, follow the instructions in the guided setup.

For more information, see Set Up an Experiment in the EthoVision 
XT Help. For details on connecting the camera, see Camera 
Installation in the EthoVision XT Help, or watch the video tutorial 
Set Up the Camera (Help > Video Tutorial).

3. Enter the name of the experiment and click OK.

4. Before you can actually acquire data, check the settings listed in the 
rest of this section.

experiment settings

Choose Setup > Experiment Settings.

Under Video Source, and Tracked Features, make sure that the options 
selected corresponds to your needs. To adjust the camera settings, click 
the video icon in the camera row.

note  The option Deep learning is only available if your PC has a graphic 
processor (GPU) that supports additional software (CUDA). See Deep 
learning: Requirements and Limitations in the EthoVision XT Help. 

arena settings

Choose Setup > Arena Settings > Open Arena Settings 1.
 General Information 15
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1. Click Grab to grab an image of the empty enclosure from the 
camera image, or click Browse to select a video file and then click 
Grab.

2. Click 1. Draw Scale to calibrate and calibrate your arena.

3. Click 2. Select Shape and Draw Arena. Check that the arena covers 
the whole area in which you want to track the animal. For open 
fields and other enclosures, remember to include enough of the 
walls so that the animal is still tracked when it rears, but exclude 
any bright reflective rims that might interfere with tracking. Make 
sure the label stays inside the arena.

tip  If you need to rotate the outline of the arena, drag 
around all elements (1), and then click the Rotation mode 
button and move the outline until it matches the arena in 
the video image (2).
  General Information



tip If you need to reshape the outline of the arena, click 
the Point edit mode button and move the vertices of the 
outline.

4. To draw zones, click 3. Select Shape and Draw Zones. See more 
details in the chapter about your test.

For details, see Arena Settings in the EthoVision XT Help.

trial control settings

In the Trial Control Settings you can define conditions for the start and 
stop of data acquisition. For details, see the EthoVision XT Help.

Choose Setup > Trial Control Settings. 

detection settings

Choose Setup > Detection Settings > Detection Settings 1. 

1. If you work with pre-recorded video, select a video file. If you work 
with the live camera image, release the animal in the arena.

2. Click Automated Setup. 
 General Information 17
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3. Select: 
- Rodent for tracking rats and mice.

- Adult fish for tracking fish from the top view.

- Other for any other case like tracking insects, crustaceans, or 
when tracking fish from the side view.

4. When the subject does not move a lot, and is far from the enclosure 
walls and other objects, draw a rectangle around it. EthoVision XT 
detects the subject.
- If the subject’s body is well detected (marked in yellow), click 

Yes.

- In other cases move the Finetune slider or click No and adjust 
the Advanced detection settings.

Note

The Automated Setup may not work in all situations. If the subject is 
not detected correctly, see below. 

Advanced detection settings

1. Under Video, choose the sample rate.

2. Under Method, check that either Dynamic subtraction or 
Differencing is selected as the detection method. Differencing is the 
preferred option if other methods do not work well, or if you work 
with hooded animals.

3. Select the tracking method. The options here are depending on your 
experiment settings, including the number of body points you want 
  General Information



to track. The optimal method is automatically selected after 
choosing the type of animal in the Automated Setup.

For more information, see Tracking methods in the EthoVision XT 
Help.

4. When using Dynamic subtraction, move the slider to define the 
animal's contrast. The animal must be fully detected in all parts of 
the arena and the noise must be minimal.

When using Differencing, set the Sensitivity slider. The slider 
determines what difference in contrast from the background is 
seen as the animal.

For more information

 Choose Help > EthoVision XT Help and search for Advanced 
Detection Settings.

 Choose Help > Video Tutorial and watch the videos under How 
Subject Detection Works. 

trial list

Choose Setup > Trial List.

Enter your independent variables such as rat ID, first or second phase of 
the experiment, treatment (with values drug vs. control), dose, type of 
object, name of the experimenter, etc. If you want, you can pre-define 
all your trials here, or you can enter the independent variable values as 
 General Information 19
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you carry out the trials. You can also prepare the trials in Excel, 
randomize them and then paste the values into your Trial List.

Furthermore, you can define a list of trials for batch acquisition. See 
Acquire a series of trials in the EthoVision XT Help.

protocols on the web featuring ethovision 
xt

Researchers are encouraged to publish test protocols to improve 
reproducibility of animal experiments. 

Browse to 

https://www.bio-protocol.org/en/searchlist?content=ethovision

There you find protocols created with or mentioning EthoVision XT. 

Figure 1.1  An example of the Trial List with four planned trials.
  General Information
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Acquire the data

protocol

Each test described in this manual has one or more specific protocols. 
See the chapter that applies.

important Always record your video with EthoVision XT or 
MediaRecorder. Do not record video with Pylon Viewer or other 
software! The resulting video file may not be compatible with 
EthoVision XT.

acquire the tracks

Procedure

1. Check that you have selected the correct Video Source in the 
Experiment Settings (see page 15).

2. Choose Acquisition > Open Acquisition.

3. optional  Skip this step if you have entered the values of the 
independent variables already in the Trial List. 

Open the Independent Variables tab of the Analysis Results and 
Scoring pane at the bottom of your screen and enter the values of 
the independent variables. You can also do this during acquisition.

4. If you did not plan any trials in the Trial List, click the New 
trial button in the Playback Control window (Ctrl+F3).
 General Information 21
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5. If you planned two or more trials: select in the Acquisition Settings 
window whether you want to track only the next planned trial, or all 
planned trials.

If you carry out batch acquisition and track live, also specify the 
Inter-trial interval.

6. optional  In the Acquisition Settings window, select Auto-start data 
analysis.

Do this to start calculation of analysis results immediately after 
acquisition. If you choose this option, first create an Analysis profile 
and optionally a Data profile and a Track Smoothing profile (see 
page 24). Choose whether to carry out analysis only for the profiles 
highlighted in blue in the Experiment Explorer, or for all possible 
profile combinations. In the latter case, first delete all profiles you 
do not need for analysis. 

7. Start the trial (either choose Acquisition > Start Trial or click the 
Start trial button in the Playback Control window or press Ctrl+F5).

8. If you do live tracking, release the animal in the arena.

9. Data acquisition starts when the Start track condition in your Trial 
Control Settings becomes true.

10.The trial stops automatically when the Stop track condition specify 
in the Trial Control Settings becomes true or when the time defined 
in the Trial Control Settings under Maximum trial duration has 
expired. If you planned a series of trials, the next trial will start. 

To stop the trial manually, either choose Acquisition > Stop Trial or 
click the Stop trial button in the Playback Control window or press 
Ctrl+F6.
  General Information



If you chose to simultaneously record a video file, the video file that 
has been created is stored on your PC in the Media Files folder of 
your experiment. 

After testing

After each test, remove any debris (bedding, feces, etc.) from the arena 
and clean all interior surfaces, walls and floor thoroughly, first using 
water and soap, or a perspex cleaner (see also Table 1), then with water. 
Allow at least 5 minutes between tests to ensure that any residual odor 
will have dissipated before the next animals are introduced into the 
test apparatus.

Do not use wet ethylene oxide, steam, strong acids, hydrocarbons, 
ethanol, methanol, or solvents containing acetone.

Table 1 Acceptable techniques and substances for cleaning acrylic 
(perspex)

Electronic beam High intensity visible light

Gamma radiation Alkaline substances 
(in low concentrations)

Ethylene oxide gas Low-temperature hydrogen 
peroxide gas plasma

Hydrogen peroxide up to 3%) Diluted solutions of isopropyl 
alcohol

UV radiation
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Analyze the data

data preparation

Track editing

Choose Acquisition > Edit Tracks.

You can fix tracking errors and swap back nose-points and tail-points 
that have been swapped in tracking. Normally you do not need to edit 
your data.

Track smoothing

Choose Acquisition > Track Smoothing Profile.

Select one or both options to remove noise and artifacts due to for 
example body wobbling. For more information, see Smooth the Tracks 
in the EthoVision XT Help.

Select data for analysis

Choose Analysis > Data Profile. The data you select on this screen will 
be analyzed or visualized (see the next sections).

 To analyze data per zone, in the Result box, click Settings and select 
Results per zone. Use this function for example to analyze the 
velocity of the subject in the different zones.

 To analyze some tracks, not others, under Filter, choose one of the 
variables available. For example, Treatment to analyze Treated 
animals only. Insert the box in the Data profile sequence.

 To analyze segments of tracks based on the subject’s behavior, 
under Nesting choose one of the options. For example, to select all 
data points when the subject was moving, choose Movement. 
Insert the box in the Data profile sequence.

 To analyze the tracks split in segments of equal duration, in the 
Result box, click Settings and select Time bins. Use this function for 
  General Information



example to analyze a 10-minute recording in ten segments of one 
minute each.

 To create groups of tracks and compare results, under Common 
Elements click Result and add a Result box. You can link each Result 
box with a specific Filter (see above). This way you can compare the 
results of different selections, or visualize groups of tracks that 
result from different treatments, etc.

For more information

See the EthoVision XT Help.

visualize the data

You can visualize your tracks in three ways:

Plot the tracks

Choose Analysis > Results > Plot Tracks.

You can view your tracks on a still image of the background. Tracks can 
be shown in different colors according to the values of independent 
variables (for example, blue for animals treated with saline and red for 
drug-treated animals). Sample points can be shown in different colors 
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according to the values of dependent variables, for example red when 
the animal was moving fast.

To set the track colors, in the Track Plot Settings pane, click the Colors 
tab.

Plot integrated data

Choose Analysis > Results > Plot Integrated Data.

Look at a track with the video file in the background. When you plot 
integrated data you can also view Time Event plots of your independent 
variables. Just like with plotting tracks, you can show tracks or sample 
points in different colors. 

Plot heatmaps

Choose Analysis > Results > Plot Heatmaps.

Make heatmaps of the location of your animals during the tracks. 

For more information, see Visualize Data in the EthoVision XT Help.

calculate the statistics

General procedure

1. Choose Analysis > Analysis Profile > New. 

Select the variables you are interested in. For information about the 
variables suggested, see the chapter about the test of your choice 
and the EthoVision XT Help.

2. Choose Analysis > Results > Statistics & Charts, then click Calculate.

The Trial Statistics tab shows the results per trial. The Group Statistics 
tab shows the statistics and charts from the results over all trials or the 
groups defined in your Data profile (see page 24).

Adjust the table layout (optional)

Sometimes you need to adjust the layout of your results table, for 
example to export the results to a statistics software. Click the Layout 
button on the toolbar and specify which headers should be on the rows 
  General Information



and which on the columns. For details and examples, search for table 
layout in the EthoVision XT Help.

Batch calculations

It is also possible to carry out multiple calculations at once with 
different filters, data profiles or analysis profiles. To do so: 

1. In the Statistics & Charts window, click Batch.

2. Select the profiles from the lists and click Add.

3. Repeat the previous step for other combinations.

4. Click Calculate. Choose the profiles from the lists on the toolbar to 
view the analysis result for that combination.

For more information, see Calculate Statistics in the EthoVision XT 
Help.

Advanced analysis with JavaScript custom variables

In the Analysis profile you can now create fully custom dependent 
variables with JavaScript code. With JavaScript you have an almost 
endless range of possibilities to extract information from your tracks. 
JavaScript variables can be of type continuous, event, or state. 

See JavaScript in the EthoVision XT Help.

note  If you are not familiar with programming, we can create custom 
analysis variables for you. Please contact Noldus for information.

export the results

To find out if your independent variables (like treatment, dose, etc.) 
have a significant effect on the dependent variables, you can export 
your data to a statistical package.

1. Choose Analysis > Export > Statistics.

2. Choose Trial Statistics or Group Statistics. 

You can also export the raw track data. Choose Analysis > Export > Raw 
Data.
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Introduction

the open field for rodents

The open field test was first published 1932 by C. S. Hall and E.L. 
Ballachey to determine the fearfulness of rats. Today, the test is often 
used with rats and mice to investigate their locomotory behavior and 
their willingness to explore. Also, the test is one of the most commonly 
used methods to investigate anxiety in rats and mice. It is based on the 
natural tendency of rats and mice to spend more time in the corners 
and the periphery than in the center. Changes in these measures are 
often used to assess the sedative or stimulant effects of 
pharmacological agents. 

The test arena consists of a circular or rectangular empty open space 
with walls to prevent the animals from escaping. The arena is divided 
into a border zone and a center zone. In addition, the arena can be sub-
divided into a number of other zones, like north, east, south and west 
zones, or corner zones. 

Figure 2.1  A rat in a square open field.
2 -  The Open Field Test 29
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Common behaviors to be measured are: 

 Time spent in the border zone and center.

 Time until the border of the center zone is first crossed.

 Walking distance in each of the zones.

 Percentage of time the animal is mobile/immobile.

 Walking speed in each of the zones.

 Frequency of rearing.

References

 Hall, C., Ballachey, E. L., 1932. A study of the rat's behavior in a field. 
A contribution to method in comparative psychology. University of 
California Publications in Psychology, Vol 6, 1-12. 

 Gould, T.D., Dao, D.T., Kovacsics, C.E., 2010. The Open Field Test. 
Neuromethods, Vol 42, 1-20.

 De Visser, L., Van Den Bos, R., Kuurman, W.W., Kas, M.J.H., Spruijt, 
B.M., 2006. Novel approach to the behavioural characterization of 
inbred mice: automated home cage observations. Genes brain and 
behavior, Vol 5(6), 458-466.

For the complete list of publications, see the results in Google Scholar.

On the downloads section of the Noldus website, my.noldus.com, you 
find a number of sample experiments, including the open field.

the open field for zebrafish

Open field

The open field test (Figure 2.2, top) is used to evaluate exploratory and 
affective behaviors. Fish are filmed with a video camera positioned 
overhead. The bottom of the tank is divided into two virtual zones, 
center and periphery (a circular zone with inner boundary 5 cm from 
the testing tank wall), which enables quantification of regional activity.
2 - The Open Field Test
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In addition to standard movement parameters, primary behavioral 
measures included the distance traveled, number of visits and time 
spent in central and peripheral zones, and the ratio of time spent in the 
center zone over total testing time. 

Novel tank diving test

The novel tank test (Figure 2.2, bottom), is used to assess exploratory 
and affective domains. The novel tank is a trapezoidal tank maximally 
filled with treated water and divided into two equal, horizontal regions 
(top/upper and bottom/lower zones).

Primary behavioral measures include the number of visits and time 
spent in central and peripheral zones, the ratio of time spent in the top 
zone over total testing time, latency to enter the top zone, time spent 
in the top zone, number of transitions to top zone.

Figure 2.2  Open field and novel tank diving test for zebrafish. Redrawn from 
Kalueff et al. Trends in Pharmacological Sciences, 35: 63 - 75.
2 -  The Open Field Test 31
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Similar to behavioral tests used in mammalian models, affective 
phenotypes are inferred from modulation of thigmotaxis (center/
periphery in the open field test) and geotaxis (top/bottom in the novel 
tank diving test).

References

Kalueff A.V., A.M. Stewart, R. Gerlai (2014). Zebrafish as an emerging 
model for studying complex brain disorders. Trends in Pharmacological 
Sciences, Vol. 35 (2), 63 - 75.

Example videos

https://www.youtube.com/watch?v=7vhK8fq_W4A.
2 - The Open Field Test
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Physical setup

The following suggestions are meant to optimize video tracking:

 The camera should have a good view of the entire region the 
animal can be in. The arena should fill the field of view. 

 The lighting should be as even as possible throughout the arena. 
Make sure there are no shadows in the corners. Bright lights are not 
necessary but should you need to supplement the light, consider 
red (or infra-red) light, as the animals will be less sleepy. Regardless 
of the light level chosen, the investigator should use a light meter 
to record the lighting level and report this level in any publication. 

 When working with multiple arenas, make sure that the 
background light intensity is the same across arenas. In the picture 
below, there is more background light in the arenas on the left than 
in the arenas on the right. This is usually not a problem, as long as 
the contrast between each animal and its arena background is 
much bigger than the difference in brightness between arena.

Figure 2.3  Minimize the shadows at the corners of open fields using even, 
diffuse light, in any case not pointing to the floor since it would create shadows.
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 The lighting should be diffuse, so as not to cast strong shadows 
(which might be tracked instead of the animal). Even, diffuse 
lighting is important to optimize tracking of the nose.

 The background should contrast with the animal. If necessary use a 
different setup for light and dark colored animals. Matt, gray walls 
often give good results. 

 Depending on circumstances, pools of urine can cause problems 
with the tracking because they reflect light. An absorbent base can 
help.

 Make sure the sides of the box are not reflective (e.g. sanding). 
Alternatively, exclude the sides from the arena, but make sure that 
the animal is tracked well in the entire border zone. 

 Always place the apparatus in the same position in the room, cues 
from overhead might influence the behavior of the animal. For the 
same reason the experimenter should not be visible to the animal 
during the trial (automated tracking makes this possible).

 Minimize disturbance from audio sources, especially from 
ultrasound sources such as ventilation fans, CRT monitors, or strip-
lights. You can mask audio disturbance by using the same 
background sounds, for example of a radio, in the test room as in 
the room where the animals are normally housed. 

 When you handle the animals, be careful to minimize stress. 

 If you use multiple arenas, make sure that the animals in the arena 
do not influence each other. The animals should, for example, not 
be able to hear or smell each other.

 In EthoVision XT, choose Help > Video Tutorial and watch the video 
chapter Set Up Your Test Environment. That provides useful tips 
about the camera position, how to improve lighting and contrast 
with the background.

 If you intend to use the Deep learning method to track the subject’s 
nose point, note that there are additional requirements and 
limitations. See the EthoVision XT Help. 
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The Open Field experiment in 
EthoVision XT

Create an experiment. For details, see Chapter 1 of this manual, or in 
EthoVision XT press F1 and see Setup an Experiment in the EthoVision 
XT Help.

experiment settings

Choose Setup > Experiment Settings.

 To detect freezing behavior, select Activity analysis under Analysis 
options. Click the video button next to it and watch the video 
tutorial to learn about Activity analysis.

 If you work with rats or mice, you can let EthoVision XT 
automatically detect behaviors like Rearing, Grooming, and 
Sniffing. Select Behavior recognition under Analysis options and 
choose the options that apply to your experimental setup. The 
Behavior recognition option is only available if you have the Rat 
Behavior Recognition module or the Mouse Behavior Recognition 
module of EthoVision XT.

manual scoring settings

Choose Setup > Manual Scoring Settings.

If you used the template for an open field experiment, two start-stop 
behaviors have been predefined in the manual scoring settings. These 
are the behaviors rearing and grooming. Depending on your research 
question, you can add other behaviors that can be manually scored, like 
defecating, which is a measure for anxiety, and urinating and vomiting. 

Note that with the Rat (or Mouse) Behavior Recognition module you 
can have EthoVision XT detect a number of behaviors automatically.
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For more information, see Manual Scoring Settings and Behavior 
Recognition in the EthoVision XT Help.

arena settings

Choose Setup > Arena Settings > Open Arena Settings 1.

We assume that you followed the procedure in arena settings on page 
15.

Arena

Check that the arena covers the whole area in which you want to track 
the animal. Remember to include enough of the walls so that the 
animal is still tracked when it rears, but exclude any bright reflective 
rims that might interfere with tracking. Make sure the label stays 
inside the arena.

tip  If you create an experiment from scratch, the arena is not yet 
defined. Click 2. Select Shape and Draw Arena and choose the drawing 
tool. If you want to have the open field divided in quadrants, choose 
one of the subdivided tools, Depending on the shape of your open field, 
then draw the outline of the arena and select the number of sectors. 

Each sector is automatically defined as zone.

Zone group “Borders”

Check that the ‘Wall’ zone covers only the wall of the open field (see 
Figure 2.4). If necessary, adjust the center zone and the border zone.
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Zone group “Quadrants”

Check that the zones ‘NW’, ‘NE’, ‘SE’, and ‘SW’ divide the ‘Floor’ zone in 
four equal quarters. 

Zone group “Squares”

Check that the zones divide the arena in equal squares.

Figure 2.4  Circular open field with ‘Border’ zone and ‘Quadrants’ zone.

Figure 2.5  Rectangular open field with a subdivided arena.
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Arena settings for Rat/Mouse behavior recognition

When you selected Behavior recognition in the Experiment Settings 
(only available when you have the Rat or Mouse Behavior Recognition 
Module of EthoVision XT), defining a few special zones and points 
significantly increases behavior recognition accuracy.

 Feeder zones. To detect eating at the feeder.

 Drinking spout points. To detect drinking.

 Wall zones. To detect rearing to wall and to discriminate this from 
unsupported rearing.

For the exact procedure, see Zones and points for Behavior recognition 
in the EthoVision XT Help.

trial control settings

In the Trial Control Settings you can define conditions for the start and 
stop of the data acquisition. 

Choose Setup > Trial Control Settings.

Default Trial Control

The templates for the open field contain two Trial Control Settings 
profiles:

 Default.

 Track duration 10 (or 30) min – When you use this profile, tracking 
starts automatically 2 seconds after the animal has been placed in 
the arena. The track stops automatically after 10 or 30 minutes. 

If you use Behavior Recognition or Activity Analysis, the default Trial 
Control rule is slightly different. See Trial Control in the EthoVision XT 
Help.

To stop acquisition after some specific time 

Open a Trial Control Settings profile, click the Settings button in the 
Condition - Time (1) box, and set the time you require.
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Traditionally, the open field test had a duration of between 2 and 10 
minutes. This short length of time was chosen in the past because the 
data were acquired manually. It also emphasizes the exploratory 
behavior and response to novelty, rather than baseline activity of the 
rodents. Technology like video tracking with EthoVision XT allows for 
much longer periods of monitoring.

detection settings

Choose Setup > Detection Settings.

We assume that you followed the procedure in detection settings on 
page 17.

Sample rate

Under Video, set the sample rate. Common values are, expressed in 
number of images analyzed per second:

 For rats: 5 samples/s.

 For mice: 12.5 samples/s.

 For nose-tail tracking of all rodents: 25 to 30 samples/s.

 For adult zebrafish: 5 samples/s.

Remember, however, that the optimal sample rate is much depending 
on a variety of factors, including the characteristics of the setup, and 
even the animal’s strain and behavior. Faster animals need a higher 
sample rate. This is also valid for fish. If the fish shows very rapid 
movements, then set the sample rate to the maximum; in other cases a 
sample rate of 5 fps may be enough.

To detect freezing behavior

Open the Activity section in the Detection Settings pane. This option is 
only available if you selected Activity analysis under Analysis options in 
the Experiment settings. Enter the Activity threshold for detecting a 
change in the pixels in the arena. Start with the default value and check 
the purple-colored pixels in the video image. Adjust the threshold in 
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such a way that when the animal is completely still, those pixels should 
be almost completely absent. 

Rat or Mouse Behavior Recognition

If you selected Behavior Recognition in the Experiment settings (only 
available when you have the Rat or Mouse Behavior Recognition 
module of EthoVision XT), remove the tail from the detected body 
contour. To do so, in the Detection Settings pane:

1. Under Subject Contour, select one or more pixels for the first 
Erosion field until the tail is no longer detected. The detected body 
area (in yellow) looks now smaller.

2. Increase the Dilation filter until the detected body area is the same 
as before.

Next, open the Behavior section in the Detection Settings pane. Wait 
until the rat has a normal, straight, posture (so not bending or rearing) 
and is moving forward. You should see the hips of the rat moving. Click 
Grab and check that the body contour is correct. You can also enter the 
values manually if you know them from previous experiments. 
However, in this case make sure that the conditions are equal, like 
lighting, size of the animal and distance between the animal and the 
camera. The detected body must have a minimum length of 60 pixels 
(sum of nose-point to center-point and center-point to tail-base) for 
Behavior Recognition. The detected body must also be smaller than 
half the arena size.

For more information, see the EthoVision XT Help.
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Acquiring data

protocol

A typical open field test is carried out in the following way:

1. Transport the subject to the testing room at least 1 hr. prior to 
testing, to allow them to acclimate to the experimental room. This 
time period should be extended if the transfer involves excessive 
changes in the environment. 

2. Clean the open field, even if it is not dirty prior to the initial trial. 
This way all animals experience the residual smell of the 
disinfectant equally. 

3. In EthoVision XT, click the Start Trial button. EthoVision XT waits 
until the subject is detected in the arena.

4. Place the subject in the open field. Commonly, the subject is placed 
in the center. However, placing adjacent to a wall is sometimes used 
to avoid immediate exposure to a stressful situation. Also, in case of 
a large open field, the position adjacent to the wall may be easier to 
reach.

5. The researcher should leave the room, or position himself or herself 
as far as possible away from the arena and field of view of the 
subject. Also the tester should remain quiet throughout each trial.

6. Tracking starts after the subject is detected in the arena (see also 
Trial Control Settings on page 38). Make sure that tracking does not 
start because your arm is detected instead of the animal. To do so, 
for example, make a door in the open field, or increase the period 
that the subject needs to be detected before tracking starts (see 
page 38). If you use multiple arenas, tracking starts in each arena 
separately, depending on when the subject is detected in that arena. 
The subject is allowed to explore freely for a standardized time. 
Traditionally track duration was between 2 and 10 minutes, but 
video tracking with EthoVision XT allows longer tracking (see also 
page 38). 
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7. After the test has ended, take the subject out of the arena and put it 
back in its home cage.

8. Optionally, count the fecal boli in each zone of the open field.

9. Clean the open field and allow it to fully dry prior to introducing the 
next test subject. 

Notes

 tip  When tracking white animals, then wear dark clothes and when 
tracking dark animals then wear white clothes. This prevents 
EthoVision XT from detecting your arms while you release the 
animals in the arena.

 See also acquiring tracks on page 21.

score behaviors manually

Once you have defined your behaviors of interest in the Manual Scoring 
Settings (page 35), you can score those behaviors in two ways:

 Live. That is, during the test. On the Acquisition screen, click the 
Manual Scoring tab and score behaviors when these occur. 

 Offline. If you have recorded video, choose Acquisition > Manual 
Scoring. Review the video and add or edit behavior scores.

For more information, see Acquire Data > Score behaviors manually in 
the EthoVision XT Help.
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Data Analysis

analysis profiles

The template experiment contains four analysis profiles:

 Distance & Time – With the variables Distance Moved and Velocity, 
the mean velocity and the total distance moved and the group 
means with their standard errors are calculated. The total distance 
moved is a measure of the activity of the test animal. 

 Movement – With this analysis profile the behavior of the animals 
is divided into moving and not moving. The frequency, duration and 
latency to either of these states and the group means with their 
standard errors are calculated. Like total distance moved, 
movement is a measure for activity. 

 In zones – With this analysis profile, the frequency the animal 
visited the zones defined in the arena settings and the group mean 
with its standard error are calculated. The data profile also contains 
the total time spent in the zones and the latency until the animal 
first enters either of the zones. 

 Behaviors – With this analysis profile, the frequency, duration and 
the group means with their standard errors of the manually scored 
behaviors are calculated. In the template experiment, the behaviors 
rearing and grooming are predefined. Possibly, you added 
additional behaviors like defecating, or urinating (see page 35). You 
can add these behaviors to the analysis profile and calculate for 
example their frequency and duration. 

analysis per zone

To calculate distance or speed in a specific zone

1. Choose Analysis > Data Profile > New.
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Click on the Settings button on the Result box, select Results per 
zone and subsequently select the zones you want to analyze.

2. Next, choose Analysis > Analysis Profile > open the analysis profile 
and select the variable (distance, velocity etc.).

3. Choose Analysis > Results > Statistics and Charts.

To calculate time spent in a specific zone

1. Choose Analysis > Analysis Profile > New.

Choose In zone, select the zones you are interested in.

2. Choose Analysis > Results > Statistics and Charts.

time variation of behavior

Define Results per time bin. In this way, the dependent variables are 
calculated over each time interval. 

1. Choose Analysis > Data Profile > New.

2. Click the Settings button on the Result box, select Results per time 
bin and specify the time interval.

3. Choose Analysis > Results > Statistics and Charts.

zone crossings

In addition to the predefined analysis profiles you can create an 
analysis profile for zone crossings. This way you can calculate the 
number of crossings from the border zone to the center zone. 

1. Click the Add button next to Zone transition.

2. Select the zone sequence.

3. Depending on which option you select (Allow intermediate zone 
visits or Only count direct transitions) you can get different results.

For more information, see the Zone transition in the EthoVision XT 
Help.
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freezing behavior

If you want to quantify freezing behavior, which is a measure of the 
fear the animals experience, create an analysis profile for Activity state. 
Activity is defined as the amount of pixels in the arena that change at 
any time. Click the Add button next to Activity state and define the 
number of states and their thresholds (for freezing, the important 
threshold is Inactive below. On the Statistics tab, choose the statistics. 
With this analysis profile the behavior of the animals is divided into the 
states you specified. 

Next, use the Plot Integrated Data function to visualize the activity 
states. Adjust the settings in the Analysis profile until the state 
“Inactive” matches the freezing behavior of the animal in the video.

The frequency, duration and latency to all those states is calculated in 
the next step (see Calculating statistics). 

For more information on Activity, see the EthoVision XT Help.

stretch-attend

Stretch-attend postures can be detected with the Body elongation 
state variable in the Analysis profile.

For more information, see Body elongation state in the EthoVision XT 
Help.

rat or mouse behavior recognition

To analyze the automatically detected behaviors, in the Analysis profile 
under Rat or Mouse Behavior Recognition choose the behaviors you are 
interested in. 

Furthermore:

 If you want to analyze multiple behaviors as one, click Merged 
Behavior. 
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 If you want to view the probability (that is, a measure of detection 
uncertainty) associated with the behaviors detected, click Behavior 
probability and specify the behaviors you are interested in.

comparing groups

1. Prerequisite: You can define groups of tracks based on independent 
variables (see page 19).

2. Choose Analysis > Data Profile > New.

3. Create a structure like that in the following picture. 

To create a new branch, click the button next to Result and connect the 
Start box with the new Result box.

visualizing data

Choose Analysis > Results > ...

Figure 2.6  An example of data selection to compare two groups of tracks.
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Plot tracks

You can view your tracks on a still image of the background. Tracks can 
be shown in different colors according to the values of independent 
variables (for example, blue for animals treated with saline and red for 
drug-treated animals). Sample points can be shown in different colors 
according to the values of dependent variables, for example red when 
the animal was moving fast. 

Plot heatmaps

You can make heatmaps of the location of the subject.

Plot integrated data

You can look at a track with the video file in the background. When you 
plot integrated data you can also view Time Event plots of your 
independent variables. 
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Introduction

the morris water maze test

The Morris water maze is a behavioral procedure designed to test 
spatial memory. It was developed by neuroscientist Richard G. Morris in 
1984, and since its initial description it has become a very popular 
paradigm for the study of learning and memory in rodents (D'Hooge 
and De Deyn, 2001). 

In the water maze paradigm, a rat or mouse is placed into a small 
circular pool of water which contains a hidden platform (the Atlantis 
platform). The platform is either fixed (a few millimeters below the 
water surface) or adjustable. In the latter case, the platform is 
submerged at the start of the trial (about 15 centimeters, depending on 
the device) and remains submerged until the subject finds the location 
of the platform. The platform is then automatically raised. Visual cues, 
such as colored shapes, are placed around the pool to aid the animal in 
learning to locate the platform. After sufficient training, a capable rat 
can swim directly from any release point to the platform. Next, animals 
are treated and the effects on spatial learning and memory are 
evaluated based on how they now perform in the Morris water maze.

Figure 3.1  A rat in a Morris water maze.
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the sample experiment

EthoVision XT comes with a sample experiment that shows you how a 
Morris water maze test is carried out with EthoVision XT. It includes a 
number of videos from a true research project and shows interesting 
patterns of spatial behavior depending on the age of the subject.

 If the sample experiment was installed during installation of 
EthoVision XT, you can open it directly: Choose File > Restore 
Backup and browse to C:\Users\Public\Documents\Noldus\ 
EthoVision XT\Experiments\Sample Experiments. Select the file 
with extension EVZ and click Open. 

 If you do not find the sample experiment, download it from 
MyNoldus.com. First log in or register, then choose Downloads > 
EthoVision XT > Sample Experiments.

references

D'Hooge, R. and De Deyn, P.P. (2001). Applications of the Morris water 
maze in the study of learning and memory. Brain Research Reviews, 36, 
60-90.

Gallagher, M., Burwell, R. and Burchinal, M. (1993). Severity of spatial 
learning impairment in aging: development of a learning index for 
performance in the Morris water maze. Behavioral Neuroscience, 107, 
618-626.

EthoVision XT and the Morris water maze test

For the complete list of publications, see the results in Google Scholar.
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Physical setup

The following suggestions are meant to optimize video tracking:

 The camera should have a good view of the entire region the 
animal can be in. The arena should fill the field of view.

 There must be maximum contrast between the background and 
the animal. If you use dark rats in the water maze, you can color the 
water with milk powder (400 g, pre-dissolved in 2 l). It is also 
possible to track white rats or mice with dark coloring in the water: 
add 300 g of tempera black nontoxic powdered paint to a 45-l pool.

 If you have reflections in your image, EthoVision XT may confuse 
those reflections with your subject, and track the reflections rather 
than your animal. Place four (or more) bulbs round the pool, below 
the level of the water surface or other indirect lighting above the 
water maze (see Figure 2). 'Globe' type bulbs are ideal (twice the 
diameter as standard incandescent light bulbs). They should be 
close enough to the pool wall so that there is no direct line of sight 
between the bulbs and the camera lens. The light is reflected off 
the walls and ceiling, so that it only reaches both the lens and 
water surface indirectly.

 The water temperature should be ± 26 °C, which is cold enough to 
encourage the animals to seek the platform, but not too cold to 
induce hypothermia.

Figure 3.2  Lighting a water maze. Left: view from 
side, right: view from above.
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The Morris water maze test in 
EthoVision XT

Create an experiment. For details, see Chapter 1 of this manual, or in 
EthoVision XT press F1 and see Setup an Experiment in the EthoVision 
XT Help.

arena settings

Choose Setup > Arena Settings > ...

We assume that you followed the procedure in arena settings on page 
15.

The zone groups in your experiment depend on what zone template 
you chose when creating the experiment.

 Platform, quadrants – This zone template creates one arena 
settings profile with a zone group Platform with zones Platform and 
Platform Zone (the zone around the platform) and a zone group 
Quadrant with a zone for each quadrant.

 Platform, quadrants, corridors, border – This zone template creates 
four arena settings profiles, one for each quadrant. The South-West 
Platform profile, for example, contains a zone group Platform with 
zones Platform and Platform Zone (the zone around the platform), a 
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zone group Quadrant with a zone for each quadrant, a zone group 
Thigmotaxis with zone Border Zone, and a Whishaw’s corridor for 
the other quadrants than the one with the platform.

Whishaw’s corridor is an 18-centimeter wide path from the starting 
location to the platform. This corridor is designated as the correct 
route and if a rat deviates from this route at any point it receives a 
maximum of one error on that trial (Whishaw's error). To be able to 
determine whether the animal deviates from this route, you should 
define the rest of the arena as an Outside corridor zone. A 
Whishaw's corridor is defined for each release point you use. By 
creating separate Arena Settings for each corridor, you can select 
the appropriate Arena Settings for data acquisition depending on 
the release point for that trial.

To resize and reshape a zone, click first the Point edit mode button on 
the toolbar, then move the corners of the zone outline. Hold Shift down 
to keep the same aspect ratio of the shape. Hold Ctrl to enlarge/reduce 
the shape size in all directions.

Figure 3.3  Part of the South-West Platform arena settings profile. The zones 
in the zone groups Platform and Whishaw’s Corridor NW are displayed.
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Zone for analyzing thigmotaxis

To quantify thigmotaxis, that is, persistent swim along the wall of the 
pool, create an additional zone group, and draw a circle which should 
be the internal margin of the zone. Place the zone label between this 
circle and the outline of the arena.

trial control settings

In the Trial Control Settings you can define conditions for the start and 
stop of the track. 

Choose Setup > Trial Control Settings > Open one of the following:

 Default (no max duration). When you use this profile, tracking 
stops when you click the Stop trial button.

 Max Track duration 1 min – When you use this profile, tracking 
starts automatically 2 seconds after the animal has been placed in 
the maze. The track stops automatically when the center-point of 
the animal has been in the zone Platform for at least 5 seconds, or 
when 60 seconds have elapsed since the start of the track.
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 Max Track duration 2 min – When you use this profile, tracking 
stops when the center-point of the animal has been in the zone 
Platform for at least 5 seconds, or after 2 minutes if the animal does 
not find the platform within that time.

Using an adjustable platform

If you use an adjustable platform you can define an action to raise the 
platform when the animal swims around the platform. Note that you 
need the Trial & Hardware Control module to be able to control the 
platform.

detection settings

Choose Setup > Detection Settings > Detection Settings 1.

We assume that you followed the procedure in detection settings on 
page 17.

Check in the Video Section that the sample rate is set to 5 samples/
second (for rats) or 12.5 samples/second (for mice).

Advanced detection settings

If detection of the subject is not optimal after using the Automated 
setup function (page 17), do the following:

1. Check that either Dynamic subtraction or Differencing is selected as 
the detection method. Differencing is the preferred option if you 
work with hooded animals.

2. When using Dynamic subtraction – Move the slider to define the 
animal's contrast. The animal must be fully detected in all parts of 
the arena and the noise must be minimal. Specify the Current frame 
weight. A low value (for instance, 10-20) usually works well.
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When using Differencing – Set the Sensitivity slider. The slider 
determines what difference in contrast from the background is 
seen as the animal.

For more information, see Configure Detection Settings in the 
EthoVision XT Help.

trial list

Choose Setup > Trial List.

Defining Independent Variables

Enter your independent variables such as:

 Subject ID with the ID of your animals as predefined values.

 Phase with Training and Probe as predefined values. 

 Treatment with Treated and Control as predefined values. 

 Dose with numerical values (e.g. 0.1 mg/kg, 0.5 mg/kg, etc.)

 Day after treatment (with values 1, 2, etc.)

 Name of the experimenter, etc.
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Making a list of trials

If you want, you can pre-define all your trials here. Click the Add Trials 
button. You can also prepare the trials in Excel, randomize them and 
then paste the values into your Trial List.

Specify the values of the independent variables in advance, or enter 
them as you carry out the trials.

Furthermore, you can define a list of trials for batch acquisition. See 
Batch Data Acquisition in the EthoVision XT Help.

Figure 3.4  The predefined Trial List in the water maze template experiment.
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Acquiring data

protocol

In a typical water maze test, an animal is put in the maze at a 
predefined position at the rim of the pool, facing the wall. Lower the 
animal gently into the water (e.g. in a paper cup), avoiding stress as 
much as possible.

Before you start data acquisition, make sure the appropriate arena 
settings profile, depending on the starting location of the animal, is 
selected in the Acquisition Settings window.

Training trials

In training trials, the animal starts swimming and the trial stops when 
the animal has found the platform or when the maximum trial 
duration has been reached.

Probe trials

After the training trials, a probe trial is conducted in which the escape 
platform is removed from the pool and the animal allowed to swim for 
60 sec. Thus typically each animal is tested n times (training) + 1 time 
(probe). Each test corresponds to a trial in EthoVision XT.

Reversal training trials

In reversal learning tasks, after one location has been thoroughly 
trained, the platform is moved to a different quadrant of the pool. 
Because it is hidden, it is not apparent that anything has changed until 
the animal fails to find the platform in its usual place. The focus is on 
how the animal reacts to this change and how quickly it learns the new 
location.

In EthoVision XT, mark different types of trials with an independent 
variable in the Trial List. For example Type, with values Training and 
Probe. Or, a variable Platform Position with values SouthWest, 
NorthWest, etc.

See also acquiring tracks on page 21.
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Data Analysis

data preparation

Track smoothing

Choose Acquisition > Track Smoothing Profile. 

 Select Lowess smoothing to remove the effect of body wobble.

 When the animal sits still on the platform, yet the body center-
point still moves slightly due to system noise. This results in an 
overestimation of, for example, the total distance moved. Select 
Minimal distance moved to only measure the total distance moved 
over the time periods in which the animal was really swimming.

analysis profiles

Choose Analysis > Analysis Profile. 

The template experiment contains five analysis profiles:

 Latency to reach platform –This profile contains the variable 
Latency to platform to calculate how long it takes the animal to 
find the platform. You can use the variable Distance to zone to 
calculate Gallagher’s index (Gallagher et al., 1993). The variable In 
quadrants calculates the frequency and duration of visits to each 
quadrant.

 Path shape – The path shape can be determined by using the 
variables Turn angle, Angular velocity and Meander.

 Whishaws Corridor (only present if you chose a zone template with 
corridors when creating the experiment)– In this profile, the 
variable Inside Whishaw’s Corridor calculates the time the animal 
spent inside any of Whishaw’s corridors. The variable Outside 
Whishaw’s Corridor calculates the time the animal spent outside 
any of Whishaw’s corridors.
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 Distance & Time – In this profile, the total Distance Moved and the 
mean Velocity and the group means with their standard errors are 
calculated.

 Heading – In this profile, the mean Heading to each of the 
platforms is calculated.

swim patterns

Thigmotaxis (wall-hugging swim)

This is a persistent swim along the wall of the pool that could include 
sporadic swims toward the center of the pool. To quantify thigmotaxis, 
calculate the time spent in the Thigmotaxis zone defined as on page 54, 
relative to the total track duration.

Random search

This is swimming over the entire area of the pool in straight swims (zig-
zag pattern), or in wide circular swims.

Divide the pool into quadrants or even more, smaller zones, then count 
the number of times each zone was visited, the time in zones. If zone 
visits/time are uniformly distributed across zones, the search pattern 
could be said to be random or at least covering the whole pool.

Scanning

The search path is restricted to a limited, often central, area of the pool.

Do the same as above, but now covering only the area/zones towards 
the center (see Figure 1C in the paper Janus C. 2004. Learning and 
Memory 11: 337-346). Relate this to the time in the external zones.

Chaining/serial visits

This is circular swimming (in anticlockwise or clockwise direction) at a 
fixed distance from the wall, in which the escape platform was located.

To quantify chaining, draw a specific circular crown zone. Calculate the 
time spent in this zone versus the time in the rest of the arena, or 
calculate rotations occurring in that zone.
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Focal search

This is searching in a restricted area of the pool, usually the target 
quadrant. The path is characterized by a directional, straight swim to a 
specific area followed by dense concentration of superimposed loops 
and turns there.

To detect rapid changes in direction, use the Multi condition dependent 
variable to define your criterion, for example Absolute Meander > 10 
degrees/cm. This marks the time when Meander is greater than the 
threshold value.

You can precisely capture the instances when the subjects turns and 
heads back to the target zone. Combine Meander with a In zone 
variable in a Free Interval, to select the time from when the rapid 
change in direction occurs, to when the subject enters the target area. 
In the Arena Settings, define a zone around the platform or any other 
target point, and name it Focal zone. In the Analysis profile, define a 
Free interval from Interval start “Meander: Absolute Meander > 10 
degree/cm” to Interval stop “In zone: Center point is in Focal zone”.

In the figure below, the peaks in the Meander variable mark the sudden 
changes in direction. The color bars represent the Free interval marking 
the time between the directional change and the zone visit.
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Direct swim path

This is the direct swim path to the location containing the escape 
platform.

Define an In zone variable based on the Whishaw’s corridor (page 59) 
to calculate the time spent in and outside this corridor before reaching 
the platform. See also the EthoVision XT Help.

Floating

A state of inactivity without forward movement. The plotted path is 
short, often with thick or tight sections caused by non-directional drift. 

Quantify floating with Movement (Not moving) or a Multi condition 
that includes Movement (Not moving) and In zone (Center point is not 
near the wall of the pool; define a dedicated zone if necessary).

gallagher’s proximity score

Cumulative search error (for training trials)

Gallagher et al. (1993; see page 50) proposed the Cumulative search 
error to provide information about the spatial distribution of the 
animal’s search during training trials. This was obtained by sampling 
the position of the animal in the water maze (10 times per second), and 
calculating the averages of distance to the platform for 1-second 
periods (see Figure 6 in the original paper). The averages are then 
summed up.

In EthoVision XT, you have two options:

 Calculate the Total distance from the platform.

In the Analysis profile, choose the dependent variable Distance to 
zone, with the Statistic Total. This equals the “true” Gallagher’s 
Cumulative search error when sample rate = 10 samples/s. In most 
cases the Total distance from the platform highly correlates with 
the “true” search error.

 Calculate the “true” Gallagher’s Cumulative search error.

a In the Data profile, select time bins (1 second).
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b In the Analysis profile, define the dependent variable Distance to 
zone, with the Statistic Mean. 

c Choose Analysis > Results > Statistics and Charts, click Calculate, 
then export the results (Analysis > Export > Statistics). 

d In Excel, open the export file and sum up the average values per 
trial.

Average search error (for probe trials)

According to Gallagher et al. (1993), the Average search error is 
obtained by calculating the average distance of the animal to the 
platform location over 1-second intervals, and then averaging the 
values (Average proximity; see Figure 9 in the original paper). 

In EthoVision XT:

In the Analysis profile, choose the dependent variable Distance to zone, 
with the Statistic Mean. This equals the Gallagher’s Average search 
error in all cases.

Data correction

For both probe trials and training trials, Gallagher et al. (1993) made a 
correction so that trial performance was relatively unbiased by 
differences in distance to the goal from the various start locations at 
the perimeter of the pool (see page 621 in the paper).

If you want to apply this correction to your data:

1. Measure the distance D between the release point and the 
platform. In the EthoVision XT Trial List, define an independent 
variable D and for each trial enter the appropriate value depending 
on the release point used in that trial. Values will be used later in 
the Excel export file.

2. In the Analysis profile, define the dependent variables Distance to 
zone, In zone (not in platform) and Velocity. 

3. Choose Analysis > Export > Raw Data. and choose Excel as File type.

4. In Excel, create macros/formulas that calculate (see the next page):
- The average velocity v when In zone =1.

- The time needed to reach the platform from that starting point: 
t= D/v.
3 -  The Morris Water Maze Test 63



64
- Insert a new column Valid time, assign the value 1 if Recording 
time in the same line is higher than t.

- Calculate the average distance to zone (platform) for when In 
zone =1 and Valid time =1 (use the Excel function averageifs).

- Calculate the total distance to platform when In zone =1 and 
Valid time =1 (use the Excel function sumifs).

Figure 3.5  Example of Excel file for calculating corrected Total distance (see 
text).
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Introduction

the novel object recognition test

The Novel Object Recognition (NOR) test was first described by 
Ennaceur and Delacour (1988). Rats or mice are exposed first to two 
identical objects and then one of the objects is replaced by a new 
(novel) object. The time spent exploring each of the objects is 
measured. The test has become popular for assessing visual memory in 
rodents in general and to test the effects of amnesic drugs in particular.

The test is based on spontaneous behavior with no reinforcement such 
as food or shock. Non-amnesic animals will spend more time exploring 
the novel object than the familiar one. An absence of any difference in 
exploration time can be interpreted as a memory defect or, in case an 
amnesic drug is tested, a non-effective drug. This chapter describes 
how a NOR test can be conducted with EthoVision XT.

On the downloads section of the Noldus website my.noldus.com, you 
find a number of sample experiments, including one that features a 
NOR test.

Figure 4.1  A mouse exploring novel objects.
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the sample experiment

To see how a Novel Object Recognition test is carried out in EthoVision 
XT, see also the sample experiment Novel Object Recognition test 
XT180 on the downloads section of the Noldus website 
(my.noldus.com). Download this file and save it on your computer. In 
EthoVision XT, choose File > Restore Backup and select the file. For 
more information, see the document Description of sample 
experiments of EthoVision XT.pdf.
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Physical setup

The following suggestions are specifically to optimize video tracking:

 For general information, see the section Physical setup in the 
chapter The Open Field test on page 28.

 The objects should contrast with the animal. If necessary use a 
different setup for light and dark colored animals.

 Make sure that the objects do not move due to the activity of the 
animal.

 Either make sure the sides of the box are not reflective (for 
example, sand the box to make it matte), or exclude the sides from 
the arena. If your objects are close to the sides, you will need to 
track the animal when it is against the side.
4 - The Novel Object Recognition Test



The NOR test in EthoVision XT

Create an experiment from a template (Ctrl+T). Choose Open field 
(round or square) as Arena template, and Novel object zones as Zone 
template.

For details, see Chapter 1 of this manual, or in EthoVision XT press F1 
and see Setup an Experiment in the EthoVision XT Help.

experiment settings

Choose Setup > Experiment Settings.

Under Video Source, and Tracked Features, make sure that the options 
selected corresponds to your needs.

If you want to use Deep learning technique to track the subject’s nose, 
under Body point detection technique choose Deep learning. Note that 
in order to use this technique there are additional requirements. The PC 
must have a powerful graphics card which supports additional 
software (CUDA). See Deep learning: Requirements and Limitations in 
the EthoVision XT Help.

manual scoring settings

These settings enable you to record behaviors manually, using 
keystrokes. This is handy for example to record exploratory behaviors 
like sniffing.

Choose Setup > Manual Scoring Settings.

If you created the experiment from the template with novel object 
zones, the Manual Scoring Settings already includes one behavior, 
Sniffing object. This is defined as “start-stop”, which means that you 
press a key (default: q) to score the start of sniffing, and then you press 
the same key once again to score the end of sniffing.
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For more information, see Manual Scoring Settings in the EthoVision 
XT Help.

note  With the Rat or Mouse Behavior Recognition add-on, you can 
have EthoVision XT detect sniffing and other behaviors, without the 
need to score them manually.

arena settings

Choose Setup > Arena Settings > Open Arena Settings 1.

To set up your Arena Settings:

1. Click the Grab Background Image button to grab an image of the 
empty enclosure from the camera image.

2. Click 1. Draw Scale to calibrate and calibrate your arena (for details, 
see the EthoVision XT Help).

tip  Draw the double-arrow in such a way it points to two opposite 
walls of the open field, at the level where the animal moves (thus 
not at the top of the walls!). When done, enter the distance in real 
world units between the tips of the arrow.

3. Click 2. Select Shape and Draw Arena. Check that the arena covers 
the whole area in which you want to track the animal. Remember to 
include enough of the walls so that the animal is still tracked when 
it rears, but exclude any bright reflective rims that might interfere 
with tracking. Make sure the label stays inside the arena.

tip  If the arena is not yet defined, and you want to divide it in equal 
zones, click 2. Select Shape and Draw Arena. Choose the tool that 

applies  depending on the shape of your open field and 

draw the outline of the arena.

4. If you used the Zone template Novel object zones, click 3. Select 
Shape and Draw Zones. 
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Click the layer Zone group Objects. Check that the ‘object 1’ zone 
and ‘object 1 boundary’ zone cover the object (Figure 4.2). If the 
predefined zones do not have the correct shape, delete the zones 
and draw new ones.

5. If necessary, draw additional zone groups/zones.

Additional zones

 Zone group Floor and Wall. Check that the ‘Floor’ zone covers the 
whole floor area of the open field (see Figure 4.3).

Figure 4.2  Zones of the zone group “Objects”. 
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 Zone group Halves. Check that the ‘West’ and ‘East’ zones divide 
the ‘Floor’ zone in two equal halves. Make sure that the vertical line 
crosses the entire arena.

trial control settings

In the Trial Control Settings you can define conditions for the start and 
stop of the track. 

Choose Setup > Trial Control Settings. The template contains the 
following profiles:

 Default. When you use this profile, tracking starts automatically 
two seconds after the animal has been placed in the arena. Tracking 
stops when you click the Stop trial button. 

 Track duration 10 min. When you use this profile, tracking starts 
automatically two seconds after the animal has been placed in the 
arena. Tracking stops automatically after 10 minutes.

To sop tracking when exploration exceed a specified time

You can also stop tracking when the subject has spent some time 
around an object. For example, when the protocol specifies that in pre-
test trials the animal must explore an object for at least 30 seconds.

Figure 4.3  Open field with ‘Floor’ zone and ‘Wall’ zone.
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Make a new Trial Control Settings, and immediately before the Stop 
track box, insert a Condition box based on the variable In zone, or 
another variable, or a combination of variables using Multi condition. 
In the Condition settings, specify that Cumulative duration in the 
boundary zone for that object must be greater than N seconds, for the 
nose point.

If you use Multi condition, you can define “exploration” as a 
combination of variables. For example: In Zone for the noise point in 
the “object zone” is true + Head directed to Zone “object” is true + 
Velocity lower than 5 cm/s is true. The trial stops only when the 
cumulative time that the three criteria are met reaches the specified 
value.

To stop tracking automatically when no exploration occurs

To stop tracking automatically even when the animal does not explore 
the object, add another condition in parallel with the first one, which 
specifies to stop tracking after some time (e.g. 10 minutes), and 
combine the two conditions with an Operator box of type “ANY”.

detection settings

Choose Setup > Detection Settings > Detection Settings 1.

Advanced detection settings

If detection of the subject is not optimal after using the Automated 
setup function (page 17), do the following:

1. Check that the sample rate is set to at least 25 samples/second 
when tracking the nose and tail.

2. Check that either Dynamic subtraction or Differencing is selected as 
the detection method. Differencing is the preferred option if you 
work with hooded animals.

3. When using Dynamic subtraction, move the slider to define the 
animal's contrast. The animal must be fully detected in all parts of 
the arena and the noise must be minimal. Specify the Current frame 
weight. A low value (for instance, 1 to 10) usually works well. A novel 
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object test normally has a duration of a few minutes in which the 
background does not change much.

When using Differencing, set the Sensitivity slider. The slider 
determines what difference in contrast from the background is 
seen as the animal.

4. When detection still is not satisfactory, select Rodents / For 
occlusions as the tracking method and repeat step 2 above. 

note  If you want to use Deep learning technique to track the 
subject’s nose, note that there are additional requirements and 
limitations. Among other things, you need a powerful graphics 
card. See Deep learning: Requirements and Limitations in the 
EthoVision XT Help.

trial list

Choose Setup > Trial List.

Defining Independent Variables

Enter your independent variables such as:

 Subject ID with the ID of your animals as predefined values.

 Phase with Acclimation, T1, T2 as predefined values, where:

- Acclimation to mark trials where the animal is free to explore the 
arena, with no objects present.

- T1 to mark trials where the animal is presented with a pair of 
identical objects.

- T2 to mark trials where one of the familiar objects is changed for 
another new (novel object test).
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 Treatment with Treated and Control as predefined values. 

If you want, you can predefine all your trials here, or you can enter the 
independent variable values as you carry out the trials. You can also 
prepare the trials in Excel, randomize them and then paste the values 
into your Trial List.

Furthermore, you can define a list of trials for batch acquisition. See 
Batch Data Acquisition in the EthoVision XT Help.

Figure 4.4  An example of the Trial List with four planned trials.
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Acquiring data

protocol

A typical NOR test consists of three phases:

 Acclimation. The animal is placed in an empty arena for 10 minutes 
to habituate to the environment. Tracking in this phase is optional. 
After 10 minutes, the animal is taken out of the arena and is put 
back in its home cage.

 T1. After 15 minutes in the home cage, the animal is put back in the 
arena in which two identical objects have been placed. The animal 
is put at a position midway between the objects and such that its 
nose points towards the wall. The animal is tracked for 3 minutes 
and is then taken out of the arena and put back in its home cage.

Define a Trial Control Settings profile for this phase, then assign 
this profile to the trials of type T1.

 T2. One of the objects in the open field is replaced with a novel 
object (sometimes the other object is also replaced with an 
identical one) and the animal is put in the arena again. Tracking is 
done for 3 minutes. 

Define a Trial Control Settings profile for this phase, then assign 
this profile to the trials of type T2.

See also acquiring tracks on page 21.

score behaviors manually

To score sniffing and other behaviors defined under Manual Scoring 
Settings, open the Manual Scoring tab on the Acquisition screen. There 
you find the key codes and the buttons for the behaviors.

To score an instance of the behavior or its end, either press the key or 
click the corresponding button on the screen.
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Notes

 important  If you do tracking from video, make sure you de-select 
DDS in the Playback Control window.

 You can also score behaviors after tracking. See Acquire Data > 
Score behaviors manually in the EthoVision XT Help.
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Data Analysis

data preparation

Track editing

Choose Acquisition > Edit Tracks.

You can fix tracking errors and swap back nose-points and tail-points 
that have been swapped in tracking. Normally you will not need to edit 
your data.

Track smoothing

Choose Acquisition > Track Smoothing Profile > open MDM Filter 2 mm.

In this profile, the Minimal Distance Moved filter is used (option set to 
Direct, with a threshold of 2 mm). When the animal sits still, the body 
points may still move slightly due to system noise. This results in an 
overestimation of, for example, the total distance moved. With the 
minimal distance moved filter, you measure the total distance moved 
over the time periods in which the animal was really walking. Adjust 
the threshold if necessary, based on your setup and sample rate.

Review video and behaviors

If you have scored behaviors manually, you can review the video and if 
necessary edit the data. Choose Acquisition > Score behaviors 
manually. For details, see Score behaviors manually in the EthoVision 
XT Help.

selecting data

Choose Analysis > Data Profile. 

You can select (Filter) your tracks according to your independent 
variable values (for example, Treated animals only) and also select parts 
of tracks (Nesting).



Figure 4.5 shows a data profile to compare 'Novel Object' and 'Familiar 
Object' trials which uses Filters. This way you create groups of tracks to 
obtain group statistics for each group.

analysis profiles

The template experiment contains four analysis profiles:

 Touching objects. This analysis profile contains an In zone variable 
Nose touching objects to calculate the frequency, duration, and 
latency of when the nose-point of the animal touches the objects. 
The variable Distance to objects is used to calculate the mean and 
standard error of the animal’s nose-point to the objects. The 
Manually-scored behavior Sniffing object calculates the frequency 
and duration, with standard errors, of the instances when you 
scored Sniffing object during the trials.

 In halves. In this analysis profile, the In zone variable In Halves is 
used to calculate the frequency, duration and latency of when the 
center-point of the animal was in either half of the arena.

Figure 4.5  An example of data selection to compare two data sets in your 
experiment.
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 Head directed to zone. This analysis profile contains two Head 
directed to zone variables, one for the novel object and one for the 
familiar object. For each object, the center plus a 0.10 cm radius is 
used as the Point of interest. The frequency and duration for Head 
direction to zone is calculated when the nose-point is in the zone of 
the corresponding object.

 Distance & Time. With the variables Distance Moved and Velocity, 
the total distance moved and the mean velocity are calculated.

All analysis profiles also contain settings to calculate the group mean 
and standard errors of the statistics for trial groups.

exploratory behavior

You can quantify exploratory behavior with the Analysis profiles 
described above, or you can create your own Analysis profiles. 

There is usually variation between subjects in the time spent exploring 
an object. To account for this variation, you can select the part of each 
track up to when the animal explored an object for a specific time, and 
then analyze the behavior of the subject in that part. 

To do so, use the Free Interval function in the Data profile.

1. Choose Analysis > Data Profile > New.

2. Under Nesting, click the button next to Free Interval. 

3. Select the following:
- As a Start criterion: Time (select Track start).

- As a Stop criterion: Dependent variable. Select the variable In 
zone, and the statistic Cumulative duration. In the settings, 
specify which zone the animal explored, and with which body 
point (for example, Novel object, nose point). Set the total 
exploration time. 

4. Click OK and insert the resulting box as in the figure below.
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5. In the Analysis profile, choose the endpoints (distance moved, time 
spent in zones etc.). 

6. Choose Analysis > Results > Statistics and Charts. The results are 
calculated for the time until exploration reaches the duration 
specified.

For more examples, see Free interval in the EthoVision XT Help.

heatmaps

Heatmaps facilitate identification of “hotspots” and clustering of data 
points. Choose Analysis > Results > Plot Heatmaps. Next, click Plot 
Heatmaps on the toolbar.

Figure 4.6  A heatmap of a trial with two 
objects, unfamiliar (left) and familiar (right). 
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Introduction

the elevated plus maze test

The elevated plus-maze was designed to provide measures of anxiety 
that were relatively uncontaminated by changes in overall motor 
activity, and has been extensively validated by Pellow et al. (1985) using 
behavioral, physiological, and pharmacological measures. 

The open and closed arms are considered to evoke the same 
exploratory drive in the animals, therefore avoidance of the open arms 
is considered to be a result of the induction of higher levels of fear 
(Rodgers and Dalvi, 1997). It is thought that the aversion of animals to 
explore the open arms of the maze is caused by fear of open and/or 

elevated spaces.

The plus-maze is sensitive to the anxiolytic effects of neurotoxic 
lesions of serotonergic neurons and to the anxiogenic effects of drugs 
(Pellow and File, 1986), drug withdrawal (File and Andrews, 1991), and 

Figure 5.1  An elevated plus maze.
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predator odor (Zangrossi and File, 1992). For a discussion of the 
additional, ethological measures that can be taken in this test, see 
Rodgers et al. (1995) and Fernandes and File (1996). Unlike the social 
interaction and light/dark tests, the elevated plus-maze does not rely 
on aversion to bright light, and it has been found repeatedly that 
behavior in the maze is independent of light level (e.g., Becker and 
Grecksch, 1996). 

For a review of the protocol, see Walf and Frye (2007).

What to measure?

 Principal component analysis of the conventional plus-maze (File, 
1991) has shown that the percentage of time spent on the open 
arms and the number of entries onto the open arms are the best 
measures of anxiety (these are increased by anxiolytic and 
decreased by anxiogenic treatments).

 The number of closed arm entries is the best measure of locomotor 
activity. 

 There are marked strain differences in baseline scores and even 
between the scores of different batches of animals. If the scores are 
high it will be hard to detect an anxiolytic effect. If they are very 
low it will be difficult to detect an anxiogenic effect. 

 The plus-maze was originally developed for male rats, but it can be 
used with female rats. However, while in male rats anxiety is the 
main factor measured, in females it is activity (Fernandes et al., 
1999). The plus maze has also been validated for mice (Lister, 1987; 
Walf and Frye, 2007). For a discussion of the factors controlling 
measures of anxiety in the mouse, see File (2001). 

Quantifying head dips

EthoVision XT can detect when the subject’s nose is outside the open 
arms. 

However, you can also score head dips manually. First define head dips 
in the Manual Scoring Settings. Next, during acquisition, press the 
assigned keyboard key when a head dip occurs.
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the sample experiment

To see how a plus maze test is carried out in EthoVision XT, see also the 
sample experiment Elevated plus maze XT180 on the downloads 
section of the Noldus website (my.noldus.com). Download this file and 
save it on your computer. In EthoVision XT, choose File > Restore 
Backup and select the file. For more information, see the document 
Description of sample experiments of EthoVision XT.pdf.
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Videos

https://www.youtube.com/watch?v=4rRsxf1U6-w

http://www.dailymotion.com/video/x2e25p_4tgndox16_animals
5 - The Elevated Plus Maze Test

https://www.youtube.com/watch?v=4rRsxf1U6-w
http://www.dailymotion.com/video/x2e25p_4tgndox16_animals


Physical setup

The following suggestions are specifically to optimize video tracking:

 Place the plus maze in such a way that its apparent size is 
maximized. You can obtain this by rotating the plus maze (or the 
camera) until the closed arms lie along one of the diagonals of your 
video window (see Figure 5.2).

 The lighting should be as even as possible throughout the arena. 
Bright lights are not necessary but should you need to supplement 
the light, consider red (or infra-red) light, as the animals will be less 
sleepy. 

 The camera should have a good view of the entire region the 
animal can be in. Center the plus maze in order to have the image 
of the arms as symmetrical as possible. This minimizes inaccuracy 
of calibration due to perspective. 

Figure 5.2  Turn the plus maze to maximize its apparent size in the video 
image from above. 
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 The lighting should be diffuse, so as not to cast strong shadows 
(which might be tracked instead of the animal; see Figure 5.3). Even, 
diffuse lighting is important to optimize tracking of the nose.

 A plus maze with transparent walls may help reducing shadows and 
make easier to observe closed arm rears. There is little practical 
difference between the two mazes in terms of their ability to detect 
differences in anxiety-related behavior. However, the transparent 
design may reduce the sensitivity for the detection of anxiolytic 
drug effects because it decreases the anxiogenic potential of the 
open arm, therefore leading to the reduction of anxiety-related 
behavioral baseline (Violle et al., 2009 and references therein). 

 The background should contrast with the animal. If necessary use a 
different setup for light and dark colored animals. In the closed 
arms, the contrast between animal and background is generally 
lower. Take this into account when positioning lights and choosing 
the background color (Figure 5.4 and Figure 5.5). 

Figure 5.3  Lighting should also adjusted to minimize the shadow made by 
the animal in the arena, which in this example (indicated by the arrow) may 
result in incorrect detection. 
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Figure 5.4  In this example, the closed arm at the top-right corner receives 
little light. This makes detection more difficult when the animal walks in that 
arm. 

Figure 5.5  An example of good contrast between animal and background, 
using a white mouse. Furthermore, the transparent walls also help reducing 
shadows. 
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 Make sure that the color of the floor is in good contrast with the 
color of the animal, and in minimal contrast with the arms. This 
makes it possible to track the animal’s nose off the edge of the 
open arms (see Figure 5.6).

Figure 5.6  Left: CORRECT. The gray floor contrasts with the black mouse. 
When the mouse dips its head off the edge of the open arms, its nose is still 
detected. Right: WRONG. When the floor is too dark, the head dip (indicated 
by the arrow) is not found. 

Figure 5.7  An example of good contrast between floor and animal 
when testing white rats. 
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 Both the plus maze arms and the floor should not be reflective. If 
necessary, place an opaque rubber mat on the floor. 

 If there are barriers above the closed arms, remove them. If that is 
not possible, in the Detection Settings use the Dilation-Erosion 
filter (see page 97) to prevent EthoVision to “see” the animal cut in 
two. See also Contour Settings in the EthoVision XT Help.

 Depending on circumstances, pools of urine can cause problems 
with the tracking. An absorbent base can help.

 Always place the apparatus in the same position in the room, cues 
from overhead might influence the behavior of the animal. For the 
same reason the experimenter should not be visible to the animal 
during the trial (automated tracking makes this possible). 

 If you want to use Deep learning technique to track the subject’s 
nose, note that there are additional requirements and limitations. 
Among other things, you need a powerful graphics card. See Deep 
learning: Requirements and Limitations in the EthoVision XT Help.
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The Elevated Plus maze 
experiment in EthoVision XT

Create an experiment. For details, see Chapter 1 of this manual, or 
in EthoVision XT press F1 and see Setup an Experiment in the 
EthoVision XT Help.

experiment settings

Choose Setup > Experiment Settings.

Under Video Source, and Tracked Features, make sure that the options 
selected corresponds to your needs. To adjust the camera settings, click 
the video icon in the camera row.

If you want to use Deep learning technique to track the subject’s nose, 
under Body point detection technique choose Deep learning. Note that 
in order to use this technique there are additional requirements. 
Among other things, you need a powerful graphics card. See Deep 
learning: Requirements and Limitations in the EthoVision XT Help.

manual scoring settings

Choose Setup > Manual Scoring Settings.

If you used the template for an open field experiment, two start-stop 
behaviors have been defined:

 Head dipping, to record manually the head dips over the edge of the 
open arms. 

 Rearing, to record manually the posture of the animal with 
forelimbs lift off the floor. Note that EthoVision XT does not detect 
rearing automatically in an Elevated plus maze. You must score 
rearing manually in order to record it.
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You can define more behaviors, like scanning. Stretched posture can in 
principle be detected automatically by using the Elongation variable in 
EthoVision.

Notes about Head dipping

 By head dipping we mean here protruding the head over the ledge 
of an open arm and down towards the floor. This response can 
occur while the animal's body is in the closed arms, central square 
or open arms.

 You can also let EthoVision count the number of times or the total 
time that the nose point is found within the head-dipping area 
(provided that this has been chosen in the template). This also 
quantifies the risk-assessment behavior. 

 For a more reliable scoring of head dips, you could place a camera in 
front of each open arm, to film the arm’s side-view. You can record 
video from multiple cameras using the software Noldus 
MediaRecorder. 

 If you film the side-view of the open arm, you can in principle record 
head-dips automatically with EthoVision by defining a zone 
immediately below the arm’s floor. For these videos you need to 
create additional Arena Settings and Detection Settings. 

For more information, see Set Up an Experiment > Manual scoring 
settings in the EthoVision XT Help.
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arena settings

Choose Setup > Arena Settings > open Arena Settings 1.

We assume that you followed the procedure in arena settings on page 
15.

Arena

Check that the arena covers the whole area in which you want to track 
the animal. 

Remember to include enough space around the open arms (so that the 
animal is still tracked when it dips its head off the edge of those arms) 
and the inner side of the walls (to track the entire animal when it 
rears).

Exclude any bright reflective rims that might interfere with tracking. 
Make sure the label Arena 1 stays inside the arena.

Figure 5.8  Arena Settings. 
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To adjust the contour of the arena to the plus maze in the video image, 
do the following:

 Click the Normal mode button on the tool bar and drag the 
arena contour until it is centered on the plus maze. 

 Click the Point edit mode button. Click one of the corners of 
the arena and drag the mouse to move the corner to the 
position you require.

If you use video files, select the aspect ratio correction that applies. For 
more information, see Adjust the video aspect ratio in the EthoVision 
XT Help. If you use the live camera image or the video was recorded 
with EthoVision XT in the same experiment, you can skip this step.

Zone group Arms

Check that each arm zone covers the corresponding sector of the plus 
maze. 

To make sure that a zone is limited to the actual arm, move the label of 
that zone until the arrow points outside the zone. The color of the zone 
should change. If the color changes for a wider area of the plus maze, it 
means that the zone label also pointed to that area. Use the edit 
functions to move and reshape the zone.

For details, see Move, rotate and resize a shape in the EthoVision XT 
Help. Do not forget to place the arrow of the zone label back in original 
position.

If the zones “closed arms” predefined in the template overlap with the 
open arms of the plus maze, rotate the entire arena and zones. 
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To do so, drag around all the shapes, so they are selected. Next, 
click the Rotation mode button. Click in the middle of the 
arena and drag the mouse to rotate it.

Click the mouse pointer icon on the toolbar to exit the rotation 
mode.

Zone group Open arms, Closed arms, Head dip zone

These are cumulative zones. They are defined automatically from the 
sum of the open arms, the closed arms and the head dip zones, 
respectively. 

trial control settings

Choose Setup > Trial Control Settings.

In the Trial Control Settings you can define conditions for the start and 
stop of the track. 

The template contains two trial control settings profiles:

 Default.

 Track duration 5 mins – When you use this profile, tracking starts 
automatically 2 seconds after the animal has been placed in the 
plus maze. The track stops automatically after five minutes.

detection settings

Choose Setup > Detection Settings.

In the Detection Settings window, check in the Video Section that the 
sample rate is set to:

 Rats: 5 samples/second.

 Mice: 12.5-15 samples/second.

 Nose-tail tracking: 25-30 samples/second.
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See Configure Detection Settings in the EthoVision XT Help for details 
on the advanced detection settings. If you use hooded animals, use the 
detection method Differencing. 

If the plus maze has barriers above the arms, the animal is not always 
well detected, like in this example.

To improve detection, open the Advanced section In the Detection 
Settings pane. Under Subject Contour, select one or more pixels for the 
Dilation filter and the second Erosion filter. Leave the first Erosion filter 
to zero. Select more pixels for Dilation than for Erosion, for example 3 
vs. 1, until the entire animal’s contour is detected.

trial list

Choose Setup > Trial List.

Do one of the following:

Click Add Variables and enter your independent variables such as 
Animal ID and Treatment (with possible values Treated, Control, Sham 
etc.), Dose, Name of the experimenter, etc. Each trial will receive only 
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one value of each of those variables; for example, one trial must be 
either Control or Treated or Sham etc. 

Making a list of trials

If you want, you can pre-define all your trials here. Click the Add Trials 
button and specify the number of trials (=recording sessions of one 
animal), and the values of the independent variables for each trial (see 
Figure 5.9). 

You can also prepare the trials in Excel, randomize them and then paste 
the values into your Trial List.

Furthermore, you can define a series of trials for batch acquisition. See 
Acquire a series of trials in the EthoVision XT Help.
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 Test animals only once, unless the intention is specifically to study 
the different form of anxiety evoked by a second trial. If the animal 
falls off, it is best to exclude its scores.

Independent variables

 You can also enter the independent variable values as you carry out 
the trials. You can edit the independent variables for trials already 
acquired, for example to enter a-posteriori data, like whether the 
animal in that trial entered the open arms or not. This way you can 
quickly create groups of tracks based on the result of the trial, and 
use such groups in analysis. 

 You can add a new independent variable at any time.

Figure 5.9  An example of the Trial List with twelve planned trials.
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Acquiring data

protocol

The subject is placed at the junction of the four arms of the maze, 
facing an open arm. Each subject is generally tested once for 5 minutes. 

For extensive protocol information, see Walf, A.A. & Frye C.A. (2007). 
The use of the elevated plus maze as an assay of anxiety-related 
behavior in rodents. Nature protocols 2(2): 322-328. doi:10.1038/
nprot.2007.44

See also acquiring tracks on page 21.

score behaviors manually

To score head dipping and other behaviors defined under Manual 
Scoring Settings, open the Manual Scoring tab on the Acquisition 
screen. There you find the key codes for the behaviors.

To score an instance of the behavior or its end, either press the key or 
click the corresponding button on the screen.

Notes

 important  If you do tracking from video, make sure you de-select 
DDS in the Playback Control window.

 You can also score behaviors after tracking. See Acquire Data > 
Score behaviors manually in the EthoVision XT Help.
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Data analysis

data preparation

Data editing

Choose Acquisition > Edit Tracks. You can fix tracking errors and swap 
back nose-points and tail-points that have been swapped in tracking. 
Normally you will not need to edit your data.

Smoothing data

Choose Acquisition > Track Smoothing Profile and open MDM Filter 0.2 
cm. In this profile, the Minimal Distance Moved filter is used with a 
value of 2 mm and option Direct.

Review video and behaviors

If you have scored behaviors manually, you can review the video and if 
necessary edit the data. Choose Acquisition > Score behaviors 
manually. For details, see Acquire Data > Score behaviors manually in 
the EthoVision XT Help.

selecting data

Choose Analysis > Data Profile. You can select your tracks according to 
your independent variable values (for example, Treated animals vs. 
Controls) and also select parts of tracks (data nesting). Figure 5.10 
shows the Data Profile Treated vs. Control from the template to 
compare 'Treated animals' and 'Control animals' trials. This way you 
create groups of tracks to obtain group statistics for each group.

For more information and to create your own data selection, see the 
EthoVision XT Help.
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Figure 5.10  An example of data selection to compare two data sets in your 
experiment, based on the independent variable “Treatment”. Two groups are 
formed: Treated and Control. Trial Statistics will be displayed per trial, and Group 
Statistics will be displayed per group of trials, according to the treatment level 
assigned to them. 
If you have more treatment groups (e.g. Sham), to create more treatment groups 
click the Common Elements - Result button in the Components pane, and place the 
new box somewhere on your screen. Create a new branch by connecting the first 
(Start) box to this new box. Click the button next to “Treatment” and select the 
new treatment level. Insert the box in the new branch. 
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visualizing data

You can visualize your tracks in three ways:

 Plot tracks. You can view your tracks on a still image of the 
background. Tracks can be shown in different colors according to 
the values of independent variables (for example, blue for animals 
treated with saline and red for drug-treated animals). Sample 
points can be shown in different colors according to the values of 
dependent variables, for example red when the animal was moving 
fast. 

 Plot integrated data. You can look at a track with the video file in 
the background. When you plot integrated data you can also view 
Time Event plots of your independent variables. Just like with 
plotting tracks, you can show tracks or sample points in different 
colors. 

 Heatmaps. You can make heatmaps of the location of your animals 
during the test.
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analysis profiles

The template experiment contains three analysis profiles:

 Time in arms – This analysis profile contains two In zone variables:

- In closed arms to calculate the frequency and duration of when 
the animal was in the closed arms.

- In open arms to calculate the frequency, duration and latency of 
when the animal was in the open arms. Here, latency (the time 
to the first visit in any open arm) is used as an indication of 
anxiety.

For all variables, the animal is considered to be in a zone when 
all its body points are found in the zone simultaneously.

 Behaviors – In this analysis profile, four variables have been 
defined.

- Head dipping and Rearing provide statistics of the behaviors 
manually scored. 

- Body elongation is used to quantify the time that the animal 
shows stretching behavior.

- Nose in Head Dip Area is an In zone variable to calculate the 
frequency and duration of when the nose point of the animal 
was in the head dip areas. 

The last two variables are present when you set the experiment 
to track the three body points or you select the zone template 
with the head dip area.

 Velocity and distance – With the variables Distance Moved and 
Velocity, the total distance moved and the mean velocity and the 
group means and their standard errors are calculated. Movement is 
based on a velocity threshold, and quantifies the time that the 
animal has moved significantly.

For more information, see the EthoVision XT Help.

False positives in arm entry statistics

Sometimes the center point of the animal fluctuates around the border 
line between the center and the arm zones. This may be caused by jitter 
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or exploration behavior, and results in false positives when calculating 
the number of zone entries.

To prevent this from happening, set the Zone exit threshold for the In 
zone variable. 

To set a Zone exit threshold

1. In the Analysis profile, add the In Zone variable. Specify the arm 
zones you are interested in, and the body points that define a zone 
entry (when tracking the center, nose and tail base points).

2. Under Threshold, enter a value for Zone exit threshold. This is the 
distance from the border of the arm zone that the animal must be in 
order to be considered outside the zone. Use the Zone exit threshold 
to filter out small movements of the body points that result from 
jitter or exploration behavior.

3. Visualize the data (Analysis > Results > Plot Integrated Data). 

Example

In the following example we see that slight movements of the mouse’s 
center point result in multiple open arm entries. In the Analysis profile, 
In zone is set with Zone exit threshold = 0 cm.

Left: Mouse enters the open zone.

Middle: The center point is detected out of the zone.

Right: The center point is inside the zone; a second arm entry is scored.
5 -  The Elevated Plus Maze Test 105



106
To remove false positives of zone entries, in the Analysis profile, In zone 
is set with Zone exit threshold = 2 cm. This means that when the center 
point is outside the zone by less than 2 cm from the border, it is still 
considered in the zone.

Result:

This time, one arm entry is scored.

For more information on the Zone exit threshold, see In zone in the 
EthoVision XT Help.
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Introduction

the sociability test (three-chamber 
paradigm)

The three-chamber paradigm test known as Crawley's sociability and 
preference for social novelty protocol has been successfully employed 
to study social affiliation and social memory in several inbred and 
mutant mouse lines. Sociability testing is a more specific study of social 
behavior and only focuses on the behavior of one animal towards 
others. There are several variances to this test, all conducted in a three-
chambered test apparatus. 

In the first variant, the animal’s interest in a social stimulus (a 
conspecific in a wired cage placed in one of the outer chambers) versus 
a neutral stimulus (an empty wired cage placed in the other outer 
chamber) is studied. In a preference test for social novelty, the two 
wired cages contain a familiar and an unfamiliar conspecific. A third 
variation involves testing the social preference for two different, but 
both unfamiliar conspecifics.

Figure 6.1  The Noldus Sociability test cage with three chambers and two wired 
cages for mice.
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In most cases the interest is measured by assessing the time spent in 
the same chamber or in close proximity to the familiar or unfamiliar 
other mouse.

Representative results

Typically, a wild type animal will spend significantly more time in the 
compartment with a strange mouse compared to the compartment 
with empty cage, indicating normal sociability, social motivation and 
affiliation.

In the social novelty test, the subject has a free choice between the 
first, already-investigated, now-familiar mouse, and a novel unfamiliar 
mouse. Usually, a wild-type animal recalls its previous contact with the 
familiar mouse, and, in this session, tends to spend more time with the 
newly encountered mouse, indicating intact social memory and 
predilection for novel experiences.
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The Sociability test in EthoVision 
XT

experiment settings

Choose Setup > Experiment Settings.

Under Video Source, and Tracked Features, make sure that the options 
selected corresponds to your needs. If you want to analyze exploration 
in detail, choose Center-point, Nose-point and Tail-base detection.

If you want to use Deep learning technique to track the subject’s nose, 
under Body point detection technique choose Deep learning. Note that 
in order to use this technique there are additional requirements. 
Among other things, you need a powerful graphics card. See Deep 
learning: Requirements and Limitations in the EthoVision XT Help.

manual scoring settings

If your EthoVision XT license does not include the Behavior Recognition 
module, EthoVision XT cannot detect sniffing or rearing automatically. 
However, you can still score those and other behaviors with keystrokes. 

Choose Setup > Manual Scoring Settings.

If you used the template for an open field experiment, four behaviors 
have been defined:

 Sniffing R and Sniffing O, to record manually sniffing at the receiver 
(unfamiliar mouse) and object (either familiar mouse or empty 
cage, depending on the test), respectively.

 Rearing R and Rearing O, to record manually sniffing at the receiver 
(unfamiliar mouse) the object cage (either familiar mouse or empty 
cage, depending on the test), respectively.

You can also rename the behaviors if you like.
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arena settings

Choose Setup > Arena Settings.

If you work with a Sociability test cage with backlight unit, you can 
reduce the intensity of the backlight before adjusting the arena 
settings. This makes the edges of the floor plate and walls more visible. 

If the separation walls show reflections of the animal, this may hinder 
tracking. In the Arena Settings, click the Arena layer, and draw 
rectangles around the separation walls, like in the example below. 

detection settings

Choose Setup > Detection Settings.

We assume that you followed the procedure in detection settings on 
page 17.

Check in the Video Section that the sample rate is set to:

 For center point tracking: 5-8 samples/second (for rats) and 12.5-15 
samples/second (for mice).

 For Nose-tail tracking (rats and mice). 25-30 samples/second.
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Notes

If detection of the subject is not optimal after using the Automated 
setup function, see Configure Detection Settings in the EthoVision XT 
Help for details on the advanced detection settings. If you use hooded 
animals, use the detection method Differencing. 

If the animal moves from one compartment to the other, it may not be 
detected well, like in this example.

To improve detection, open the Advanced section In the Detection 
Settings pane. Under Subject Contour, select one or more pixels for the 
Dilation filter and the second Erosion filter. Leave the first Erosion filter 
to zero. Select more pixels for Dilation than for Erosion, for example 3 
vs. 1, until the entire animal’s contour is detected.

trial list

Choose Setup > Trial List. Click Add Variables and enter your 
independent variables such as the experimental phases and the ID 
code of your test subject. 
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Acquiring data

protocol

Sociability test

For each test animal, three trials are carried out:

1. The first trial (for example 5 min) aims at habituating the test 
individual to the chamber. Tracking is required when one wishes to 
know whether the animal explores one chamber more than the 
other.

2. A second trial (5 min) is carried out with the empty tubes in the test 
chambers. The aim of this trial is to quantify the time spent in the 
two side chambers and near the tubes. 

3. In the third trial (next 5 min), an empty tube is removed and replaced 
by a female animal restrained in an identical tube. This session is 
designed to observe differences between the time spent sniffing the 
social versus non-social object.

Social discrimination test

For each test animal, three trials are carried out:

1. The first trial (10 min) is aimed at habituating the test individual to 
the chamber and empty tubes.

2. In the sociability test (next 10 min), an empty tube is removed and 
replaced by a female animal restrained in an identical tube. This 
session is designed to observe differences between the time spent 
sniffing the social versus non-social object. 

3. In the social discrimination test (10 min), the other empty tube is 
removed and replaced by a novel female. This session is designed to 
test the ability of the test animal to distinguish between the two 
females.

See also acquiring tracks on page 21.
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score behaviors manually

To score sniffing and other behaviors defined under Manual Scoring 
Settings, open the Manual Scoring tab on the Acquisition screen. There 
you find the key codes for the behaviors.

To score an instance of the behavior or its end, either press the key or 
click the corresponding button on the screen.

Notes

 important  If you do tracking from video, make sure you de-select 
DDS in the Playback Control window.

 You can also score behaviors after tracking. See Acquire Data > 
Score behaviors manually in the EthoVision XT Help.
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Data analysis

data preparation

Data editing

Choose Acquisition > Edit Tracks. You can fix tracking errors and swap 
back nose-points and tail-points that have been swapped in tracking. 
Normally you will not need to edit your data.

Smoothing data

Choose Acquisition > Track Smoothing Profile and open MDM Filter 0.2 
cm. In this profile, the Minimal Distance Moved filter is used with a 
value of 2 mm and option Direct.

Review video and behaviors

If you have scored behaviors manually, you can review the video and if 
necessary edit the data. Choose Acquisition > Score behaviors 
manually. For details, see Acquire Data > Score behaviors manually in 
the EthoVision XT Help.

analysis profiles

The template experiment contains four analysis profiles:

 Distance and velocity. For quantifying activity and exploration. 
Combine this with a Data profile that specifies Results per zone.

 In chambers. To calculate the time spent in each of the three 
chambers.

 Behaviors. To analyze behaviors scored manually (rearing and 
sniffing) or the time that the nose point was detected in the area 
around each cage (sniffing zone).
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 On cage. To calculate how often and how long the center point of 
the subject was found in the zone “cage” (left and right). This 
correlates with the time the mouse spent on top of the cages.

Add other analysis profiles according to your research questions. Click 
one of the buttons in the Dependent Variables pane and open the Trial 
Statistics tab to select which statistic to calculate. 

Example

The researcher wants to know the time from the moment the animal is 
entirely in the right compartment to the first moment the animal’s 
nose-point is close to the cage in the same compartment.

To calculate this time, in the Analysis profile choose Free Interval. 
Select an interval that goes from the time when the Current value of In 
zone, for zone Cage right, and for all body points, is “true” (Start 
criterion), to when the Current value of In zone for the zone “Interest 
zone right”, and for the nose point, is true (Stop criterion).

In the Statistics tab, select Cumulative duration.

For more information, see the EthoVision XT Help.
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visualizing data

Choose Analysis > Results > ...

 Plot tracks. You can view your tracks on a still image of the 
background. Tracks can be shown in different colors according to 
the values of independent variables (for example, blue for animals 
in Phase 2 and red for animals in Phase 3). Sample points can be 
shown in different colors according to the values of dependent 
variables, for example red when the animal was moving fast. 

 Plot integrated data. You can look at a track with the video file in 
the background. When you plot integrated data you can also view 
Time Event plots of your independent variables. Just like with 
plotting tracks, you can show tracks or sample points in different 
colors. 

 Plot Heatmaps. Make heatmaps of the location of your animals 
during the different trials. In the example below: Left heatmap: 
Cages empty. Right: mouse restrained in the Left cage (right cage 
empty).
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Introduction

measuring social interactions

The Social Interaction test is widely used as a rodent model of anxiety-
like behavior, under the assumption that anxiety is incompatible with 
social behavior (File and Hyde, 1978; File, 1980, 1988). So, an increase in 
anxiety generally results in a decrease in time spent on social 
interaction. The Social Interaction test is used to measure I) sensitivity 
to both anxiogenic and anxiolytic stimuli, ii) sensitivity to 
pharmacological, physiological and environmental manipulations and 
iii) ethologically relevant behaviors that do not require confounding 
manipulations such as food deprivation, pain or conditioned fear. Until 
recently, it has been difficult to automate the test with tracking 
systems. The features in EthoVision XT make this possible. This 
document describes the general procedure of how to do this.

In most cases for a social interaction test you need the Social 
Interaction module. This module allows you to track two or more 
subjects in one arena. This module also includes the Deep learning 
option for individual recognition in a 2-subject interaction test.

Here below you find an overview of the ways you can implement a 
social interaction test in EthoVision XT:

Sociability test (1-subject tracking)

If you intend to track a free-moving subject while a second subject is 
caged (social target) and barely visible from above, you can track only 
the free-moving animal and measure the behavior of that animal 
towards the cage defined as a zone. In that case you do not need the 
Social Interaction module. See The Sociability Cage Test on page 107. 

Social Interaction - with Deep learning-based recognition

This solution, new in EthoVision XT 18, is based on artificial intelligence 
which discriminates between two subjects in the arena. One of the two 
subjects must be marked, e.g. its back being partially shaved. For this 
solution you can use a monochrome digital camera.
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note  In order to apply artificial intelligence to animal tracking you 
need to have a compatible Graphics Processing Unit (GPU) installed on 
the EthoVision XT computer. See the EthoVision XT Help for more 
information. 

Social Interaction - marker-based tracking

This option assumes that you can color-mark your subjects that 
interact in the arena, and you have a color camera compatible with 
EthoVision XT. Most of this chapter is based on this solution.

Social Interaction - Live Mouse Tracker

With the Live Mouse Tracker add-on module you can import and 
analyze Live Mouse Tracker data. Live Mouse Tracker allows long-term 
analysis of behavior of socially-grouped mice. With Live Mouse Tracker 
you do not have to color-mark the subjects, however each subject must 
have a RFID chip implanted. For more information, see the EthoVision 
XT Help.

the sample experiment

To see an example of a social interaction test carried out in EthoVision 
XT, see also the sample experiment Social Interaction XT180 on the 
downloads section of the Noldus website (my.noldus.com). Download 
this file and save it on your computer. Next, in EthoVision XT, select File 
> Restore Backup and select this file. For more information, see the 
document Description of sample experiments of EthoVision XT.pdf.

references
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Physical setup

The following suggestions are aimed at optimizing video tracking of 
multiple, color-marked animals.

lighting conditions

 For general information on lighting condition, see the section 
Physical setup in the chapter The Open Field Test. 

 Use a sensitive camera if possible. A low light intensity makes it 
difficult to separate different colors. When it is not possible to use a 
sensitive camera or strong illumination in your setup, try using 
fluorescent marker colors with UV lighting.

 For optimal color separation, illuminate your setup with lamps that 
approximate to day-light in color temperature, that is, have a wide 
spectrum range.

marked vs. unmarked subjects

In some cases it is required that the identity of the animals that 
interact in the arena is known and followed, for example in resident-
intruder or male-female interactions, or whenever one need to 
separate behavioral endpoints (e.g. speed, zone visited) for each 
individual. In such situations, we recommend to mark the animals (see 
below). EthoVision XT can also track unmarked animals, however 
identity switches may occur. It is not guaranteed that the correct 
identity of each unmarked animal is kept throughout the trial.

Markers for when using the Deep learning technique

When using Deep learning, shave the back of one subject so that it 
looks different from the other. The shaved part should always be 
visible from the top. For more details, see the EthoVision XT Help.
7 -  The Social Interaction Test 123



124
Color marker characteristics

 Use a color scale (for example from a paint company) to find out 
which colors are most easily recognized by EthoVision in your setup 
and lighting conditions. Do this before applying color markers to 
your animals.

 Use colors that have different hue values (Figure 7.1). For example, 
use orange and green, pink and yellow, not red and orange. Avoid 
using red for marking, since it looks like blood.

 Note that marking your animals may stress them, and therefore 
affect their behavior. If necessary, ensure that you select a marking 
method that lasts for a longer period of time.

 Make sure that the marker is as round as possible, this will ensure 
that the relative movement of the center of gravity of the marker is 
the same in all directions when the edges of the marker change due 
to posture changes or otherwise.

 Make sure the marker is not too big; the marker can interfere with 
proper detection of the body contour. For example, make sure that 
a dark marker on a white animal does not cover the complete width 
of the animal because it can cause the body to be split in two 
(during tracking in EthoVision XT).

 See also Tips for Color Tracking in the EthoVision XT Help.

Figure 7.1  An example of color-marked rats in a social interaction test.
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The Social Interaction test in 
EthoVision XT

create an experiment

For Live Mouse Tracker

1. Choose File > New and in the dialog that opens select Live Mouse 
Tracker experiment. 

2. For the rest of the procedure, see the EthoVision XT Help.

For all the other cases

Choose File > New From Template and choose a predefined template in 
the guided setup. See below.

experiment settings

Choose Setup > Experiment Settings.

 Under Video Source, click the video icon in the camera row and 
adjust the camera settings if necessary.

 Under Subjects, specify the Subject roles (for example Resident or 
Intruder, or Subject 1 and Subject 2). Do not enter the ID of the 
individual animals.

 Under Tracked Features, select the option that corresponds to your 
needs. In most cases that is Center-point, nose-point and tail-based 
detection.

 Under Body Point Detection Technique, select Contour-based if you 
use color-marked animals, or Deep learning if your subjects look 
different (e.g. the back of one individual has been partially shaved).

note  You can use Deep learning to track two subjects per arena. 
The Deep learning technique works if you have a recent Graphics 
card and the driver is up to date.
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manual scoring settings

Choose Setup > Manual Scoring Settings.

Here you can define behaviors that you score manually, for instance by 
pressing a keyboard key. 

In the template experiment, two start-stop behaviors, Rearing and 
Grooming, have been defined. Define other behaviors if needed, for 
example Sniffing and Boxing.

For more information, see Set Up an Experiment > Manual Scoring 
Settings in the EthoVision XT Help.

trial control settings

Choose Setup > Trial Control Settings > New.

In the Trial Control Settings, define conditions for the start and stop of 
the track.

 Starting condition. For instance, 'Start tracking 5 seconds after both 
animals are detected in the arena'. If you are tracking live, this 5-
second delay enables you to put both animals in the arena and to 
take out your hand before tracking starts (5 seconds might not be 
enough; check beforehand how much time you need). 

tip  To make sure that tracking starts when both individuals are in 
the arena, not before, click Settings in the Condition box before the 
Start track box.Select Current Duration from the Statistic list, then 
click Settings and then Actors. Select both subject names and select 
All selected subjects from the list.

 Stopping condition. In order to be able to compare the tracks in the 
analysis, they must have the same length. Either define a 
Maximum Trial duration or a Stop track condition based on time 
(see the next figure).
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detection settings

Choose Setup > Detection Settings > Detection Settings 1. 

important Follow the instructions in the order described below! 

If you selected Deep learning in the Experiment Settings (page 125), set 
the sample rate (below), and skip the nest steps. The software is able to 
recognize the subjects automatically so you do not need to adjust 
subject contrast, size, contour filters etc. Go to trial list on page 131.

Sample rate

Click Video. Select a high sample rate: 25 (for PAL analog cameras) or 30 
(for NTSC analog cameras and digital cameras) samples per second.

Automated setup

Once the animals are in view, click Automated Setup. Select the type of 
animal you are going to test. Click Next and draw a rectangle around 
each subject. Make sure that you do this when the animal are not in 
close contact.

If detection of the subject is not optimal after using the Automated 
setup function, see Configure Detection Settings in the EthoVision XT 
Help for details on the advanced detection settings.

Subject Identification for color-marked subjects

If you mark animals with colors, under Subject Identification make sure 
that Marker-assisted identification is selected.

Figure 7.2  Trial control settings that specify a track duration of 10 minutes.
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1. Put the marked animals in the arena or play the video. Make sure to 
select a point in the video where the animals do not touch each 
other! Alternatively, place the animals in the arena one at a time.

2. In the Subject Identification section, select one of the subjects and 
click the Identification button. As a result, the Identification 
[Subject name] window opens.

3. Move the mouse pointer to the Video window so the pointer 
becomes an eyedropper. Move the eyedropper over the color marker 
of the subject you want to identify and click the left mouse button.

4. Fine-tune the color settings by adjusting the Hue, Saturation and 
Brightness in the Identification [subject role name] window. Change 
the range of color settings by changing the numbers or by resizing 
the Hue box on the vertical color bar, or resizing/moving the box in 
the color map (horizontally to adjust Saturation, vertically to adjust 
Brightness). As a result, the outline covers (almost) the complete 
marker (see Figure 7.3).

5. Next, play the video to see in the Video window whether the marker 
is detected correctly in different parts of the arena. If the marker 
'dances' then your color settings are too sensitive. Go back to step d 
and make the box larger.

6. When you are finished fine-tuning the color settings, you continue 
with setting the Minimal marker size: increase the Minimal marker 
size until, first, noise is not detected anymore and, second, the 
marker is not detected anymore (as a result, the outline in the Video 
window disappears). Now enter a value for the Minimal marker size 
that is somewhere in between.
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7. Click OK when you are done and repeat steps 1-6 for the other 
subjects.

For details, see Advanced detection settings for color marks in the 
EthoVision XT Help. 

Also watch the video Identification Settings in the EthoVision XT video 
tutorial.

Set the subjects' contrast

Make sure you have selected the correct contrast and check the 
following:

 When you use Static Subtraction or Dynamic Subtraction, move the 
slider to define the animal's contrast. The animal must be fully 
detected in all parts of the arena and the noise must be minimal. 
For Dynamic Subtraction, set the Current frame weight slider to a 
value between 1 and 5 to compensate for the changes in the 
background with time.

Figure 7.3  The color of the marker after fine-tuning the color settings. Most of 
the marker is now selected as indicated by the black outline.
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 When you use Differencing, adjust the position of the Sensitivity 
slider until the subjects are properly detected. From the 
Background changes list, select an option that reflects your 
conditions (usually, Medium slow works just fine).

Contour erosion/dilation

You need Contour erosion/dilation to get a smooth contour without 
the tail for accurate modeling and to remove individual pixels of noise.

To improve detection, open the Advanced section In the Detection 
Settings pane. Under Subject Contour, select one or more pixels for the 
first Erosion filter and the Dilation filter. Leave the second Erosion filter 
to zero. Increase the number of pixels for Erosion until the animal’s tail 
is removed, then increase Dilation until the entire animal’s body 
contour is detected.

Subject Size

Before you set the Subject Size, make sure the animals are properly 
detected and do not touch each other.

Click Subject Size, then click Advanced.

1. Under Modeled subject size, make sure the Apply to all subjects and 
Fix (for all subjects) options are selected.

2. Click the Grab button. This adjusts the Average size to the Current 
size.

3. Repeat clicking the Grab button, until the body fill completely fits 
the animal.

Shape stability and Modeling effort

The Shape stability setting is used when you track animals whose body 
can be occluded by, for example, cage bars or part of the body of 
another animal.

When you set the slider closer to Occlusions, EthoVision considers 
separate objects that are close together part of one animal. When you 
set the slider close to Noise, EthoVision considers separate smaller 
parts not part of the animal.
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The Modeling effort setting is used when two animals touch and 
EthoVision loses the separate shapes. At this point, EthoVision tries to 
determine which part of the big 'merged' blob belongs to either 
animal, using a lot of processor load in the process.

When you set the slider close to Performance, EthoVision is only 
allowed a short time to determine which part of the 'merged' blob 
belongs to which animal. Therefore, modeling quality is low. When you 
set the slider to Modeling, EthoVision is allowed a longer time to 
determined which part of the 'merged' blob belongs to which animal. 
Therefore, modeling quality is good, but this costs a lot of processor 
load. If you track from video, video tracking slows down.

trial list

Enter your independent variables such as rat ID, treatment (drug vs. 
control), dose, name of the experimenter, etc. If you want you can 
predefine all your trials here, or you can enter the independent variable 
values as you carry out the trials. You can also prepare the trials in Excel, 
randomize them and then paste the values into your Trial List.

Notes

 When using color markers, add a Marker color variable to the Trial 
List to specify the marker color you assigned to each Subject role. 
This is useful when you have defined, for example, the Subject 
name Experimental and Stimulus, or Subject 1 and Subject 2, and you 
have randomly assigned the marker colors to the Subject roles.

 Furthermore, you can define a series of trials for batch acquisition. 
See Acquire a series of trials in the EthoVision XT Help.
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Figure 7.4  An example of Trial List for a social interaction test.
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Carrying out your trials

protocol

Animals 

In many social interaction experiments, two animals from the same 
treatment group are tested together and scored as a single unit. 
According to Lapiz-Bluhm et al. (2008), this potentially can result in an 
artificial exaggeration of behavioral effects, that is, a treatment that 
only slightly impacts social behavior may have an apparently larger and 
more significant effect if the social behavior of both animals is 
affected. Their alternative approach test an experimental animal 
paired with a 'neutral' stimulus animal, whose behavior is as constant 
as possible. See The Sociability Cage Test on page 107.

Habituation

The experimental animals are gently handled for 2 minutes on each of 
3 days prior to the social interaction test. In addition, they are 
individually familiarized with the testing room and social interaction 
arena for 5 minutes on the 3 days prior to testing. The stimulus animals 
are habituated to the testing room and arena for 5 minutes per day for 
3 days prior to testing. The stimulus animals are pre-exposed to the test 
arena in pairs, with a different, unfamiliar other stimulus animal on 
each pre-exposure day.

When using color marks

To control for the effect that the color of the marker might have on the 
behavior of the other animal, it is recommended to randomly assign 
the marker color to stimulus and experimental animals. To take into 
account the combinations of animal type and marker color, you can 
either add a user-defined variable like Marker color to the Trial List or 
define two Detection Settings, one for each combination. In the latter 
case, make sure you set the appropriate Detection Setting as current 
before you start data acquisition.
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Social memory test (1-min confrontation)

1. Let the focal animal establish a home-cage territory (e.g. 5 days).

2. Introduce the stimulus female into the home cage of a male mouse 
for a 1-min interaction. 

At the end of the 1-min trial, remove the stimulus animal.

3. Repeat step 2 a number of times, with a 10-min inter-exposure 
interval.

4. “Dishabituation” trial: Introduce a different stimulus female to the 
same male mouse for one minute.

In EthoVision XT:

 If you use color markers, alternate different colors for the same 
subject (e.g. half resident mice marked orange, half marked green). 
If you use different colors for the resident animal, make different 
detection settings in such a way that Subject 1 is always the 
resident animal. Before acquisition, make sure that you use the 
detection settings that apply to that animal.

 Mark different types of trials with an independent variable in the 
Trial List. For example Type, with values C1, C2 ... for confrontation 
with the first stimulus female and D for the second stimulus 
female.

Scoring behaviors manually

If you want to score the subject’s behavior manually, define them first 
under Manual Scoring Settings (page 126). After you have started the 
trial, watch the subjects in the video and in the Manual Scoring tab at 
the bottom of the screen, click the button to the category that applies. 
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As soon as the behavior of the subject changes, click the button for the 
corresponding category.

For more information, see Acquire Data > Score behaviors manually in 
the EthoVision XT Help.
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Data analysis

data preparation

Track editing

Choose Acquisition > Edit Tracks. 

You can fix tracking errors and swap back nose-points and tail-points 
that have been swapped in tracking. Normally you will not need to edit 
your data.

Track smoothing

Choose Acquisition > Track Smoothing Profile > open MDM Filter 2 mm. 
In this profile, the Minimal Distance Moved filter is used with a value of 
2 mm and option Direct selected.

Review video and behaviors

If you have scored behaviors manually, you can review the video and if 
necessary edit the data. Choose Acquisition > Score behaviors 
manually. For details, see Acquire Data > Score behaviors manually in 
the EthoVision XT Help.

Selecting data

Choose Analysis > Data Profile. 

You can select (Filter) your tracks according to your independent 
variable values (for example, Treated animals vs. Controls) and also 
select parts of tracks (Nesting). Figure 7.5 shows a data selection to 
compare Treated and Control animals. This way you create groups of 
tracks to obtain group statistics for each group.

To create a group, click the button next to Common elements - Result. 
Connect the Start box to the new Result box. This creates a new group. 
Next, to specify a criterion for the new group, click an option under 
Filter, and insert the resulting Filter box between Start and the new 
Result box.
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analysis profiles

The template experiment contains a number of analysis profiles, 
depending on which arena / zone template you selected in the 
template wizard:

 Distance & Time – With the variables Distance Moved and Velocity, 
the total distance moved and the mean velocity are calculated.

 Movement – The variable Movement calculates how often and how 
long the center-point was moving.

 In zones – The variable In zone calculates how often and how long 
the subjects visited each zone in the Arena Settings. The latency to 
the first visit in a zone is also calculated for each subject. 

Figure 7.5  A data profile to compare tracks of Treated animals and Control 
animals.
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 Behaviors – In this analysis profile, the frequency and duration of 
Body elongation and the manually scored behaviors Rearing and 
Grooming are calculated.

For all statistics also the group means with standard errors are 
calculated.

social interaction in detail

The following variables are commonly used to study social 
interactions:

 Distance between subjects – Use this dependent variable to 
measure the average distance between the subjects. 

You can also use this dependent variable to determine the 
appropriate thresholds for the dependent variable Proximity.

 Proximity – When the nose-point of the experimental animal is In 
proximity relative to any of the body points of the stimulus animal, 
the experimental animal can be considered to be exploring or 
sniffing the other animal.

 Body contact – You can use this variable to quantify body contact, 
for example how often and for how long two animals are in contact 
with one another. 

 Relative movement – Use Relative movement to determine how 
much time the experimental animal is actively seeking contact 
with the stimulus animal.

 Net weighted movement – Net Weighted movement can be used 
as an objective measure for the intensity of approach and 
avoidance behavior.

 Weighted movement from – Weighted movement from can be 
used as an objective measure for the intensity of avoidance.

 Weighted movement to – Weighted movement to can be used as 
an objective measure for the intensity of approach.
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 JavaScript state variables - Additional variables in JavaScript code 
are available to quantify social approach, leaving, social contact and 
following behaviour. You can find those variables on the 
installation package under Utilities > JavaScript custom variables, 
also available on my.noldus.com or on the GitHub repository.

https://github.com/noldus/EthoVision-JavaScriptCustomAnalysis

See Dependent Variables in Detail in the EthoVision XT Help for details. 
Also see the analysis profile ‘Social - Nose to Tail’ in the sample 
experiment Social Interaction XT180 which you can download from our 
web site.

statistics and charts

Choose Analysis > Results > Statistics & Charts, then click Calculate.

The Trial Statistics tab shows the results per trial. The Group Statistics 
tab shows the statistics and charts from the summarized results over 
all trials or the groups defined in your Data profile (see page 136). 

visualizing data

Choose Analysis > Results > Plot Integrated Data. 

Select a trial from the list on the tool bar. The video file and the Time 
Event Plot are displayed. You can select other data/analysis profile 
combinations from the lists on the tool bar. 

Choose Analysis > Results > Plot Heatmaps. 

There you can make heatmaps of the location of your animals during 
the test.
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Introduction

the radial arm maze test

The radial arm maze was designed to measure spatial learning and 
memory in rats (Olton and Samuelson, 1976; Olton, 1978, 1985). The 
original apparatus consists of eight arms, each about 4 feet long, and 
all radiating from a small circular central platform. At the end of each 
arm there is a food site, the contents of which are not visible from the 
central platform.

The design ensures that, after checking for food at the end of each arm, 
the rat is always forced to return to the central platform before making 
another choice. For example, when investigating working memory, all 
arms are provided with a food reward and the animal should visit each 
arm only once. 

Correct performance of the radial maze task requires intact spatial 
memory abilities. Performance is affected by hippocampal impairment 
and a variety of pharmacological agents (e.g., Janitzky et al. 2011).

Figure 8.1  Example of an 8-arm radial maze.
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Physical setup

The following suggestions are specifically to optimize video tracking:

 The camera should have a good view of the entire region the 
animal can be in. The arena should fill the field of view.

 There must be maximum contrast between the background and 
the animal. If you use white animals in the maze, make sure the 
floors of the arms are dark and vice versa. Preferably, the floor of 
the room should be the same color (and matted) as the maze, 
contrasting with the animal.

 Lighting should be uniform and even with no shadows.

 If you have reflections in your image, EthoVision XT may confuse 
those reflections with your subject, and track the reflections rather 
than your animal. To prevent reflections, place indirect lighting 
above or around the maze. 'Globe' type bulbs twice the diameter as 
standard light bulbs are ideal. They should be close enough to the 
maze so that there is no direct line of sight between the bulbs and 
the camera lens. The light should reflect off the walls and ceiling, so 
that it only reaches both the lens and radial maze indirectly.
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The Radial Arm Maze test in 
EthoVision XT

In EthoVision XT, you can set up a radial 8-arm maze experiment by 
using a predefined template in the guided setup. 

Create an experiment. For details, see Chapter 1 of this manual, or see 
Setup an Experiment in the EthoVision XT Help.

experiment settings

1. Make sure that the radial maze is connected to the EthoVision XT 
computer.

To connect the radial maze to EthoVision XT, you must have the 
Trial and Hardware Control add-on and the USB-IO box. The 
procedure and the necessary cabling may differ between 
manufacturers of the radial maze. Please see the accompanying 
documentation.

2. Choose Setup > Experiment Settings.

3. Under Video Source, and Tracked Features, make sure that the 
options selected corresponds to your needs. To adjust the camera 
settings, click the video icon in the camera row.

4. If you want to use Deep learning technique to track the subject’s 
nose, under Body point detection technique choose Deep learning. 
Note that in order to use this technique there are additional 
requirements. Among other things, you need a powerful graphics 
card. See Deep learning: Requirements and Limitations in the 
EthoVision XT Help.

5. Under Trial Control Hardware, select Use of Trial Control Hardware 
and click Settings. Select Noldus USB-IO box.

6. In the Device Configuration window, for TTL ports 1 to 4, under 
Device type, select Custom Hardware. Next, type in Doors1&2 for TTL 
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Port 1, Doors3&4 for TTL Port 2, Doors5&6 for TTL Port 3 and 
Doors7&8 for TTL Port 4.

arena settings

Choose Setup > Arena Settings > Open Arena Settings 1.

1. In the Grab Background Image window, click the Grab button to 
grab a background image of the radial maze from the camera 
image.

2. Click 1. Draw Scale to calibrate and calibrate your arena. For details, 
see Make the arena in the EthoVision XT Help).

3. Click 2. Select Shape and Draw Arena and check that the predefined 
arena has the correct shape and size. If necessary, adjust the contour 
of the arena to fit the radial maze.

4. If you used the Zone template, click 3. Select Shape and Draw Zones. 
Check that the zones have the correct shape and size. If necessary, 
resize or add new zones.
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5. If you are using automated doors, click Arena - Hardware mapping in 
the Arena Settings window to assign the doors to the arena.

trial control settings

In the Trial Control Settings you can define conditions for the start and 
stop of the track.

Choose Setup > Trial Control Settings > Open one of the following:

 Default (no max duration) - When you use this profile, tracking 
starts automatically 2 seconds after the animal has been placed in 
the Center zone. Tracking stops manually (for example when you 
click the Stop trial button). 

 Track duration 10 min – When you use this profile, tracking starts 
automatically 2 seconds after the animal has been placed in the 
Center zone. The track stops automatically when 10 minutes have 
elapsed since the start of the track.

Controlling automated doors

If you want to control the automated doors with EthoVision XT, you 
need to create new Trial Control Settings. 

An example of Trial Control Settings for a protocol as described in Unit 
8.5A of Current Protocols in Neuroscience (2004) to test basic working 
memory is the following:

 Start condition. We assume that the animal is released in the 
Center zone with all doors closed. Tracking starts 3 seconds after 
the animal is put in the Center zone.
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 Opening all doors simultaneously. You can create a Sub-rule with a 
Reference for this. In the Sub-rule, each door is opened. For each 
door, you need to create a separate Hardware Action box, with the 
corresponding Device name (‘1&2’) and appropriate Action (‘Output 
1 High’ which opens door 1. The figure below shows part of the 
sequence of Sub-rule ‘open beginning’ in which doors 1-3 are 
opened.

The figure below shows the Reference box to the Sub-rule. The 
reference is activated immediately after the Start trial command.

 Closing and then opening all doors. When the animal has visited the 
Goal zone of one of the arms and returns to the Center zone, all 
doors are closed and re-opened after 5 seconds.
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You can create a Sub-rule with a Reference for this. In the Sub-
rule, you need to create a Zone transition Condition for each arm 
separately. Next, all these 8 Zone transition Conditions need to be 
connected to an Operator ‘Any input True’.

The figure below shows part of the sequence of the Sub-rule 
‘open close Center’. Here you see the Zone transition Conditions 
for arms 1 and 2. The Zone transitions Conditions of all 8 arms are 
connected to the Operator ‘Any input True’.

Next, with a Hardware Action box, all 8 arms are closed. The 
figure below shows an example of closing door 4. Put the 
Hardware Action box for all doors in a sequence similar to opening 
doors as described in step 1 above.
8 - The Radial Arm Maze Test



 Stop condition. The trial stops when the animal has visited the Goal 
zones of all 8 arms OR after 15 minutes have elapsed since the start 
of tracking.

For the first criterion (the animal visits the Goal zone of all arms) 
you use an In Zone Condition for each Goal zone. All eight In Zone 
Condition boxes are connected to the Operator ‘Num 
simultaneously True inputs’. The figure below is an example and 
contains only two of the eight In Zone Goal zone Condition boxes.

For the second criterion (after 15 minutes) you need a Time 
Condition box as shown in the figure below. 

The two criteria must be combined with OR logic. The Time 
Condition box and the ‘Num simultaneously True inputs’ Operator 
box are connected to a ‘Any input True’ Operator box (see figure 
below. In this example sequence, an extra delay of 3 sec is 
included before the trial stops).
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detection settings

Choose Setup > Detection Settings > Detection Settings 1.

We assume you followed the procedure on page 17.

Advanced detection settings

1. Under Video, check that the sample rate is set to 25 or 30 samples/
second for multiple body-point tracking.

2. Click Advanced.

3. Under Method:

By default, Static subtraction is selected as the detection method 
and Rodents / Default as the method for nose-tail detection. The 
background in a radial maze test usually does not change much, 
so Static subtraction usually works well. Make sure the lighting is 
even and there are no shadows in the maze.

If after running some test trials, you get nose-tail swaps, try using 
the tracking method Rodents / For occlusions.

If you selected to use the Deep learning technique to track the 
subject’s nose, next to Deep learning click Define and select a box 
around the subject. Make sure that the box includes the 
subject’s nose. For details, see the EthoVision XT Help.

4. optional  Select Track noise reduction. Under Smoothing, set Track 
noise reduction to On.

In some cases better quality tracking can be obtained by reducing 
track noise during acquisition. This may especially be the case if 
you use Trial and Hardware Control. As an example, if the center 
point of an animal is detected in the center-zone of the maze, you 
want specific doors to open followed by the closing of doors as 
soon as the animal enters one of the arms. If the detected center 
point is moving rapidly because of noise, this may result in a doors 
opening and closing, every time the center point crosses the 
border of the zone. Track noise reduction may solve this problem.

5. Under Subject size, click Advanced and set a minimum subject size 
to prevent droppings from detected.
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trial list

Enter your independent variables such as Animal ID, Treatment, Baited 
arms, Name of the experimenter, etc. (for blind trials, enter only the 
Animal ID). If you want, you can predefine all your trials here, or you can 
enter the independent variable values as you carry out the trials. You 
can also prepare the trials in Excel, randomize them and then paste the 
values into your Trial List.

Furthermore, you can define a list of trials for batch acquisition. See 
Acquire a series of trials in the EthoVision XT Help.

Baited arms

To mark the trials with the arms that were baited, create an 
independent variable Baited arms of text type, and define the various 
combinations as Predefined Values: for example, 1-3-6-8, 1-3-5-7, etc. For 
each subject to be tested, assign the correct value in the appropriate 
cell of the Baited arms column. 

Figure 8.2 The predefined Trial List in the radial 8-arm maze template experiment.
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Acquiring data

protocol

The following protocol tests for basic working memory (the subject 
learns not to re-enter a baited arm).

Habituation (pre-training)

In a typical radial 8-arm maze test, first a pre-training session is carried 
out in which the animal is allowed to freely visit all arms for 10 to 15 
minutes per day. Also, the doors are regularly opened and closed to 
habituate the animal.

Training trials

In this phase, the animal is exposed to where the food is, and this is 
what the later tested memory is based on. Animals are trained one 
session per day, for approx. one week.

Typically, all arms are baited in this phase. At the start of the trial, the 
animal is placed it the center of the maze, facing the same direction on 
every trial, everyday.

Stop the trial when (a) all eight arms have been visited; (b) 10 minutes 
passed since the start of the trial; or (c) 2 minutes since the animal’s 
last arm entry.

Performance

Among the variables commonly used for the analysis of the 
performance are (a) the number of errors in each session (entering an 
arm that has been visited previously counted as an error) and the total 
number of errors across eight sessions, and (b) the number of correct 
choices in the first eight arm entries of each session. See Data analysis 
on page 154.
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Reference memory errors

While the previous protocol is primarily sensitive to impairments in 
working memory, an alternate protocol allows a disassociation to be 
achieved between working and reference types of memory.

In this protocol, four arms are baited for the training phase. The same 
maze arms are baited each day and, across sessions, the animal learns 
to ignore the other arms, which never contain a reward. This is the 
reference memory component of the task. In the test phase, food items 
are placed in the same arms as they were on the memory trials that 
day. It is recorded when the animal gets 100% correct on his memory 
trials. When the animal enters an arm that is not baited, it is marked as 
an error.

See Wenk, G.L. (2004). Current Protocols in Neuroscience, 8.5A.1-8.5A.12.
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Data analysis

data preparation

Track editing

Choose Acquisition > Edit Tracks. 

You can fix tracking errors but normally you will not need to edit your 
data.

Track smoothing

Choose Acquisition > Track Smoothing Profile > open one of the two 
Track Smoothing Profiles:

 No filter.

 MDM 0.2 cm – In this Track Smoothing Profile, the Direct Minimal 
Distance Moved filter is used, with an MDM of 0.2 cm.

Use Smoothing when you want to eliminate small movements, such as 
body wobbling during locomotion, that might affect dependent 
variables such as total distance moved.

Selecting data

Choose Analysis > Data Profile. 

The template contains two data profiles:
 All Data – This data profile contains all data.

 Treated vs. Control – This data profile contains two Results 
containers with data for the treated animals and the control animals 
(see also trial list on page 151). This way you create groups of tracks 
to obtain group statistics for both groups. 
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analysis profiles

Default analysis profiles

The template experiment contains three analysis profiles:

 Distance and Velocity – In this profile, the total Distance Moved 
and the mean Velocity are calculated for the center-point.

 In Zones – In this profile, the Frequency, Duration and Latency to 
First for all zones (arms and goal zones, see also arena settings on 
page 145) are calculated for the center-point. A visit to a previously 
chosen arm is considered a working memory error. Normal healthy 
young rats will perform this task almost perfectly every time, so 
will visit each arm and goal zone only once.

 Zone transitions – In this profile, the Frequency of zone transitions 
from the center zone to any arm is calculated for the center-point.

For all statistics also the group means with standard errors are 
calculated.

testing working memory

Time taken to obtain all rewards

The most basic test conducted using the radial-arm maze is to bait the 
ends of all of the arms with the reward and record the time taken to 
obtain all the rewards. The following procedure applies to trials where 
all baited arms were visited.

1. In the Analysis profile, choose Target visits and errors.

2. In the Target zones box, select all the zones that were baited.

3. Under Calculate Statistics for, select Target first visits.

4. Click the Trial Statistics tab and select Latency to Last.

Incorrect arm choices

To obtain a reward, an animal must remember which arm(s) it visited 
previously and not re-visit those arms. 
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1. In the analysis profile, choose Target visits and errors. 

2. In the Target zones box, select all the zones that were baited.

3. Under Calculate Statistics for, select Target revisits.

4. Click the Trial Statistics tab and select Frequency.

Percentage of correct choices

One of the parameters described in the Unit 8.5A of Current Protocols 
in Neuroscience (Wenk, 2004) to calculate performance of all groups is: 
The percentage of correct choices made in each test session in relation to 
the total number of arms entered.

1. In the analysis profile, choose Target visits and errors. 

2. In the Target zones box, select all the zones that were baited.

3. Under Calculate Statistics for, select Target first visits and Target 
revisits.

4. Click the Trial Statistics tab and select Frequency. 

5. You can calculate the percentage of correct choices with:

Target first visits /(Target first visits + Target revisits)*100.

Where the statistics given by EthoVision XT are shown in italics.

testing reference memory

The radial-arm maze may also be used to test reference memory by 
only baiting some arms of the maze. In training trials, the reward is 
placed consistently from trial to trial for the same animal, but its 
placement is varied from animal to animal. In the test trials, the time to 
acquire the reward and the number of incorrect choices (i.e., entering 
an unbaited arm or re-entering a baited arm) are analyzed.

Time taken to obtain the rewards

1. In the analysis profile, choose Target visits and errors. 

2. In the Target zones box, select all the zones that were baited.
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3. Under Calculate Statistics for, select Target first visits.

4. Click the Trial Statistics tab and select Latency to Last.

Number of entries into unbaited arms

1. In the analysis profile, choose Target visits and errors. 

2. In the Target zones box, select all the zones that were baited.

3. Under Calculate Statistics for, select Not-target first visits and Not-
target revisits.

4. Click the Trial Statistics tab and select Frequency.

note  Re-entries into baited arms are considered working memory 
errors.

Because the arms chosen to be baited differ between animals, make 
copies of the dependent variable Target visits and errors and edit the 
arms that are considered targets. Rename the variables (right-click the 
variable name and select Rename) and give them logical names (e.g. 
Baited arms 1-3-6-8).

In the analysis results, locate the variable that applies to specific 
subjects. 

To easily locate which subjects were assigned to which baited arms in 
your results table, create an independent variable in the Trial List, 
which specifies which arms were baited (see page 151). This variable can 
then be included in the results table (in the Statistics and Charts 
screen, choose Show/Hide > Independent Variable).

integrated visualization

Choose Analysis > Results > Plot Integrated Data.

Select a trial from the list on the tool bar. Choose a data profile and an 
analysis profile from the tool bar.
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heatmaps

Choose Analysis > Results > Plot Heatmaps. Next, click Plot Heatmaps.

Use heatmaps to visualize the location of the subject during the test.

calculating statistics

Choose Analysis > Results > Statistics & Charts. Select an analysis 
profile from the list on the tool bar, then click Calculate.

Choose Analysis > Export > Statistics.

Choose whether you want to export the statistics per trial, or the 
combined statistics of groups of trials. 

Figure 8.3  Heatmap of a 1-minute trial in a radial maze.
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Introduction

the porsolt forced swim test

The Porsolt Forced Swim Test (Porsolt et al., 1977; Hédou et al., 2001; 
Juszczak et al., 2008) is the most commonly used test for assessment of 
depression in animal models. In the Porsolt test, a state of depression is 
induced by forcing a rodent to swim in a narrow cylinder or water tank 
from which it cannot escape.

 
The procedure is generally divided into a pre-test session lasting 15 
minutes, followed 24 hours later by a 5-minute test session. After a 
period of vigorous activity in the pre-test session, the animal adopts a 
characteristic immobile posture. Twenty-four hours later, after 
administration of antidepressants, the effect on immobility can be 
investigated by measuring the time of being immobile in the test 
session and comparing this with control animals.

Figure 9.1  A Porsolt forced swim test carried out in EthoVision XT.
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the sample experiment 

To see how a Porsolt forced swim test is carried out in EthoVision XT, 
see the sample experiment Porsolt Forced Swim test XT180 on the 
downloads section of the Noldus website (see my.noldus.com). 
Download this file and save it on your computer. Next, in EthoVision XT, 
select File, Restore Backup and select this file. See also the document 
Description of sample experiments of EthoVision XT.pdf for more 
information.
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Physical setup

The following suggestions are meant to optimize the quality of 
tracking.

Camera view

The camera should have a good, frontal view of the entire region the 
animals can be in. The complete body of the animal should be visible.

Number of animals

You can test two or more animals simultaneously, when the Porsolt 
cylinder fit in the same camera view. For tracking multiple animals you 
need the Multiple Arenas add-on module.

Contrast

 Try to create as much contrast as possible between the animal and 
the background. This can be done by placing the cylinder or tank 
against a contrasting, non-reflecting background (so, a matt black 
background for white animals and vice versa). 

 You can also use back-lighting to create maximum contrast. In this 
case, make sure you place a screen or curtain between the lights 
and the cylinders to avoid reflections.

Figure 9.2  Backlighting allows to improve contrast between animal 
and background, and minimize reflections. 
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Water surface

You can reduce the contrast due to the water surface by placing the 
cylinders in a bigger tank with the water surface of the tank above 
those of the cylinders.

Figure 9.3  Place the Porsolt cylinder in a water tank to remove or minimize the 
image of the water surface inside the cylinder. 
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The Porsolt Forced Swim test in 
EthoVision XT

Create an experiment. For details, see Chapter 1 of this manual, or in 
EthoVision XT press F1 and see Setup an Experiment in the EthoVision 
XT Help.

experiment settings

Choose Setup > Experiment Settings.

Under Video Source, and Tracked Features, make sure that the options 
selected corresponds to your needs. To adjust the camera settings, click 
the video icon in the camera row.

Under Analysis options select Activity analysis. Click the video button 
next to it and watch the video tutorial to learn about Activity analysis. 
Activity is a useful feature that helps you detect changes in the 
movement patterns of the subject.

manual scoring settings

EthoVision determines the behavior of your subjects automatically on 
the basis of the intensity of the subject’s movement (see determining 
mobility thresholds on page 171). This means that you do not have to 
manually score the subject’s behavior manually. 

However, if you want to compare the data scored by EthoVision XT with 
your own ratings, define behavioral categories under Manual Scoring 
Settings (see below). Next, during acquisition watch the video and 
score those categories during your trial. You can also edit the data after 
acquisition.

Procedure

Choose Setup > Manual Scoring Settings.
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1. To add a behavior, click the Add Behavior button. Enter a name for 
that behavior (for example, Struggling) and specify Mutually 
exclusive as Behavior type. Specify the name of the behavior group 
(for example, Behavior Categories).

2. Add the remaining behaviors to the same group.

Notes

 We advise you to create three categories for scoring the animal’s 
mobility levels, which correspond to the three possible states of the 
Mobility dependent variable in EthoVision XT:

- Immobile (corresponding to EthoVision XT’s Immobile state);

- Swimming (corresponding to Mobile);

- Struggling/Climbing (corresponding to Highly Mobile)

 See score behaviors manually on page 170.

arena settings

1. Choose Setup > Arena Settings > Open Arena Settings 1.

2. Click 2. Select Shape and Draw Arena and check that the pre-defined 
arenas have the correct shape and size. If necessary, adjust the 
contour of the arena to fit the cylinders.

important  If you work with multiple cylinders and use Activity 
analysis to quantify the animals’ behavior, make sure that the 
arenas have the same size (you can check this under Shape Size and 
Position in the Arena Settings window).

3. Click 3. Select Shape and Draw Zones. Check that the zones (if you 
used a Zone template) have the correct shape and size. If necessary, 
draw additional zone groups/zones.

For details, see Arena Settings in the EthoVision XT Help.
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trial control settings

Choose Setup > Trial Control Settings > Open one of the following:

 Default. In this profile, tracking starts 1 second after the animal has 
been detected in the arena. Tracking stops manually (for example 
when you click the Stop trial button). 

 Max Track Duration 15 mins. In this profile, tracking starts 1 second 
after the animal has been detected in the arena. Tracking stops 
automatically after 15 mins or when the animal has been in the 
Diving zone for over 1 second. You can use these Trial Control 
Settings for the pre-test session (See protocol on page 170).

If you need more time to put an animal in its cylinder, increase the 
number of seconds. This way you prevent that detection of your 
hand or arm starts tracking. The Start Condition works 
independently for each cylinder.

Figure 9.4  Example of Arena Settings for the Porsolt Swim test with two arenas.
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 Max Track Duration 5 mins – This profile is similar to the previous 
one, but now the maximum tracking duration is 5 minutes. You can 
use these Trial Control Settings for the test session.

When you work with multiple arenas, trial control is applied to each 
arena separately. Therefore, tracking may start at different times in 
different arenas, depending on when the animal is released.

detection settings

Important note

It is important for stable detection, that the extremities of the animal 
(paws and tail) are either always included with the tracked body or 
always excluded from it. If the paws and tail are temporarily excluded 
and then included again in the detected subject during data 
acquisition, these changes affect the variables Mobility and 
Movement, while the animal might not actually be mobile or moving. 
On the other hand, the variable Activity is not affected by such 
changes, because it is based on the image change in the whole arena, 
not the change in the detected subject.

Detection Settings

1. Choose Setup > Detection Settings > Detection Settings 1.

2. Under Video, choose a Sample rate of 5 (for rats) or 12.5 samples/
second (for mice) or higher.

3. Click Advanced.

4. Under Method, choose Dynamic subtraction.

Under Detection, check you selected the correct contrast. Move the 
slider to define the animal's contrast. The animal’s body must be 
fully detected in all parts of the arena and the noise must be 
minimal. Set the Current frame weight slider to a value between 1 
and 5 to adjust the number of past images that contribute to the 
reference image.
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5. If the limbs and the tail are not included in the detected body, and 
you want to include them, under Subject Contour select the Dilation 
filter, then the second Erosion filter. Leave the first Erosion filter to 
zero. Adjust Dilation and Erosion to achieve stable detection.

6. Under Subject Size, click Edit. Define a Minimum Subject size to 
prevent small objects like droppings from being detected.

7. If you intend to use Activity analysis to score the behavior of the 
subject automatically, click Activity. Enter the Activity threshold for 
detecting a change in the pixels in the arena. Start with the default 
value and check the purple-colored pixels in the video image. Adjust 
the threshold in such a way that when the animal is immobile, those 
pixels are almost completely absent.

Set Compression artifacts filter to On if you work with pre-recorded 
video.

trial list

Choose Setup > Trial List.

Enter your independent variables such as rat ID, Session type (with 
values Pretest or Test), Treatment (with values Drug vs. Control), Dose, 
Time of drug administration, Name of the experimenter, etc. For 
variables which differ between subjects, select Subject as a Scope.

If you want you can pre-define all your trials here (click the Add Trials 
button), or you can enter the independent variable values as you carry 
out the trials. You can also prepare the trials in Excel, randomize them 
and then paste the values into your Trial List. 

Furthermore, you can define a list of trials for batch acquisition. See 
Acquire a series of trials in the EthoVision Help.
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Figure 9.5  A trial list with four planned trials. Each trial includes two arenas, 
and therefore two subjects. 
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Acquiring data

protocol

Basic protocol (rats)

 Pre-test trial (day 1, before drug administration). The animal is 
placed in the cylinder for 15 minutes. No scoring of immobility is 
performed during the first session. This session is needed to 
acclimatize the rats to the experimental situation and to induce a 
stable, high level of immobility during the test session.

 Test (day 2). After drug administration, the animal is placed in the 
cylinder for 5 minutes. Score the duration of immobility by 
summing the time spent immobile; score as immobile minor 
movements strictly necessary to maintain the animal’s head above 
water. 

Alternate protocol (mice)

The mouse is placed in the cylinder. The trial lasts 6 minutes. Measure 
the latency to immobility from the start of the trial and the duration of 
immobility for the last 4 minutes.

See Castagné et al. (2011). Current Protocols in Neuroscience 8.10A.1-
8.10A.14.

See acquiring tracks on page 21.

score behaviors manually

If you want to score the subject’s behavior manually, define them first 
under Manual Scoring Settings (page 164). After you have started the 
trial, watch the subjects in the video and in the Manual Scoring tab at 
the bottom of the screen, click the button to the category that applies. 
As soon as the behavior of the subject changes, click the button for the 
corresponding category.
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Notes

 important  If you do tracking from video, make sure you de-select 
DDS in the Playback Control window.

 You can also score behaviors after tracking. See Acquire Data > 
Score behaviors manually in the EthoVision XT Help.

determining mobility thresholds

To find the optimal Highly mobile and Immobile thresholds, you can 
run a few test trials and check in the Analysis Results and Scoring pane 
(Dependent Variables tab) the values for Mobility state in relation to 
the behavior the animal displays. If the Mobility states do not 
correspond to the behavior of the animal, in the Analysis Results and 
Scoring pane click Dependent Variables (see figure below), click the 
button under Mobility state and adjust the Highly mobile threshold 
and Immobile threshold.

For example, if the animal is struggling, its corresponding Mobility 
state is Highly mobile. If the current Mobility score is Mobile or 
Immobile, you probably need to reduce the Highly mobile threshold.

Note that you can also adjust the Mobility thresholds after acquisition. 
in the Analysis profile, add the Mobility state variable (see page 175), 
and visualize the data.

Figure 9.6  During acquisition, you can check the values of any dependent 
variable in real-time. In this example, Mobility and Mobility state have been 
chosen. Mobility state has three possible states, Immobile, Mobile and Highly 
mobile, depending on where the value of Mobility lies relative to some user-
defined thresholds. In Arena 1, the animal is struggling and the current value of 
Mobility is about 14%. In order to score struggling as “Strongly mobile”, set the 
Highly mobile threshold to, for example, 12%. 
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If you do not see the Mobility state variable on your screen, click Show/
Hide on the toolbar and select Show Dependent variables, then 
Mobility state and Mobility.

determining activity thresholds

In the same way as you defined thresholds for Mobility state, you can 
define thresholds for Activity state. Use Activity state if Mobility state 
does not give satisfying results, for instance when detecting thrashing 
of the animal’s limbs which may not be detected properly by Mobility.

Note that when you work with multiple cylinders in the same video 
image, Activity state gives good results when the size of the arena is 
the same for all cylinders. In the Arena Settings, adjust the contour of 
the arenas to make them similar.
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Data analysis

data preparation

Track editing

Choose Acquisition > Edit Tracks. 

You can fix tracking errors but normally you will not need to edit your 
data.

Track smoothing

Choose Acquisition > Track Smoothing Profile > open MDM 0.2 cm. In 
this profile, the Minimal Distance Moved filter is used (option set to 
Direct, with a threshold of 2 mm). This filter filters out small 
movements which result from system noise.

Note that smoothing influences the track, that is, the coordinates of 
the center point of the subject, not the subject’s detected area, and 
therefore does not influence the calculations of Mobility. It also has no 
effect on Activity analysis.

Review video and behaviors

If you have scored behaviors manually, you can review the video and if 
necessary edit the data. Choose Acquisition > Score behaviors 
manually. For details, see Acquire Data > Score behaviors manually in 
the EthoVision XT Help.

Selecting data

Choose Analysis > Data Profile. 

You can select your tracks according to your independent variable 
values and also select parts of tracks (nesting). You can also create 
groups of tracks to obtain group statistics for each group. Figure 9.7 
shows an example of a Data Profile to compare the animals that were 
treated with a drug, with those that were treated with saline. 
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integrated visualization

Choose Analysis > Results > Plot Integrated Data. 

Select a trial from the list on the tool bar. The video file and the Time 
Event Plot are displayed. 

In the Time Event Plot tool bar you can choose which profiles to use for 
display of the variables. Figure 9.8 shows how variables are visualized 
in the sample experiment Porsolt Forced Swim Test XT180 with the 
Analysis Profile Mobility_10 containing the variable Mobility. 

Play the video and check whether the states scored under Mobility 
state correspond to the behavior of the animal. If they don’t, fine tune 
the Mobility (or Activity) thresholds in the Analysis profile (see page 
175). Then, check the results of your changes again in the Integrated 
Visualization.

Figure 9.7  An example of data selection to compare two data sets in your 
experiment.
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analysis profile

Mobility analysis

In an Analysis Profile, you select the dependent variables and statistics 
for analysis. For the experiment made with the template for the Porsolt 
Test, a dependent variable Mobility is already present.

Choose Analysis > Analysis Profile > Open > Mobility.

1. Double-click the row for the Mobility state variable.

2. Under Outlier filter, the Averaging interval is the number of samples 
on which the running average mobility is based. With an Averaging 
interval of 1 sample, sudden changes in surface area caused by 
reflections are not filtered out.

Figure 9.8  The Plot Integrated Data screen for the Analysis profile ‘Mobility_10’ 
in sample experiment Porsolt Forced Swim Test XT180. The plot shows the 
variables Mobility (line plot) and the duration of Mobility state (colored bars) for 
both animals (here indicated as Arena 1 and Arena 2). The vertical line shows the 
current position in the Time Event Plot and the video window displays the 
corresponding frame. You can use this function to fine tune the Mobility state 
thresholds and detect the behaviors you are interested in. 
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3. Under Threshold, set the Highly mobile and Immobile thresholds to 
the values you have previously determined (see determining 
mobility thresholds on page 171).

4. Under Calculate statistics for, select the states you want analyze.

5. Click the Trial Statistics tab and select Duration and Frequency. 
Optionally select additional statistics in the Group statistics tab. 

6. Click OK.

Comparing EthoVision Mobility data with your ratings

If you have scored the animal’s behavior manually, you can easily 
compare your data with those scored by EthoVision (Mobility). Make 
sure that your analysis profile includes the three Mobility states and 
the behaviors scored manually, then visualize the data. 

If the EthoVision data do not match your ratings at an acceptable level, 
adjust the Mobility threshold values in acquisition (page 171) and in 
analysis (see above).

An alternative to Mobility analysis

You can use Activity state if the Mobility state variable does not give 
good results, for instance when detecting thrashing of the animal’s 
limbs which may not be detected properly by Mobility state.

Activity analysis is based on the temporal change in pixel value in the 
whole arena. Because it is not based on the detected animal’s surface 
area, it is independent of tracking.

1. In the Experiment Settings, under Analysis options select Activity 
analysis. Click the video button next to it and watch the video 
tutorial to learn about Activity analysis.

2. In the Detection Settings, click Activity. Enter the Activity threshold 
for detecting a change in the pixels in the arena. Start with the 
default value and check the purple-colored pixels in the video image. 
Adjust the threshold in such a way that when the animal is 
immobile, those pixels are almost completely absent.

3. Run the trial. 

4. In the Analysis profile add Activity and Activity state.
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5. Visualize the data (Plot Integrated Data). There you see the scored 
Activity states and the subject in the video (see Figure 9.8 for an 
example with Mobility states). Adjust the Activity state settings in 
such a way that the states scored by EthoVision XT match the 
behavior of the subject at that time.
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Introduction

principle of operation

Fear Conditioning

In a typical Fear Conditioning paradigm, single-frequency sounds are 
delivered as a neutral or conditioned stimulus (CS). Experimental 
procedures where the CS is administered are usually named Cued Fear 
Conditioning. Electric current from the grid floor is delivered as the 
naturally aversive, or unconditioned stimulus (US).

This chapter describes how you can use EthoVision XT with the Ugo 
Basile Fear Conditioning System NG-series 46000, to carry out fear 
conditioning experiments. 

If you use a version of EthoVision XT earlier than 17.5, please refer to 
the EthoVision XT Application Manual for that version.

For an overview of Fear Conditioning, and how fear is measured in 
EthoVision XT, see the white paper which you can download from our 
web site:

www.noldus.com/animal-behavior-research/fear-conditioning 

Controlling the FCS stimuli from EthoVision XT

1. Connect the EthoVision XT computer to the Ugo Basile Fear 
Conditioning System (FCS). For details, see Physical setup on page 
184.

2. In EthoVision XT, create your experiment and declare the devices 
that you are going to use. Next, program the activation of the 
devices in the Trial Control Settings. For details, see the The Fear 
Conditioning experiment in EthoVision XT on page 207.

If you have multiple FCS cubicles, you can control the stimuli in 
each cubicle independently.

3. Carry out data acquisition. See Acquire the data on page 230.
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Experiment devices and parameters

You can specify the devices and their parameters directly in EthoVision 
XT. This also makes it easier to test a device. 

 Shock, with adjustable current intensity.

 Tone, with adjustable frequency and volume.

 White noise, with adjustable volume.

 Visible (white) light, with adjustable light intensity.

 IR light, with adjustable light intensity.

 Fan, which can be switched on and off.

 You can also have EthoVision XT check if the door of the FCS cubicle 
is open or closed. 

note  If you work with EthoVision XT 16 or earlier, you must connect the 
EthoVision XT computer to the Ugo Basile Touchscreen Controller 
40500-001. Please refer to the EthoVision XT - Application Manual for 
that version.

Analysis of freezing 

The detection of freezing can be automated and based on analysis of 
the variable Activity in EthoVision XT. For details, see Activity and 
Activity State in the EthoVision XT Help, under Dependent Variables in 
detail. 

changes relative to previous ethovision xt 
versions

With EthoVision XT 17.5 and later versions you can control the Ugo 
Basile FCS without connecting the touchscreen controller. For new 
systems, the cabling is largely reduced and the system is easier to 
troubleshoot. 

 Cable connections are way simpler - from the PC directly to the FCS 
cubicles through USB.
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 When you create an EthoVision XT experiment, the devices of the 
Ugo Basile FCS are automatically added to the experiment.

 In the Trial Control Settings, you can easily recognize the names of 
the devices (e.g. Tone) instead of for example Line 1, as it occurred in 
the previous EthoVision XT versions.

 You can test the devices directly in the Trial Control Settings, before 
carrying out the actual tests.

 With FCS Model 46110-NL and Serial Number higher than 0676U24, 
you can control the IR light inside the cubicle directly from the 
software. You no longer need additional hardware. If you encounter 
problems, contact Noldus Support. See also update the cubicle 
firmware on page 204.

See Physical setup on page 184.

if you have the “old” fcs setup

FCS controlled through the Noldus USB-IO box

Your FCS setup is connected to EthoVision XT through the Noldus USB-
IO box, and you have upgraded EthoVision XT to version 17.5 or later. In 
this case you can keep using the “old” connections. For the 
instructions, see the EthoVision XT 17.0 - Application Manual, which 
you can find on the downloads page of 

my.noldus.com

If you purchased an upgrade kit for your setup, see upgrade your fcs 
system on page 200. 

FCS with manual IR light controller

Your FCS setup is equipped with a IR-light box placed on top of the 
conditioning cage and with the IR light box manual controller. You can 
keep using this configuration. However, you cannot control the IR light 
intensity from the software.
  The Fear Conditioning Test
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for general information

EthoVision XT Help

For more details, choose Help > Help Topics or press F1 in the software.

Other documentation

On the Windows Apps screen, choose Noldus > EthoVision XT 18 Other 
Documentation. See in particular:

 For information on programming trial control, conditioning 
routines, actions and conditions, and the USB-IO box: the 
EthoVision XT 18 - Trial and Hardware Control - Reference Manual.

 For information on conditioning tests and examples: see other 
chapters in this manual.

You can find these and other manuals on the Noldus website at 
my.noldus.com. Note that you need to log in first to access the 
downloads page. 

About the Ugo Basile Fear Conditioning System

This system comes with the instruction manual Fear Conditioning 
Systems-NG Series 46000, in PDF format.

Technical Support

If you encounter problems, browse to my.noldus.com, and contact the 
help desk.
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Physical setup

one-cubicle configuration
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note The diagrams only include the connections essential for 
communication between EthoVision XT and the FCS. See also the Ugo 
Basile Fear Conditioning Systems NG Series instruction manual.

Step by step instructions

1. Connect the EthoVision XT computer to the Ugo Basile FCS using 
the appropriate USB cable. You need a USB cable with a type-A 
connector at one end and a type-B connector at the other end.

2. Connect the camera to the PC. 

If your computer has an Ethernet board with one or two ports, you 
need a Power over Ethernet (PoE) injector (see also the figure on 
the previous page). 
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- Connect one of the ports of the Ethernet board of the computer 
to the PC port (IN) on the PoE injector.

- Connect the camera port on the back of the cubicle (see the 
figure below) to the CAM port (OUT) of the PoE injector.

- Next, connect the PoE injector to a power outlet.

If your computer has a 4-port Ethernet board installed, and if this 
board receives power from the PC internal power supply, you do not 
need a PoE injector. Connect the camera directly to one of the 
board’s Ethernet ports. See the EthoVision XT Help for details.

3. Connect the Ugo Basile USB Hub to the power outlet using the 
appropriate power adapter (see step 1). 

With the current version of the FCS you can control the IR light from 
EthoVision XT. If you have an older version, you must use the IR 
manual controller (see page 188) or upgrade the FCS (Please contact 
Noldus for information).

The video camera

The camera is embedded in the IR light box at the top of the cubicle. 

If you have not done yet so, you must configure the IP address of the 
camera and of the Ethernet port on your PC. You can find the IP address 
of the camera on the front panel of the cubicle’s light box.
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Install and configure the cameras

For details on how to install and configure the EthoVision XT cameras, 
and adjust the IP addresses, see Camera Installation in the EthoVision 
XT Help.

For more details on camera settings, see camera settings on page 195.

IR light box with software control

FC systems of Model 46110-NL and Serial Number higher than 0676U24 
are equipped with a IR light box that is switched on automatically 
when the cubicle is powered up. The default intensity is 100%. You can 
control the IR light intensity directly from the software (Trial Control 
Settings > Action > UB FCS IR Light; see an example below). You no 
longer need additional hardware.
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It could happen that your system is recent but is not yet updated for 
this option. Please contact Noldus for information. You can also update 
the firmware of the cubicles with the procedure on page 204. 

IR light box with manual control

In older FCS models adapted to use with EthoVision XT, the cubicle is 
equipped with an IR light box above the conditioning cage, and a IR 
light controller to adjust the IR light intensity. 

1. Connect the red and black cable that comes from the cubicle to the 
IR light controller. 

2. Connect the IR light controller to a power outlet through its power 
adapter. Attach the IR light controller as indicated on the labels.
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If you work with multiple cubicles, connect the IR controller as 
explained above for all the cubicles.
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four-cubicle configuration

1 - Cubicles
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2 and 3 - Video cameras and IR light controllers

Element 3 is for manual control of IR light, no longer necessary in the 
current version of FCS. See also page 181 and page 182.
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Step by step instructions

See the schemes on the previous pages.

1. Connect each cubicle to the EthoVision XT computer through the 
Ugo Basile USB Hub.

For this you need 5x USB cables with a Type-A connector at one end 
and a Type-B connector at the other end.

2. Connect the Ugo Basile USB Hub to the power outlet using the 
appropriate power adaptor (see the top figure above).
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3. Connect each camera to one of the ports of the Ethernet Interface 
board in the EthoVision XT computer (see the figure below). For this 
you need 4x Ethernet cables with RJ45 connectors. See also 2 in the 
figure on page 191.

4. Connect the Top Light Units to the power outlet through the 
appropriate power adaptors.

For more information on how to install and configure the Ethernet 
Interface board, see Install the GigE cameras in the EthoVision XT 
Help.

5. Connect one IR controller to each cubicle, as described in the 
procedure on page 188. See also 3 in the figure on page 191.

note  The external IR light controller is no longer necessary if you 
updated the cubicle. See update the cubicle firmware on page 
204.

Connect multiple cameras

If your EthoVision computer is provided with a 4-port Ethernet 
interface board for connecting multiple GigE cameras, the cameras can 
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get the power from the PC itself. If you purchased the computer and 
Ethernet board from Noldus, the board is already powered by the PC. 

Otherwise, open the computer casing and connect the Ethernet 
interface board with the internal power supply of the computer.

Once power is provided through the PC, connect each camera to one of 
the ports of Ethernet interface board. Label the ports and the cables so 
you always know which port is connected to which camera (and which 
cubicle).

IP addresses

note  If you have the Ugo Basile FCS equipped with USB cameras, 
connect the cameras directly to the EthoVision XT computer. Please 
skip this section.

If your FCS is equipped with Basler GigE cameras through Ethernet 
connections, each camera must have a IP address that matches the IP 
address of the Ethernet interface board on your PC. 

The basic rules are:

 The first two numbers are the same for all cameras: 192.168.

 The third number should be the same and unique for each camera-
Ethernet port combination (see the examples below). 

 The fourth number can be any, but must differ between camera 
and Ethernet interface board, and should suggest which cubicle 
(arena) it refers to.

 For example: 

- 192.168.1.101 for camera 1 (cubicle 1) and 192.168.1.51 for the 
Ethernet port 1 of the Ethernet interface board.

- 192.168.2.102 for camera 1 (cubicle 1) and 192.168.2.52 for the 
Ethernet port 1 of the Ethernet interface board.

- etc.
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The IP address of each camera can be found on the front panel of the 
cubicle’s light box. You need those addresses to configure the cameras.

For details about assigning IP addresses:

 In the HTML help: choose Help > EthoVision XT Help > Camera 
installation > Install GigE cameras.

 In the Video Tutorial: choose Help > Video Tutorial > Set Up the 
Cameras.

camera settings

Camera type and lens

The camera used in Noldus systems for Fear Conditioning is a Basler 
camera acA1300-60gm with a 2.95 mm fixed focal lens, F2.0, 1/1.8”.

How to view the live camera image

In order to view the camera image, you must activate the IR light in the 
cubicle. The camera has a IR-pass filter that blocks visible light.

1. Make sure that the camera has been configured and connected to 
the PC (see above).

2. Start EthoVision XT and create a new experiment (File > New) or 
open an existing experiment without trials acquired.

3. Choose Setup > Experiment Settings.

4. Under Video Source select Live tracking. 

5. Select the camera from the list under Source. 
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6. Click the camera button for the live view. 

Camera orientation

The camera has been optimized at Noldus before shipping, therefore in 
most cases you do not need to adjust its orientation. If, for any reason, 
the video image is not optimized, follow the instructions below. 

Camera alignment

This section applies for previous FCS versions which had Noldus IR light 
box on top. 

Turn the three screws indicated to alter the camera orientation.

If you tighten one of the screws, the camera points more to the other 
side. Loosen the same screw to have the opposite effect. For example, 
tighten the screw b to have the camera pointing more to the back of 
the cubicle. Check the resulting image in EthoVision XT; make sure that 
the bottom of the cage is aligned at the center of the camera view.
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Camera software settings

The camera frame rate, exposure time and other settings can be 
adjusted in EthoVision XT, or in the camera software Pylon Viewer.

In EthoVision XT, choose Setup > Experiment Settings. Click the camera 
button and locate the settings you want to change. See below for the 
values recommended.

For multiple cameras, you need to adjust the settings for the first 
camera. Then, adjust the resolution of the Merged view. 

Video resolution and camera zoom level

The camera lens of the FCS is a fixed focal lens. To adjust the zoom 
level, adjust the video resolution (in pixels) so that a portion of the 
maximal camera view is recorded. The following example may help you 
choose the video resolution. Note how the resolution setting crops the 
image.

Analog gain 1

Color space Mono8 (Y800)

Video resolution single 
camera (H x V)

640 x 480

Video resolution merged 
view (H x V)

1280 x 960

Acquisition Frame rate 25 or 30

Exposure 16000 s

640 x 480 800 x 600 1280 x 1024
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In this example, EthoVision XT makes a video of 1600 x 1200 from four 
cameras set to 800 x 600.

important  Whenever you change the resolution, open the Arena 
Settings and update the background image for your arenas before 
acquiring the data.

The Binning option 

If you need to reduce the video resolution without cropping the image, 
you can use the Binning option in the Video Settings of EthoVision XT.

In EthoVision XT, choose Setup > Experiment Settings. Click the camera 
button and in the Video Settings window click the General tab. Select 
the Binning option and leave the value 2. The Binning option reduces 
the number of pixels of the single camera image by half but does not 
crop the image.

If you choose to select Binning, mind that the brightness of the image 
increases. Make sure that this does not have negative effects on 
detection. If the image is too bright, reduce the Exposure time or the 
Gain (see above). 

The Binning option must be the same across cameras! Remember to 
select (or de-select) the Binning option for all cameras, before setting 
the resolution of the merged view.

Image brightness

If the image from the camera is too dark, do one of the following based 
on what FCS version you have:
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 If you have the IR light controller attached to the cubicle, turn the 
knob of the IR light controller all the way to the right (see page 188). 
In most cases this is enough to make detection optimal. 

 Increase the IR light intensity up to 100% with the Trial Control 
Settings in EthoVision XT.

 Increase the IR light intensity using the software on the tablet PC.

 Place white plates at the sides and at the bottom of the FCS cage to 
increase contrast with dark-fur animals. Place dark plates in case of 
white animals.

To increase the brightness of the image further, you can adjust camera 
settings in EthoVision XT or Pylon Viewer: 

 Increase the camera Exposure time. Be aware that a too high 
Exposure time may conflict with the camera frame rate. EthoVision 
XT shows a message in the Video Settings window if that is the 
case.

 Increase the Gain to 1 or 2. Mind that a higher Gain also creates 
more image noise. 

 Another option to increase the brightness of the image without 
increasing noise is to set the image Binning Horizontal and Binning 
Vertical to 2. Make sure that the Binning Mode is Summing for 
both. However, with binning the video resolution (that is, the width 
and the height of the camera image, in pixels), is half of the 
original. See The Binning option on page 198.

Older versions of the Ugo Basile FCS have the IR light source placed at 
one of the top corners of the cubicle. You do not need to operate this 
light if you have the IR light box above the conditioning cage.
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upgrade your fcs system

Aim

To adapt the Fear Conditioning System to use in combination with 
EthoVision XT 17.5 and later.

 The touchscreen controller is no longer needed.

 You can adjust the FCS settings (e.g. tone frequency, shock current) 
directly in EthoVision XT.

 The time needed for installation and setting adjustment is about 
one hour.

Prerequisites

 You have received the following from Ugo Basile:

- 1x upgrade box for each cubicle.

- 1x power cable, 1x USB cable, 4x color-coded cables for each 
cubicle.

- Two hexagonal Allen keys.

 Ugo Basile needs first the touch screen controller back, so that they 
can copy the settings of the touch screen controller / Fear 
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Conditioning box to the upgrade box. That way you can work with 
the same settings as before.

Procedure

1. Remove the four screws at the corners of the upgrade box and 
remove the cover plate.

2. Locate the holes on the back panel of the cubicle.
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3. Attach the box to the back panel. Make sure that the cable 
connections are on top.

4. Put the lid of the box back in place and tighten the screws.
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5. Connect the color-coded cables as shown in the next figure.

6. Finally, connect:
- The upgrade box to the PC (or USB hub, in case of 2 or more 

cubicles) using the USB cable that came with the upgrade box.

- The upgrade box to a power outlet.

- The camera to the PC’s Ethernet board.

See also Physical setup on page 184.

7. Repeat the steps above for the remaining cubicles.

8. Next, follow the steps in the next section The Fear Conditioning 
experiment in EthoVision XT on page 207.
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update the cubicle firmware

Aim

To make the FCS cubicles compatible with the new IR illumination 
system that is fully controllable from EthoVision XT.

important  Follow this procedure only when requested by Noldus 
Support.

What you need

 The firmware updater installation files: FW_Updater Setup.msi and 
setup.exe.

 The new firmware file Cubicle.elf_7.34.S19.

See below for how to get those files.

Procedure

1. On the EthoVision XT full installation package, open Drivers and 
Tools > Utilities > Ugo Basile FCS.

You can download the full installation package from 
my.noldus.com.

2. Copy the file Ugo Basile FCS FirmWare Updater [version number].zip 
to your EthoVision XT PC and extract its contents.

3. Double-click the file setup.exe. Complete the installation procedure.

4. Power up the cubicle and connect it to the EthoVision XT PC through 
the USB cable.

5. Start the application.

6. Choose Select Firmware.
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7. In the window that opens, choose the file Cubicle.elf_7.34.S19. 

8. Click Firmware Update.

9. If the current version is 2.27 or newer, the update process should 
start automatically. Otherwise, you need to:
- Disconnect both the power supply and the USB cable from the 

cubicle.

- Reconnect both the power supply and the USB cable, 
approximately at the same time.

10.Wait until the Erase and the Programming processes are completed.

11. After the device has rebooted, you can change the tab to BOARD 
SETTINGS.
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12. Leave or set the Device ID to 1 and set the Default IR intensity to the 
desired value (recommended: 100%). This will be the default 
intensity at startup.

13. Click Save to Board.

Check the Ugo Basile Interface for EthoVision XT

1. Open the Control Panel > Programs and Features.

2. Check that the software Noldus - HardwareInterface UgoBasile -x64 
package version 1.0.14 or later is installed.

If a previous version is installed, uninstall it. Next, copy the file 
HardwareInterfaceUgoBasile - X64 Package - [version number].msi 
from the EthoVision XT 18 full installation package, under Drivers and 
Tools > Prerequisites > HardwareInterfaceUgoBasile to your PC, then 
run this file.

Test the IR light

To test the IR light, in the Trial Control Settings create an Action based 
on the IR Light. Set the intensity to 100% and click Test. Click OK then 
check in the Detection Settings whether the IR light is still on.
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The Fear Conditioning 
experiment in EthoVision XT

prerequisites

Make sure that all devices are connected and powered up.

create an ethovision xt experiment

1. Start EthoVision XT and choose File > New From Template, then 
click Apply a pre-defined template.

2. On the How is the arena configured page, select:
- If you work with one or two cubicles, Fear Conditioning System 1 

cubicle. Next to Number of arenas, select 1 or 2.

- If you work with four cubicles, Fear Conditioning System 4 
cubicles. Next to Number of arenas, select 4.

note  This template does not include pre-defined zones as they are 
not used often in Fear Conditioning. 
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3. When you are asked How many subjects per arena will you track, 
select 1 subject.

4. Complete the guided procedure and give the experiment a name. 
Next, click OK.

experiment settings

Cameras

1. Choose Setup > Experiment Settings.

2. Under Video Source, next to Number of sources, select how many 
cameras (one per cubicle) you are working with. In the list under 
Source, select the name of each camera.

The IP address should tell which camera belongs to which cubicle, 
provided that you have assigned IP addresses 

3. Next to Merged camera view, select 800 x 600 (cropped view of the 
cage) or 1280 x 1024 (full view of the cage). See Video resolution and 
camera zoom level on page 197. 

Number of Arenas and Tracked Features

important  Do this before selecting the Ugo Basile FCS in the Trial 
Control Hardware Settings. 

1. In the Experiment Settings, under Arenas, select the Number of 
Arenas you use, that is, the number of cubicles (1 to 4).

2. Under Tracked Features, in most cases Center-point detection will 
suffice for fear conditioning experiments.
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Activity analysis for freezing detection

1. In the Experiment Settings, under Analysis Options, select Activity 
analysis if you want to analyze freezing behavior.\

tip  Click the Video Tutorial button next to that option for an overview 
of Activity analysis.

Specify the Ugo Basile Fear Conditioning System

important  Have you already selected the number of arenas (see 
above)? Make sure that Number of Arenas selected corresponds to the 
number of FCS cages used in that experiment. Only after that, follow 
the instructions below.

1. In the Experiment Settings, under Trial Control Hardware, select 
Use of Trial Control Hardware, and click Settings.

2. In the Hardware Interface window, select Ugo Basile F.C. Controller. 

3. In the Fear Conditioning System COM Port Settings window, click 
the Add button. 
- Select a COM port and click OK. Repeat this step to add the COM 

ports connected to all the FCS cubicles. 

- For a setup with the Ugo Basile USB Hub and four cubicles, add 
COM11, then COM12, COM13 and COM14. 
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- For a setup with one cubicle connected directly to the PC, select 
the COM port associated with that cubicle. To find out which 
COM port is associated with a cubicle, see com port 
communication on page 210. If you have created the experiment 
from a template, there may be one or more COM ports already 
selected in the Fear Conditioning System COM Port Settings 
window. If they do not match those associated with the cubicles 
of your setup, delete them and add the correct ones.

4. When finished, click OK and proceed with arena settings: define 
the arenas on page 212.

Notes

 important  Take note of which cubicle is connected to which COM 
port. Make sure that only the necessary COM ports are added. If you 
added accidentally a wrong COM port, select that and click Delete.

 When adding more COM ports in the Fear Conditioning System 
COM Port Settings window, start with the port for cubicle 1. 
Disconnect cubicle 1 and see which COM port disappears from the 
Windows Device Manager (see com port communication below). 
Next, reconnect the cubicle and add that COM port. Repeat those 
steps for cubicle 2, then 3, then 4.

com port communication

In order to know which COM port is associated with a specific cubicle, 
do the following:

1. In Windows, open the Device Manager. Choose View > Devices by 
type.

2. Open the item named Ports (COM and LPT).

If the cubicles are connected physically to the PC through the Ugo 
Basile USB Hub (see page 190) and powered up, you should see one 
up to four items USB Serial Port (COMx): COM11 to COM14.
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tip  If you do not see the Ports item, from the View menu of the 
Device Manager select Devices by type.

3. Disconnect the USB cable from one of the FCS cubicles. 

4. Look at the Ports (COM and LPT) list. One of the items has 
disappeared. That is the COM port currently associated with that 
cubicle. For example, after disconnecting cubicle 4 (COM14):

tip  Number the FCS cages and cubicles, and take note which COM port 
is linked with each cubicle. That makes troubleshooting easier.

If, after disconnecting a cubicle, a COM port other than the expected 
one disappears from the list, it may be that cables are swapped 
between the ports in the USB Hub and the corresponding cubicles.
 The Fear Conditioning Test 211



212
arena settings: define the arenas

Create and calibrate the arenas

1. Choose Setup > Arena Settings. 

2. Grab a background image from the cameras, calibrate and draw the 
arenas. For details, see Arena Settings in the EthoVision XT Help.

tip To quickly calibrate, draw lines between opposite walls of the 
cage, next to the grid, and enter 17 cm (the cage width).

See page 197 for tips how to get a bright image of the cage.

3. If the image of a cage is not centered, see Camera orientation (page 
196).

4. Proceed with declaring the FCS devices for each arena (next section).

arena settings: declare the fcs devices

Follow this procedure to specify the FCS devices that you want to use 
for each cage (arena).
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1. In the Arena Settings, click the Arena – Hardware Mapping button 
at the bottom-right corner of the EthoVision XT screen.

2. The Arena - Device Mapping window opens.

This window lists under Device groups the FC systems connected to 
the COM ports currently declared (page 208). The second column, 
Arena, lists the arenas currently associated with each system.

3. Check carefully that the name of each arena matches the physical FC 
system (and the COM port associated with it). If the two do not 
match, select the correct arena name under Arena.

4. Once you are ready, click OK. The Arena-Hardware Mapping window 
opens. 

This window lists the names of the actual devices that EthoVision 
XT can control. By default, each device is uniquely associated 
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automatically to one arena based on the scheme in the window 
that opened in the previous step.

For example, all the devices of Fear Conditioning System 1 at COM 1 
are listed under Arena 1.

- The column Device type shows the types of device currently 
selected. If the type you want to use does not appear, add a new 
device (see page 214).

- In the column Device name you find names like Device A, Device B, 
etc. These are generic names for a specific type of device, which 
you find back when you program the activation of the devices in 
the Trial Control Settings. If you like, you can change them to 
Shock, Tone, etc.

- In the columns Arena 1, Arena 2, etc. you find the list with the 
names of unique physical devices. These are automatically 
assigned based on which FCS system connected to a specific COM 
port is associated with which arena in EthoVision XT (see 
through the COM ports (see above). Your task now is to assign 
each physical device to a specific arena.

5. important  Test the devices! See page 218. You can also test the 
devices in the Trial Control Settings.

note  The item UB FCS IR Light listed in the Arena - Hardware Mapping 
window is for controlling the IR lamp located at the top-left corner of 
the cubicle, not the IR light given by the light box. You can control the 
IR light of the light box by turning the knob of the IR controller (page 
191). 

Add a new device

If the FCS devices are not listed in the Arena-Hardware Mapping 
window, do the following: 

1. Click the Add device button.

2. Under Device type, select a device (e.g. UB FCS Tone).

3. Under Device name, either accept the default name or enter a new, 
meaningful name, for example Tone.
- If you plan to activate a device type in all the cages at the same 

time, a generic name like Shock or Tone is fine.
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- If you plan to activate a device type in different cages at different 
times, it is a good idea to specify a unique Device name, for 
example Tone for Cage 1, and assign that device only to the arena 
associated with that cage.

4. Locate the column for the arena you want to assign the device to, 
and select the physical device from the drop-down list. For example, 
under Arena 1, select UB FCS Shock 1; under Arena 2, select Ugo 
Basile FCS Shock 2, etc. 

How many devices are available in a list depends on how many 
COM ports you have declared (see page 209). Make sure you do not 
select the same unique device under two or more arenas.

examples of arena-hardware mapping

EthoVision XT controlling one cage

note  The item UB FCS IR Light is for controlling the IR lamp at the top-
left corner of the cubicle, not the IR light box.
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EthoVision XT controlling four cages - 1

Use this configuration whenever you plan to administer a stimulus in 
all the FCS cages at the same time, for example, to activate the tone in 
all the cages exactly one minute after the start of the trial.

Define a Device name that is valid for all the cages (arenas). Under 
Arena 1, Arena 2, etc., select the physical devices for each of those 
arenas.

In the following example, Device A represents the foot shock for all the 
cages. This means that when you use a hardware action Device A - 
Shocker On in the Trial Control Settings (see page 221), that action is 
carried out in all the cages.

 Make sure not to select the same physical device twice for two 
arenas.

 Repeat the steps for the remaining devices.

note  You can also use this configuration when tracking starts at 
different times in different arenas, for example when you release the 
subject at different times and EthoVision starts tracking after the 
subject has been detected.

EthoVision XT controlling four cages - 2

Sometimes you need to apply different protocols to different cages 
(arenas). For example, to provide a stimulus after the subject has been 
immobile for one minute. Or, give a shock in cage 1 after 1 minute and 
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give a shock in cage 2 after a random time, or the like. In such cases the 
activation of a stimulus device is cage-specific. 

You can create this configuration by linking a specific device name (e.g. 
Device A) only to a specific physical device in one of the arenas (e.g. 
Arena 1). Device A should not be assigned to other arenas.

Therefore, you must add four new devices (see page 214) of the same 
type, and assign each of them to one arena. 

For example, in the case of UB FCS Tone:

 Device A: UB FCS Tone 1 under Arena 1.

 Device B: UB FCS Tone 2 under Arena 2.

 Device C: UB FCS Tone 3 under Arena 3.

 Device D: UB FCS Tone 4 under Arena 4.

Furthermore:

 Remember to select <No device allocated> in the remaining cells of 
the table.

 Note that with this setup tone stimuli are presented at different 
times in different cages. If the cubicles are near each other, the 
animal in cubicle 1 may be affected by the tone presentation in the 
other cubicles, when it is supposed not to hear any tone. Make sure 
that the cubicles are far apart or in different rooms when using 
non-simultaneous tone presentation. 

 Repeat the steps for the other device types that you want to use.
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 For more information about applying different protocols to 
different cages, see Applying different protocols to different arenas 
in the EthoVision XT 18 - Trial and Hardware Control - Reference 
Manual.

test the fcs devices

Prerequisites

 All the connections are set as in the section Physical setup.

 You have created an experiment and have specified the FCS in the 
Experiment Settings (see page 208).

 You have drawn and calibrated the arenas (see page 212).

 You have specified the FCS devices for each arena (see page 212).

Procedure for actions

This applies to Visible Light, Tone, Shocker, White Noise, Fan, IR Light.

1. In EthoVision XT, choose Setup > Trial Control Settings and open 
one of the existing profiles.

2. In the Components pane, under Actions, click the button next to the 
name of the device you want to test.

3. In the window that appears, select the device, the type of action, 
adjust its settings, and click Test.

4. Verify that the devices works as expected. Next, click Reset to reset 
all devices to their default values.

If the action is carried out in another cubicle, it means that the wrong 
device has been selected in step 3, or that the devices have not been 
mapped correctly in the Arena Settings (see page 212).

Procedure for the UB FCS door

This applies to the device UB FCS Door.

1. In EthoVision XT, choose Setup > Arena Settings and click the 
Arena-Hardware Mapping button.
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2. In the Arena-Hardware Mapping window, select the row for UB FCS 
Door. Next, click the Test button.

3. The Test UB FCS Door window opens on the screen. Open/close the 
door of the corresponding cubicle and check the message displayed 
in the window (Door Open? True or false).

Verify that the shocker actually gives a shock

Place a LED diode between two bars of the shocker grid, or touch a bar 
with a phase detector. 

 A phase detector. 

If the shocker is connected correctly and working, the LED turns on. You 
can also touch the grid bars, however a current intensity around 1 mA is 
the threshold of feeling. A lower current may not be felt.
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Measure the amplitude of the shock

important  For this you need an oscilloscope and an oscilloscope probe 
with insulated channel and a 100 K resistor. 

1. Set the oscilloscope to 50V/DIV and time base 10 ms.

2. Connect the oscilloscope probe with a 100 K resistor to the shock 
grid, as indicated in the following picture.

3. In EthoVision XT, in the Arena - Hardware Mapping window, select 
the shock device for a specific cubicle and click Test. Set the shock 
intensity to 1.5 mA.

4. Click the Test button to activate the shock. You should see a square 
wave on the display of the oscilloscope. Read the amplitude there; 
remember that with the current settings one vertical division 
corresponds to 50 V. Once you know the voltage, the current is equal 
to the voltage divided by the resistance (in this example 100000).
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trial control settings

Follow this section to learn how to program EthoVision XT to send 
commands to the FCS devices at the right time during data acquisition.

Basic structure: Actions and Conditions

To activate /deactivate a stimulus, use the Actions function. In general, 
two actions must be separate by some time. Here you find an example 
of activation of a stimulus for one second.

1. Choose Setup > Trial Control Settings.

2. In the Components pane, under Actions click the button next to the 
device name that you want to use, and specify the type of action.

3. In most cases you need to add a number of boxes in a sequence. For 
example, the sequence Shock On (Action) > Time Condition > Shock 
Off (Action) define the activation of the shock for a specific time set 
in the Time Condition. 

4. Click and drag from the center of one box to the next to connect the 
boxes with the arrows.

Depending on how you map the devices on the Arenas (see page 216), 
this action can be carried out in one or more cubicles simultaneously.

Recurring stimulation using Sub-rules

In most cases you need to administer a stimulus at regular intervals, for 
example every minute. If you repeat the sequence depicted in the 
figure above, one for each round, you would end up with a large 
number of boxes to manage. Instead, create a Sub-rule that contains 
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the actions that you want to repeat. Specify how often and when the 
routine is repeated in the Sub-rule settings. 

In the following example, a Sub-rule with the same instructions as 
above will be repeated 15 times. The shock is given every minute. After 
the start of the trial, the software waits one minute (box A), then the 
Sub-rule reference box (B) activates the Sub-rule (C). The stimulus is 
given as above (D-E-F). A time condition of 59 seconds (G) ensures that 
the next stimulus is given exactly one minute later (1 s of shock + 59 s = 
60 s). The Sub-rule is repeated 15 times as specified in the Settings of 
box B. After that, the trial stops (box H).

Cued conditioning: pairing tone and shock

In the following example we follow the protocol by Curzon et al. (2009) 
[In Buccafusco (ed). Methods of Behavior Analysis in Neuroscience, 
Chapter 2]. During the conditioning session, a tone (Frequency 1000 
kHz, Amplitude 50% of the maximum) is presented for 15 seconds. 
During the last 2 seconds of the tone presentation, the shock is 
administered (0.5 mA). Tone and shock end at the same time. After the 
shock, a period of 60 seconds with no stimuli follows.

This procedure is as follows:
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If you want to have this sequence repeated a number of times, place it 
within a Sub-rule.

In this example the Sub-rule is called by a Reference rule after 120 s of 
habituation.

Controlling lights

 IR Light. The FCS provided by Noldus has the IR light activated by 
default. If, for some reason, you notice that the IR light is off, you 
can activate the IR light at the start of the trial. To do so, add an 
action for the IR light just after the Start Trial box.

 Visible Light. In many FC protocols it is required that a house light 
illuminates the test chamber continuously during testing. Add an 
action for the UB FCS Visible Light and insert the Light On Action 
box after the Start Trial box. Add a second action box (this time 
with a Light Off action) immediately before the Stop Track box.
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Controlling the fan

The fan is by default activated when you start the cubicle.

To ensure that the fan is on at the start of a trial, also in the case that 
the fan was accidentally switched off during the testing phase (page 
218), in the Trial Control Settings click the button next to UB FCS Fan 
and insert the Fan On Action box after the Start Trial box. 

notes

 If you add a Fan On Action at the start of the trial, the fan switches 
on at the start of the trial and switches off at the end of the trial.

 If you do not add any action about the fan in the Trial Control 
Settings:

- If the fan was already on at the start of the trial (for example 
after you start up the cubicle), the fan stays on during the trial.

- If the fan was off, for example when testing it in the Trial Control 
Settings, it stays off during the trial.

Analyze data using Trial Control events

If you want to analyze the data in specific time segments, you can use 
the actions and conditions of Trial Control Settings to define specific 
intervals. See analyze intervals on page 233. 
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For more information

For more information and examples of actions, conditions and sub-
rules, see the EthoVision XT 18 - Trial and Hardware Control - Reference 
Manual. To open this manual, choose Apps > Noldus > EthoVision XT 18 
Other Documentation.

detection settings

Release the subjects in the FCS cages.

Choose Setup > Detection Settings.

Detect the subject

In the Detection Settings window, click Automated Setup. Draw a 
rectangle around each subject in the video image, and follow the 
instructions on the screen.

Minimize the indentations caused by the grid

In the Detection Settings, click Advanced. Under Subject Contour, 
choose what follows depending on the color of the subject and the grid 
bars:

 If the grid bars are the same color as the subject, use the first 
Erosion filter. Increase the value near Erosion until the grid is no 
longer detected. Normally 2-3 pixels are fine. Check that the whole 
body is detected, indicated by the yellow blob.
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 If the grid bars are of a color other than the subject, and the 
detected subject appears to be broken in multiple parts, use the 
Dilation filter. Increase the value near Dilation until the yellow body 
is entirely over the subject’s body. After that, reduce the size of the 
yellow blob by means of the second Erosion filter.

For details, see Advanced detection settings: Subject contour in the 
EthoVision XT Help.

Minimize the effect of the subject’s shadow

Make the contrast range smaller, to exclude the pixels in the shadow. 
For example, if the subject has dark fur, and the shadow is included in 
the yellow blob, then next to Dark move the left slider to the right. This 
will exclude smaller values of contrast. You should see the yellow area 
over the shadow shrinking. EthoVision XT will not follow the shadow 
anymore.

Do this in small steps, until the shadow is no longer detected. Make 
sure that the whole body is still detected in all parts of the cage.

tip  If the background looks too similar to the color of the subject, place 
a sheet of paper or plastic in the drawer that you find under the shock 
grid. Try to make as much contrast as possible between the subject and 
the background.

Set Activity analysis for freezing detection

In the Detection Settings window, click Activity. 
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Adjust the settings in such a way that a large number of purple pixels 
appear only when the subject moves. 

 If the Activity threshold is too low, purple pixels also appear in the 
background (see the next figure, left and middle).

 Increase the value of Activity threshold until you see the purple 
pixels appearing only when for example the mouse moves its head 
(see the next figure, right).

 If the Activity threshold is too high, purple pixels disappear 
completely. That’s not good either, because you need to have a 
sufficiently wide range of the amount of purple pixels in order to 
detect immobility (freezing). 

When the subject freezes, the number of purple pixels should be 
minimized.

For more information

 See Activity settings in the EthoVision XT Help.

 Click the video button next to Activity, and watch the video 
tutorial.
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 For details about the advanced detection settings, See Configure 
Detection Settings in the EthoVision XT Help.

troubleshooting

All the FCS devices are listed for Arena 1 only. For the other arenas, all 
is set to <No device allocated>.

This may have occurred when you selected the number of arenas (for 
example, 4) after defining the COM ports for the FCS cages. If, at the 
time of defining the COM ports, the number of arenas was still 1, 
EthoVision XT assumes that all the devices must be associated with 
one arena, that is, Arena 1.

Do the following:

1. In the Arena-Hardware Mapping window, select each row and click 
Remove device. Do so to remove all the devices.

2. Choose Setup > Experiment Settings. 

3. Under Trial Control Hardware, click Settings, then choose Ugo Basile 
F.C. Controller. In the window that opens, make sure that the COM 
ports are listed and click OK.

4. Under Number of Arenas, select the number of arenas you work 
with.

5. Choose Setup > Arena Settings and click the Arena-Hardware 
Mapping button. At this point the devices should be correctly 
selected under one of the arenas.

The IR light is switched off, or its intensity is not optimal. What can I 
do?

1. Create a new Trial Control Settings profile (Setup > Trial Control 
Settings > New). 

2. Click the button next to Action - UB FCS IR light.

3. Select the device from the UB FCS IR light list. 

4. Select Light ON and choose the Intensity Level (recommended: 
100%).
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5. Click Test, then OK.

6. Open the Detection Settings and verify that the chamber is 
illuminated.

7. tip  Keep the new Trial Control Settings profile so you can always 
access it in case you want to restart the IR light. Do not use this 
profile for tracking.

Another way to restore the default IR light is to restart the cubicle 
(disconnect and then reconnect the power).

See also update the cubicle firmware page 204 to make sure that the 
default state of the IR light is to set the default light intensity.

The fan is switched off. What can I do?

Restart the cubicle (disconnect and then reconnect the power).
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Acquire the data

things to check first

Before starting one or more trials, it is useful to do some checks.

Hardware

 Check that all devices are properly connected according to the 
schemes in this manual.

 Check that all devices are powered up.

 Insert the conditioning cage in the cubicle as in the figure below. 
The cage fits between the two clear support angles attached to the 
IR light box.

Test the devices In EthoVision XT

 Choose Setup > Arena Settings. Open the Arena Settings you want 
to use. Click the Arena – Hardware Mapping button and test the 
devices (page 218).
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Run a test trial

 To check that the system works correctly, run a test trial with a 
basic Trial Control settings profile that contains actions and 
conditions.

 After data acquisition, in the Analysis profile under Hardware 
choose Hardware command and define the event you want to view, 
for example Device A, Output 1 High (=Light on). 

 Choose Analysis > Results > Integrated Visualization and check 
whether the event occurred at the expected time.

acquire data

In EthoVision XT, choose Acquisition > Open Acquisition.

Follow the general procedure described in the EthoVision XT Help. 
Browse to Acquire Data > Acquire one trial.
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Analyze the data

basic steps

1. Define the intervals you want to analyze. Choose Analysis > Data 
Profile > New. See analyze intervals below.

If you want to calculate statistics for the whole duration of your 
trials, you can skip this step.

2. Choose Analysis > Analysis Profile > New. Choose the variables you 
want to analyze. For example, velocity, time in zone, or activity. See 
Dependent variables below.

3. Choose Analysis > Results > Statistics and Charts to calculate 
statistics, or Integrated Visualization to view the video and the 
variable plotted against time.

analyze events

Add the following variables, if not already listed in the Analysis profile:

 Activity state to analyze freezing events. For more information 
about Activity and Activity state, and how to set the thresholds to 
detect freezing, see the EthoVision XT Help.

 Distance moved, and Movement to quantify locomotory behavior.

 Hardware command especially to visualize events like Light On, 
Shock On, etc. together with the video and the tracks (Analysis > 
Results > Integrated Visualization).

 Trial Control Event to visualize for example when a condition 
becomes true. Use this especially for testing purposes.
  The Fear Conditioning Test



analyze intervals

Define the intervals with the Nesting function

By default, the whole trial timeline is selected for analysis. However, 
you may want to select part of the timeline, for example to analyze the 
Activity variable only when the white light was on. To do so, in the Data 
profile define an interval based on the event “White Light On”.

1. Choose Analysis > Data Profile > New.

2. Under Nesting, click the option corresponding to the type of interval 
you want.

3. Specify the interval and place the Nest box between the Start and 
Results box.

Which options shall I choose?

 To analyze the behavior of the subject when, for example, the 
white light was on, choose Trial Control State. In the window that 
appears, select the action that marks the start of the interval (e.g., 
Light On - becomes active), and the action that marks the end of 
the interval (Light Off - becomes active). 
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 If you want to analyze a complex interval, from A to B, where A and 
B are events of different type, for example, behavior and activation 
of a stimulus, choose Free interval.

For example, select the time from the end of the shock (Shock Off - 
becomes active) and the first instance of freezing (detected using 
Activity or Activity state). 

 You can also combine events with time. In the following example, 
we select the 30 seconds interval immediately after the end of the 
Shock. From Trial Control - Action: Shock Off - becomes active to 
Time - Elapsed time: 30 s after start event. See the figure below.

Visualize the intervals

Once you have defined the intervals for analysis, it is always a good idea 
to plot the data and check that the intervals defined in the previous 
steps are correct.

1. Choose Analysis > Results > Plot Integrated Data.

2. The data selected within the intervals is shown in full colors while 
the data outside the intervals is showed in dimmed colors. Check 
that the intervals defined correspond to the time segments that you 
want to analyze. 
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In the example below, Activity is visualized within an interval defined 
as “from Tone On to Shock On”.

If the intervals are defined correctly, proceed with the statistics 
calculation. 

Calculate the statistics

Choose Analysis > Results > Calculate Statistics and click the Calculate 
button. The results table shows the statistics of the dependent 
variables defined in the Analysis profile, within the intervals defined in 
the Data profile.

For more information

 For details about the analysis variables, see Dependent Variables in 
Detail in the EthoVision XT Help (F1).

 For more examples about analyzing intervals, see Analyze Track 
Segments in the EthoVision XT Help (F1).

 For more examples of control of hardware devices and PhenoTyper, 
see also the Chapter Conditioning tests in this manual.
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Technical specifications

infrared top light and controller

For the technical specifications of the Fear Conditioning system, see 
the Instruction Manual FCS 46000.pdf that comes with that system. 

Noldus device numbers Top light: UBIRT-001x

Controller: UBIRC-001x

Voltage 24V (standard Noldus power supply)

Current consumption 
on max LED intensity

220mA

Light wavelength 940nm

Incorporated camera  1280 x 1024 pixels at max 60 fps (30 fps 
is recommended)

Dimensions (L x W x H) Top light

28.6 x 29.3 x 8.5 cm  
(11 17/64” x 11 17/32” x 3 11/32”)

Controller

8.0 x 4.0 x 4.2 cm  
(3 5/32” x 1 37/64” x 1 21/32”)

Weight Top light: 860 g (30.3 oz)

Controller 50 g (1.76 oz)

Power adapter Type number TRH70A240-01E13VI  
Input 100-240V, 1.5 A  
Output 24V, 3.0 A 

CE marking: see the next page
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Introduction

EthoVision XT can be used in learning tests, such as the water maze 
test (see Chapter 3 The Morris Water Maze Test) and the conditioning 
tests (e.g., Pham et al., 2009). 

The Trial and Hardware Control module of EthoVision XT can be used to 
operate hardware devices to be used in both classical and operant 
conditioning tests. In the latter, an action of the animal produces a 
result, for example, pressing a lever results in the food dispenser 
dropping a food pellet. This and other hardware actions (such as, 
turning on a light when the animal enters the shelter, or closing the 
door of a radial maze when the animal has exited that arm) can be 
operated through the Trial and Hardware Control in EthoVision XT. 
Learning can be demonstrated by a change in the frequency of the 
animal’s action over time. For example, when the animal is presented 
with an aversive stimulus every time it performs a certain action, the 
performance of the action will likely decrease over time because the 
animal tries to avoid the negative stimulus.

To be able to operate hardware devices with EthoVision XT you need:

 The Trial and Hardware Control module. This module allows you to 
control hardware devices from within EthoVision XT.

 The USB-IO Box. This is the device that connects the EthoVision XT 
PC with external hardware devices such as the sound and light 
devices of PhenoTyper or a third-party hardware device.

This document describes how to set up EthoVision XT using Trial and 
Hardware Control in an operant conditioning test in PhenoTyper. 

PhenoTyper

PhenoTyper is an instrumented cage to measure and test the behavior 
of laboratory rodents. See the following web page:

 www.noldus.com/animal-behavior-research/products/phenotyper for 
more information on PhenoTyper.
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If you want to use EthoVision XT to operate a third-party hardware 
device, please contact Noldus Information Technology 
(www.noldus.com).

To see how a test with PhenoTyper is carried out in EthoVision XT, see 
the sample experiment PhenoTyper hardware XT180 on the downloads 
section of the Noldus website (my.noldus.com). In EthoVision XT, 
choose File > Restore Backup and select this file. See also the document 
Description of sample experiments of EthoVision XT.pdf for more 
information.

Fear Conditioning test

In the fear conditioning test, you can use EthoVision XT to 
automatically detect freezing behavior as a measure of conditioned 
fear. For details, see page 179.
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Physical setup

The following suggestions are meant to optimize tracking:

 The camera should have a good view of the entire region the 
animals can be in (for zones like the shelter where the animal is not 
visible, you can define hidden zones).

 The lighting should be as even as possible throughout the arena 
and should be diffuse, so as not to cast strong shadows (which 
might be tracked instead of the animal).

 The background should contrast with the animal. If necessary use a 
different setup for light and dark colored animals.

 Either make sure the sides of the box are not reflective (e.g., 
sanding), or exclude the sides from the arena. If your objects are 
close to the sides then you will need to track the animal when it is 
against the side (so the camera sees the side instead of the base 
behind the animal).

 If you want to use Deep learning technique to track the subject’s 
nose, keep in mind that there are additional requirements. Among 
other things, you need a powerful graphics card. See Deep learning: 
Requirements and Limitations in the EthoVision XT Help.

For more information

 About PhenoTyper: see the PhenoTyper - EthoVision XT 18 - 
Reference Manual.

 About using hidden zones: see the section Shelters and other 
hidden zones in the EthoVision XT Help.
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A conditioning test in EthoVision 
XT

Create an experiment. For details, see Chapter 1 of this manual, or in 
EthoVision XT press F1 and see Setup an Experiment in the EthoVision 
XT Help. In the following sections we assume that you created an 
experiment using the PhenoTyper arena template.

experiment settings

1. Make sure that the PhenoTyper cages are connected to the 
EthoVision XT PC. See the PhenoTyper - EthoVision XT 18 - 
Reference Manual for how to connect PhenoTyper to EthoVision XT.

Connect a third-party hardware device, which can be controlled by 
TTL, to one of the TTL control ports on the USB-IO Box.

2. Open the experiment and choose Setup > Experiment Settings.

3. Check that the correct cameras are selected under Video source.

Select whether the resolution of the first camera and that of the 
mixed image. Note that depending on the number of cameras and 
the frame rate, you may need to reduce the resolution of the mixed 
image. For more information about installing and connecting 
multiple cameras, see Camera installation in the EthoVision XT 
Help and the PhenoTyper - EthoVision XT 18 - Reference Manual.

4. If you want to use Deep learning technique to track the subject’s 
nose, under Body point detection technique choose Deep learning. 
Note that in order to use this technique there are additional 
requirements. Among other things, you need a powerful graphics 
card. See Deep learning: Requirements and Limitations in the 
EthoVision XT Help.

5. Under Analysis options, select Activity analysis if you want to 
measure freezing behavior.
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6. Next to Hardware, select Use of Trial Control Hardware and click 
Settings.

7. Select Noldus USB-IO box.

8. In this next step, you define the ports of the USB-IO box connected 
to PhenoTypers. Select SDI port 13, then Top Unit Interface. Select 
Top Unit (Standard) for all the rows below (depending on how many 
Phenotypers are connected to a Top Unit Interface) 

For PhenoTyper 2, and for more details and examples, see the 
PhenoTyper - EthoVision XT 18 - Reference Manual.

If you use third-party devices, also select the TTL ports that are 
connected to those devices.

9. Click OK.

For more information

 About port mapping: the EthoVision XT 18 - Trial and Hardware 
Control - Reference Manual.

 About PhenoTyper connections and devices:

- PhenoTyper - EthoVision XT 18 - Reference Manual.

- PhenoTyper - EthoVision XT 18 - Service Manual for specific 
devices like the Pellet dispenser and the Lickometer.

 About general experiment settings: Set Up an Experiment in the 
EthoVision XT Help.

arena settings

Choose Setup > Arena Settings > open Arena Settings 1.
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We assume that you followed the general procedure on page 15.

Click the Arena - hardware mapping button at the bottom of the Arena 
Settings pane (see Figure 11.1).

If you only have one arena, the hardware will be assigned to this arena 
automatically. If that is the case, proceed with Trial Control Settings on 
page 245.

In the Arena - Hardware Mapping window, click Add Device for each 
device you want to add:

 For PhenoTyper – Under Device Type, select Top Unit (Standard). 
Enter Device Name PhenoTyper and the corresponding Top Unit 
(Standard) # for each Arena (Figure 11.2).

Figure 11.1  The Arena Settings pane. 
In this example, Arena 1 contains four 
pre-defined Zone groups: Feeding 
zones, Spot light zone, Floor zone and 
a Hidden In shelter zone.
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 For a third-party hardware device – Under Device Type, select 
Custom Hardware. Enter a Device name and select a device from 
the list for each Arena.

Click 4. Validate Setup to validate the Arena Settings. 

trial control settings

With the Trial and Hardware Control add-on module in EthoVision XT, 
you can control PhenoTyper and third-party devices in a variety of ways. 
For example:

 Start recording when the animal is detected on top of the shelter.

 Stop recording when the animal has performed a specific task 50 
times.

 When the animal sits on the shelter, drop a food pellet. Repeat this 
task 25 times.

The template experiment contains two trial control profiles:

 Default – The default Trial Control Start-Stop rule.

 Max. Trial duration 24 hrs – In this profile, a trial stops after 24 
hours.

Maximum trial duration (tested)

 Without video recording: 72 hours.

 With simultaneous video recording: 3 hours.

If you need to record video of the same subject for more than three 
hours, we recommend that you make a series of trials.

Figure 11.2  Part of the Arena - Hardware Mapping window. In this example, two 
devices have been added: one PhenoTyper and a ‘custom’ Buzzer.
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Below you find a few examples of Trial Control Settings. Modify the 
Trial Control Settings to suit your own application.

Procedure overview

1. The trial starts with a 30-second delay (See Start trial rule and 
Condition ‘Start delay’ below).

2. Next, as soon as the mouse enters the LightSpot zone, with both the 
nose- and center-point, the spotlight of the PhenoTyper is turned on. 
When both the nose- and center-point are not in the LightSpot zone, 
the spotlight is turned off. This sequence is repeated three times 
(see Sub-rule ‘Activation LightSpot’ on page 247).

3. After the Sub-rule is completed, the trial is stopped after a 5-second 
delay.

Choose Setup > Trial Control Settings > New and give this a new name.

Start trial rule

1. To start recording as soon as the Start trial button is clicked:
- Click the (default) Condition In zone box and press Delete.

Keep this Condition if you want to start recording some time 
after starting the trial.

Condition ‘Start delay’

2. To insert a 30-second delay, after recording has started:

a In the Components pane, under Conditions, double-click the Time
Condition or click the button next to it.

b In the Time condition window, type ‘Delay of 30 seconds’ in the 
Condition name field. In the Condition is met: group, select After 
a time of 30 secs. Optionally, enter a comment and click OK.
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c Insert the Condition box into the main sequence.

For more information about Conditions, see the EthoVision XT 18 - Trial 
and Hardware Control - Reference Manual.

Sub-rule ‘Activation LightSpot’

3. Because the sequence of turning on/off the spotlight depending on 
whether the animal is inside/outside the Spot Light Zone is repeated 
three times, you need to create a Sub-rule for this:

a In the Components pane, under Structures, double-click Sub-rule
or click the button next to it.

b In the Sub-rule window, type ‘Anxiety Test’ in the Sub-rule name 
field. Optionally, enter a comment and click OK.

4. Create an In zone Condition for when the animal enters the Spot 
Light Zone:

a In the Components pane, double-click the In zone Condition or 
click the button next to it.

Figure 11.3  Example of the Start trial rule and Condition ‘Start Delay’: with this 
sequence recording starts as soon as you click the Start trial button. Immediately 
after that, a 30-sec delay starts.

Figure 11.4  The empty Sub-rule ‘Anxiety Test’ sequence.
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b In the In zone Condition window, type ‘Inside LightSpot’ in the 
Condition name field.

c In the Condition is met when: group, from the Statistic list, select 
Frequency.  
Next, click the Settings button, select zone Spot Light from In the 
following zones, and select When in any of the selected zones 
from the list. 
In the From the following body points group, select both Nose-
point and Center-point. Make sure to select All selected points 
from the list.

d Click OK.

e Insert the Condition box into the Sub-rule sequence.

5. Create a Hardware Action (White Light on) for when the previous 
Condition is met:

a In the Components pane, under Actions - Hardware double-click 
Top Unit (standard) or click the button next to it.
If a third-party device has been connected (see step 4 on page 
243), under Actions - Hardware double-click Custom Hardware.

b Next to Action name, type in “White Light on”.

c Next to Action to perform, select White spot on from the list and 
click OK.

d Insert the Action box into the Sub-rule sequence.

If a third-party device has been connected, select an action from 
the Custom Hardware.

6. Create an In Zone Condition for when the animal leaves the Zone 
LightSpot:

a In the Components pane, double-click the In zone Condition or 
click the button next to it.

b In the In zone Condition window, Type Outside LightSpot in the 
Condition name field.

c In the Condition is met when: group, from the Statistic list, select 
Frequency. 

Next, click the Settings button, select zone Spot Light from In 
the following zones and select When not in any of the zones.
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In the From the following body points group, select both Nose-
point and Center-point. Make sure to select All selected points 
from the list at the bottom.

d Click OK.

e Insert the Condition box into the Sub-rule sequence.

7. Create a Hardware Action (White spotlight off) for when the 
previous Condition is met:

a In the Components pane, under Actions - Hardware double-click 
Top Unit (standard) or click the button next to it.

b Next to Action name, type in White Light off.

c Next to Action to perform, select White spot off from the list and 
click OK.

d Insert the Action box into the Sub-rule sequence.

If a third-party device has been connected, select an action from 
the Custom Hardware.

The Sub-rule Anxiety Test is now completed (see Figure 11.5).

Sub-rule Reference ‘Start Anxiety Test’

8. To create a Reference in the main sequence to the Sub-rule 
LightSpot:

a In the Components pane, under Structures, double-click Sub-rule 
reference or click the button next to it.

b Next to Reference name, type Start Anxiety Test.

c Next to Reference to sub-rule, select Anxiety Test.

d Next to Stop Conditions, select Repeat per start condition. Select 
for a number of ... times and set it to 3.

e Click OK and insert the Reference box into the main sequence.

Figure 11.5  The Sub-rule ‘LightSpot’ with the sequence as describe above in  
steps 4-8.
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Condition ‘Stop delay’

9. To insert a 5-second delay, before the trial is stopped:

a In the Components pane, under Conditions, double-click the Time
Condition or click the button next to it.

b If the Add a condition window appears, it means that there is at 
least one condition of the same type in your experiment. You are 
asked to choose between creating a new condition, or re-use an 
existing one. Choose the option you require and click OK. If this 
window does not appear, skip this step.

c In the Time condition window, type ‘After 5 seconds’ in the 
Condition name field. In the Condition is met: group, select After 
a time of 5 secs. Optionally, enter a comment and click OK.

d Insert the Condition box into the main sequence.

Figure 11.6 shows the complete Trial Control Settings. 

For more information and examples

 About PhenoTyper: PhenoTyper - EthoVision XT 18 - Reference 
Manual.

 About subrules, conditions and actions: EthoVision XT 18 - Trial and 
Hardware Control - Reference Manual.

Figure 11.6  The Trial and Hardware Control. The main sequence is displayed at 
the top, the Sub-rule sequence at the bottom.
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detection settings

Choose Setup > Detection Settings > open Detection Settings 1.

We assume you followed the main procedure on page 17.

1. Check in the Video Section that the sample rate is set to:
- Rats: 5 samples/second.

- Mice: 12.5 samples/second.

- Nose-tail tracking: 25-30 samples/second.

2. Under Method, choose your detection method and the contrast with 
the background.

If you selected to use the Deep learning technique to track the 
subject’s nose, next to Deep learning click Define and select a box 
around the subject. Make sure that the box includes the subject’s 
nose, and does not include objects of the same color as the subject. 
For details, see the EthoVision XT Help.

3. If you selected Activity analysis in the Experiment settings, open the 
Activity section in the Detection Settings pane. Enter the Activity 
threshold for detecting a change in the pixels in the arena. Start 
with the default value and check the purple-colored pixels in the 
video image. Adjust the threshold in such a way that when the 
animal is completely still, those pixels should be almost completely 
absent. Leave the Compression artifacts filter Off if you track live. 

trial list

Enter your independent variables such as rat ID, first or second phase of 
the experiment, treatment (drug vs. control), dose, duration of 
treatment, name of the experimenter, etc. If you want you can pre-
define all your trials here, or you can enter the independent variable 
values as you carry out the trials. 

You can also prepare the trials in Excel, randomize them and then paste 
the values into your Trial List.

To carry out batch acquisition, plan your trials in the Trial list. 
Optionally select Arena Settings, Trial Control Settings and Detection 
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Settings for each trial. If you do not select these settings in the Trial list, 
the ones selected in the Acquisition settings pane (see next section) 
will be used for all trials.

For data acquisition, see acquiring tracks on page 21.

Figure 11.7  A Trial List with two planned trials. Each trial includes four arenas 
(four PhenoTypers combined with a quad unit).
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Pre-Pulse Inhibition of the startle 
response (PPI)

introduction

Startle Pre-Pulse Inhibition (PPI) is an experimental paradigm to study 
sensorimotor gating. With this term we intend the ability of the brain 
to filter out irrelevant sensory stimuli to suppress or decrease a motor 
response, in this case, a startle response. 

The Startle PPI paradigm has been widely used in rodents, such as mice 
and rats, to study sensorimotor gating deficits in different animal 
models. In a typical PPI experiment, a startle baseline is measured as a 
response to a loud sound, or a light or air-puff. A pre-pulse stimulus is 
delivered shortly before the loud stimulus. That is supposed to 
decrease the startle reaction.

This section refers to the Ugo Basile system for the Pre-Pulse Inhibition 
of the Startle Reflex. You can have this system send TTL signals to 
EthoVision XT when a pulse is fired or terminated, and when an 
environmental output is activated or deactivated. This way the 
EthoVision XT tracking information is synchronized with the main 
events generated by the PPI system.

connection scheme
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For this you need the Ugo Basile PPI Startle Reflex Interface (see the 
figure above). This Interface box is connected to the PPI Startle Reflex 
system through a flat cable and has two additional output connectors, 
OUT 1 and OUT 2. You can connect one or both outputs to TTL ports of 
the USB-IO box. Contact Noldus if you need the proper adapter cables. 

 OUT 1 can be enabled with each stimulus pulse (or pre-pulse). The 
status is ON while the pulse is fired and OFF when the pulse is 
terminated.

 Out 2 can send out “environment” signals, like that for the visible 
light, the infrared light or the fan that can be turned ON or OFF at a 
specific time during the trial.

 See also the Ugo Basile Pre-Pulse Inhibition of Startle Reflex (PPI) 
User Guide.

EthoVision XT

 In the Experiment Settings, define the TTL ports as Custom 
Hardware.

 In the Arena Settings, click the Arena - Hardware Mapping button 
and define the devices for each arena.

 In the Analysis profile, define a Hardware State variable for 
example to visualize the pulses together with the tracking data.
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Data analysis

In this section you find general information on how to analyze data in a 
conditioning test (see page 242). 

data preparation

There are three optional steps you can take to prepare your data:

Edit the tracks

Choose Acquisition > Edit Tracks. 

You can fix tracking errors and swap back nose-points and tail-points 
that have been swapped in tracking. Normally you will not need to edit 
your data.

Smooth the tracks

Choose Acquisition > Track Smoothing Profile. 

You can use Smoothing and/or the Minimal Distance Moved filter to 
remove outliers from your data and correct the distance moved 
calculation as a result of body wobble.

Select tracks and intervals

Choose Analysis > Data Profile. 

Select your tracks according to your independent variable values and 
also select parts of tracks (nesting). You can also make groups of tracks 
to obtain group statistics. And you can define Time bins (see data 
selection below).
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data selection

Groups of tracks

Figure 11.8 shows a Data Profile to compare the animals that were 
treated with a drug, with those that were treated with saline. This way 
you create groups of tracks to obtain group statistics for each group.

Time bins

Using time bins means that you create time intervals of constant 
duration to analyze how variables change over time. 

The default data selection does not specify time bins, so the behavior 
will be analyzed as a whole. If you define time bins and specify an 
interval length of, for instance, 1 minute, you can investigate whether a 
specific behavior changes over time.

To define time bins:

1. From the Analysis menu, select Data Profile.

2. Select New and type in Time intervals.

3. Click the Settings button on the Result box.

Figure 11.8  An example of data selection to compare two data sets in your 
experiment.
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4. Select Results per time bin and enter the length of one interval, for 
example 30 s or 1 minute depending on the duration of your 
experiment. The data will be split in a number of intervals of the 
same length. 

When the track duration is not an exact multiple of the time bin 
that you set, the last time bin is shorter than the others. To ignore 
this time bin, select Ignore last time bin if incomplete.

5. Click OK.

If the white spotlight is aversive to the animal, the time spent in the 
Spot Light zone should decrease in the course of the trial. In contrast, 
the time interval between consecutive entries into Zone LightSpot 
should show an increase. Via data analysis in EthoVision XT, this can be 
investigated.

analysis profiles

Choose Analysis > Analysis Profile.

If you have multiple Data Profiles, create or open a Data profile without 
Results per time bin. 

Below is described how to create two analysis variables: 

  In Zone. This variable calculates how often and how long the 
mouse stayed in the illuminated zone.

 Trial Control State “Interval in Spot Light zone”. This variable 
measures the time elapsed until the mouse enters the light spot 
again. This is done for each repeat of the learning routine.

 Trial Control State “Duration Light on”. This variable measures the 
time that the mouse stays in the light spot in each repeat of the 
learning routine.

 Trial Control Event “Frequency light on”. This variable measures the 
number of times that the light is switched on.

In Zone

1. Select New and type in In Zone.
11 -  Other Conditioning Tests 257



258
- The new Analysis Profile contains the default dependent 
variables Distance moved and Velocity. Click on a dependent 
variable and press Delete to remove it.

2. Click the Add button next to In Zone.

a Under In the following zones, select Spot Light. Under From 
following body points, select both Nose-point and Center-point
and select All selected points from the list at the bottom. 

b In the Trial Statistics tab, select Mean, Frequency and Duration.

c Select additional statistics In the Group Statistics tab, if you 
created groups of tracks in your Data Profile.

d Click OK.

Trial Control

1. Click the Add button next to Trial Control State.

a From the From Element list, select Rule: Anxiety Test. From the 
From Event list, select becomes active.

b From the to Element list, select Action: Light on. From the to 
Event list, select becomes active.

c Select Calculate statistics per interval, for consecutive intervals: 1 
to 3.

d In the Trial Statistics tab, select Cumulative duration.

e Select additional statistics in the Group Statistics tab, if you 
created groups of tracks in your Data Profile. Next, click OK.

f Right-click Trial Control State, select Rename and type “Interval 
in Spot Light zone”.

2. Click the Add button next to Trial Control State.

a From the From Element list, select Action: White Light On. From 
the From Event list, select becomes active.

b From the to Element list, select Action: White Light off. From the 
to Event list, select becomes active.

c Select Calculate statistics per interval, for consecutive intervals: 1 
to 3.

d In the Trial Statistics tab, select Cumulative duration.

e Select additional statistics in the Group Statistics tab, if you 
created groups of tracks in your Data Profile. Next, click OK.
11 - Other Conditioning Tests



f Right-click Trial Control State, select Rename and type “Duration 
Light on”.

3. Click the Add button next to Trial Control Event.

a From the From Element list, select Action: White Light On. 

b From the From Event list, select becomes active.

c In the Trial Statistics tab, select Frequency.

d Select additional statistics in the Group Statistics tab, if you 
created groups of tracks in your Data Profile. Next, click OK.

e Right-click Trial Control Event, select Rename and type 
“Frequency light on”.

More options with the Free interval function

The Free interval function in the Data profile and in the Analysis profile 
allows you to extend the possibilities to define the start and the end of 
intervals. For example, from the time a stimulus event occurs, to 10 
seconds after that event. 

1. Choose Analysis > Analysis Profile.

2. Under Miscellaneous, click next to Free Interval.

For details, search the EthoVision XT Help for “Free interval”.

integrated visualization

When you Plot Integrated Data, the video file and the Time Event Plot 
are displayed. The Time Event Plot displays the variables of the active 
Analysis Profile. 
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Figure 11.9 shows the variables defined in the Analysis profile Trial 
Control described above, plotted against time.

Figure 11.9  The Integrated Visualization for the an Analysis profile containing 
Trial Control variables. The Time Event Plot shows (from top to bottom) Duration 
Light on, Frequency Light on and Interval in LightSpot, all for each arena 
separately. The vertical line shows the current position in the Time Event Plot and 
the video window displays the corresponding frame in the video.
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Introduction

the rotarod test

The rotarod test is widely used to evaluate drug effects on motor 
coordination in rodents. The principle of this test is that rats or mice are 
first trained to walk on a rod rotating at a certain speed. Once the 
animals have learned this, the effect of a test-compound on their 
motor performance is evaluated. Animals experiencing impaired motor 
coordination are unable to cope with the rotating rod and will drop off 
when the rotation speed exceeds their motor coordination capacity. 
The more disturbed the animals are, the sooner they fall off the rod.

The use of rotating rods to measure balance in rodents has been 
described since at least the 1950s (Dunham and Miya, 1957; Kinnard 
and Carr, 1957). Jones and Roberts (1968) introduced a significant 
modification of the basic design with an accelerating rod.

The rotarod is a horizontal cylinder that rotates along its long axis. It is 
situated above the cage floor, high enough to make sure rodents do not 
jump off the rod and low enough to avoid them being injured when 
they fall off. 

Figure 12.1  Rotarod for mice.
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The speed of the rotarod is mechanically driven and can be constant or 
accelerated during the test. 

The test consists of a training phase in which the rats or mice learn to 
walk on the rod at a certain speed. Then three test trials are carried out 
in which a drug is tested. A commonly measured parameter is the time 
until falling off.

With EthoVision XT the Rotarod test can be automated. A camera is 
placed above the Rotarod, which gives a top-view image of the setup. 
The rat or mouse that stays on the rod is present in the center of the 
camera image. When the animal falls off, or clings onto the rod and 
turns round on it, it moves out of the center of the image. This can be 
automatically quantified with various parameters in EthoVision XT.
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Physical setup

In most use cases, a video camera is positioned above the rod to record 
video. For systems with multiple rods, it is best to point one camera 
towards each rod. You can mix camera images directly with EthoVision 
XT or a video mixer. 

To detect the falling off the rod automatically, place the camera in front 
of the rotarod. You can have EthoVision XT detect the fall off event 
when the animal disappears from the arena, or a zone drawn around 
the rod.

 

Figure 12.2  Camera view.
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The Rotarod test in EthoVision XT

Create an experiment. For details, see Chapter 1 of this manual, or in 
EthoVision XT press F1 and see Setup an Experiment in the EthoVision 
XT Help.

experiment settings

Select the number of cylinders as Number of Arenas.

arena settings

Choose Setup > Arena Settings > Open Arena Settings 1.

After calibrating, click 2. Select Shape and Draw Arena. The arena 
covers the region around the rod. make sure that the animal is always 
within the arena boundary.

Zones

Click 3. Select Shape and Draw Zones. 

To quantify the position of the subject’s center point relative to the 
center of the rod, define a zone (Reference zone) at known distance 
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from the rotation axis of the rod. For example, draw a line (Reference 
line) at the right margin of the arena, and define a zone. 

You can then analyze the distance of the subject’s center point from 
the border of this zone. If you know that the border of the zone is for 
instance at 10 cm from the rod axis (Reference distance), than you can 
back-calculate the relative distance of the subject-center from the axis. 
The values of Distance to zone (border) diminished by the Reference 
distance will be either positive (when the subject moves forward on 
the rod) or negative (when it moves backward).

To measure the reference distance exactly, place a ruler on top of the 
rod, and refresh the background image. Then draw the Reference line at 
a specific distance from the rod. 

Note: do not define the Reference zone in the middle of the rod. If you 
do that, distance from the zone border will always be positive, no 
matter what the position of the subject is.

Zones for turnaround behavior detection

To automate turnaround behavior (mice grip themselves to the rod and 
turn around without falling off), you can define zones in front and at 
the back of the rod. 
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Divide the arena in three main zones: Middle (the rod area), the front 
and the back areas just outside of the rod.

It is then possible to detect turnaround behavior with the following 
sequence in the Zone transition variable: Middle (mouse in normal 
position) > Back > Front (The mouse reappears in view) > Middle (see 
Data analysis on page 269).

detection settings

Click Advanced. Under Subject Contour, select one or more pixels for 
the first Erosion and Dilation filter. Increase the first Erosion until the 
subject’s tail is not detected anymore. Then, increase Dilation until the 
entire body is detected.
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Acquiring data

Training phase

This phase lasts typically three days. Each subject is placed on the 
rotarod for a maximum of 1 minute. The trial is repeated a few times 
each day, with 5 to 10 minutes inter-trial interval.

Testing phase

Each subject is placed on the rotarod for a maximum of 1 minute. The 
trial is repeated two times with 5 to 10 minutes inter-trial interval.

See also acquiring tracks on page 21.

Scoring behaviors manually

If you want to score when the animal falls off the rod, define the 
behavior Falling off under Manual Scoring Settings. After you have 
started the trial, watch the subjects in the video and in the Manual 
Scoring tab at the bottom of the screen, click the button for the arena 
(subject) that applies.
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Data analysis

Choose Analysis > Analysis Profile > New.

Mouse position

In the Analysis profile, choose Distance to zone and select the 
Reference zone (see page 265).

Turnaround behavior

In the Analysis profile, click the button next to Zone transition. 

Select the following sequence: Middle > Back > Front > Middle.

The zones must be defined in the Arena Settings (page 266).

Latency to fall

If the camera is placed in front of the rotarod apparatus, you can 
measure the latency to fall by using the In zone variable. This calculated 
the time that the animal was detected in the arena (that is, until it fell 
off the rod).

See also calculate the statistics on page 26.
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Introduction

the y-maze

The Y-maze is constructed with three arms of equal length that extend 
from a central platform at a 120° angle. In the basic version, the animal 
is free to explore the maze arms. In a modified version, it is possible to 
close off some arms either to keep the animal in a specific arm for a 
fixed time once it has entered that arm, or to limit exploration to some 
arms, not others.

The Y-maze is generally used to investigate alternation behavior, where 
animals are supposed to alternate choices of maze arms on successive 
opportunities. Irrespective of the precise function of alternation, the 
animal must remember which arm it had entered on a previous 
occasion to enable it to alternate its choice on a following trial. 
Therefore, the use of the Y-maze is based on the assumption that, 
following some pharmacological manipulation, it is primarily modified 
memory processes that are reflected in changed alternation rates.

Figure 13.1  A Y-maze setup with automatic doors in each arm.
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spontaneous alternation

Definition

Spontaneous Alternation is a behavioral test for measuring the 
willingness of rodents to explore new environments. Rodents typically 
prefer to investigate a new arm of the maze rather than returning to 
one that was previously visited. Many parts of the brain, including the 
hippocampus, septum, basal forebrain, and prefrontal cortex--are 
involved in this task (Conrad et al. 1996).

Classical procedure

The animal is released in the center of the maze, and allowed to freely 
explore the three arms (A, B, C). Over the course of multiple arm 
entries, the subject is expected to show a tendency to enter a less 
recently visited arm (A > B > C > A > ...). The observer records the 
number of arm entries and the number of visits to the three arms 
without a re-visit in between; for example, A > B > C, B > C > A, etc.) in 
order to calculate the percentage of alternation. An arm entry is scored 
when all four limbs are within the arm.

Calculation of Alternation index

Given a zone sequence:

A > B > C > B > ...

An alternation is defined as multiple entries into the three different 
arms on overlapping triplet sets. In this example the first three visits 
are an alternation:

A > B > C > B > ...

The next overlapping triplet set, B > C > B is not an alternation.

The Alternation index is given by the number of alternations divided by 
the maximum number of possible alternations, that is, the number of 
alternations that would be obtained if the animal visited the zones in 
the sequence: A > B > C > A > B > C ... 

For a 3-arm maze, like the Y-maze, The maximum number of 
alternations is equal to total number of visits minus 2.
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Alternation index is expressed in percentage:

Spontaneous Alternation in EthoVision XT

You can easily calculate the Alternation index using the outputs 
Alternations and Max Alternations in the Zone alternation dependent 
variable. See page 281.

For more information, see Zone alternation in the EthoVision XT Help.

delayed alternation

The delayed alternation task allows assessing spatial working memory 
in a T- or Y-maze. The main difference with spontaneous alternation is 
that performance is evaluated between trials.

Classical procedure

In the first trial of the test, the animal is placed at the end of the start 
arm and has to choose between the two other arms that are baited. 
Once the choice made, the subject is removed and after a variable 
delay, is returned in the start arm. In this second trial, the one arm 
baited is now the opposite arm to which chosen during the first trial. 
The animal has to make a different choice than its first one (correct 
choice) to get the reward.

Delayed Alternation in EthoVision XT

For all tests where maze arms can be considered as targets of a choice, 
and others non-targets (errors), you can use outputs Target first visits 
and Total errors in the Target visits and errors dependent variable. See 
page 281.

For more information, see Target visits and errors in the EthoVision XT 
Help.

Alternation index Number of alternations
Total nr. of zone visits - 2
-------------------------------------------------------------- 100=
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The Y-maze test in EthoVision XT

Create an experiment. For details, see Chapter 1 of this manual, or in 
EthoVision XT press F1 and see Setup an Experiment in the EthoVision 
XT Help.

For suggestions about optimize lighting, see page 87.

experiment settings

Choose Setup > Experiment Settings.

 Number of Subjects per Arena: 1.

 Tracked Features: Center-point detection or Center point, nose-
point and tail-base detection.

 If you want to use Deep learning technique to track the subject’s 
nose, under Body point detection technique choose Deep learning. 
Note that in order to use this technique there are additional 
requirements. Among other things, you need a powerful graphics 
card. See Deep learning: Requirements and Limitations in the 
EthoVision XT Help.

arena settings

We assume that you followed the procedure in arena settings on page 
15.

For the Spontaneous alternation task

1. Choose Setup > Arena Settings > Open Arena Settings 1.

2. Choose the video / camera image and click Grab.

3. Click 2. Select Shape and Draw Arena. Resize and move the outline of 
the arena to make it overlap with the Y maze image.
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For details on how to resize and move the outline the arena, see arena 
settings on page 15 and Arena Settings in the EthoVision XT Help.

For the Delayed alternation task

Choose Setup > Arena Settings > New.

After calibrating and drawing the outline of the arena. click 3. Select 
shape and draw zones. Draw the three arm zones. To draw the start box 
zone and the target zones (that is, the arm ends which will be baited 
with food), create an additional zone group (Figure 13.3). 

For details on how to work with zone groups, and draw and edit shapes, 
see Arena Settings in the EthoVision XT Help.

Figure 13.2  Example of arena and zones in a Y-maze for spontaneous 
alternation. Zones are highlighted with different overlay colors.
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trial control settings

In the Trial Control Settings you can define conditions for the start and 
stop of the data acquisition. 

Choose Setup > Trial Control Settings > New.

Default Trial Control

The templates for the Y maze contain the following Trial Control 
Settings profiles:

 Default. Tracking starts when the subject’s center point is detected 
for 1 second in the arena. Tracking stops at the end of the video or 
when you give the stop command.

Figure 13.3  Example of arena and zones in a Y-maze for delayed alternation. On 
the right, the Arena Settings window shows two zone groups: Zone Group 1 with 
the zones Left arm, Right arm and Start arm (these zones are like in the Arena 
Settings for spontaneous alternation), and Start zone and targets with the target 
zones (Left bait and Right bait) and the Start zone.
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 Tracking Duration 5 min. Tracking starts when the subject’s center 
point moves from the start box to the center arm. Tracking stops 
after 5 minutes.

detection settings

Choose Setup > Detection Settings.

We assume that you followed the procedure in detection settings on 
page 17. 

Check in the Video Section that the sample rate is set to:
- For rats: 5 samples/second.

- For mice: 12.5-15 samples/second. 

However, when tracking the nose-point, center-point and tail-base 
point of the rodents, always choose the maximum sample rate.

If you selected to use the Deep learning technique to track the subject’s 
nose, under Method next to Deep learning click Define and select a box 
around the subject. Make sure that the box includes the subject’s nose. 
Try not to include objects like walls, especially if they are the same color 
as the subject. For details, see the EthoVision XT Help.

trial list

Independent variables

If you perform a Y-maze test where one of the arms is closed off or 
provided with food, it is always a good idea to create independent 
variables that mark the type of trial, and which you can use to select a 
subset of trials for answering a specific question. For example, create 
the independent variable Correct choice with possible values Yes and 
No, depending on whether the subject chose the arm not visited in the 
previous trial. At the end of each trial, enter the value for that subject. 
You can use this variable to filter the trials based on the value of Correct 
choice.
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Acquiring data

protocols

Continuous Spontaneous Alternation

1. Release the subject in the center of the Y maze.

2. Start the trial.

3. Let the subject explore the maze for the time required (typically 5-6 
minutes). Then, stop the trial. 

4. Put the subject back in its home cage. Proceed with the next subject.

Forced-choice Alternation

In this variant, the subject is forced to explore one of the two arms in 
the first trial.

1. Close one of the arms of the maze. Place the subject into the start 
arm, and allow it to explore the maze for 15 minutes.

2. After a fixed inter-trial interval, open the door in the blocked arm. 
Return the subject to the maze by placing it in the start arm. The 
subject is allowed to explore freely all three arms of the maze for 5 
min. The Y-maze is often rotated between the two trials.

Two-trial Spontaneous Alternation

In this task, the subject is confined for a fixed time in the T- or Y-maze 
arm chosen in the first trial. This allows to manipulate the time that 
the animal has experience with one of the arms.

1. In the first trial, let the subject access one of the arms after having 
left the start arm. Once an arm has been entered, close off that arm 
by lowering a guillotine door behind the subject. Leave the subject 
there for a fixed time (this is called intra-trial interval).

2. Remove the subject and, after an inter-trial interval, let it choose the 
arm in a second trial. This two-trial sequence is repeated a number 
of times.
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Delayed Alternation

This task is usually designed with a T- or a Y- maze where one arm is the 
starting location, and the other arms are baited.

1. Release the subject in the start arm. Once the subject enters one of 
the other two arms, close the door for that arm (trial 1). 

2. After a predetermined inter-trial interval, release the subject and let 
it freely choose one of the two arms (trial 2).

If the subject chooses the alternate arm, this is scored as alternation. 
This two-trial procedure is repeated several times.

See also acquiring tracks on page 21.
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Data analysis

analysis profiles

Choose Analysis > Analysis Profile...

The template experiment contains the analysis profiles:

 Distance, Time & Movement. To calculate the total Distance moved 
(a measure of activity of the animal), the mean Velocity, and the 
total time spent in the to states of Movement (moving and not 
moving). The group means with their standard errors are also 
calculated.

 Zone alternation. with the variables In zone (to calculate the 
frequency, total time and latency to first visit for each zone; and 
Zone alternation, to calculate the number of alternations and the 
maximum number of alternations for that set of zone visits (see 
below). 

See the section below to create analysis profiles for specific tasks.

alternation behavior

Spontaneous alternation

Choose Analysis > Results > Statistics and Charts. 

Select the Analysis profile that contains Zone Alternation variable.

Locate the column Zone Alternation in the table.

To calculate the Alternation index, divide Alternations by Max 
alternations and multiply this by 100.

To change the Zone alternation definition, open the Analysis profile 
Zone Alternation and double-click the variable Zone alternation. Here 
you can specify which statistics you want to have. You can also enter a 
Zone exit threshold, to remove false re-entries in a zone from the 
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statistics, due to small movements of the body point near the zone 
borders.

For more information, see Zone alternation in the EthoVision XT Help.

Delayed alternation

For delayed alternation tests, Zone alternation is not the correct 
dependent variable. To analyze correct and incorrect choices, use Target 
visits and errors to compare performance between trials. Because the 
target arm changes between trials (for trial 2, the target is the arm 
which was not visited in the previous trial), you must define multiple 
instances of Target visits and errors.

Whether an arm can be defined as “target” depends on the outcome of 
the previous trial. If the subject went to the Left arm in trial x, then for 
trial x+1 the target should be the Right arm, and a revisit to the Left arm 
should be scored as an error.

To do this, in the Trial List (Setup > Trial List) mark each trial with a 
variable which states which arm was the correct choice. By definition, 
the 1st trial of each subject has no “correct” choice (the values for 
subsequent trials depend on what the animal does in that trial).
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In the Data Profile, filter the trials based on this variable. Make two 
Data profiles, one for “Right arm correct” and one for “Left arm 
correct”.

Next, create two analysis profiles. For example:

 Analysis profile Target visits and errors for when the target (correct 
choice) was the Left arm. The Right arm is a non-target; visits to 
that arm are scored as errors.

 Analysis profile Target visits and errors for when the target (correct 
choice) was the Right arm.
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When you analyze the data, make sure to combine a Data profile with 
the correct Analysis profile.

visualizing data

Choose Analysis > Results > Integrated Visualization.

Figure 13.4 shows an example of visualization of spontaneous 
alternation behavior.

The first plot shows the variable In zone defined in the Analysis profile; 
there you can see which arms were visited during the trial. 

The second plot is of Zone alternation. The subject visits first the zone 
marked in blue, then that in red, and when the subject enters the green 
-marked zone, an alternation is completed. This is scored as 
Alternations (blue vertical segment; A). At every visit except the last 
two in a trial, also Max Alternations is scored (purple vertical segment; 
B). This marks the moment a possible alternation could have occurred. 
This variable is useful to calculate the Alternation index (see page 281).

The plot also includes direct revisits (for example, green > green) or 
indirect revisits (green > red > green; C). The more revisits, the lower 
the Alternation index.
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Figure 13.4  Integrated visualization of the dependent variables In zone and 
Zone alternation for a Y-maze test. See explanations in the text.
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Introduction

optogenetics and ethovision xt

In the last decade, a method was developed to specifically activate or 
even inhibit small groups of neurons with light. Today, scientists can 
insert light-sensitive receptor proteins (originally found in algae) into 
single mammalian neurons in vivo, making these neurons sensitive to 
activation by light of specific wavelengths. This allows scientists to 
control the activity of these neurons and study their downstream 
influence on a variety of biological processes [ref. 1, 2].

Optogenetics is an important development for behavioral research. Not 
only can the actual influence of specific neurons on behavior more 
specifically be determined, but also, with the help of an automatic 
video tracking system such as EthoVision XT, behavior can be 
manipulated via optogenetic methods in real time. With the Trial & 
Hardware Control module, EthoVision XT can control light pulses given 
by a third party device, based on the behavior of the animal (for 
instance, presence in a trigger zone).

In this manual we focus on the optogenetics solution for rodents that 
combines EthoVision XT, PhenoTyper (as test environment) and the 
Prizmatix optogenetics devices. For how to conduct optogenetics 
experiments with zebrafish, see the DanioVision DVOC-0041 -
Reference Manual.

examples

Place preference

The animal is placed in an arena with two distinct sides - one of which 
is paired with optogenetic stimulation. Depending on whether this 
stimulation is activating or deactivating, and which neurons are 
affected, this can be a rewarding or aversive stimulus for the animal. If 
in further sessions the animal spends more time on the stimulated 
sides, it is fair to conclude the stimulus had a rewarding effect. If the 
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animal avoids this side, the stimulus could then be considered aversive 
[ref. 3,4]. 

Operant conditioning

In operant conditioning tests, the animal learns to perform an action in 
order to get a reward or avoid an aversive stimulus. The behavioral 
response can be recorded with EthoVision XT, either by detecting the 
animal (or its nose point) in a certain zone, such as the feeder, or by 
analyzing the external signal initiated by the nose poke or lever press. 
Following this action, EthoVision XT sends out the command for 
optogenetic stimulation [ref. 3,4].

Off-on-off stimulus test

In an off-on-off stimulus test, you can program EthoVision XT to turn 
optogenetic stimulation on for a period of time during the test. For 
example, a 15 minute test during which continuous optogenetic 
stimulation takes place in the middle 5 minutes.
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Physical setup

components (example)

Devices

 PC with EthoVision XT installed.

 Noldus USB-IO Box.

 PhenoTyper with adapted Top Unit (optional).

 Prizmatix LED controller (for different light wavelengths).

important  To control the LED through EthoVision, on the back 
panel of the LED controller, near/below the TTL connector, select 
Ext (but if you want to activate the LED manually using the button 
located on the front panel, you should select Int). The other switch 
on the LED controller, just near/above the Ain 0-5V connector, 
should be in the Int position.

 Prizmatix Pulser (left) or PulserPlus (right) (with advanced setup).

   

Main cables and fiber cords

(in bold, port names; power cords and video cables not listed)
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 USB cable (USB-A to USB-B). Use this cable to connect the 
EthoVision XT PC to the USB-IO box [USB, type-B]. Also use this 
cable to connect the Pulser to the PC.

 UTP to BNC cable. To connect the USB-IO box [TTL control] to the 
LED Controller [TTL] or Pulser [Trig. In].

note 1  Each TTL port of the USB-IO box has two output lines. The 
white RCA jack corresponds to Output 1 and the red RCA jack to 
Output 2. Take note of this when selecting the TTL commands in 
EthoVision XT page 299).

note 2  If you received UTP-to-BNC cables with four BNC 
connectors, only use those marked with Output to connect the LED 
controller or Pulser. 

 BNC to BNC cable. From Pulser [TTL Out] to LED Controller [TTL].

 Fiber patch cord, core 1000 m. To connect the LED Controller [front 
panel] to the PhenoTyper Top Unit [Fiber Coupler adapter, see 
Figure 14.2B-C].

 Fiber patch cord, core 1000. This is located inside the PhenoTyper 
Top Unit. It connects the FC adaptor to the Rotary joint.
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 Single fiber. To connect the Rotary joint fixed on the bottom plate 
of the PhenoTyper Top Unit to the implantable cannula. Available in 
various core diameters (e.g. 500 m).

Other components

 Zirconia ferrules (sleeves) for 2.5 mm and 1.25 mm cannulae. 

 Optogenetics implantable cannulae (2.5 mm, 1.25 mm).

basic setup

Aim

With a basic setup, without the Pulser, EthoVision XT controls 
activation of the LED directly via the Noldus USB-IO box. With this 
setup you can, for example, activate the LED for one second.

Functional scheme

Notes

 Activation of the LED can be repeated during a trial using the 
Subrule function in the Trial Control Settings.

 For generating two pulses of different length, you must create 
separate Trial Control commands.

Limitations

 The pulse cannot be shorter than 0.1 s.

Figure 14.1  Activation of the optogenetics fiber directly from the USB-IO box.
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 Accuracy of onset, offset and duration of a pulse is approximately 
the time taken by three samples. When tracking at 30 fps, this time 
is 0.1 s. The higher the sample rate, the higher the accuracy.

For the advanced setup, see page 293.

Connection scheme

Figure 14.2  Cable connections for controlling the LED controller directly from 
EthoVision XT and the USB-IO box. A. Back panel of the LED controller. Under the 
TTL connector there is a switch; set it to Ext. This way you enable external control 
of the LED. Note that each TTL port of the USB-IO box has two output lines. 
Connect the LED controller to the USB-IO box using the white RCA jack if you use 
Output 1, or with the red jack if you use Output 2 (see page 290). The other switch 
on the LED controller, just near/above the Ain 0-5V connector, should be in the 
Int position so you can manually adjust the light intensity using the knob on the 
front panel. B. Front panel of the LED controller with patch fiber cord connected. C. 
PhenoTyper Top Unit adapted for connecting the LED controller. D. Bottom plate of 
the PhenoTyper Top Unit with Rotary joint and optical fiber.
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note  If you received UTP-to-BNC cables with four BNC connectors, only 
use those marked with Output to connect the LED controller.

advanced setup (with pulser)

Aim

With this setup, EthoVision XT controls activation of the LED via the 
Prizmatix Pulser and PulserPlus devices. With this setup you can send 
out a very specific sequences of pulses, at a frequency higher (max 0.5 
kHz) than with the basic setup. The sequence is predefined in the 
Pulser/PulserPlus (see page 305).

note  PulserPlus is the device with three BNC connectors.

Functional scheme

Figure 14.3  Activation of the optogenetics fiber from EthoVision XT with a train 
of pulses programmed in the Prizmatix Pulser or PulserPlus.
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note  For information about how to use the Pulser with its own 
software, see the Prizmatix Pulser/PulserPlus user manual which 
comes with the device.
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Connection scheme

Notes

 If you received UTP-to-BNC cables with four BNC connectors, only 
use those marked with Output to connect the Trigger In/Trig. In 
port on the Pulser/PulserPlus.

Figure 14.4  Cable connections for controlling the Pulser and the LED controller. 
For A to D, see Figure 14.2. On the LED controller, make sure that the switch near/
below the TTL connector is in the Ext position. Also keep the switch near/above 
the Ain 0-5V connector in the Int position. 
E. Front and back panel of the Pulser/PulserPlus. Note that each TTL port of the 
USB-IO box has two output lines. Connect the Trigger in / Trig. In port of the 
Pulser/PulserPlus to the USB-IO box with the white RCA jack if you use Output 1, or 
with the red jack if you use Output 2 (see page 290). Connect the Pulser/PulserPlus 
to the PC with a USB cable. 
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 important  If you have the PulserPlus, set the Operation mode 
switch to PC. For more information on how to install the Pulser/
PulserPlus, see the user manual that comes with the device.

 For more information and connection schemes, see also the section 
The DanioVision Optogenetics add-on in the DanioVision DVOC-
0041 - EthoVision XT 18 - Reference Manual.

measure the led light output

In some circumstances you may want to measure the LED light 
intensity at the tip of the cannulae.

For this you need a sensor and a power meter. Note that a standard 
power meter may not give accurate measurements. See this link for a 
few suggestions.

https://www.prizmatix.com/blog/main/0/23/Optical-Power-Meters-
for-Optogenetics

An example is the Thorlabs S140C or Thorlabs S142C coupled with the 
Thorlabs PM100USB interface which shows the measurements on a 
computer screen.

See also https://www.thorlabs.com/navigation.cfm?guide_id=37
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Optogenetics experiments in 
EthoVision XT

Create an experiment. For details, see Chapter 1 of this manual, or in 
EthoVision XT press F1 and see Setup an Experiment in the EthoVision 
XT Help.

If you use PhenoTyper, you can create an experiment from a 
PhenoTyper template. Choose File > New from Template and in the 
guided wizard, from the Arena template list, choose PhenoTyper (for 
one cage) or PhenoTyper quad (for two to four cages).

experiment settings

Choose Setup > Experiment Settings.

General settings

 Set Video Source to Live Tracking and select the camera image.

 Choose the Tracked Features that apply to your experiment.

Use of Trial Control Hardware

1. Under Trial Control Hardware, Select Use of Trial Control Hardware.

2. Click Settings and choose Noldus USB-IO box.

3. In the window that appears, locate the TTL port of the USB-IO box 
that is connected to the LED controller, and from the Device type list 
choose Custom Hardware. Under Device ID give this device a unique 
name (for example LED controller 1, or Pulser if you use the Prizmatix 
Pulser/PulserPlus).

4. Repeat the previous step if you have more LED controllers or Pulsers. 

important  Make sure that Custom Hardware is selected in the Device 
Configuration window, not TTL Tester or others.
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arena settings

Choose Setup > Arena Settings > Open Arena Settings 1.

We assume that you followed the procedure in arena settings on page 
15.

Arena-Hardware Mapping

1. Make sure that you have drawn all the arenas.

2. At the bottom of the Arena Settings window, click the Arena-
Hardware Mapping button.

3. In the Arena-Hardware Mapping window, click Add device one or 
more times depending on how many physical devices (LED 
controllers or Pulsers) are connected.

4. Assign the devices to the arenas.

For setups with one cage (and one device), that is automatically 
assigned to Arena 1.

For setups with multiple cages (and devices), assign each device to 
the corresponding arena.

5. For each row, rename the Device name (for example, rename Device 
A to LED controller 1 or Pulser 1).

tip  Give devices unique names. That is also handy when analyzing 
the data and events of specific devices.

To test the LEDs

note  This procedure is only valid for the Basic setup (without Pulser).
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1. In the Arena-Hardware Mapping window, Click the row that 
corresponds to the device you want to test and click the Test 
button.

2. Choose Output 1 High and click Test. Check that the LED is activated.

3. Choose Output 1 Low and click Test. Check that the LED is 
deactivated.

trial control settings

In the Trial Control Settings you can program activation and 
deactivation of the LED controller during the trial. If you use the 
Prizmatix Pulser, see page 305.

Choose Setup > Trial Control Settings.

Below you find a simple example. It shows how to switch on a LED one 
minute after the start of the trial, keep the LED active for one second, 
and then switch it off.

To switch on the LED

1. Under Actions, click the button next to Custom Hardware.

2. From the Custom Hardware list select the LED controller device (this 
is the name given under Device name in the Arena-Hardware 
Mapping window; see page 298).

3. From the Action to perform list select Output 1 High (or Output 2 
High if you connected the USB-IO box to the LED controller using the 
cable with the red RCA connector - see page 290).

4. optional  Rename the Action name (for example, rename Hardware 
act (1) to Start Pulse).
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5. Click OK and insert the new Action box in the Trial Control sequence, 
usually after a condition.

In the example below, the stimulation is given one minute after the 
start. Therefore, a Time Condition box is inserted between the Start 
track box and the Action box just made.

note  With this Trial Control procedure, the stimulus does not stop 
unless you insert another Action box that specifies Output 1 Low (see 
below).

To switch off the LED after some time

1. Follow the instructions on the previous page to program activation 
of the pulse.
14 - Optogenetics Experiments



2. Under Conditions, click the button next to Time. Select After a time 
of and enter the duration of the pulse (minimum possible: 0.1 s). 
Next, insert the Condition box immediately after the Action box.

3. Under Actions, click the button next to Custom Hardware.

4. From the Custom Hardware list select the LED controller device (this 
is the name given under Device name in the Arena-Hardware 
Mapping window; see page 298).

5. From the Action to perform list select Output 1 Low (or Output 2 Low 
if you connected the USB-IO box to the LED controller using the 
cable with the red connector).

6. optional  Rename the Action name (for example, from Hardware 
act (2) to Pulse Off).

7. Click OK and insert the new Action box after the second Time 
Condition box.

The sequence can be read as follows:

One minute after the start of tracking (first box), activate the LED 
controller (second box), then wait one second (third box) and 
deactivate the LED controller (fourth box).
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To activate the LED when the animal is in a zone

It is often required to activate the LED multiple times, for example, 
every time the subject enters a trigger zone, or every time the subject 
presses a lever.

In such a situations you need to create a Subrule that can be repeated 
indefinitely. The Subrule contains the following instructions (see the 
next picture, from left to right):

 Check that the subject is in the zone (or the lever is pressed) (a). In 
this example the condition is based on “Current Duration”, that is, 
it becomes true when the subject is found in the zone for a specific 
time. 

 When the previous condition is met, turn the LED on (b; for details, 
see page 299).

Figure 14.5  Trial Control Settings for activating the LED when the subject is in a 
specific zone. a. Condition box that checks if the animal is in the zone. b. When the 
condition a becomes true, then the Action box activates the LED. c. Condition box 
that checks if the animal is out of the zone. d. When the condition c becomes true, 
then the Action box switches off the LED. Next, the Subrule starts again with 
condition a being evaluated. The Reference box (at the top) specifies that the 
Subrule is repeated indefinitely until the end of the trial.
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 Check that the subject is out of the zone (or presses another level/
performs an action to be linked to the end of stimulation) (c).

 When the previous condition is met, turn off the LED (d).

note  You can also base the “In Zone” conditions on the statistic 
“Current”. However, in such case when the subject walks along the 
zone border its center point will jitter between somewhere outside the 
zone and inside the zone. For this reason the “Current” value of the In 
Zone variable will rapidly change from true to false and vice versa, 
therefore the conditions based on this variable become true and false 
very often. To prevent this from happening, in the “In Zone” Condition 
window click Settings and enter a Zone exit threshold. This way the 
subject is still considered in the zone (Current In Zone = true) if its body 
point is found within the threshold distance from the zone border. The 
subject is only considered out of the zone (Current In Zone = false) if it 
crosses the threshold.

tip  Reduce the zone by a distance half of the exit threshold; for 
example if the exit threshold is 4 cm, reduce the zone border by 2 cm. 
This way you do not overestimate the size of the zone when using the 
exit threshold. For details, in the EthoVision XT Help see Dependent 
Variables in Detail > In zone.
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detection settings

Choose Setup > Detection Settings.

We assume that you followed the procedure in detection settings on 
page 17.

Set the sample rate

In the Video section, check that the sample rate is set to:

 Rats. 5 samples/second.

 Mice. 12.5 samples/second.

However, when tracking the nose-point, center-point and tail-base 
point of the rodents, always choose the highest possible sample rate, 
for example 25 or 30 samples/s, depending on your camera.

Remove the effect of cables and fibers

When working with physiology and optogenetics setups, the cables 
and fibers often make detection of the subject impossible with the 
default settings (see the figure below, left). 

To filter fibers out of the video image (right), use the Subject Contour 
options. If the fiber is the same color as the subject, like in the figure 
below (left), then increase the value in the first Erosion filter until the 
fiber is no longer detected (figure below, right). Increase Dilation to 
make the entire body fully detected. Leave the second Erosion filter to 
zero.

If the fiber has a different color and “cuts” the yellow blob in two, try 
first Dilation, and then increase the second Erosion filter.
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Using the Pulser

pulse sequences

Aim

To specify a train of pulses of frequency up to 0.5 kHz.

The Pulser software

The Pulser/PulserPlus can send out a very specific modulated pulse 
sequence. You can program the Pulser by specifying a number of 
parameters in a command line (string command; see below). This 
command line is sent out from EthoVision XT to the Pulser.

Structure of the pulse sequence

Pulse train. Two pulses (1 and 2) are organized in a Pulse train. This is 
described by (see Figure 14.6):

 The duration of pulse 1 (P1D).

 The interval between pulse 1 and pulse 2 (P1I).

 The duration of pulse 2 (P2D).

 The interval between pulse 2 and the end of the train (P2I).

 The interval between trains (BI).

Figure 14.6  Parameters describing a train of pulses 1 and 2.
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Number of trains. A pulse train can be repeated a number of times 
specified by the parameter TNT (see below). The total duration of the 
signal is given by TNT times the total duration of the other five 
parameters. 

Group of pulse trains. A number of trains defined as above can be seen 
as a group. The duration of the group is defined automatically by the 
parameters above. Multiple groups of pulse trains are therefore 
defined by the interval between groups (GI) and the total number of 
groups (TNG).

Structure of the string command

echo MTNT,BI,P1D,P1I,P2D,P2I,TNG,GI,OM,NoT,ToDy,ToDu,ToIt,ToNu@ > 
[COM port number]

Where

Figure 14.7  Parameters describing groups of pulse trains.

echo DOS command that sends the string.

M Command prefix. Do not put commas between this 
and the next parameter.

TNT Total number of trains.

BI Interval between trains (msec).

P1D Duration of pulse 1 (msec).

P1I Interval between pulse 1 and 2.

P2D Duration of pulse 2 (msec).
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Example

In an optogenetics protocol we want to stimulate the animal with light 
bouts of 20 ms separated by 20 ms off. This would result in 25Hz 
stimulation. P1D = P2D = P1I = P2I = 20 ms. 

The resulting string command we need to send to the Pulser would be 
(Note: OM = 3 for Pulser, 103 for PulserPlus):

P2I Interval between pulse 2 and end of train (ms).

TNG Total number of groups of pulse trains.

GI Interval between groups (sec).

OM Operational mode. For Pulser [0,1,2,3], for PulserPlus 
[100 to 103] where
0 (100) = Do not use the trigger input
1 (101) = Use the trigger for single sequence
2 (102)= Use the trigger. Perform the and when 
finished wait for the next trigger.
3 (103) = Use the trigger. Perform the sequence as 
long as the trigger is “high”. This is the 
recommended option.
See also the Pulser/PulserPlus User Manual.

NoT Number of Triggers [1, 2,...].

ToDy Delay of TrigOut from last train finish (not used by 
EthoVision XT).

ToDu Duration of TrigOut (not used by EthoVision XT).

ToIt TrigOut interval (not used by EthoVision XT).

ToNu Total number of TrigOut (not used by EthoVision XT).

@ End of command (no comma before it)

MTNT BI P1D P1I P2D P2I TNG GI OM NoT

echo M1, 0, 20, 20, 20, 20, 1, 0, 3 
(103),

1,
14 -  Optogenetics Experiments 307



308
Notes

 Although the total number of trains TNT is set to 1, the pulses are 
sent out continuously because the Operation mode is set to 3. In 
this case the pulse trains are generated as long as EthoVision XT 
sends the TTL signal “high”. When EthoVision XT sends the TTL 
signal “low”, the sequence stops.

 If one wants to stimulate the animal as long as the animal is in a 
specific zone, in the Trial Control Settings the TTL signal “high” 
must be associated with a condition based on the variable In zone 
(see an example on page 314). 

 With Operation mode 3, during generation of the pulse sequence 
the LED is lit on continuously.

 If you have the Pulser and the older Pulser software (version 2.1) the 
command above would be: C echo 1,0,20,20,20,20,1,0,3,1@.

configure the com port for each pulser

Aim

To configure the COM port in such a way the Pulser/PulserPlus accepts 
commands from EthoVision XT.

Procedure

1. Connect the Pulser/PulserPlus to the PC using the USB cable (type-
A to type-B connectors).

2. In the Control Panel, open the Device Manager.

3. Under Ports (COM & LPT), right-click USB Serial Port and select 
Properties.

ToDy ToDu ToIt ToNu

0, 0, 0, 0 @
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4. Click the Port Settings tab.

5. Make sure that the parameters are as below, then click OK.

6. Take note of the port number (in the example above it is COM3).

7. Repeat the procedure for each Pulser/PulserPlus.
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Notes

 The COM port number is retained in the Pulser, so if you disconnect 
the Pulsers and reconnect them, you do not have to assign the COM 
ports again.

 tip  To know which COM port is assigned to a Pulser/PulserPlus 
device, disconnect the USB cable from the Pulser/Pulser Plus. Then, 
re-connect it. The item that appears under Ports (COM & LPT) 
indicates the COM port.

 tip  To change the COM port for a specific Pulser, in the Control 
Panel, open the Device Manager. Under Ports (COM & LPT), right-
click the COM port, select Properties, Port Settings, then Advanced. 
From the COM Port Number list select the COM port among those 
available.

program the prizmatix pulser/pulserplus 
within ethovision xt

Aim

To program the pulse sequence.

Prerequisites

 The Pulser driver is installed. If not, see page 335.

 The COM port is configured as described on page 308.

 important  Make sure that Custom Hardware is selected in the 
EthoVision XT Device Configuration window, not TTL Tester or 
others. See page 297.

Procedure 1 - Initialize the COM port

In EthoVision XT, open the experiment and choose Setup > Trial Control 
Settings > New. Follow all instructions below.

1. Under Actions choose External command.

2. Next to Select program to run browse to 
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C:\Windows\System32\cmd.exe

3. Add the Command line options as follows.

/C mode COMn BAUD=57600 PARITY=N DATA=8 STOP=1 DTR=off 
RTS=off

important  In place of “n”, enter the number of the COM port for 
that Pulser.

note 1  The command /C closes the window after sending the 
command line.

note 2  If you have the Pulser and the older Pulser software (version 
2.1) the command above would be: /C mode COMn BAUD=57600 
PARITY=N DATA=8 STOP=1 DTR=on.

4. Click OK and insert the resulting box after the Start Trial box.
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5. Under Conditions choose Time.

6. In the Time Condition window, select After a time of 2 secs.

7. Insert the Time Condition box after the Action box. 

Why this Time condition?

A Time condition is placed to allow the instructions in the external 
command to be processed, before the next external command (that 
is, the one defining the pulse sequence; see below) is received by 
the Pulser. Because the two external commands act on the same 
program cmd.exe, if this Time condition is absent the second 
command may not be executed by the Pulser which is still busy 
with the first command.

important  If you use multiple Pulsers, there may be more time 
needed to initialize the ports. If the Pulser does not respond it could 
be due that the 2 s waiting time is not enough. Set a longer time, 
like 5 seconds or the like.
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Procedure 2 - Define the pulse sequence

The aim of this procedure is to have EthoVision XT send the command 
that specifies the sequence parameters.

1. Under Actions choose External command.

2. Select the Program to run and the Command line options as follows 
(remember to enter the number of your port instead of [n]):

/C echo MTNT,BI,P1D,P1I,P2D,P2I,TNG,GI,OM,NoT,ToDy,ToDu,ToIt, 
ToNu@ > com[n]

(see page 306 for an explanation of the parameters).

For example, for a continuous pulse sequence 20 ms on and 20 ms 
off, and with COM port 3:

/C echo M1,0,20,20,20,20,1,0,103,1,0,0,0,0@ > com3

note 1  The Operation mode 103 (for PulserPlus, or 3 for Pulser) 
means that the pulse sequence is generated as long as EthoVision 
XT sends the TTL command to the Pulser.
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note 2  If you have the Pulser and the older Pulser software (version 
2.1) the command above would be: /C echo 1,0,20,20,20,20,1,0,3,1@ 
> com3.

3. Click OK and insert the resulting box after the Time Condition box 
created in the previous procedure.

When this procedure is carried out, the Pulser “knows” what 
sequence to send out to the LED Controller when it is triggered. The 
last piece is to program one or more actions in the Trial Control 
procedure that activate the Pulser at the right time. See the next 
section.

Procedure 3 - Program activation of the pulser

In general activating the Pulser requires four elements:

1. Trigger condition (wait that the condition is met).

2. Action that triggers the pulser.

3. Stop condition (wait that the condition is met).

4. Action that stops the pulser.

In this example, stimulation is set to start one minute after the start of 
tracking, and last 1 second. For more examples see page 316 and 318.

1. Under Conditions choose Time and set it to 1 minute.

2. Under Actions choose Custom Hardware. Choose the Pulser device. 
This device must be defined in experiment settings (page 297) and 
arena settings (page 298). Under Action to perform, select Output 1 
High.

3. Under Conditions choose Time and set it to 1 second.
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4. Under Actions choose Custom Hardware. Choose the Pulser device 
as in step 2. However, under Action to perform, select Output 1 Low 
for deactivating the Pulser.

5. Place the four boxes one after the other.

tip  Add a condition after the last box, otherwise tracking stops 
immediately after stimulation stops.

If you want these actions to be repeated, insert them in a Subrule. In 
the settings of this box, under Stop conditions specify Repeat 
indefinitely (or as long as required).

Note

Consider the following sequence:

/C echo M1,0,500,500,0,0,1,0,103,1,0,0,0,0

This means that the LED is switched on for 0.5 s, then is switched off for 
the next 0.5 s. If the Time condition between the trigger actions is set 
to 1 second, at the end of that time the TTL output sent to the Pulser is 
still high; this triggers another pulse. As a result, the LED switches on 
two times (On, Off, On, Off), for a total of 2 seconds.
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To have just one sequence, set the Time condition to a time slightly less 
than one second, for example 0.9. If, on the other hand, you want to 
have a sequence like in the figure above, we recommend to set 1.1 s. 

Procedure 3b - Program activation based on zone visit

In this example stimulation is given every time the subject visits a zone 
named A. The Trial Control procedure is as follows

1. Trigger condition: Is the subject in zone A?

2. Action that triggers the pulser.

3. Stop condition: Is the subject not in the zone?

4. Action that stops the pulser.

The sequence must be placed in a Subrule, and the Subrule reference is 
set to Repeat indefinitely, so the Pulser is triggered again at the next 
zone visit. See a similar Subrule on page 302; set the Action boxes 
based on the Pulser, not the LED controller.

For more information

For more information on Subrules, see the EthoVision XT 18 - Trial and 
Hardware Control - Reference Manual. To open this manual, choose 
Apps > Noldus > EthoVision XT 18 Other Documentation. For more 
information on the Pulser, see the Prizmatix Pulser/PulserPlus User 
Manual.
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program the prizmatix pulser/pulserplus 
with the prizmatix software

It is also possible to define a LED activation sequence with the software 
that comes with the Pulser/PulserPlus. EthoVision triggers the Pulser 
with a TTL signal, as shown above. The advantage is that the Prizmatix 
graphical interface makes the definition simple. However, you cannot 
change the sequence definition during a trial.

A few things to remember:

 Keep the Pulser software open during your trials. If you have 
multiple Pulsers, open one instance of Pulser software for each 
Pulser.

 Make sure that the pulse sequence is defined in the Pulser 
software.

 Check that the Pulser software indicates that a COM port is 
selected (COM3, COM4, etc.) and shows the message Prizmatix 
Pulser is connected. Do this for each instance of Pulser software.

 On the Pulser software, set the Operation Mode to (3) Execute pulse 
sequence after trigger HIGH, then stop when LOW.

 Before starting the trial, click the Start sequence button. If you work 
with multiple Pulsers, do so in each instance of the Pulser software. 
The Pulser software now waits for the trigger signal from 
EthoVision XT.

 For connection schemes and further details, see the chapter The 
DanioVision Optogenetics add-on in the DanioVision DVOC-0041 - 
EthoVision XT 18 - Reference Manual.
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Advanced applications

differential stimulation depending on zone

Aim

To give a pulse sequence with frequency fA when the subject is in zone 

A, and a pulse sequence with a frequency fB when the subject is in zone 

B.

Prerequisites

In the Arena Settings, you have defined two non-adjacent zones, A and 
B.

Procedure 

1. Create new Trial Control Settings.

2. In the main Trial Control procedure, right after the Start Trial box, 
define an External command box to initialize the port for the Pulser. 
For details, see page 310.

3. Add a Time condition and set it to 2 seconds.
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4. Add one External command, to the program 
C:\Windows\System32\cmd.exe with the line options:

/C echo S>com[port number]

In this example /C echo S>com3.

This instructions cancels the current pulse sequence definition 
stored in the Pulser in case you have used other definitions in a 
previous trial.

5. Add one Hardware command, to set the Output 1 to Low.

Result:

6. Create two Subrules, one for zone A and the other for zone B. In the 
main Trial Control sequence, after the Start track box, insert the two 
reference boxes. For both Reference boxes, select Repeat 
indefinitely.
14 -  Optogenetics Experiments 319



320
7. In each Subrule, define the following instructions; see the next 
picture.

Notes

 important  Do not use zones that are adjacent; always make some 
space between the two.

 The 1-second Time condition (boxes b) has been inserted in both 
Subrules to ensure that there is enough time between the reset of 
the Pulser port at the end of one Subrule (box g) and the new pulse 
sequence definition in the other Subrule (box c) when the animal 
switches from one zone to the other.
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 Box c: See Procedure 2 - Define the pulse sequence on page 313.

 Boxes d-e-f: See Procedure 3 - Program activation of the pulser on 
page 314.

 Box g is an External command to C:\Windows\Systrem32\cmd.exe 
with line option \C echo S>com[port number]. See also step 4. This 
command stops the pulse sequence definition and makes sure that 
the Pulser listens to the next definition in case the subject enters 
the other zone.

 You need as many Subrules as trigger zones.

 note  See a remark under To activate the LED when the animal is in a 
zone (page 302) for more options about the statistic to be used for 
the “In zone” condition.

Figure 14.8  a. In zone Condition: Is the animal in the zone A (or B) (Current = true)?. b. Time
Condition: Wait 1 second. c. External command: Define the pulse sequence (for details, see pag
313). d. Custom hardware Action: Output 1 High. e. In zone Condition: Is the animal NOT in zon
(Current= true)? f. Custom hardware Action: Output 1 Low. g. External command: Stop the las
sequence definition. 
These instructions check that the animal is in a particular zone (a). If it is, after one second (b;
see below for why this 1-s has been added) the corresponding pulse sequence is defined (c) and
the Pulser is triggered (d). When the animal leaves the zone (e), stimulation stops (f) and the 
sequence definition is canceled (g). 
- If the animal enters the other zone, the instructions in the other Subrule after (b) will be 
executed; the corresponding stimulation starts.
14 -  Optogenetics Experiments 321



322
multiple simultaneous stimulations in one 
arena

Aim

To generate different pulse sequences and send them simultaneously 
to different subjects in one arena.

note  Using multiple Pulsers is necessary when stimulation in two or 
more subjects can occur at the same time.

Basic steps

1. Follow the instructions on page 335 to install the driver for the 
Pulser on the EthoVision XT computer. 

2. Follow the instructions on page 308 to configure the driver for a 
specific Pulser (COM port). When connecting multiple Pulsers to the 
EthoVision XT computer, the Device Manager shows multiple 
instances of Prizmatix DVR (COM[n]) or USB Serial Port (COM[n]). 
Repeat that procedure for each instance. 
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3. Connect the Trig. In port of each Pulser/PulserPlus devices to a TTL 
port of the USB-IO box.

4. In EthoVision XT (Experiment Settings; see page 297), assign a TTL 
port to Pulser 1, and another TTL port to Pulser 2, etc.

tip  Rename the Device IDs to something like Pulser 1 and Pulser 2.

5. In EthoVision XT (Arena Settings), click the Arena-Hardware 
Mapping button. Add two devices and assign them to the arena.

6. In EthoVision XT (Trial Control Settings), for each pulser, initialize the 
COM port and define the pulse sequence. Follow the instructions 
from page 310 and repeat that procedure for each Pulser.

Details

For each Pulser, define three external command Action boxes, and 
place them in a linear sequence before the Start track box: one for 
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initializing the port (Procedure 1 - Initialize the COM port, page 310), one 
for stopping previous definitions (for example from a previous trial; see 
page page 319), and one for defining the pulse sequence (Procedure 2 - 
Define the pulse sequence, page 313).

In this example, Pulser 1 is set to a pulse sequence of 20 ms on and 20 
ms off (25 Hz stimulation; boxes A for initialization and C for pulse 
definition; see the following picture); Pulser 2 is set to a pulse sequence 
of 10 ms on and 10 ms off (50 Hz stimulation; boxes D,E).

First, for Pulser 1 (com 3):

Then for Pulser 2 (com 5):

Note that actions are separated by Time conditions (1-2 s). For the 
reason why that is done, see page 312.

Complete your Trial Control procedure (to the right of the Start track 
box). In this example, the Subrule for triggering the Pulser for 1 second 
stimulation, and with an interval of 5 seconds, looks like this:
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Notes

 Different protocols must be defined with different Subrules. For 
example, create a Subrule 1 for controlling Pulser 1, and Subrule 2 
for controlling Pulser 2.

 tip  When using multiple Pulsers, it is handy to use batch files. For 
example, the instructions for stopping sequence definitions for 
com3 and com5 would look like:

echo S>com3

echo S>com5

Enter these instructions in a text file, and rename it with extension 
.cmd. Then instead of the single instructions, create an External 
command to this cmd file.

 important  Test the system thoroughly before the real 
experiments. When using multiple Pulsers, there may be more time 
needed to initialize the ports. If the Pulser does not respond it could 
be due that the 2 s waiting time is not enough. Set a longer time, 
like 5 seconds or the like.
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simultaneous stimulations in two or more 
arenas

When you run a trial with multiple arenas, EthoVision XT controls 
multiple pulsers, each assigned to a specific arena. This is only possible 
with the aid of batch files (see below).

Why are batch files needed?

A batch file is necessary to send a commands for initializing the COM 
port and define the pulse sequence for a specific arena. The reason for 
this is that the Trial Control rules are applied to each arena 
independently, but the External commands specified in those boxes are 
not arena-specific. You can imagine two identical copies of the picture 
of the previous page, one for each arena. This means that an external 
command would be sent twice to the same COM port, which may 
result in unexpected behavior. To prevent this from happening, a batch 
file is needed that sends the command lines based on the name of the 
arena.

You need two batch files, one (“Initialize COM ports.cmd”) for 
initializing the COM port, and one for defining the pulse sequences 
(“Define sequences”). The two batch files are activated one after the 
other, with a time interval in between. A third batch file (“Stop 
sequences”) stops the definition of sequences previously used, and is 
handy when you use different sequences in the same trial or between 
subsequent trials.
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note  If you do not have those batch files, please contact Noldus IT, or 
follow the instructions below.

To create the batch file “Initialize COM ports”

1. Open the Windows Notepad and enter the following (here we 
assume that four arenas are used, with COM ports 3, 4, 5 and 6):

@echo off

set arena=%1

set arena=%arena:~2,-2%

If "%arena%"=="Arena 1" C:\Windows\System32\cmd.exe /C mode 
COM3 BAUD=57600 PARITY=N DATA=8 STOP=1 DTR=off RTS=off

If "%arena%"=="Arena 2" C:\Windows\System32\cmd.exe /C mode 
COM4 BAUD=57600 PARITY=N DATA=8 STOP=1 DTR=off RTS=off

If "%arena%"=="Arena 3" C:\Windows\System32\cmd.exe /C mode 
COM5 BAUD=57600 PARITY=N DATA=8 STOP=1 DTR=off RTS=off

If "%arena%"=="Arena 4" C:\Windows\System32\cmd.exe /C mode 
COM6 BAUD=57600 PARITY=N DATA=8 STOP=1 DTR=off RTS=off

2. Save the file, and give it the extension .cmd.

important   Make sure that “Arena 1”, “Arena 2” etc. are the exact 
name of the arenas in the Arena Settings. Make sure to avoid leading or 
trailing spaces in the names. Note that this differs from that in 
EthoVision XT 17 and earlier versions. Also, make sure to enter the 
correct COM port number of your Pulsers (see page 309).

To create the batch file “Define sequences”

1. Open the Windows Notepad and enter the following:

@echo off

set arena=%1

set arena=%arena:~2,-2%

If "%arena%"=="Arena 1" C:\Windows\System32\cmd.exe /C echo 
M1,0,500,500,0,0,1,1,103,1,0,0,0,0@>com3
14 -  Optogenetics Experiments 327



328
If "%arena%"=="Arena 2" C:\Windows\System32\cmd.exe /C echo 
M1,0,500,500,0,0,1,1,103,1,0,0,0,0@>com4

If "%arena%"=="Arena 3" C:\Windows\System32\cmd.exe /C echo 
M1,0,500,500,0,0,1,1,103,1,0,0,0,0@>com5

If "%arena%"=="Arena 4" C:\Windows\System32\cmd.exe /C echo 
M1,0,500,500,0,0,1,1,103,1,0,0,0,0@>com6

The example above would produce a sequence of 500 ms pulses 
(frequency 1 Hz). Replace the “500” with the pulse durations and 
intervals you require.

2. Save the file, and give it the extension .cmd.

To create the batch file “Stop sequences”

1. Open the Windows Notepad and enter the following:

echo S>com3

echo S>com4

echo S>com6

echo S>com7

Replace the port number with those assigned to your Pulsers.

2. Save the file, and give it the extension .cmd.

Basic steps

1. Follow the steps 1 to 4 on page 322.

tip  Rename the Device IDs to for example Pulser 1 and Pulser 2.

2. important  In EthoVision XT (Arena Settings), make sure that the 
name of the arenas is Arena 1, Arena 2, etc.

3. In EthoVision XT (Arena Settings), click the Arena-Hardware 
Mapping button. Add two devices, and assign each pulser to only 
one arena.
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important  Make sure that <No device allocated> is selected in the 
remaining cells under Arena 1, Arena 2, etc.

4. In the Trial Control Settings, define the following boxes, and insert 
them between the Start trial and the Start track box (see the 
following picture). 

An External command for the first batch file, “Initialize.cmd”. Enter 
“%an%” in the Command line options.

A time condition, set to two seconds.

An External command for the first batch file, “Stop 
sequences.cmd”. Command line options are not necessary.

A time condition, set to two seconds.

An External command for the second batch file, “Sequence.cmd”. 
Enter “%an%” in the Command line options.

5. Complete your Trial Control procedure to the right of the Start track 
box. Different protocols must be defined with different Subrules. For 
example, create a Subrule 1 for controlling Pulser 1, and Subrule 2 for 
controlling Pulser 2.
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Data Analysis

simple data selection

Choose Analysis > Data Profile > New.

To select the track segments when the LED was activated

1. Under Nesting choose Hardware state.

2. From the Device type list, choose Custom Hardware.

3. Choose the Device, the Signal (Is output 1 High), Value (true).

4. Click OK and insert the Nest box in the Data profile sequence.

5. Choose Analysis > Analysis Profile > New and define the variables 
you want to calculate for when the animal was stimulated (for 
example, the distance moved).
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To select the track segments when the LED was not activated

1. Under Nesting choose Hardware state.

2. From the Device type list, choose Custom Hardware. 

3. Choose the Device, the Signal (Is output 1 High), Value (false).

4. Click OK and insert the Nest box in the Data profile sequence.

5. Choose Analysis > Analysis Profile > New and define the variables 
you want to calculate for when the animal was not stimulated.

advanced data selection

To compare two sets of track segments (LED activated vs LED not 
activated)

Create the two Nest boxes as described above. Place each box in a 
separate branch ending with a Result box. To create another Result 
box, under Common Elements choose Result.

Note that if you use the Pulser to generate high frequency optical 
pulses, the individual pulses are not “seen” by EthoVision XT. Because 
EthoVision XT controls the Pulser via the single TTL start/stop 
commands (“Output 1 High/Low”), it only “sees” the time that the 
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command was sent out (Output 1 High/Low). Therefore, the pulse 
sequence is seen as a one time segment.

For more information on data selection, see the EthoVision XT Help.

To select the track segments when a particular frequency was 
generated (setup with pulser)

Prerequisite: your Trial Control procedure includes control of frequency 
of stimulation, like that described on page 318. Here, two Subrules were 
defined, one for zone A (stimulation at 25 Hz) and one for zone B 
(stimulation at 50 Hz). Within a Subrule, Hardware actions “Activate 
Pulser” and “Deactivate Pulser” can be used to mark the time that a 
particular frequency was used.

1. In the Data Profile, under Nesting choose Trial Control State.

2. Choose the name of the actions that refer to a particular frequency.

From Element Action: [action that triggers the Pulser]

To Element Action: [action that stops the trigger]

From the Event lists, select becomes active for both elements.

3. Click OK and insert the Nest box in the Data profile sequence.

4. Choose Analysis > Analysis Profile > New and define the variables 
you want to calculate.
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calculating statistics

Once you have selected the track segments you are interested in, 
choose the variables you want to calculate. 

Choose Analysis > Analysis Profile > New.

 To calculate the number of times that the optical stimulation was 
activated, in the Analysis profile choose Hardware command. 
Choose the following:

- Device type = Custom Hardware.

- Device = the LED controller (or Pulser).

- Command = Output 1 High.

- Under Trial Statistics choose Frequency.

 To calculate the total time that stimulation was activated, in the 
Analysis profile choose Hardware state. Choose the following:

- Device type = Custom Hardware.

- Device = the LED controller (or Pulser).

- Signal = Is Output 1 High.

- Value = true. 

- Under Trial Statistics choose Cumulative Duration.

To calculate the statistics, choose Analysis > Results > Statistics and 
Charts.

integrated visualization

Choose Analysis > Results > Integrated Visualization.

The following picture shows the integrated visualization for a few 
dependent variables defined in the Analysis profile.

The Trial Control protocol is the same as that explained from page 318: 
a stimulation of 25 Hz is given when the animal is in zone A; a 
stimulation of 50 Hz is given when the animal is in zone B.

 In zone. Shows when the animal was in zones A and B. To show this 
variable, you must define it in the Analysis profile (choose In zone 
under Location).
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 Hardware command. Marks the time when the Output 1 High was 
sent out from EthoVision XT. This happened 1 s after the animal was 
detected in a zone (see page 321).

 Hardware state. Marks the time interval when Output 1 stayed 
High.

 Trial Control state - Pulser 25 / Trial Control state - Pulser 50. Marks 
the time that the Hardware command within one of the Subrules 
was High. That command triggered the pulser for a specific 
simulation (25 or 50 Hz). This way instances of Hardware state can 
be split according to the frequency of the stimulation.
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Installing the Prizmatix Pulser

Follow this section if the Prizmatix Pulser/PulserPlus is not properly 
installed on the EthoVision XT computer.

software installation

Insert the Prizmatix Pulser software CD in the EthoVision XT 
computer’s CD/DVD ROM drive, or download the most recent version 
from www.prizmatix.com/software.htm under Pulser/PulserPlus 
Software.

Double-click setup.exe. Follow the instructions on the screen and at 
the end of installation restart the computer. Follow the instructions 
below to update the driver.

note  The installation procedure differs depending on whether you 
have the Pulser or PulserPlus. For more information, see the Prizmatix 
Pulser/PulserPlus User Manual.

driver update

Do this for each Pulser you use, when they are not recognized.

1. Connect the Pulser to the computer with the supplied USB cable.

2. In the Control Panel, open the Device Manager.

3. Under Other Devices, right-click Unknown device and select Update 
driver.

4. Choose Browse my computer for driver software.

5. Click Browse and select the following folder 

C:\Program Files (x86)\Prizmatix Pulser [version number]\Drivers

Then click Next.
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note  This location may differ on your PC if you downloaded the 
drivers and saved them on another location.

6. In the Windows Security dialog click Install.

7. At the end of the update process click Close.

8. In the Device Manager, under Ports, you should see Prizmatix DRV.

To configure the Pulser driver for EthoVision XT, see page 310.
14 - Optogenetics Experiments



14 -  Optogenetics Experiments 337



338
Chapter 15
Experiments with 
Calcium Imaging 

Introduction ................................................................339

Physical setup .............................................................342

Basic settings ............................................................. 346

Program control of devices in EthoVision XT ........... 349

Detection settings ...................................................... 355

Aligning data ..............................................................358

Data analysis in EthoVision XT...................................362
  Experiments with Calcium Imaging



Introduction

ethovision xt and calcium imaging

To understand the working of neural circuits in the brain, it is vital to be 
able to view neural activity simultaneously with behavioral data. 
Calcium Imaging is a microscopy technique to optically measure the 

calcium (Ca2+) status of a cell, a tissue or a medium. This allows to 
monitor the electrical activity in single neurons at a spatial scale that is 
not possible to achieve with other techniques.

The Inscopix nVista miniature microscope system enables researchers 
to conduct genetically targeted calcium imaging over time in awake, 
freely behaving rodents, and has provided insights from multiple brain 
areas, from the prefrontal cortex all the way to the hypothalamus. 
nVista’s compact, sleek plug-and-play interface makes it easy to add 
powerful new neural circuit insights to any laboratory’s behavioral 
research arsenal.

You can combine EthoVision XT with the Inscopix nVista system in such 
a way that EthoVision XT takes control over the recording activity of 
nVista. For this you need the Noldus USB-IO box interface connected 
between the two systems.

ethovision xt and optogenetic stimulation

In vivo Calcium Imaging is often coupled with Optogenetic stimulation 
to causally link neural circuit activity and behavior. For this purpose, 
the Inscopix nVoke system is coupled with EthoVision XT, which can 
trigger both calcium imaging and the optogenetic LED stimulation. The 
two triggering systems can be set independent of one another. 
Similarly to what is done for the EthoVision XT and the nVista system, 
you need the Noldus USB-IO box interface connected between 
EthoVision XT and nVoke.
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nvista vs nvoke

 nVista is Inscopix system for in vivo Calcium imaging in free 
behaving animals. It includes a head-mounted miniature 
microscope that enables one-photon epifluorescence imaging of 
calcium dynamics, a correlate of neural activity. 

 nVoke is the Inscopix system that enables simultaneous in vivo 
Calcium imaging and optogenetic manipulations.

ethovision xt license needed

To enable control of Inscopix devices by EthoVision XT, you need the 
Trial and Hardware Control module. If you are not sure whether this 
function is activated, in EthoVision XT select Help > About EthoVision 
XT > License Info.

If the Trial and Hardware Control checkbox is not selected, contact 
Noldus to purchase an upgrade with this module.

application examples

Place preference in the PhenoTyper

The nVista microscope is triggered every time the mouse enters a 
target region of the PhenoTyper, as defined in the EthoVision XT 
software.

In an experiment that combines Calcium Imaging and Optogenetics, 
the PhenoTyper was divided in two side zones, and in each session one 
side was assigned as stimulus (LED)-paired side. Each time the mouse 
crossed to the stimulation side, stimulation was delivered until the 
mouse crossed back into the non-stimulation side (Stamatakis et al. 
2018).

Contextual fear conditioning

Simultaneous Calcium Imaging and Optogenetic stimulation are 
performed during a fear conditioning experiment. Optogenetic 
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stimulation during the shock phase reduced the percent time freezing 
during context retrieval (Jimenez et al. 2020).

Motor behavior

Simultaneous optogenetics and calcium Ca2+ imaging is performed in 
different populations of cells to look into the functioning of fast-
spiking interneurons in the control of motor behavior in an open field 
(Owen et al. 2018).

references

 Jimenez et al. (2020). Contextual fear memory retrieval by 
correlated ensembles of ventral CA1 neurons. Nature 
Communications 11: 3492. doi:10.1038/s41467-020-17270-w

 Owen et al. (2018). Fast-spiking interneurons supply feedforward 
control of bursting, calcium, and plasticity for efficient learning. Cell 
172(4): 683-695. doi: 10.1016/j.cell.2018.01.005

 Stamatakis et al. (2018). Simultaneous optogenetics and cellular 
resolution calcium imaging during active behavior using a 
miniaturized microscope. Frontiers in Neuroscience 12: 496. doi: 
10.3389/fnins.2018.00496
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Physical setup

hardware components

Noldus USB-IO box PTIO-002x

Noldus Optical Isolated TTL-IO interface PTISO-00x0

Also known as opto-isolator.

Inscopix nVoke or nVista DAQ box
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connection schemes

Calcium Imaging (nVista)

Figure 15.1  Basic connections for triggering video recording from EthoVision XT 
in nVista/nVoke systems. Connect one of the TTL ports of the USB-IO box to the 
Opto-isolator using a network cable (here in orange). Connect the Out-1 port of 
the Opto-isolator to the TRIG port of the Inscopix device using cables with BNC 
connector (in gray). 
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Calcium Imaging + LED stimulation (nVoke)

Figure 15.2  Basic connections for triggering video recording and OG-LED 
stimulation from EthoVision XT in nVoke systems. Connect the Out1 and Out2 
ports of the Opto-isolator to the TRIG port and the GPIO port of the Inscopix 
device using cables with BNC connector. Note that a TTL port on the USB-IO box 
can send out signals through two independent lines (Output 1 and Output 2). 
Make sure that the Trial Control procedure sends the correct commands to the 
Inscopix DAQ box through the two lines Out 1 and Out 2, one for TRIG and the 
other for GPIO. See also page 353.
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notes

Why use a Opto-isolator?

If you do not have the Noldus Opto-isolator, you can connect the USB-
IO box and the Inscopix directly. For this you need a cable with an 
Ethernet (RJ45) at one end and a BNC connector at the other end. 
However, we recommend to use a Noldus Opto-isolator also to prevent 
ground loops to occur and preserve the TTL signals. Use one opto-
isolator per TTL port of the USB-IO box.
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Basic settings

ethovision xt: experiment settings

After creating a new experiment, choose Setup > Experiment Settings. 
Define the number of arenas, the features that you want to track, and 
the camera properties. 

To define the Inscopix devices:

1. Select Use of Trial Control hardware, and click the Settings button.

2. Depending on the type of USB-IO box you use, choose either Noldus 
USB-IO box or Noldus Mini USB-IO box. 

3. Locate the TTL port that you use to connect the USB-IO box (see page 
343), and from the Device Type list choose Custom Hardware.

4. Under Device ID, enter a name for the device. For example, nVista 
Video, or nVoke Video, nVoke LED.

5. Repeat the steps 3-4 above to declare more devices. If you want to 
trigger Calcium Imaging and LED stimulation, you must use two TTL 
ports from the USB-IO box, one for the TRIG input and one for the 
GPIO[n] input of the nVoke device. See Figure 15.2 and page 353. 

6. Click OK. Next, open the Arena Settings (see below).

ethovision xt: arena settings

Choose Setup > Arena Settings. Calibrate and define the outline of the 
of arena(s) and the zones.

To map the Inscopix devices to the arena(s):

1. Click the Arena - Hardware Mapping button at the bottom-right 
corner of the screen.

2. Check that the device appears under the arena name. In the case of 
multiple devices, assign each of them to one arena and make sure 
that they do not occur in the cells for other arenas. 
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3. Optionally, edit the Device name (default: Device A, B, etc.). You will 
see this name back in the Trial Control Settings and in the Analysis 
profile.

4. Repeat the steps 2-3 to map the remaining devices.

inscopix devices

1. Connect the microscope to the subject and pass the cord through 
the tracking chamber/PhenoTyper and connect it to the Inscopix 
device (see page 343).

2. On the Inscopix computer, launch the data acquisition software and 
adjust the imaging settings, like the frame rate and the gain.

3. In the data acquisition software, select to trigger from external 
hardware. If you do Calcium Imaging only, you can use the Basic 
Recording mode in the Inscopix software. Make sure that the 
Recording Start mode is set to Triggered Recording. 

4. When using optogenetics stimulation, in most cases you must use 
the Advanced Recording mode. Specify the type of stimulation, 
power, number of repeats etc. See also the nVista and nVoke User 
Manual for examples.
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Program control of devices in 
EthoVision XT

trial control settings

The Trial Control Settings in EthoVision XT allows you to program 
activation of calcium imaging and optogenetic stimulation by Inscopix 
devices at specific times or when specific events occur, for example 
when the subject enters a target zone of the arena.

In addition, in Trial Control Settings you can define the conditions for 
the start and stop of data acquisition. 

In EthoVision XT, choose Setup > Trial Control Settings > New, and enter 
a name for the new settings profile.

For more information

For more information on how to work with Conditions and Actions in 
Trial Control Settings, see the EthoVision XT Help (press F1 in 
EthoVision XT) and the EthoVision XT 18 - Trial and Hardware Control - 
Reference Manual, which you can find in the Apps screen under Noldus 
> EthoVision XT 18 Other Documentation.

example 1 - image recording (nvista)

Use case

EthoVision XT starts tracking after locating the subject’s center point. 
in the arena. Next, the EthoVision XT sends out a high TTL pulse to the 
TRIG port of nVista. After a time delay of 10 minutes, EthoVision XT 
stops tracking the subject.

Hardware connections

See the scheme on page 343.
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Prerequisites in EthoVision XT

You specified the TTL port and output line (either 1 or 2) for TRIG in the 
Experiment Settings and mapped the port to the arena (see page 346).

Procedure

1. In the Trial Control Settings, under Actions, click the button next to 
Custom hardware. 

2. Specify the device (e.g. Device A) and the type of signal (Output 1 
High).

3. Optionally, edit the name in the Action name field.

4. Click OK and insert the Action box between the Condition - In zone 
box and the Action - Start track box.

5. Click Settings in the Condition - Time box and select 10 minutes. This 
way tracking stops after 10 minutes.

6. If you want to stop recording in nVista when you stop behavior 
tracking, bring a new Action box in the flow line which instructs the 
system to send out a low TTL pulse to nVista. Make sure that you 
place the Action box at the right of the 10-minutes time box. 
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tip  In the Hardware Action box you can test whether Ethovision XT 
triggers the nVista. To do so, click the Test button.

note  Make sure to instruct nVista/nVoke to record video based on the 
TRIG signal.

example 2 - manual video recording, 
triggered og-led stimulation

Use case

EthoVision XT starts tracking after locating the subject’s center point. 
in the arena. You start video recording in nVoke manually by clicking 
the Record button. At the planned time, for example at 10 minutes 
after start, EthoVision XT sends out a high TTL pulse to the GPIO[n] 
port of nVoke.

 In the Inscopix DAQ software, under Video Recording configuration, 
make sure that Trigger is set to NONE and Control is set to Video 
Recording ON.
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Hardware connections

 See the scheme on page 344. You do not need to use the TRIG port 
of the nVoke device.

 Set the GPIO[n] to Input in the Inscopix DAQ software.

Prerequisites in EthoVision XT

In the Experiment Settings, you defined the TTL port and output line 
(either 1 or 2) connected to the GPIO[n] of nVoke. In Arena Settings, you 
mapped that port to the arena (see page 346).

Procedure

Because calcium imaging is started manually in this example, you only 
have to program the activation of the OG-LED. In the following 
example, the Time condition is set to wait 10 minutes before the 
triggering action.

1. In the Trial Control Settings, under Conditions, click the button next 
to Time. 

2. Specify the time (e.g. 10 minutes). Optionally, edit the name in the 
Condition name field.

3. Click OK and insert the Condition box after the Action - Start track 
box (or wherever it applies in your protocol; for example in a sub-
rule).

4. In the Trial Control Settings, under Actions, click the button next to 
Custom hardware. 

5. Specify the device (e.g. Device A) and the type of signal (Output 1 
High).

6. Optionally, edit the name in the Action name field.

7. Click OK and insert the Action box at the right of the Condition box 
just created.
  Experiments with Calcium Imaging



8. When that applies, define a Condition and an Action (Output Low) 
for stopping the trigger action and insert them in the trial control 
flow line.

Notes

 In the Inscopix DAQ software, make sure to set the Trigger mode for 
the GPIO[n] port to Follow. 

 When the Trigger is set to low, LED stimulation is stopped. To set 
the Trigger to Low, add an Action to the same device/TTL port and 
output line as above, and select the signal Output Low.

 You can also let the DAQ software run its own pulse protocol while 
the Trigger is ON. In that case the Control for the GPIO[n] port is set 
to Pulse protocol.

 For more information, see the nVista and nVoke User Manual. 

example 3 - triggered video recording and 
led stimulation

Use case

EthoVision XT starts tracking after locating the subject’s center point. 
in the arena. Both video recording and the OG-LED are triggered by 
EthoVision XT when the corresponding conditions (time or event) are 
met.
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Hardware connections

 See the scheme on page 344. 

 Set the GPIO[n] to Input in the Inscopix DAQ software.

Prerequisites in EthoVision XT

In the Experiment Settings, you defined two TTL lines from the USB-IO 
box: one connected to the TRIG and the other to the GPIO[n] port of 
nVoke. In Arena Settings, you mapped the ports/lines to the arena (see 
page 346).

Procedure

Define actions and conditions as explained for the previous examples.

 Condition to trigger video recording.

 Action to trigger video recording through the TRIG port.

 Condition to trigger OG-LED stimulation.

 Action to trigger the OG-LED stimulation through the GPIO[n] port.

When applicable, define additional conditions and action to stop video 
recording and OG-LED stimulation.

Notes

 In the Inscopix DAQ software, make sure to set the Trigger mode for 
the TRIG port to Follow, and the Control is set to Video Recording 
ON. In an alternative configuration, you can set Control to 
Recording schedule to record video for a specific time.

 In the Inscopix DAQ software, make sure to set the Trigger mode for 
the GPIO[n] port to Follow. Select the type of Control you require 
(e.g. Pulse protocol).

 See the Example Configuration #3 in the nVista and nVoke User 
Manual.
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Detection settings

general

Ensure your subjects are detected well by Ethovision XT.

Choose Setup > Detection Settings.

See also detection settings on page 17. For more details, see the 
EthoVision XT Help.

Sample rate

In the Video section, specify the sample rate. Some commonly-used 
values are:

 For tracking rats: 5 samples/second.

 For tracking mice: 12.5 samples/second.

 When tracking the nose- and tail-base points of rodents: 25-30 
samples/second.

detect immobility

There are two ways to detect immobility of the subject during the trial.

 Activity measures the number of pixels that change their intensity, 
so whenever the subject sits still, the Activity value will be low. 
However, when the subject is connected to a microscope cable, the 
cable can move continuously and keep Activity high. 
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As a result, Activity measurements may not detect immobility with 
sufficient accuracy. Instead, use Mobility.

 Mobility is based on the change of the detected shape (i.e., the 
yellow blob). You can define Mobility in the Analysis profile, so you 
do not need to specify anything in the Detection Settings. However, 
make sure that the yellow blob covers the entire body of the 
subject and is not affected by the cable (see below).

remove the effect of the microscope cable

When the microscope cable is detected as the subject, it changes both 
the Mobility measure and the position of the center point. The latter 
affects distance moved and other readouts.

Step 1 - Define the contrast

The first thing to do is to make sure that the entire body of the subject 
is well detected throughout the arena. Use for example Dynamic 
subtraction and choose the smallest range of contrast that enables 
detection of the subject’s body.

In this example the cable is still detected. This will be removed in th 
next step. Make sure that the contour of the subject is not too much 
indented and noise (i.e. the orange areas) is limited.
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Step 2 - Erode and then dilate the contour

In the Detection Settings, locate the Subject Contour options. Select 1 
or a higher value for the first Erosion and a similar value for Dilation 
until the cable is no longer highlighted in yellow.

The Erosion filter removes the pixels from the contour (and therefore 
the cable too); the Dilation filter restores the original size of the yellow 
blob but excludes the cable.
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Aligning data

sync signal

To align the data streams from EthoVision XT and Inscopix nVista/
nVoke, there are two solutions:

 Have EthoVision XT send a time code signal (TCAP).

 Have EthoVision XT send a sequence of TTL pulses.

Either way, the Inscopix system records the signal in one of its 
channels. The difference between the two is that with TCAP you need 
to export the TCAP signal that is stored in Inscopix back to EthoVision 
XT, together with the Inscopix data, so that EthoVision XT reads the 
time code and aligns the Inscopix data with the tracks.

Note

The nVista/nVoke system can also send a sync pulse to EthoVision XT 
through the USB-IO box every time a video frame is recorded. However, 
the pulse generated from the SYNC port of nVista/nVoke has a duration 
of 10 ms. That is too little for EthoVision XT to detect and record the 
signal. Therefore, this solution is not optimal to sync the two data 
streams.

using the tcap signal

Prerequisites

For this solution you need:

 The External Data add-on module for EthoVision XT. Contact Noldus 
if you need to purchase it.

 An interface cable between EthoVision XT and the BNC connector 
of the nVista/nVoke DAQ box. Contact Noldus to have one made for 
you.
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 A way to convert the Inscopix data to a format compatible with 
EthoVision XT: fixed sample rate, without gaps.

Procedure

1. Set the TCAP signal in the Experiment Settings of EthoVision XT, 
and specify the sample rate of the Inscopix channel that will 
receive that signal.

2. Start acquisition in Inscopix and then start the trial in EthoVision XT. 
nVoke/nVista records the TCAP signal, which should be visualized on 
the system’s screen. 

3. Export the Inscopix data to text files. Note that here the sample rate 
must be fixed and all samples must be written in the file, otherwise 
import won’t work.

4. After import EthoVision shows the TCAP signal and other Inscopix 
data together with the track data. 

For more information, see External Data in the EthoVision XT Help.

using a ttl signal

Connections

Connect a TTL port of the USB/IO box to one of the GPIO ports of the 
Inscopix DAQ box. For this you need a cable with a RJ45 connector at 
one end and a BNC connector at the other end.

Procedure

1. In the Experiment Settings in EthoVision XT, define a TTL port of the 
USB-IO box. Select Custom Hardware from the list. In the Arena 
Settings, map that TTL port to one of the arenas.

2. In the Trial Control Settings, add a subrule that activates the TTL port 
every few seconds. For example: TTL Output 1 High for 1 second, then 
TTL Output 1 Low for 4 seconds. Let the subrule repeat a number of 
times or when a Trial Control variable reaches a specific value. In 
general, make sure that the ON-OFF sequence runs through the 
duration of the trial.
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Example:

tip  To stop the subrule at the end of the trial, add an Action box 
immediately before the Stop Trial box, where a Trial Control 
Variable, for example END, gets the value 1. In the Subrule reference, 
specify to end the subrule when END =1.

3. Run a test trial and make sure that Inscopix records the signal 
coming to the GPIO port.

4. Visualize the data in both systems. In EthoVision XT, you can 
visualize the TTL signal by selecting, for example, Trial Control state 
in the Analysis profile and defining the state from the action Output 
1 High to the action Output 1 Low (here the numbering depends on 
which TTL line you use).

5. If the data are well aligned, the time between the first and the last 
pulse should be the same in EthoVision XT and Inscopix, or differ by 
a few milliseconds.

For more information

 The nVista/nVoke User Manual.

 The EthoVision XT 18 - Trial and Hardware Control - Reference 
Manual.
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mark ethovision events on the calcium 
imaging timeline

You can also use the GPIO ports on the nVoke/nVista box to send 
specific events to the Calcium Imaging software.

In the following example, a setup that includes a fear conditioning 
system, all GPIO ports are set to digital and work as inputs.

 GPIO-1 receives a signal from a TTL port of the USB-IO box that is set 
to high when tracking starts.

 GPIO-2 receives a signal from a TTL port of the USB-IO box that is 
set to high when a 5-kHz tone is given.

 GPIO-3 receives a signal from a TTL port of the USB-IO box that is 
set to high when a 15-kHz tone is given.

 GPIO-4 receives a signal from a TTL port of the USB-IO box that is 
set to high or low when the optogenetic stimulation is given/
stopped, respectively, or when a shock is given/stopped, 
respectively.
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Data analysis in EthoVision XT

Once you acquire your trials, you want to pair the behavioral tracking 
with the calcium imaging/optogenetic stimulation events.

To view and analyze those events, you must first define them in the 
Analysis profile. Here we report a few examples.

Choose Analysis > Analysis Profile > New.

define a simple event

With the variable Hardware command you can visualize the time that 
the USB-IO box sends a trigger command to nVista/nVoke.

1. In the Dependent Variables pane, under Hardware, choose 
Hardware command.
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2. Choose the device and the output state, for example Output 1 High. 
Note that Output represents one of the two communication lines 
present in each TTL port of the USB-IO box. Choose the line that you 
used in the Action box in the Trial Control Settings to trigger the 
device (see the examples on page 349).

3. Visualize the event (Analysis > Results > Integrated Visualization).

analyze intervals (global)

You can analyze the behavior of the subject within an interval based on 
events. For example, calculate the average velocity of the subject from 
the time that stimulation starts (i.e., when the TTL Output 1 is High) to 
the time that stimulation end (i.e., nVoke is triggered with Output 1 
Low. To analyze the behavior within intervals, you must use the Nesting 
function in the Data profile.
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1. Choose Analysis > Data Profile > New.

2. In the Components pane, under Nesting, choose Hardware state.

3. Select the device and the status of the device. For example, Device A 
- Is Output 1 High - true. This selects the time that the TTL Output 1 
signal remains high.

4. Insert the box in the flow line. 

5. Visualize the interval (Analysis > Results > Integrated Visualization).

note   If Output 1 stays high multiple times during one trial, EthoVision 
XT considers the cumulative time that Output 1 stays High, and that is 
used as the analysis interval. When you want to analyze the time 
defined by a specific triggering event, see below for a different solution.

analyze specific intervals

You can use Free Intervals to specify a single interval based on one of 
the occurrences of a triggering event. Suppose that nVoke is triggered 
in ten intervals, and you want to analyze the second interval.
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1. Choose Analysis > Data Profile > New.

2. In the Components pane, under Nesting, choose Free interval.

3. For both Start criterion and Stop criterion, select Hardware. Define 
the start and stop event. For example, Start criterion: Output 1 High; 
Stop criterion: Output 1 Low.

4. Select Calculate Result for interval and choose the occurrence. In 
this example, 2.

5. Insert the box in the flow line. 

6. Visualize the interval (Analysis > Results > Integrated Visualization).

7. In the Analysis profile, define the variable that you want to calculate 
within the interval (e.g. velocity).

note  You can also use the commands of Trial Control to define 
intervals. For example, define an interval that starts when the tone cue 
is given (i.e. when the Action Tone cue becomes active). You can also use 
Conditions (e.g. the interval starts when the Condition Wait 30 seconds 
becomes active). If an Action follows immediately a Condition, then the 
time that the condition becomes true is essentially the same as the 
time that the following action becomes active, because both boxes are 
processed in the same sample time. In that case it does not matter 
which box you use for defining the interval.

export the raw data

You can export the raw data (behavior and hardware events) with their 
time stamps, for example to sync EthoVision XT data with calcium 
imaging in a third-party application.

Choose Analysis > Export > Raw data. 

 Note that Raw data also include the Trial Control events and states 
(e.g. a condition being true) once you include them in the Analysis 
profile.

 Select the Hardware log option if you want to export hardware 
events.
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align ethovision xt and inscopix data

Computer clocks

Ensure that the two computers used for data acquisition (EthoVision 
XT and Inscopix IDAS) have their clocks synchronized, for example 
using Network Time Protocol. Point all PCs at a time server or point one 
and set it up to act as a time server to the other.

Unix time

Inscopix software often exports time stamps to Unix (Epoch) time. 
Unix time is also known as Epoch Time or Unix timestamp. It’s a system 
that counts the number of seconds that have elapsed since the Unix 
Epoch, i.e. January 1st, 1970. To put in simple words, Unix time is the 
total number of seconds that have elapsed since 00:00:00 UTC 
Thursday, 1 January 1970.

Convert EthoVision XT time to Unix time

You can use an Excel formula to convert the trial time in EthoVision XT 
to Unix time.

In general, the formula goes like this:

Unix time = (EthoVision Time - DATE(1970,1,1))*86400

Because the trial (or recording) time in EthoVision XT is relative time 
(e.g. 0.200), you need to convert it to absolute time using the Reference 
time cell in the raw data (A in the next image).

Then use a second formula (B) that adds the trial (or recording) time to 
the reference time A.
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