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Up and running quickly

This Quick Start Guide guides you through the main steps to analyze facial expressions with
FaceReader. Only the most basic features are addressed. Inevitably, some features that may
be vital to your application are not discussed. You can find additional information in the
FaceReader Help.

GENERAL INFORMATION

The first part of the Quick Start Guide contains general information on using FaceReader.
Follow the instructions to set up your system, install FaceReader and to analyze the facial
expressions. The second part of this Quick Start Guide describes the Project Analysis
functions. The Project Analysis functionality allows you to create groups of participants
based on independent variable values like age and gender, and to analyze average
expression values per group. In addition to this, you can view the stimulus video together
with the video of the test participant’s face and the FaceReader analysis.

You can extend your FaceReader license with a number of modules.
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OTHER MODULES

FaceReader also has the following other modules:
Action Unit Analysis Module

To analyze a set of 20 action units of the Facial Action Coding System (FACS). These are the
action units that are most commonly used.
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Vital Signs Module

To estimate the heart rate, heart rate variability, and breathing rate of the subject in front of
the camera. Heart rate and heart rate variability are measured by means of remote
photoplethysmography (RPPG). This is a method based on the fact that changes in blood
volume due to pressure pulses cause small changes in the reflectance of the skin. Breathing
rate is measured by detecting upper-body movement associated with respiration.
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Consumption Behavior Module

To analyze consumption behaviors like Intake event and Chewing.If you have the
Consumption Behavior Module and want to use this in the analysis, you have to enable this
analysis (File - Settings - Analysis Options - Optional Classifications)

Voice Analysis Module

With this module FaceReader can recognize emotions in the voice (Neutral, Happy, Sad and
Angry) and Valence and Arousal in the voice.

Advanced Research Module

The Advanced Research Module allows you to analyze multiple faces in a video
simultaneously. With this module you can also track the test participant’s gaze when you
present stimuli using the Stimulus Presentation Tool, view the gaze overlay on the stimuli
when you analyze the data and make heatmaps.

MORE INFORMATION?

See the FaceReader Help that opens when you press F1in the program. It can also be accessed
in the Windows apps screen, and can be downloaded from the MyNoldus portal. From the
Help menu select Noldus Online and then Customer Support Center to access the MyNoldus
portal.
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Support

If you encounter problems, see the Support section on the MyNoldus portal or a help desk in
your area. From the Help menu select Noldus Online and then Contact Help Desk to access
the MyNoldus portal.

Note that if you send us videos showing people's faces, you should have permission from
those people that you can use the video for that purpose and you may need to sign a form
granting consent for us to use those videos.

Up and running quickly



Physical setup

The physical setup of your experiment is crucial for an accurate analysis with FaceReader. We
give the following general guidelines:

e Place the camera in front of the test participant and slightly below eye level. Make sure
your camera provides images with good contrast and brightness.

e Good lighting is crucial to get a good image. Avoid direct light, reflections and shadows
on the face. Diffuse frontal lighting is desirable. The light intensity or color is less
relevant. If possible, place the FaceReader setup in front of a window. Make sure that any
windows to the sides of the subject are blinded. Lights from the ceiling, common in most
buildings, will produce shadows below the eyebrows and nose. In situations where
interior lighting cannot be controlled, stronger lights (e.g., on either side of the monitor
or professional photo lights) can be used to negate the effect of other, undesirable, light
sources. You can purchase such lights from Noldus IT. You can also use (near) infrared
light, in combination with a camera that is sensitive to this type of light.

Physical setup



Install FaceReader

To install FaceReader

1.

Download the installation file (FaceReader [version number] Setup.exe) from the
MyNoldus portal of the Noldus website (my.noldus.com).

If you do not have a MyNoldus account yet, you can create one.

. Double-click the file.
. As Installation type, select Standard.

. Follow the rest of the instructions on your screen to install FaceReader.

To install the Stimulus Presentation Tool (Project Analysis Module only)

If you have the Project Analysis Module, You need the Stimulus Presentation Tool to present
stimuli automatically. To install it:

1.

Download the installation file (Stimulus Presentation Tool 5 Setup.exe) from the Noldus
website using your MyNoldus account (my.noldus.com).

. Double-click the file to run it.
. As Installation type, select Standard.

. Follow the rest of the instructions on your screen to install the Stimulus Presentation

Tool.

Install FaceReader
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Work with FaceReader

SETUP

1. Dependent on your license, do one of the following:
- If you have a software license key, start FaceReader and activate your license. You can
choose between a Floating or a Computer-locked activation.

¢ Floating license - Online connection required: Choose Floating if you want to be
flexible on which computer you use FaceReader. Your computer needs to be
connected to the Internet every time when starting up the software.

o Computer-locked license - Online activation: A Fixed activation is linked to one
computer. Your computer must have an Internet connection to activate/deactivate
a fixed license. After you have activated the license you can use FaceReader
without an Internet connection.

o Computer-locked license - Offline activation: Use this option if your computer
does not have an Internet connection. You need to use a smartphone with
Internet instead.

Meldus license activation X

Dongle or Software key License type Activation Done
License type

I want to use this license as a:

& Floating license - Online connection required (jf)
Use the application simultaneously up to the number of seats your license has.
In case you have activated your floating license on other computers as wel,
you will stil be able to use the software on those computers, if there are enough seats left

« Computer-locked license - Online activation (i

Use the application offline, anly for activation an internet connection is required.

& ‘Computer-locked license - Offline activation i
Use the application offline, online mobile device for activation required

v.noldus. com/license-types

For more information about license types, go to: https:/}

- If you have a hardware key, insert it into the computer and open FaceReader.

N>
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2. Create a new Project (File > New > Project). Give the project a name and select a location
to store it, or accept the default location.

Project Information

— Name

Fruit juices ‘

— Project folder N
C:\U5er5\N0|du5IT\D0cuments\Noldus\FaceReader'IDI:I ‘

oK Cancel

3. Choose Participant > Add Participant. Enter a name or identification code for the

participant. You can also automatically add participants by selecting a video with multiple
faces on the Multi-Subject Sources tab.

Participant Information

— MName
Olivia Smith

4. The gender and age of your participants are added as independent variables and are
automatically estimated by FaceReader. To select the age and gender manually, double-

click the participant name. Click on the pencil button next to the independent variable to
enter the values.

ndependent Variables

Gender Automatic &
Age Male
Female
Cther
B Automatic

5. Add one or more analyses for each participant and choose to analyze from video, live from
your camera or from images. To do so, select the participant for which you want to add an

Work with FaceReader
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analysis in the Project Explorer. Click on the Video, Camera or Image button on the toolbar
to add the appropriate analysis. It is not possible to mix image analyses with camera or
video analyses.

Participants  Multi-Subject Sources

v & Participant 1 - Olivia Smith

# Independent Variables

The Multi-Subject Sources tab is only available if you have the Advanced Research
Module. On this tab click the Add multi-subject icon and select the video that you want
to analyze.

. To carry out a camera analysis, select the option Use as default camera if you always use

this camera. To record audio, select your microphone. Optionally, select Record to create a
video file of the test participant’s face. The video will always be saved at a frame rate of 15
frames per second.

Camera Selection

~— Select camera

USE Video Device [~] |
~ Microphone

Microphone (USB Audio) [~] |
& record

To add multiple video analyses to a participant, right-click the participant’s name, select
Add Multiple Video Analyses, and select your videos.
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v 2 Participant 1 - Olivia Smith
. Add Participant...
> Independent Variables v .

> Analysis 1 Delete Participant...

Add Analysis

] Add Multiple Video Analyses...

ANALYZE

1. Click on the magnifying glass button next to an analysis to open it.

v B Participant 1 - Olivia Smith
? Independent Variables
> Analysis 1 02

2. Check the options for this analysis by clicking the Analysis Settings button at the bottom
of your screen.

;@’?i II-@/' :R:|

To create default settings for each new analysis, choose File > Settings. Open the tab
Default Analysis Settings and make your selection.

Work with FaceReader
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Application Settings @

G General Active Face Model
m Default Analysis Settings ~ Face model
General : v] ‘
[} Analysis Options | General
.|Baby
| EastAsian
D Data Export

Visualization 3 2
0 Calibration

L A —
D sl |_J Continuous calibration

Reset to default oK Cancel

See the FaceReader Help for an explanation of the options. Press F1in the program to
open it.

Choose File > Settings > Analysis Options and select Action units,-Consumption behavior,
Vital signs and/or Voice analysis to activate the Consumption Behavior Module, the Vital
Signs Module and/or the Voice Analysis Module.

IMPORTANT If you select the Baby Face model, Facial expressions are not available as
analysis output. You will obtain Action Unit intensities. See Action Unit Module in the
FaceReader Help for more information.

3. Click on the Start analysis button at the bottom of your screen to carry out the analysis.

"
e N |~
{ \ i i i \
(= A EE] [ (A=
M N A e

4. TIp To analyze all analyses at once, click on the Start batch analysis button on the toolbar.
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Project Explorer
FR10 - Sample_Project-Two_stimuli

FRI

Participants  Multi-Subjq Start batch analysis

Ao e R 2| =

IMPORTANT Bear in mind that carrying out batch analysis on a high number of long
videos with a high resolution and frame rate may cause problems.

5. The Model quality bar should cross the dashed line. If this is not the case, improve lighting
or reposition your camera.

Model quaity [ |

OUTPUT

FaceReader displays a number of windows with graphical and tabular output.

Important notes

e Not all visualization options may be available by default. If you do not see some of the
options described in this Quick Start Guide, choose File > Settings > Analysis Options and
select all options.

o If you selected the Baby Face model, not all output is available. See the FaceReader Help
for more information.

Procedure

1. Click on one of the buttons in the Analysis Visualization window to show, for example,
the key points in the face or the Facial States.
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Analysis Visualization = Il LR ¢
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2. To switch windows, click on the Select window button in the upper-
right corner of one of the windows and make your selection. See = | |:| X
Analysis windows on page 16 for a short description of the options.

3. Tozoom, or to copy or save graphs, click on one of the icons on the
window toolbar.

Timeline

8 b | & &

4. To show more windows, click on the Split/Unsplit buttons in the
upper-right corner of one of the windows. EI o

TIP If you notice the test participant shows a bias towards some facial expressions, use
one of the calibration methods to correct for that. See Analyze Facial Expressions/
Calibrate FaceReader in the FaceReader Help for details.

Analysis windows

You can choose between:
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o Face Analysis

Action Unit Intensity — Available with the Action Unit Module.

Circumplex Model of Affect — A chart in which emotions are described in a two-
dimensional circular space, containing arousal on the vertical axis and valence on the
horizontal axis.

Expression Intensity — A chart that displays which of the facial expressions show up in
the face.

Expression Line Chart — A line chart with the facial expression intensities over time.
Expression Summary — A pie chart with the distribution of the facial expressions.
Facial States — Whether, for example, mouth or eyes are open or closed.

Gaze Angles Line Chart —Horizontal and Vertical gaze angle on a time line.

Head Orientation Line Chart — The head orientation on a time line (Pitch, Yaw and
Roll).

Head Position Line Chart —Horizontal, Vertical and Depth position on a time line.
Subject Characteristics — With, for example, the estimated age and gender.

Valence and Arousal Line Chart — Valence indicates whether the emotional status of
the test participant is positive or negative. Arousal is based on the activation of the 20
Actions Units in FaceReader.

e Consumption Behavior (available with the Consumption Behavior Module)

« Vital Signs (available with the Vital Signs Module)

« Voice Analysis (available with the Voice Analysis Module)

o Analysis Visualization — Click on a button on the left to view how FaceReader analyzes
the face.

e Custom Expression Table — Available with the Action Unit Module.

e Custom Expression Line Chart — Available with the Action Unit Module.

e Stimulus View

e Timeline — An overview of the facial expressions, and facial states on a timeline.

See FaceReader’s Output in the FaceReader Help for a full description of the analysis
windows.

EXPORT

To export your data, choose File > Export. Choose to export the results of the analysis,
participant, or entire project. You have the following options:
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State log — A text file or Excel file with the dominant facial expressions as states over
time.

Detailed log — A text file or Excel file with the intensities of all facial expressions over
time.

To save extra options, like facial states, global gaze direction, valence and arousal values
to the log file, select these options in the Data Export tab of the Settings window (File >
Settings).

Optionally, adjust the sample rate of the export file and select whether to include
headers.

Heart beat log — A text file or Excel file with the inter-beat interval data (the time
intervals between individual heart beats).

The Observer XT log — Choose this option if you want to import the analysis results in the
annotation software The Observer® XT for further analysis.

The screenshot below comes from The Observer sample project ‘Child FaceReader’. In
this project a 3-year old boy is observed playing an online game. His face is filmed with a
webcam, while the screen is captured with the Noldus screen capture device. The video
of the boy’s face was analyzed in FaceReader. The Observer log was exported from
FaceReader and imported into The Observer XT. The screenshot shows the facial
expressions on the time line.

Work with FaceReader



Willard face video.avi

Screen capture video Willard.avi =

Playback Control
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TIP It is also possible to send the analysis results directly during the FaceReader analysis to
The Observer XT, using the Noldus network communication program N-Linx. See FaceReader
with The Observer XT in the FaceReader Help for details.

Work with FaceReader
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Project Analysis

SETUP

The Project Analysis section contains the following extra options:

1. Independent Variables - The independent variables Age and Gender are present by
default. Choose Project > Independent Variable > Add Independent Variable to add more
independent variables, like whether the participants saw the commercial before, or their
native language.

Stimuli  Event Markers  Independent Variables Tests

Double-click Independent Variables under a participant name to score them. Age and
Gender can be estimated by FaceReader, or entered manually.

w B Participant 2 - Andreas

* Independent Vanables

> [ Analysis 1 X
2. Stimuli and Event Markers — Define stimuli or event markers (Project menu) to mark

episodes of interest. Stimuli have a fixed duration and can be linked to a video orimage to
show to the test participants.
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Stimuli  Event Markers Independent Variables Tests

A

i

® Twins eating

> Frying insects 2

STIMULUS PRESENTATION TOOL

Use the stimulus presentation tool to automatically show stimuli to the test participants
and synchronize them with the analyses.

IMPORTANT In a two computer setup, synchronize the computer clock times with a time
server. See Synchronize computers with a network time protocol in the FaceReader Help
how to do so.

On the computer with FaceReader

1. Choose File > Settings > Data Export and under External Communication (API and
Stimulus Presentation Tool) select the Enable External Control checkbox.

2. To add tests, open the Tests tab in the bottom pane of the Project Explorer. Then click on
the Add test button.

LEEhEE Fuent Markers Independent Variables

3. Select the camera and the stimuli to show to the test participants.

Optionally, choose to let participants enter their own name, age and gender, perform
gaze calibration, randomize the presented stimuli, set the stimulus display size and the
length of the pause between the stimuli.

On the test participant computer

1. Start the Stimulus Presentation Tool and follow the instructions to connect with the
FaceReader computer.
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Connect to FaceReader @

- Facereader ip/host
localhost ‘

~ Facereader port
o |

~ Temporary storage path
C:\Users\Public\Documents\Noldus\Stimulus Presen I:I ‘

Connect D

2. Select a test and click Start.

3. Fill'in the participant details and click Start again, or let the participant do this. The test
and analysis start.

Welcome

Please enter your name
(RobinJohnson ]

Gender
(Male IZI]

Ei |

Start =
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ANALYZE

Participants are automatically added when you use the stimulus presentation tool. Also,
analyses are automatically carried out. Watch the Model quality bar when the test runs. The
bar should cross the dashed line. If this is not the case, improve lighting or reposition your
camera.

Model ity [ |

Optionally, score event markers during the analysis.

OUTPUT

Apart from the general FaceReader output options (page 15), the Project Analysis section has
the following output:

e Quick Layouts— This will open a number of charts to give you a first impression of the
data.

o Pie chart, Bar chart, Box plot, Line Chart or Circumplex model — Circumplex Model is
only available if you scored stimuli in your project.
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e Heatmap —Only available if you used the Stimulus Presentation Tool and tracked the

test participant’s gaze. The latter is possible with the Advanced Research Module.

o Table —To calculate statistics on the analyzed facial expressions and other parameters

of all participants, participant groups or single participants.

Twins eating =5
Baseline Correction : None | Temporal Aggregation : Mean | Participant Agaregation : Mean

Neutral Happy Sad Angry Surprised Scared Disgusted

Participant
Mean Mean Mean Mean Mean Mean Mean

Mean 0.3521 0.5033 0.0387  0.0320 0.0261 0.0051 0.0055

e Stimulus — To add your stimulus videos to the visualization. You can play back your
stimulus videos together (synchronized) with a Line chart with the facial expressions and

other parameters.

Twins eating

& Twins eating
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e Participant — To add your participant face video to the visualization. You can play back
your participant videos together (synchronized) with the stimulus video and a Line chart
with the facial expressions and other parameters.

Participant 3 - Hans - Analysis 1

> 0007119

@ Twins eating @ Frying insects

e Compare —To compare two or more data sets in a chart or table and carry out a t-test to
test for significant differences.

Sad Angry Surprised Scared
Mean Standard Deviation Mean Standard Deviation Mean Standard Deviation Mean Standard Deviation
0.0177 0.0148 0.0112 0.0153 0.0152 0.0085 0.0019 0.0019

0.0702 0.0065 0.0632 0.0580 m 0.0086 0.0099 0.0006

You can select what data to include in the analysis:
e Select what parameters to visualize/tabulate.

e Select a stimulus or event marker to visualize/tabulate the data during this stimulus/
event marker.
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e Select whether you want to do a baseline correction and visualize/tabulate absolute or
relative values of your parameters.

e Select how to aggregate data over time.
e Select how to aggregate data over test participants.

o Select which test participants to include in your analysis.

Bar Chart X

I 1. Select which data your want to use

& Angry

& Contempt & Disgusted

& Neutral & Surprised :
I 2. (Optional) Select the advanced options select
: Temporal Aggregation : Mean : : Participant Aggregation : Mean :
oK Cancel
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