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Up and running quickly

This Quick Start Guide guides you through the main steps to analyze facial expressions with 
FaceReader. Only the most basic features are addressed. Inevitably, some features that may 
be vital to your application are not discussed. You can find additional information in the 
FaceReader Help.

general information

The first part of the Quick Start Guide contains general information on using FaceReader. 
Follow the instructions to set up your system, install FaceReader and to analyze the facial 
expressions.

You can extend your FaceReader license with a number of modules. 

project analysis module

The Project Analysis Module allows you to create groups of participants based on 
independent variable values like age and gender, and to analyze average expression values 
per group. In addition to this, you can view the stimulus video together with the video of the 
test participant’s face and the FaceReader analysis. 

The second part of this Quick Start Guide describes the Project Analysis Module.
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other modules

FaceReader also has the following other modules:

Action Unit Analysis Module 

To analyze a set of 20 action units of the Facial Action Coding System (FACS). These are the 
action units that are most commonly used.
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Remote PPG Module

To estimate the heart rate and heart rate variability of the subject in front of the camera by 
means of remote photoplethysmography (RPPG). This is a method based on the fact that 
changes in blood volume due to pressure pulses cause small changes in the reflectance of 
the skin. 

Consumption Behavior Module

To analyze consumption behaviors like Intake event and Chewing. Please note that the 
Consumption Behavior Module is experimental. If you have the Consumption Behavior 
Module and want to use this in the analysis, you have to enable this analysis (File - Settings - 
Analysis Options - Optional Classifications)

more information?

See the FaceReader Help that opens when you press F1 in the program. It can also be accessed 
in the Windows apps screen, and can be downloaded from the MyNoldus portal. From the 
Help menu select Noldus Online and then Customer Support Center to access the MyNoldus 
portal.
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Support

If you encounter problems, see the Support section on the MyNoldus portal or a help desk in 
your area. From the Help menu select Noldus Online and then Contact Help Desk to access 
the MyNoldus portal. 

Note that if you send us videos showing people's faces, you should have permission from 
those people that you can use the video for that purpose and you may need to sign a form 
granting consent for us to use those videos.
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Physical setup

The physical setup of your experiment is crucial for an accurate analysis with FaceReader. We 
give the following general guidelines: 

 Place the camera in front of the test participant and slightly below eye level. Make sure 
your camera provides images with good contrast and brightness.

 Good lighting is crucial. Avoid direct light, reflections and shadows on the face. Make 
sure the lighting on the face comes directly from the front, for example by placing the 
setup in front of a window. If necessary, use lights on either side of the monitor, or a 
professional photo light to increase light intensity, or to compensate for unwanted light 
sources. 
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Install FaceReader

To install FaceReader

1. Download the installation file (FaceReader [version number] Setup.exe) from the 
MyNoldus portal of the Noldus website (my.noldus.com).

If you do not have a MyNoldus account yet, you can create one.

2. Double-click the file.

3. As Installation type, select Standard.

4. Follow the rest of the instructions on your screen to install FaceReader.

To install the Stimulus Presentation Tool (Project Analysis Module only)

If you have the Project Analysis Module, you need the Stimulus Presentation Tool to present 
stimuli automatically. To install it:

1. Download the installation file (Stimulus Presentation Tool 4 Setup.exe) from the Noldus 
website using your MyNoldus account (my.noldus.com).

2. Double-click the file to run it.

3. As Installation type, select Standard.

4. Follow the rest of the instructions on your screen to install the Stimulus Presentation Tool.
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Work with FaceReader

setup

1. Dependent on your license, do one of the following:
- If you have a hardware key, insert it into the computer and open FaceReader.

- If you have a software license key, start FaceReader and activate your license. You can 
choose between a Floating or a Fixed activation. 
 Floating — Choose Floating if you want to be flexible on which computer you use 

FaceReader and your computer is connected to the internet. 
 Fixed — A Fixed activation is linked to one computer. Your computer must have an 

internet connection to activate/deactivate a fixed license. After you have activated 
the license you can use FaceReader without internet.

2. Create a new Project (File > New > Project). Give the project a name and select a location 
to store it, or accept the default location.



10 Work with FaceReader

3. Choose Participant > Add Participant. Enter a name or identification code for the 
participant. 

4. The gender and age of your 
participants are added as 
independent variables and 
are automatically estimated 
by FaceReader. To select the 
age and gender manually, 
double-click the participant 
name. Click on the pencil 
button next to the independent variable to enter the values.

5. Add one or more analyses for each participant and choose to analyze from video, live from 
your camera or from images. To do so, select the participant for which you want to add an 
analysis in the Project Explorer. Click on the Video, Camera or Image button on the toolbar 
to add the appropriate analysis. It is not possible to mix image analyses with camera or 
video analyses.



Work with FaceReader 11

6. To carry out a camera analysis, select 
the option Use as default camera if 
you always use this camera. To record 
audio, select your microphone. 
Optionally, select Record to create a 
video file of the test participant’s face. 
The video will always be saved at a 
frame rate of 15 frames per second. 

To add multiple video analyses to a 
participant, right-click the participant’s name, select Add Multiple Video Analyses, and 
select your videos. 
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analyze

1. Click on the magnifying glass button next to an analysis to open it. 

2. Check the options for this analysis in the Settings window in the bottom-left corner of the 
analysis window.  

To create default settings for each new analysis, choose File > Settings. Open the tab 
Default Analysis Settings and make your selection.
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See the FaceReader Help for an explanation of the options. Press F1 in the program to 
open it. 

Choose File > Settings > Analysis Options and select Action units, Estimate heart rate 
and heart rate variability and/or Consumption behavior to activate the Action Unit 
module, the Remote PPG module and/or the Consumption Behavior module.

important  If you select the Baby Face model, Facial expressions are not available as 
analysis output. You will obtain Action Unit intensities. See Action Unit Module in the 
FaceReader Help for more information. 
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3. Click on the Start analysis button to carry out the analysis.  

tip  To analyze all analyses at once, click on 
the Start batch analysis button on the 
toolbar. 

important  We recommend to close all 
visualization windows before you start 
batch analysis. Bear in mind that carrying 
out batch analysis on a high number of long videos with a high resolution and frame rate 
may cause problems. 

4. The Model quality bar should cross the dashed line. If this is not the case, improve lighting 
or reposition your camera.

output

FaceReader displays a number of windows with graphical and tabular output. 
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Important notes

 Not all visualization options may be available by default. If you do not see some of the 
options described in this Quick Start Guide, choose File > Settings > Analysis Options and 
select all options. 

 If you selected the Baby Face model, not all output is available. See the FaceReader Help 
for more information. 

Procedure

1. Click on one of the buttons in the Analysis Visualization window to show, for example, 
the key points in the face or the Facial States. 

2. To switch windows, click on the Select window button in the upper-
right corner of one of the windows and make your selection. See 
Analysis windows on page 16 for a short description of the options. 

3. To zoom, or to copy or save graphs, click on one of the icons on the 
window toolbar.
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4.  To show more windows, click on the Split/Unsplit button in the 
upper-right corner of one of the windows. 

tip  If you notice the test participant shows a bias towards some facial expressions, use 
one of the calibration methods to correct for that. See Analyze Facial Expressions/ 
Calibrate FaceReader in the FaceReader Help for details. 

Analysis windows

For the upper windows you can choose between:

 Analysis Visualization – Click on a button on the left to view how FaceReader analyzes 
the face.

 Subject Characteristics – With, for example, the estimated age and gender.

 Facial States – Whether, for example, mouth or eyes are open or closed.

 Expression Intensity – A chart that displays which of the facial expressions show up in 
the face.

 Expression Summary – A pie chart with the distribution of the facial expressions.

 Circumplex Model of Affect – A chart in which emotions are described in a two-
dimensional circular space, containing arousal on the vertical axis and valence on the 
horizontal axis. 

 Action Unit Intensity – Available with the Action Unit Module. 

 Heart rate – Available with the Remote PPG Module. 

 Consumption Behavior Statistics – Available with the Consumption Behavior Module.

 Custom Expression Table – Available with the Action Unit Module.

For the lower windows you can choose between the line charts: 

 Timeline – An overview of the facial expressions, and facial states on a timeline.

 Valence Line Chart – The valence indicates whether the emotional status of the test 
participant is positive or negative. 

 Arousal Line Chart – Arousal indicates whether the test participant is active or not active.

 Expression Line Chart – A line chart with the facial expression intensities over time.

 Head Orientation Line Chart – The head orientation on a time line (Pitch, Yaw and Roll).

 Heart Rate and Variability Line Chart – Available with the Remote PPG Module.



Work with FaceReader 17

 Custom Expression Line Chart – Available with the Action Unit Module.

 Heart Beat Chart – Available with the Remote PPG Module.

 Head Position Line Chart —Horizontal, Vertical and Depth position on a time line.

 Gaze Angles Line Chart —Horizontal and Vertical gaze angle on a time line.

See FaceReader’s Output in the FaceReader Help for a full description of the analysis 
windows. 

export

To export your data, choose File > Export. Choose to export the results of the analysis, 
participant, or entire project. You have the following options:

 State log – A text file or Excel file with the dominant facial expressions as states over 
time.

 Detailed log – A text file or Excel file with the intensities of all facial expressions over 
time. 

To save extra options, like facial states, global gaze direction, valence and arousal values 
to the log file, select these options in the Data Export tab of the Settings window (File > 
Settings). 

Optionally, adjust the sample rate of the export file and select whether to include 
headers. 

 Heart beat log — A text file or Excel file with the inter-beat interval data (the time 
intervals between individual heart beats).

 The Observer XT log – Choose this option if you want to import the analysis results in the 
annotation software The Observer® XT for further analysis. 

The screenshot below comes from The Observer sample project ‘Child FaceReader’. In 
this project a 3-year old boy is observed during play with an online game. His face is 
filmed with a webcam, while the screen is captured with the Noldus screen capture 
device. The video of the boy’s face was analyzed in FaceReader. The Observer log was 
exported from FaceReader and imported into The Observer XT. The screenshot shows the 
facial expressions on the time line.
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tip  It is also possible to send the analysis results directly during the FaceReader analysis to 
The Observer XT, using the Noldus network communication program N-Linx. See FaceReader 
with The Observer XT in the FaceReader Help for details.
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Project Analysis Module

setup 

The general procedure to set up an experiment with FaceReader also applies to the Project 
Analysis Module. The Project Analysis Module contains the following extra options:

1. Independent Variables - The independent variables Age and Gender are present by 
default. Choose Project > Independent Variable > Add Independent Variable to add more 
independent variables, like whether the participants saw the commercial before, or their 
native language. 

Double-click Independent Variables under a participant name to score them. Age and 
Gender can be estimated by FaceReader, or entered manually. 

2. Stimuli and Event Markers – Define stimuli or event markers (Project menu) to mark 
episodes of interest. Stimuli have a fixed duration and can be linked to a video or image to 
show to the test participants.  
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stimulus presentation tool

Use the stimulus presentation tool to automatically show the stimuli to the test 
participants and synchronize them with the analyses. 

important  In a two computer setup, synchronize the computer clock times with a time 
server. See Synchronize computers with a network time protocol in the FaceReader Help how 
to do so. 

On the computer with FaceReader

1. Choose File > Settings > Data Export and under External Communication (API and 
Stimulus Presentation Tool) select the checkbox Enable External Control.

2. To add tests, open the Tests tab in the bottom pane of the Project Explorer. Then click on 
the Add test button. 

3. Select the camera and the stimuli to show to the test participants. 

Optionally, choose to let participants enter their own name, age and gender, randomize 
the presented stimuli, set the stimulus display size and the length of the pause between 
the stimuli. 
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On the test participant computer

1. Start the Stimulus Presentation Tool and follow the instructions to connect with the 
FaceReader computer. 

2. Select a test and click Start. 

3. Fill in the participant details and click Start again, or let the participant do this. The test 
and analysis start.
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analyze

Participants are automatically added when you use the stimulus presentation tool. Also, 
analyses are automatically carried out. Watch the Model quality bar when the test runs. The 
bar should cross the dashed line. If this is not the case, improve lighting or reposition your 
camera.

Optionally, score event markers during the analysis. 

output

Apart from the general FaceReader output options (page 14), the Project Analysis Module has 
the following output:

 Quick Layouts— This will open a number of charts to give you a first impression of the 
data.

 Pie chart, Box plot, Bar chart, Circumplex model or Line chart — Circumplex Model and 
Line Chart are only available if you scored stimuli in your project.
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 Table —To calculate statistics on the analyzed facial expressions and other parameters of 
all participants, participant groups or single participants.

 Stimulus — To add your stimulus videos to the visualization. You can play back your 
stimulus videos together (synchronized) with a Line chart with the facial expressions and 
other parameters. 

 Participant — To add your participant face video to the visualization. You can play back 
your participant videos together (synchronized) with the stimulus video and a Line chart 
with the facial expressions and other parameters.
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 Compare —To compare two or more data sets in a chart or table and carry out a t-test to 
test for significant differences.

You can select what data to include in the analysis:

 Select what parameters to visualize/tabulate.

 Select a stimulus or event marker to visualize/tabulate the data during this stimulus/
event marker.

 Select whether you want to visualize/tabulate absolute or relative values of your 
parameters.
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 Select how to aggregate data over time.

 Select how to aggregate data over test participants.

 Select which test participants to include in your analysis.
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