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1 Introduction

about this technical note
In this Technical Note you find all information you need to establish 
communication between The Observer XT and the E-Prime software for 
stimulus presentation, run a test and analyze the data of E-Prime and 
The Observer XT as one data set. 

Throughout this note we assume that you are familiar with the basic 
use of The Observer XT and E-Prime Professional 3.0, and that you have 
created an E-Prime experiment in E-Studio.

After reading this note you will be able to:

 Set up The Observer XT and E-Prime to communicate with each 
other.

 Start recording in E-Run through The Observer XT.

 Automatically Import the E-Prime data into The Observer XT.

 Analyze the E-Prime data in The Observer XT.

You can find this technical note in PDF format in the folder C:\Program 
Files (x86)\Noldus\EPrime Server.

note  The Observer XT 14.1 and later versions combined with E-Prime 
Client/Server 1.5 and later were not tested with E-Prime 2.x. If you have 
E-Prime 2.0, make sure that this combination works before running an 
experiment.

For more information

 For more information on The Observer XT, see The Observer XT 
Help. To open the Help, press F1 in the program.

 For E-Prime, see the E-Prime Reference Manual.
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the observer xt and e-prime: workflow
The workflow is generally as follows:

1. Make sure that the Observer XT and the E-Prime computers are 
connected to the local network.

2. In The Observer XT, open the project you require. 

3. In E-Studio, open the E-Studio experiment that you require.

4. Prepare the test subject in front of the test monitor. 

5. In The Observer XT, start an observation. This will send a start 
command to E-Run.

6. Let the E-Prime experiment run as usual.

7. When the E-Studio experiment has terminated, in The Observer XT 
stop the observation. The E-Prime experiment events are imported 
automatically into The Observer XT.

Figure 1  Schematic representation of the physical connections and the software 
needed for communication between The Observer XT and E-Prime 3.0.
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tools you need
In order for The Observer XT and E-Prime to communicate, you need 
additional software installed on your computers (Figure 1):

 Noldus E-Prime Client 1.6. Installed on the computer where The 
Observer XT is installed. See page 8. 

 Noldus E-Prime Server 1.5. Installed on the computer where E-
Studio is installed. See page 8.

Noldus E-Prime Server also includes this technical note as 
documentation. You can find this technical note in PDF format in 
the folder C:\Program Files (x86)\Noldus\EPrime Server.

note  If you have E-Prime 3.0 and The Observer XT 14.0, update The 
Observer XT to 14.1 or later version. The Observer XT 14.0 only works 
with older versions of E-Prime Server and E-Prime Client made for E-
Prime 2.x.

prerequisites

Computer connection

The Observer XT and E-Prime must be installed on two separate 
computers, connected through a Local Area Network (LAN; Figure 1). 
Make sure that your connection is stable. If connection is lost once 
during an observation, it cannot be restored and most likely the data of 
that observation will be incomplete or invalid.

The Noldus E-Prime plug-in 1.5 was developed with The Observer XT 
14.1, E-Prime 3.0.3.31 and E-Studio Professional version 3.0.3.18.

E-Prime add-on license

Your copy of The Observer XT can only work together with E-Prime if 
your Observer XT license includes the E-Prime Tool.

Operating system

The Noldus E-Prime Client and E-Prime Server software supports the 64 
bit Professional editions of Microsoft Windows 10.
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In case of complex setups

When The Observer XT and E-Prime are part of a more complex 
observational setup, including for example a physiological data 
acquisition system which uses a dedicated board on the E-Prime PC, or 
IP cameras, make sure that The Observer XT communicates directly 
with the E-Prime PC, using either a crossover cable or a dedicated 
network switch.

If you use a network switch to connect The Observer XT and the E-
Prime computers (see Figure 2), it must have a fixed IP address with a 
range different from that of other switches, in order to prevent 
communication conflicts. For example: 192.168.0.101 for switch 1 and 
192.168.1.xxx for switch 2.

Figure 2  Example of a complex observational system including The Observer XT, 
E-Prime, IP video cameras and a system for acquisition of physiological data. 
Make sure to connect The Observer XT computer and the E-Prime computer with a 
separate network switch, and the rest (IP cameras in this example) with another 
switch. You can also use a crossover cable to connect the two PCs instead of a 
network switch.
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2 Install the software

The E-Prime integration solution consists of two pieces of software: 

 The E-Prime Client software, to be installed on the computer where 
The Observer XT is installed,

 The E-Prime Server software, to be installed on the E-Prime 
computer.

on the observer xt pc
1. Copy the file E-Prime Client 1.6 Setup.exe to The Observer XT 

computer.

2. Double-click this file and follow the instructions on your screen to 
install the E-Prime Client. Accept the terms in the License 
Agreement. 

The software is installed on C:\Program Files\Common 
Files\Noldus\The Observer\EPrime Client 1.

Proceed with the next section. 

on the e-prime pc
1. Copy the file E-PrimeServer 1.5 Setup.exe to the E-Prime computer.

2. Double-click this file and follow the instructions on your screen to 
install the E-Prime Server. Accept the terms in the License 
Agreement. 

The software is installed on C:\Program Files (x86)\Noldus\EPrime 
Server. Proceed with the next section.
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3 Set up communication

the observer xt pc

Procedure
1. In The Observer XT, create a new project or open an existing one.

2. Click Setup Project in the main window. Under Observation Source, 
select Live Observation.

3. If the Devices window does not open, click Devices under Live 
Observation.

4. In the Devices window, select the option E-Prime, and double-click 
the cell under Status.

5. In the new window that appears, next to E-Prime computer enter 
the IP address of the E-Prime computer. Leave the Port value as 155.
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To obtain the IP address of the E-Prime computer: 
On the E-Prime computer, start the Noldus E-Prime Server, then 
click the Advanced settings tab. The window that appears contains 
the E-Prime Controller IP address.

6. Click OK, then OK in the Devices window.

7. Proceed with the settings on the E-Prime PC (next section).

Notes

 You can also use a port number other than the default 155, but you 
must set it in both The Observer XT and in E-Prime Controller. 

 If the E-Prime item does not appear in the Devices window, check 
that the E-Prime Client software is installed (page 8) and that your 
license includes the E-Prime add-on (page 6). 

 Some Firewalls can block communication ports. If port 155 is 
blocked, ask your system administrator to find a free port that is 
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not blocked. Select this new port number in step 5 above and in the 
Advanced settings of the E-Prime Server (see page 52). 
Alternatively, let your system administrator create an exception in 
Windows Firewall for port 155.

the e-prime pc
1. On the E-Prime PC, start Noldus EPrime Server.

2. On the Experiment Settings tab, browse to the experiment file you 
want to use (*.ebs3).

3. Click Start to activate Noldus E-Prime Server. From this moment on, 
it will accept messages from The Observer XT. 

Notes

 For E-Prime 2.0, the file extension is ebs2. note  E-Prime 2.0 was not 
tested with The Observer XT 14.1 and later versions.

 Notice the difference between the file extensions: .es3 is the 
extension of E-Studio files, which specify the experimental 
procedure. The extension .ebs3 is of the E-Basic script file generated 
for that experiment. In order to have a ebs3 file in your experiment 
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folder, generate it in E-Studio: choose E-Run > Generate. The 
experiment folder now also contains the ebs3 file.

 E-Prime Server can only be started once. If you start it multiple 
times, the Noldus E-Prime Server window comes on top of your 
screen.

 Do not click Exit until you are done with data recording. Instead, 
click the Minimize button or the Close (X) button.

 For the Advanced settings see page 52.
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4 Prepare the experiment in E-
Studio

specify the events to import
A typical E-Prime experiment consists of a number of E-objects 
(instructions, stimuli, feedbacks) organized in nested sequences called 
procedures. Follow this section to specify the E-objects that you want 
to import in The Observer XT, and their properties.

1. Start E-Studio and open your experiment.

2. In the Experiment Explorer window, double-click one of the E-
objects in your procedure.

3. In the window that appears, click the Properties button (this is 
located just under the window’s title bar).

4. Click the Logging tab. Follow all steps below.

Default parameters

5. Make sure that OnsetTime and Duration are selected. System events 
like the presentation of a stimulus will be imported in The Observer 
XT as state events for the subject System using these properties.  See 
how e-prime events are stored in the observer xt on page 34.
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Properties for User responses

6. For the experiments in which a response is given by the test 
participant after presentation of a stimulus, make sure that the 
following items are selected:
- CRESP (Correct Response)
- RESP (Actual Response)
- RTTime (Subject response timestamp)

The participant responses will be imported in The Observer XT as 
point events for the subject “User” (see page 34). 

7. Click OK.

Repeat the steps 2 to 7 for all the other objects you are interested in.
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display settings

E-Prime experiments in Windows 10

Windows 10 only supports 32 bit color depth. However, when an E-
Prime experiment that was created in a prior version of E-Prime and 
with a bit depth lower than 32 is loaded into E-Prime 3.0, E-Prime keeps 
the originally-specified color depth setting. This may affect the E-Prime 
correct functioning.

To check that the Color bit depth is correct.

1. In E-Studio, choose Edit > Experiment (Ctrl+E).

2. Click the Devices tab, then double-click Display. 

3. Next to Color Bit Depth, select 32 if not selected already.

important  You must follow this procedure for any experiment that 
you open on that computer. 

For a more general solution for Windows 8 and 10 computers, see the 
web page:

https://support.pstnet.com/hc/en-us/articles/115001493487-INFO-
Windows-8-DirectX-11-or-greater-detected-23888-
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specify the event properties to import
For some events you may want to import additional information to The 
Observer XT, like the name of the picture used as a stimulus. This 
information can be imported as modifiers. See how e-prime events 
are stored in the observer xton page 34 for the way The Observer XT 
handles the E-prime data.

General rule

The Observer XT imports the object property that, in the Trial List, has 
the same name as the object. The values in the column cells are 
imported as modifiers.

In the example below, the object in the procedure is named Stimulus. 
Of this object, The Observer XT imports the values in the column 
Stimulus of the Trial List, RedCar.bmp and BlueCar.bmp. They are 
imported as modifiers of the behavior Show Stimulus.

Example 1: To import stimulus file names

An image E-object has been inserted in a procedure, and named Prime. 
The trial list specifies that for Prime an image will be chosen randomly 
between the available image files, and displayed on the test participant 
monitor. The researcher requires that, for each instance of image 
presentation, the image file name is imported in The Observer XT as a 
modifier of the event “Show Prime”. For example, “Show Prime - 
Flower_12.bmp”.

1. Open the experiment in E-Studio.
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2. In the Experiment Explorer window, double-click the list in which 
the object is located.

3. In the list properties window, click the Add attribute button. Enter 
the name as the object (in this example, Prime).

4. Fill in the cells in the new column with the names you want to 
import (in this example, the name of the image files for Prime).

5. In the Experiment Explorer window, click the E-object again.

6. important  If the attribute value is a file (image, video, etc):

a In the Properties window locate the Filename item. In the field 
next to it, click the Browse button and select the folder that 
contains the stimulus files, then click OK.

  

b In the field next to Filename, type in the object name in brackets 
[ ]. In this example: [Prime].
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7. Run the experiment in E-Studio (E-Run > Run or F7). 

8. The experiment is ready to work with The Observer XT. The value of 
the attribute in a specific trial will be imported as a behavior 
modifier in the group Media. For example:

Notes

 For correct import into The Observer XT, the name of the attribute 
must be the same as the name of the object, including the case.

 It is not possible to import two or more attributes to the same 
object.

For example, a stimulus object has two attributes, File (with the 
image file names as values) and CorrectAnswer (with values 1 or 2). 
For this object, you can import either the image file name or the 
correct response as a modifier, not both. In the first case you 
rename File as the object name, in the second you rename 
CorrectAnswer as the object name.

 It is not possible to change the name of the modifier group Media 
in The Observer XT.

 See also Example 3: To import responses as numerical modifiers on 
page 20.
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Example 2: To Import non-filenames

A stimulus has an attribute named PictureType with possible values 
Positive and Negative defined in the Trial List. For each stimulus event, 
the corresponding value must be imported in The Observer XT as 
modifier of the behavior Show Stimulus.

1. In E-Studio, open the experiment.

2. In the Experiment Explorer window, double-click the list in which 
the object is located.

3. In the list properties window, take note of the attribute that 
contains the values to import (in this example, PictureType).

4. Rename the object as the attribute.

5. Run the experiment in E-Studio (E-Run > Run or F7).

6. After that, the experiment is ready to work with The Observer XT. 
The value of the attribute in a specific trial will be imported as a 
behavior modifier in the group Media. For example:
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Example 3: To import responses as numerical modifiers

Attributes that are imported as modifiers are by default nominal. This 
means that you can calculate durations and frequencies, but not 
average values or other numerical statistics. If this is what you want, 
for example to calculate the average rating for the pictures that are 
shown, you must specify additional settings for the attribute.

important  If your E-Prime experiment includes the possibility to give 
numerical responses to a stimulus, these must be scored during the 
test. If you skip a numerical response, this will result in errors in the 
event log in The Observer XT.

1. Open the experiment in E-Studio.

2. In the Experiment Explorer window, double-click the element with 
the numerical response options.

3. In the window that opens, double-click the Properties button.

 

4. Open the Common tab and in the Tag field enter the following:
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numericalpredefined for response options with predefined values. 
numericalrange for response options within a range.

5. Click the Logging tab and select Tag.

6.  Run the experiment in E-Studio.

 

7. After that, the experiment is ready to work with The Observer XT. 
The values of the attribute in a specific trial will be imported as 
numerical modifiers. For example:
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Notes

 The tag you specified in step 4, is present in the log file of the E-run 
experiment, which is the text file present in the same folder as your 
experiment. See the picture below for an example.

 You can specify one response for each stimulus for import into The 
Observer XT. Multiple answers per stimulus is not supported. 

 If you want to use numbers as responses, do not use an existing 
project created in The Observer XT 13 or earlier. Since this option did 
not exist in a previous version, it will result to errors in the Event 
log. Create a new project instead.
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ensure high synchronicity between the 
observer xt and e-prime
In order to ensure synchronicity with E-Run, The Observer XT needs to 
acquire the time information with the highest accuracy. To do so, it 
uses a package that runs in the E-Prime experiment. You must specify 
this package in all your experiments that work together with The 
Observer XT.

note  A package is a re-usable block of E-Basic script that you can add to 
E-Prime experiments via the PackageCall objects. 

Procedure
1. With the File Explorer, make sure that the file TheObserverXT.epk3 

is present in the following two locations:

C:\Users\[user name]\Documents\My Experiments\3.0\Packages

This is the default E-Prime search folder for packages.

note  If you use E-Prime 2, the correct folder for this package is 
C:\Users\[user name]\Documents\My Experiments\Packages. The 
package file extension is epk2.

The second location is C:\Program Files (x86)\Noldus\EPrime 
Server.

This is the installation folder of Noldus E-Prime Server. This package 
must be in that folder only if you installed Noldus E-Prime Server 
with a user account different from that you use when working with 
E-Prime. If the package file is not present, repeat installation of 
Noldus E-Prime Server.

note  If you use E-Prime 2, the correct folder for this package is 
C:\Program Files (x86)\ Noldus\EPrime Server. The package file 
extension is epk2.
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2. Specify the Packages Search Folders in E-Studio.

a In E-Studio, choose Tools > Options > Packages.
Under User Search Folder you should see the default folder 
C:\Users\[user name]\Documents\My Experiments\3.0\ 
Packages

note  For E-Prime 2.0, the folder is C:\Users\[user name]\ 
Documents\My Experiments\Packages.

b Under User Search Folder you should see a second location 
(C:\Program Files (x86)\Noldus\EPrime Server). If that is not the 
case, click the New button. 

 
Browse to C:\Program Files (x86)\Noldus\EPrime Server, then 
click OK. 

c Now the Packages tab in the Options window should look like 
this: 

3. Specify the TheObserverXT package file in the E-Studio experiment. 

a In E-Studio, open the experiment, and in the Experiment Explorer 
window double-click the experiment name.

      

b Click the Packages tab, then click the Add button.
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c Select TheObserverXT, click OK. If this package is not visible, 
restart E-Studio. 

d Click Apply, then OK. The package can now be inserted in the 
experiment.
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4. Insert the PackageCall in the E-Studio experiment.

a In the Toolbox window, locate PackageCall, and drag it to the 
beginning of the first procedure.

          

b Result: An object named PackageCall1 is inserted.

      

c Double-click PackageCall1, click the General tab, and from the 
Package list select TheObserverXT. From the Routine list select 
SyncTime. 

     

d Click the Common tab. Ignore the warning and click OK.
e Next to Name, rename PackageCall1 to SyncTime, and click OK.
f Result: In the Structure window, the PackageCall object is now 

named SyncTime.
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5. Run the experiment once (E-Run > Run, or press F7) then save the 
experiment.

Notes

 The SyncTime routine of the TheObserverXT package reads the 
timestamps with high accuracy from E-Run, and writes it down in a 
text file named NoldusSync.txt. This time will be read by Noldus E-
Prime Server when sending the E-Prime data to The Observer XT PC.

 The file NoldusSync.txt is stored in the same location as that of the 
experiment file.

 If the TheObserverXT package is not added to your E-Prime 
experiment, when importing the data from E-Prime The Observer 
XT shows a message in the Comment column of the first line of the 
E-Prime event log, that accurate synchronization is not possible for 
that E-Prime data set. The E-Prime event log is still added to the 
observation, but aligned with the Observer XT data with a 1-second 
accuracy.

 If you use E-Prime 2.0, see the Technical Note - E-Prime - The 
Observer 12.5, which you can also find on the Observer XT 12.5 
download web page.
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5 Acquire data

things to check first
1. On the E-Prime PC, make sure to close the E-Run window.

2. On the E-Prime PC, make sure that Noldus E-Prime Server is running 
in the background. To do so, check that its icon is visible in the 
taskbar:

If Noldus E-Prime Server is not running, in the Apps screen choose 
Noldus > E-Prime Server (in Windows 7, choose Start > All Programs 
> Noldus > E-Prime Server > E-Prime Server).

3. On the E-Prime PC, in the Noldus E-Prime Server window, click Start.

Result: Noldus E-Prime Server says “Server is running”.
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important  Do not click Exit until your test sessions are finished!

The Start button is not available when the server is already running.

procedure
1. On the Observer XT PC, open your project in The Observer XT.

optional  Create a coding scheme which you can use to annotate 
the test participant’s behavior manually. See The Observer XT Help 
how to do so. 

2. Create a new observation (Alt+F6) and give it a name, then click OK.

Result: The E-Prime Status window opens. The status is Ready to 
start. 

3. Ask your test participant to sit in front of the test PC, and give him/
her the necessary instructions.
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4. On the Observer XT PC, when ready, click the Start observation 
button.

Result: The E-Prime Status window says:

Connection: . Status: Waiting for E-Prime. 

5. On the E-Prime PC, The experiment starts. Insert the subject and 
session data, then let the test participant carry out the assigned 
tasks. The Noldus E-Prime Server window says Client connected.

6. On the Observer XT PC, optionally manually code the test 
participant’s behavior. 

When the experiment in E-Prime is finished, the E-Prime Status 
window says Finished.

The Noldus E-Prime Server says Client disconnected.

7. On the Observer XT PC, stop the observation by clicking the Stop 
observation button. 

8. The E-Prime events are imported as a new event log named E-Prime 
in the current observation.
30 5 - Acquire data



notes
 In order for the Noldus E-Prime Server to start correctly, the 

experiment script file ebs3/ebs2 file must be selected under E-
Prime Experiment. See Set up communication - the e-prime pc on 
page 11.

 If you create an observation (step 2 in the procedure above) before 
starting Noldus E-Prime Server, the E-Prime Status window on the 
Observer XT PC says Connection . 

To solve this problem, do the following:

a In The Observer XT, click another item in the Project Explorer, for 
example the coding scheme. This action closes the observation.

b On the E-Prime PC, in Noldus E-Prime Server, click the Start 
button.

c In the Observer XT, in the Project Explorer, click the name of that 
observation. This re-opens the observation.

Note that the observation name is labeled with a yellow triangle 
icon. This indicates that the observation has yet to be started.

d The E-Prime Status window says now Connection . You are 
ready to start the observation.

 Make sure that you stop the observation in The Observer XT only 
when the E-Prime Status window says Connection  and Status 
Finished. If you do it before, The Observer XT won't import the E-
Prime data for that observation!

 If you cancel the run on the E-Prime PC after starting the 
observation, for example when clicking Cancel in one of the dialog 
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that appear at the start of the run, connection is lost for that 
observation. On the Observer XT PC, stop the observation, delete it 
and create a new one.

 There may be a significant delay (30 s or more) between the start of 
the observation (step 4) and the start of E-run (step 5). This could be 
doe to a number of factors, like:
- The driver software of the E-Prime hardware key is not up-to-

date. Go to http://sentinelcustomer.safenet-inc.com/
sentineldownloads/, and download Sentinel HASP/LDK Windows 
GUI Run-time Installer. Next, remove the E-Prime hardware key 
for the E-Prime PC, and launch installation of the driver. After 
installation is complete, insert the hardware key in the E-Prime 
PC and start E-Studio.

- The E-Prime PC has other hardware installed that conflicts with 
E-Prime, for example an additional network card. See In case of 
complex setups on page 7.

 When E-Prime data are imported into The Observer XT, it adds two 
subjects to the Coding Scheme (see page 40). When you now 
manually score events, The Observer XT expects that for each event 
you first score a subject and then a behavior. Define a subject in the 
Coding Scheme. Then choose Setup > Project Settings > Scoring 
Options and select Auto-record subject. You now have to score the 
subject only once at the start of the test.

scoring data offline
Once you finish an observation, the E-Prime data are sent to The 
Observer XT. It may happen that you want to review the observation, 
possibly with external video, and score events manually. However, after 
data import, the coding scheme has two additional subjects: User and 
System. This means that every time you want to score an event 
manually, you must score the subject in the Observer XT’s Codes 
window before you can score the event (behavior). To prevent this from 
happening, and to reduce the number of key presses, you can use the 
Auto-record subject function. With this option The Observer XT 
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assumes you will be scoring events for the first subject you score in an 
observation session.

1. In The Observer XT, choose Setup > Project Settings > Scoring 
options.

2. Select Auto-record Subject.

3. If they are not already present, define one or more Subjects (roles) in 
the coding scheme, which can be used to score events manually.

4. Open and start the observation as usual.

5. Position the observation (or video) at the time where you want to 
enter the event.

6. Score the event as usual, including the subject: [Subject] - [Behavior] 
- [Modifiers].

7. The next time you score an event, that subject is scored 
automatically. Complete the event with the Behavior and Modifiers.

For more information, see Auto-record Subject in the Observer XT Help.

note  The subjects User and System added after E-prime data import 
are not shown in the Codes window.
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6 Analyze data

how e-prime events are stored in the 
observer xt

Event files

The data of E-Prime are stored in a separate event file named E-Prime. 
You can see this in the tree view of the Project Explorer. Click the 
observation name, and open Event Files.

 E-Prime contains all events imported from the E-Prime computer.

 Event log is the event file that The Observer XT creates by default 
when you create an observation. If you code events manually 
during the observation, the events are written to this file. If you do 
not code events, Event log only contains two lines that mark the 
start and the end time of the observation.

Click E-Prime to open the E-Prime event log.

Two subjects: System and User

In the E-Prime event log, the column named Subject specifies the 
subject of the event in each row.
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 System: for all events determined by E-Prime (for example, a 
stimulus presentation).

 User: for all responses by the test participant. 

System events

A state event like the presentation of a stimulus is indicated by two 
rows:

 The start row (with a green symbol in the Behavior column). The 
start time is the value of OnsetTime of the E-object in E-Prime. 

 The stop row (with a red symbol in the Behavior column). The stop 
time is the value of OnsetTime + Duration of the E-object in E-
Prime.

Note that the times in the event log may differ from the times in the E-
Prime output file (a text file generated by E-Run). This is normal, since 
the time stamps are corrected to ensure millisecond-accurate 
synchrony between E-Prime and The Observer XT.

For system events, the name shown in the Behavior column is always 
Show followed by the name of the E-object. 

User responses

A point event like the user response is indicated by one row, with a blue 
circle in the Behavior column. The time of the event is the value of 
OnsetTime of the E-object in E-Prime.
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The Modifier column shows two modifiers:

 Response: followed by the character(s) entered by the test 
participant

 Correct: followed by the correct response for the corresponding 
stimulus (that is set in the E-Prime Trial List).

Numerical responses

Modifiers are by default nominal, unless you specified in E-Prime, they 
should be imported as numerical (see Example 3: To import responses 
as numerical modifiers on page 20). Numerical responses are then 
imported into the Event log as numerical modifiers.

Notes

 If events are missing or incomplete, it could be due to wrong 
settings in E-Prime. For example, if RTTime is not selected in E-
Prime logging settings, user answers will not be imported in The 
Observer XT. If CRESP or RESP are not selected, an event line is 
imported but does not contain the corresponding modifier (correct 
response or actual response, respectively). If neither of the two is 
selected, the event is not imported at all.

 If the Subject, Behavior, or Modifier columns are not shown in the 
E-prime event log, right-click one of the column headers and select 
them. 
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 It is not possible to remove Show from the name of system events. 
It is also not possible to customize the behavior Answer and the 
part of its modifiers Correct: and Response:. You can only 
customize the responses; to do so, edit the values in the Trial List.

 See Prepare the experiment in E-Studio on page 13 for how to 
customize the information in the E-Prime events sent to The 
Observer XT.

 If the first event line of the E-Prime event log contains the message 
The E-Prime data could not be synchronized automatically in the 
Comment column, it means that E-Prime could not use the 
TheObserverXT package correctly, or the package was not installed 
(see page 23). 

In such cases the E-Prime event log is added to the observation and 
aligned with other data with a 1-second accuracy.

 Note that the times in the event log may differ from the times in 
the E-Prime output file (a text file generated by E-Run). This is 
normal, since the time stamps are corrected to ensure millisecond-
accurate synchrony between E-Prime and The Observer XT (see 
page 23 for how to set this).
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synchronicity between e-prime and the 
observer xt data
We advise to connect the Observer XT PC and the E-Prime PC to a local 
area network (LAN). In most cases the network speed is high enough to 
have a negligible delay between the start of the observation in The 
Observer XT and the start of the E-Run experiment. The Observer XT 
assumes that the start command arrives immediately to Noldus E-
Prime Server.

To quantify network data delay, you can use a computer network 
administration utility like Ping. 

 Windows 7: From the Windows Start menu of the Observer XT PC, 
select Run and type cmd, then press Enter. 

 Windows 10: In the Apps screen, type Run, click the app, type cmd 
and press Enter. 

In the DOS prompt window that appears, type ping followed by the IP 
number of the other computer, then press Enter. The Average statistic 
measures the Observer XT to E-Prime delay.

Note that the maximum time resolution that can be visualized in The 
Observer XT is 1 ms, therefore any delay time in the network smaller 
than 1 ms cannot be traced in The Observer XT data.

If for some reason the delay in the network is significant, the “zero 
time” of E-Run comes after the “zero time” of the observation. If you 
score events in The Observer XT during the experiment, then the E-
Prime data and the manually-scored data may be slightly out of sync. If 
you score events offline, a network delay does not affect your data.

visualization
You can view the imported E-Prime events in a time-event plot. 

Choose Analyze > Visualization. Select the observation you require.

The E-Prime data are shown in two charts, one for the subject System 
and the other for the subject User.
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Click the + symbol next to the behaviors to expand the chart and view 
the modifiers.

Notes

 All the system events are states of Start-stop type (see Set up your 
Project in The Observer XT Help for information on this event type).

 There is usually an empty area in the chart from the observation 
start time (Relative time 0) to the start of the first event 
(Instructions in the example above). This is the time from when the 
E-Run starts to when the first instructions are shown on the screen. 
This time may vary between observations, depending on how long 
it takes to fill in the information in the dialog boxes that appear at 
the start of the experiment (Subject ID, Session Number etc.)
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the e-prime events in the coding scheme

Subjects

Behaviors

The name of a behavior depends on the name of the corresponding E-
object set in E-Prime (see Prepare the experiment in E-Studio on page 
13).

System events and user responses are stored in separate Start-Stop 
behavior groups, System Behaviors and User Behaviors.

 System Behaviors contains events named Show followed by the E-
object name.

The Show Stimulus behavior has a modifier group attached, named 
Media. This group contains the names specified in the Trial List 
under Stimulus. 

 User Behaviors contains a behavior named Answer.
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The Answer behavior has two modifiers attached, Response and 
Correct (see below).

Nominal modifiers

In this example, the following modifier groups have been imported, 
with their elements:

 Response (nominal). Contains Response: followed by the 
character(s) entered by the test participant.

 Media (nominal). Contains the filenames of the stimuli, or other 
attributes you may want to import (see page 16 for how to 
customize this). 

 Correct (nominal). Contains Correct: followed by the correct 
response for the corresponding stimulus (that is set in the E-
Prime’s Trial List).

Numerical modifiers

If you specified in E-Prime that the answer was numerical, they are 
added as a numerical modifier group to the Coding Scheme. See 
Example 3: To import responses as numerical modifiers on page 20.
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Note

You can modify the names of coding scheme elements at any time, 
however we advise you not to do so. If you import new data, these will 
have the names set in E-Prime, and added to the coding scheme. The 
same event type could therefore be represented by two or more 
different subjects, behaviors and modifiers, leading to wrong analysis 
results.

analysis
The analyses in The Observer XT allow you to calculate most statistics 
on the stimuli and the user responses. 

Nominal (default) responses

Nominal responses are analyzed with a Behavior Analysis. Choose 
Analyze > Behavior Analysis > New and click Calculate.

Example 1: Correct vs. incorrect responses

In the default Behavior Analysis result, each cell contains the statistics 
of a specific combination of behavior and modifiers. For example, the 
table below lists the statistic Total Number for the events of type 
Answer and a specific combination of the modifiers Correct and 
Response. 
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In this example, the test participant gave three times a correct 
response: one time when Correct= 1 and Response= 1, and two times 
when Correct =2 and Response =2 (first two lines). In one case the test 
participant gave an incorrect response, when choosing 2 when the 
Correct response was 1 (third line). Therefore, the percentage of correct 
responses is 3/(3+1)= 75%.

In the table above, the response “SPACE” was given by the user to start 
the procedure and should be ignored. “Any Modifier” is the number of 
events with any combination of modifiers.

Example 2: Response time (RT)

We have two main cases:

 If the stimulus ends exactly when the user gives a response, the 
response time is equal to the stimulus presentation time. For 
example:

 

In this case the response time is the duration of the state event 
Show stimulus.

 If the stimulus duration is independent of the user’s response, like 
in this example:
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Then do the following:

a In the Data profile, choose Select Intervals - By manual selection 
and define an interval from the start of the event Show Stimulus 
to the start of the event User Answer. 

      

b Choose Analyze > Behavior Analysis > New. 
c Click the Statistics button and under Intervals select Analyzed 

interval duration. 
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d In the results table, look for the column named Analyzed interval 
duration.

Example 3: Response time grouped per response

In this example we want to calculate Response time (RT), but for when 
the subjects gave a particular response. 

Here for simplicity we only show the solution for how to calculate RT 
when the subject responses were correct. 

For example: 

 Correct response was “1” - User Response was “1”  RT was ...

 Correct response was “2” - User Response was “2”  RT was ...

Etc.

1. We first define an interval that captures the response time, just like 
in Example 2 (see the figure on page 44). Choose Intervals - By 
manual selection and select From System Show Stimulus to User 
Answer. This is the least selective interval, because it captures all 
instances of response times, even those for incorrect responses. The 
following steps we add more interval criteria, to select only the 
instances of response time when Correct =1 and Response =1, OR 
Correct =2 and Response =2.
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2. We then create two branches that point to two result containers (to 
create a new result container, click Result Containers - Result). One 
branch will select Correct = 1, Response = 1, the other Correct = 2, 
Response = 2. We name the result boxes R1 C1 and R2 C2, respectively.

3. In each branch, we define intervals (Select intervals - By manual 
selection) that include a correct answer. Intervals are defined From 
2.00 s before start of User Answer - to 0.00 seconds after end of 
User Answer (see below why 2 seconds is chosen as a start criterion). 
However, intervals can only be defined with one modifier (either 
Correct or Response). Therefore, we define two intervals in each 
46 6 - Analyze data



branch. For the branch ending with R 1, C 1 (Correct response 1 when 
Response was 1), the first interval is based on Correct = 1, the second 
is based on Response = 1. By placing the two Interval boxes one after 
the other, we define an interval that meets both criteria, that is, an 
interval for when the Response 1 was Correct. We create a similar 
selection in the other branch, for Correct =2, and Response =2. 

note  We choose “2 seconds before User Answer” to make sure that 
the time around the answer is included in the selection. Choosing 0 
seconds for a point event like User Answer would make the 
selection invalid. 

The intervals defined in this step reduce the total number of 
instances of response time, because they are set after the first, less 
selective Interval box made in step 1. Only the time segments 
corresponding to the most selective criterion will be in the Result 
Container.

4. Finally, we use a Filter to choose which data to analyze. This removes 
all events in the selected intervals that are not of interest. This box 
should be placed at the end of the branch.
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5. The Data profile looks like this:

For details about selecting events and intervals for analysis, see 
Select Data for Analysis in The Observer XT Help. 

6. Select Analyze > Visualize Data. The two charts at the top show the 
intervals (response times) selected for R 1, C 1. The other charts show 
the same for R 2, C 2. You can see that the first instance of response 
time is not selected because of the incorrect response given 
(Response = 1, Correct = 2).
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7. Run Behavior Analysis and look at the statistics that refer to a 
specific response (this is indicated with the Result Container column 
header).

8. To group results, select Layout > de-select Intervals. Look at the 
Mean duration statistic for the mean response time.

 Note:

 This data profile is also valid when the response does not terminate 
the stimulus presentation.

 You can create more complex data profiles by adding branches that 
select instances of incorrect responses (for example: Response was 
“1”, Correct was “2”).

Numerical responses

If you specified in E-Prime that the answer was numerical, for example 
to rate the stimulus, you may want to calculate numerical statistics, 
like the mean value or median. See Example 3: To import responses as 
numerical modifiers on page 20 how to specify the response as 
numerical. In The Observer XT, carry out a numerical analysis. Choose 
Analyze > Numerical Analysis > New and click the Calculate button.
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By default the minimum value, maximum value and mean value of the 
numerical modifiers are calculated. To select other statistics, click the 
Statistics button on the toolbar and select the statistic under 
Numerical Modifiers.

For more information

See Calculate Statistics in The Observer XT Help.

lag sequential analysis
With Lag Sequential Analysis you can quickly calculate how often a 
stimulus triggers a specific response.

Choose Analyze > Lag Sequential Analysis > New.

Example: how often a stimulus produces a correct response

In this example, a stimulus picture is presented for a few seconds, and 
the test participant must enter a response. The response ends the 
presentation of the stimulus. For this reason a State lag sequential 
analysis can be carried out (a Time lag analysis is also possible).

The stimulus presentation is as the behavior Show Stimulus and its 
modifier Media. The test participant’s response and the correct 
response are stored as modifiers Response and Correct of the behavior 
Answer, respectively.

Click Settings and under Lag Type choose State lag. Because the 
stimulus and the response events are events scored for different 
subjects (System and User), de-select Restrict lag to Subject-Behavior 
group combination. Then run analysis.

In the Lag Sequential Analysis result, locate the part of the table that 
contains the transitions from the behavior Show stimulus (on the rows) 
to the behavior Answer (on the columns).
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In this example, the stimulus BlueCar.bmp was followed two times by 
a correct response (Response= 2 and Correct= 2; see the middle cell in 
the first row). The stimulus RedCar.bmp was followed by one correct 
(Response= 1 and Correct= 1; first cell in the second row) and one 
incorrect response (Response= 2 when Correct= 1; third cell in the 
second row).

For more information

See Lag Sequential Analysis in The Observer XT Help. 
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7 Advanced settings

Aim

To change basic settings like the port number for communication 
between The Observer XT PC and the E-Prime PC, and the location of 
the E-Prime software and experiments.

If some events are not imported correctly to The Observer XT, see 
Prepare the experiment in E-Studio on page 13.

Procedure
1. On the E-Prime computer, start Noldus E-Prime Server (Apps > 

Noldus > Noldus E-Prime Server).

2. Click Advanced Settings.

IP Address

This is the IP address of the E-Prime computer. It is shown for 
information purposes only, and cannot be changed. This number must 
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be entered in the Noldus E-Prime Client software (see the observer xt 
pc on page 9).

Port

The port number should always be the same as that set in The Observer 
XT (see the observer xt pc on page 9). The default is 155.

E-Run location

This is the location on the E-Prime PC where the E-Run.exe software is 
installed. If it has been installed on another location, please specify 
that location here. 

The default is C:\Program Files (x86)\PST\E-Prime 3.0\Program.

For E-Prime 2.0, the default location is C:\Program Files (x86)\PST\E-
Prime 2.0\Program.

Experiment text output

This is the folder where the E-Prime output text file is stored. By 
default, this is the same folder as where the experiment file (*.ebs3/
*.ebs2) you are using is stored (see the e-prime pc on page 11). 

 If you change the Port number after clicking Start, this has no effect 
on the software. Click Restart to activate communication on the 
new port. 

 If you set the Experiment text output location in E-Prime different 
from that of the experiment file (*.ebs3/*.ebs2), you must specify 
this new location also in Noldus E-Prime Server.

 When clicked, the Start button of Noldus E-Prime Server does not 
start the E-Prime experiment; it activates the E-Prime Controller to 
accept messages from The Observer XT. 
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8 Troubleshooting

e-prime error messages

Runtime error “Unable to obtain a valid refresh rate”

This occurs on Windows 10 computers with Windows version 1703 or 
later (Windows Creators).

Please see the workaround on the following web page:

https://support.pstnet.com/hc/en-us/articles/115011182147
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