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1 Introduction

The BitBrain Diadem is a 12-channel wearable and portable, dry EEG 
device designed for real-world applications that require easy set-up 
and high signal quality. The Diadem system is designed to address the 
pre-frontal, frontal, parietal and occipital brain areas to measure 
emotional and cognitive states such as cognitive workload.

The Diadem has been designed for adults. It can be used for children 
from the age of 10.

The sample frequency is 256 Hz and battery life is more than 8 hours.

Sensor layout

The headband includes 12 EEG sensors, plus ground (GND) and 
reference (REF). The sensors are placed at positions AF7, Fp1, Fp2, AF8, 
F3, F4, P3, P4, PO7, O1, O2 and PO8, according to the EEG 10/10 
international standard. REF is located on the ear clip.

The correspondence between channel numbers and sensors is as 
follows:

Channel 1: AF7

Channel 2: Fp1
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Channel 3: Fp2

Channel 4: AF8

Channel 5: F3

Channel 6: F4

Channel 7: P3

Channel 8: P4

Channel 9: PO7

Channel 10: O1

Channel 11: O2

Channel 12: PO8
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this technical note

This document describes how to achieve automatic synchronization 
between observational data in The Observer XT and EEG data acquired 
with and exported from a Bitbrain system. You can:

- Start and stop data acquisition in the Bitbrain Acquisition 
software from The Observer XT.

- Manually import Bitbrain EEG data into The Observer XT after 
the observation is ready.

system tested

Processing unit 

Dell Precision T3660

 Processor: Intel Core i7 12700K (12 Core), 3.6 GHz or better

 Internal memory: 16 GB

 Operating system: Windows 10 and Windows 11 Professional Edition

Software

 The Observer XT 16 or higher

 N-Linx Server 1.4 or higher 

 N-Linx Agent 1.4 or higher

 BitBrainControl 1.0 software to control the EEG device

 Bitbrain Acquisition 0.3 software — The acquisition software for 
the Bitbrain device

note 

Tests were carried out with all the software on one PC. You can also use 
two PCs and set up a local network. In that case The Observer XT and N-
Linx Server are installed on PC 1 and the BitBrain Acquisition software, 
the Bitbrain Control software and N-Linx Agent are installed on PC 2.
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for further information and help

Other manuals

 User Guide - Diadem - Bitbrain

 The Observer XT Help

 The Observer XT Quick Start Guide

 N-Linx - Reference Manual

Customer Support

For technical support, please visit the MyNoldus portal 
(my.noldus.com). Log into your account or create a new one and submit 
a support case. 
Introduction
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2 Software setup

If you purchased your PC from Noldus Information Technology, all the 
software is already installed and tested. If you purchased your own PC, 
please follow the instructions below.

install the observer xt

1. Download the Observer XT installation file (The Observer XT 
Setup.exe) via your MyNoldus account (my.noldus.com, under 
Downloads > The Observer XT > Versions).

2. Double-click the installation file to run it and follow the instructions 
on the screen.

3. Activate or insert your license key:
- If you have a software license —Activate your license.

- If you have a hardware key - Insert the key into your computer.

install n-linx server

important  If your set-up includes more than one PC — Install N-Linx 
Server on the Observer XT computer.

1. Download the N-Linx Server installation file (N-Linx Server 
Setup.exe) via your MyNoldus account (my.noldus.com, under 
Downloads > The Observer XT > Drivers & Tools).

2. Double-click the installation file to run it.

3. Next to Installation type choose Standard, unless you want to 
specify an installation folder other than the default one (C:\Program 
Files\Noldus\N-Linx Server 1).

4. Follow the instructions on your screen.
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install and connect n-linx agent

Install N-Linx Agent

important  If you use a 2-PC set-up — Install N-Linx Agent on the 
Bitbrain computer.

1. Download the N-Linx Agent installation file (N-Linx Agent 
Setup.exe) via your MyNoldus account (my.noldus.com, under 
Downloads > The Observer XT > Drivers & Tools).

2. Double-click the installation file to run it.

3. Next to Installation type choose Standard, unless you want to 
specify an installation folder other than the default one (C:\Program 
Files\Noldus\N-Linx Agent 1).

4. Agree with the license agreement, click Install and follow the 
instructions on your screen.

5. If the N-Linx Agent window does not open after installation, at the 
bottom-left corner of the screen, on the system tray, click the Show 
hidden icons icon and double-click the N-Linx Agent icon.

6. Next to N-Linx Server Address, enter the IP address of the computer 
where N-Linx Server is installed. This IP address must be fixed. If N-
Linx Server and N-Linx Agent are installed on the same PC enter 
localhost as the N-Linx Server Address.

tip  You can also enter the Computer name instead of the IP 
address. To find the Computer name of the computer where N-Linx 
Server is installed, on that computer open the Control Panel and 
choose System. Locate Device name.

7. Click Connect. If connection is established, the message at the 
bottom of the N-Linx window says Connected.
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install bitbrain control software

1. Download the BitBrainControl installation file 
(BitBrainControl.Installer.exe) via your MyNoldus account 
(my.noldus.com, under Downloads > Versions).

2. Double-click the installation file to run it and follow the instructions 
on your screen.

3. Browse to C:\ProgramData\Noldus\BitBrain Control\1, copy the file 
with the name Noldus.Proxy.BitBrain.config and rename it to 
Noldus.Proxy.BitBrain.config_old to make sure that you have an 
original version of the file.

The ProgramData folder is a hidden folder. To view this folder, 
browse to C:\ and on the View tab select Hidden items.

4. Open Notepad or another text editor and open the file with the 
name Noldus.Proxy.BitBrain.config.

5. Edit the file as follows:
- <RabbitMQAddress>IP address of the PC on which N-Linx Server is 

installed<RabbitMQAddress>
- <BitBrainAddress>IP address of the PC on which Bitbrain 

software/N-Linx Agent is running<BitBrain Address>
- <BitBrainDeviceId>shown on the amplifier device<BitBrain 

DeviceId>
- <BitBrainOutputFolder>folder in which the data will be 

saved<BitBrainOutputFolder>

Notes: 
- Always use a forward slash (/) in the pathname, not a backward 

slash (\).
- The RabbitMQAddress is localhost if N-Linx Server is installed on 

the same PC as the BitBrainControl software.
- The BitBrainAddress is 127.0.0.1 if have a 1-PC set-up.

6. Save the config file with the same name.

7. Create the folder that you defined as the output folder in step 5.

To find an IP address:
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1. Click the Windows button, type cmd and press Enter. A Command 
Prompt window will open.

2. Type ipconfig and press Enter.

3. The IP address you need is the IPv4 address.

install bitbrain acquisition software and 
prepare data acquisition

1. Download the Bitbrain acquisition software (bitbrain-acquisition-
0.3.zip) via your MyNoldus account (my.noldus.com).

2. Turn on the Bitbrain amplifier by pressing the power button. The LED 
on the amplifier will flash until a connection with the software is 
established, at which point the light will be steady.

3. Connect the Bitbrain Diadem via bluetooth: 

- Click the Windows button, type Settings and press Enter.

- Click Devices and then click the plus (Add Bluetooth or other 
device) icon at the top of the screen. Click Bluetooth and wait till 
the Bitbrain device with the ID that you entered in step 5 in the 
procedure above appears.

4. Click the device name. The device will then start making connection 
with the PC. When the connection is established you will see a 
message that your device is ready to go. Click Done. The device ID 
will appear in the list with Other devices and will have the status 
Paired.

prepare the observer xt

Connect The Observer XT to N-Linx Server

Follow this procedure just once. The settings are also valid for any new 
The Observer XT project that you create.

1. In The Observer XT, choose File > Preferences.
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2. Click N-Linx settings on the left.

3. Select Use N-Linx Server to connect with other applications.

4. Next to N-Linx Server address, leave the default entry localhost.

5. Make sure the N-Linx Server port is 5672. 

Ask your system administrator for assistance if this port is used by 
another program.

6. Click Test connection, and check that the message Connected 
appears.

If connection fails, it means that N-Linx Server is not installed properly. 
Reinstall N-Linx Server (page 7).

Project Setup

Follow these steps for each new Observer XT project you create to work 
together with the Bitbrain system.

1. Open the project and choose Setup > Project Setup.

2. Under Observation Source, select Live Observation.

3. In the Devices window, select BitBrain Control.

If you do not see this item, it is likely that N-Linx Agent is not 
installed.

4. Double-click the Status cell next to BitBrain Control and check that 
the status is Enabled, Running.
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3 Carry out data acquisition

To carry out data acquisition:

1. Place the headset on the test participant’s head following the 
instructions in the User Guide - Diadem - Bitbrain 2021.pdf.

2. Browse to the folder in which you installed the BitBrain Acquisition 
software and open the bin subfolder, for instance  
D:\BitBrain\bitbrain-acquisition-0.3\bitbrain-acquisition-0.3\bin.

3. Double-click the file with the name Bitbrain Acquisition.exe. A 
Console window will open.

4. In The Observer XT, create a new observation (Alt+F6).

5. To start data acquisition, click the Start Observation button.

The Bitbrain window shows the channels in green (good 
connection), yellow (unstable connection) or red (bad or no 
connection).

6. If necessary, adjust the diadem, wait a few seconds (> 10) and then 
check whether the status of the channels has changed to green.

7. To stop data acquisition, click the Stop Observation button. 

The data are saved in the output folder that you defined in step 5 on 
page 9. Both raw data (*_eeg.csv) and derived data (alpha, beta, 
delta and theta rhythms) are saved. The latter are saved in the 
eeg_power subfolder.

8. Browse to the output folder and copy the data files from the BitBrain 
PC to The Observer PC in a 2-PC set-up.
Carry out data acquisition



4 Import the Bitbrain data into The 
Observer XT

The Observer XT 17 has a built-in import profile for Bitbrain data. In the 
Observer XT 16 this is not present yet. If you work with The Observer XT 
16, follow steps 1-3 in the procedure below. If you use The Observer XT 
17 you can skip these steps.

1. Make sure that The Observer XT is not running.

2. Download the zip file with the Bitbrain import profile (Profiles.zip) 
via your MyNoldus account (my.noldus.com) and copy it to The 
Observer PC.

3. Unzip the zip file and copy the import profile (BitBrain EEG.eip) and 
the folder with the data file (BitBrain EEG) to C:\ProgramData\ 
Noldus\Common\Profiles.

The ProgramData folder is a hidden folder. To view this folder, 
browse to C:\ and on the View tab select Hidden items.

4. Start The Observer XT and from the File menu select Import and 
then External Data. The Import External Data window opens.

5. Select the Bitbrain EEG (*.csv) import profile from the Files of type 
drop-down list.

6. Select the observation that corresponds with the data file.

7. Browse to the output folder and select the appropriate data file, 
either a data file with the raw EEG data or a data file with pre-
processed data (alpha, beta, theta and delta activity). You can use 
the import profile for both types of data files. Click Open. The EEG 
data for each channel are now imported. The data stream names 
will appear in the Project Explorer and in the Independent Variable 
list.
Import the Bitbrain data into The Observer XT 13
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Optionally, in The Observer XT you can select data, visualize them, carry 
out further data analysis and export the synchronized observational 
and EEG data. For details, see The Observer XT Help. You can also 
further process your data in EEGLab, Matlab or Python.

how to interpret the data

By measuring when and in what brain regions activity occurs you can 
get important insights in brain functions. It is key to take the context 
into account when trying to interpret EEG data. The Bitbrain system 
allows you to measure alpha, beta, theta and delta activity.

 Alpha —In healthy awake adults alpha waves occur while resting 
with the eyes closed. They disappear when people concentrate on a 
specific task. Relative asymmetry in alpha activity in the frontal 
cortex indicates positive affect and approach motivation (Paul et 
al., 2022).

 Beta —Beta waves are involved in conscious thought and logical 
thinking.

 Theta — Theta waves are relevant for cognition studies including 
learning, memory and spatial navigation. Recent research has 
Import the Bitbrain data into The Observer XT



shown that theta activity in the frontal cortex is an index for 
cognitive workload (Chikhi et al., 2022).

 Delta — Delta waves are the slowest brain waves in human 
subjects. They are related to sleep depth.
Import the Bitbrain data into The Observer XT 15
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