
Technical Note

MindWare and The 
Observer XT





Information in this document is subject to change without notice and 
does not represent a commitment on the part of Noldus Information 
Technology bv. The software described in this document is furnished 
under a license agreement. The software may be used or copied only in 
accordance with the terms of the agreement.

Copyright © 2019 Noldus Information Technology bv. All rights 
reserved. No part of this publication may be reproduced, transmitted, 
transcribed, stored in a retrieval system, or translated into any other 
language in whole or in part, in any form or by any means, without the 
written permission of Noldus Information Technology bv.

The Observer is a registered trademark of Noldus Information 
Technology bv.

Documentation: Patrick Zimmerman, Olga Krips.

November 2019

Noldus Information Technology bv.

International headquarters

Wageningen, The Netherlands

Telephone: +31-317-473300

Fax: +31-317-424496

E-mail: info@noldus.nl

For addresses of our other offices and support, please see our web site 
www.noldus.com.
3

www.noldus.com
info@noldus.nl


1 Introduction

this technical note

This document describes how to achieve automatic synchronization 
between observational data in The Observer XT and the physiological 
data acquired with and exported from the MindWare system using the 
BioLab 3.1 software and the analysis modules.

systems used

The Observer XT 

Processing unit: Dell Precision T5810.

Processor: Intel Xeon E5-1620 v3, at 3.50 GHz.

RAM Memory: 8 GB.

Operating system: Windows 10 64 bit.

Software: The Observer XT 14.1.

MindWare BioNex system

Processing unit: Dell Precision T5810.

Processor: Intel Xeon E5-1620 v3, at 3.50 GHz.

RAM Memory: 8 GB.

Operating system: Windows 10 64 bit.

Software: BioLab 3.3, EDA Analysis 3.1.5, HRV Analysis 3.1.5.

for further information

 The Observer XT Help (press F1 in The Observer XT).

 Quick Start Guide - The Observer XT.
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On your The Observer XT installation CD

 All documents and technical notes.

On the Noldus web site www.noldus.com

 The Noldus Customer Support Database: www.noldus.com/
support-center.

The MindWare documentation

 The user manuals of MindWare products for more information 
about how to acquire data.

 The MindWare web site http://www.mindwaretech.com.
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2 Automatic synchronization

overview

Automatic synchronization of observational and physiological data 
involves a few basic steps:

1. Connect the Observer XT computer and the MindWare system 
using the special synchronization cable provided by MindWare. This 
must be done if you want to have the data of the two systems 
automatically synchronized.

See cable connections on page 7.

2. Set The Observer XT for DAQ co-acquisition; here you specify which 
synchronization signal you want to use (On-Off or Time Code (TCAP)) 
and the sample rate used on the MindWare system. 

See set the observer xt for daq co-acquisition on page 8.

3. Set up the MindWare system. Set the sample rate and set up 
channels.

See set up the mindware system on page 9.

4. Carry out a live observation while The Observer XT sends out the 
synchronization signal to the MindWare system. Simultaneously, 
the MindWare BioLab software acquires data (e.g., ECG, GSR).

See carry out data acquisition on page 11.

5. Export the MindWare data file (native format: *.mw) to a text file. 
Choose the procedure depending on the type of data.

See Export data from MindWare on page 12.

6. Import the MindWare text file (containing both the physiological 
data and the time information from the synchronization signal) into 
The Observer XT. At this point, the observational and physiological 
data are automatically synchronized.

See Import files into The Observer XT on page 19.
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Note

Optionally, you can next make a data selection, visualize your data, 
carry out quantitative analysis and export the synchronized 
observational and physiological data. For details, see The Observer XT 
Help.

cable connections

Before you make settings in The Observer XT with regard to DAQ co-
acquisition, connect the Observer XT computer to the MindWare 
acquisition system using the synchronization cable.

1. Plug connector 1 (see the figure below) into the 9-pin COM port of 
The Observer XT PC. If your computer does not have a physical COM 
port, use a a USB-to-COM converter. 

2. On the BioNex chassis, connect the synchronization cable to 
Transducer Channel 1 on the front using connector 3 and ‘Trigger In’ 
on the back of the chassis using connector 2 in the figure below.
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3 Software setup

set the observer xt for daq co-acquisition

Procedure

1. Choose Setup > Project Setup.

2. In the Project Setup screen, select Live Observation.

3. In the Devices window, select DAQ Settings and click the Edit 
settings button at the bottom-right.

4. In the DAQ Hardware Settings window:

- Select the COM1 port as the Output Device.
- If you use a USB-to-COM converter (for example, when there is 

no COM port available on the The Observer XT computer), you 
might need to select a different COM port. Please check the 
documentation of the USB-to-COM device to see which COM port 
the device uses.

- Select Time Code (TCAP) under Signal Type. 
- Set the same DAQ sample rate as the Sample Rate in the 

MindWare BioLab program (see Figure ).

5. Click OK twice.
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set up the mindware system

Aim

To set data acquisition to start automatically when you start an 
observation in The Observer XT.

Procedure

1. Connect your subject to the corresponding channels on the BioNex 
chassis depending on the type of signal you want to acquire. See 
the MindWare documentation for details.

2. Start the BioLab program on the MindWare computer.

In the example below, a Sample Rate of 200 is used, Triggering is 
set to Rising and two channels are defined: channel 4 for skin 
conductance and channel 5 for the synchronization signal.

3. Turn on the Channels you want to acquire. Under Filter Type select 
the filter that will be used on the channel while acquiring data. Here 
are some examples:

ECG. This is Channel 1 of the 3-Channel Bio-Amp and GSC module. 
Use a Gain of 500 or 1000.
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EDA. This is Channel 4 of the 3-Channel Bio-Amp and GSC module. 
Use a Gain of 50 or lower.

Synchronization signal. This is Channel 5 which corresponds to 
Channel 1 on the 4-Channel pass-thru module. You do not need to 
set a filter for this channel.

Respiration. This is one of the Channels of the 4-Channel 
transducer module. Use a Gain of 100.

Skin temperature. This is one of the Channels of the 4-Channel 
transducer module. Set the Filter Type to Low Pass and the Low 
Cutoff to 1. Use a Gain of 50.

4. Under Channel Name, type in the name for each channel.

5. Set the Sample Rate at the top left, for the physiological signals you 
want to acquire.

6. Set the Trigger Modes to Rising so the MindWare system is started 
automatically with the first pulse of the synchronization signal at 
the start of an observation in The Observer XT.

important  Make sure the synchronization cable which connects 
The Observer XT computer and the MindWare system is connected 
both to the Trigger In and the Transducer Channel 1 on the BioNex 
chassis.

Note

It is not possible to automatically stop the MindWare program with 
The Observer XT. You must manually stop acquisition of physiological 
data by clicking the Start/Stop (Enter) button in the BioLab Acquisition 
window.
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4 Data acquisition

carry out data acquisition

In BioLab

1. Click the green Acquire button at the bottom of the window.

2. Type in a file name, select a folder and click OK.

In The Observer XT

3. Create a new observation (Alt+F6) and then click the Start 
Observation button.

4. The BioLab program is triggered and acquisition starts 
automatically.

5. Score events in The Observer XT if required.

6. Stop the observation.

In BioLab

7. Stop acquisition.

For more information

See Carry out an Observation and External Data in The Observer XT 
Help.
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5 Export data from MindWare

export options

There are three options for exporting MindWare data from the BioLab 
software:

 You can convert the raw physiological signal to text format and 
import this raw data into The Observer XT. For this, you use BioLab 
3.3. 

See export the mindware raw data below.

 You can carry out pre-analysis of physiological data in one of the 
MindWare analysis modules, convert the analysis result to text and 
import these results into The Observer XT. Below is described how 
to process EDA and heart rate data.

See export the mindware eda data on page 13 and export the 
mindware heart rate data on page 16.

 If you do not use a synchronization signal, you can also export the 
BioLab data as EDF file. You can synchronize the Observer and 
MindWare data after import in The Observer XT, using the manual 
procedure. 

For details, see External Data in The Observer XT Help.

Note

Importing the BioLab data with a synchronization signal as EDF data 
into The Observer XT was not tested. Therefore, we cannot guarantee 
that automatic synchronization works correctly.

export the mindware raw data

Aim

To export raw data to a file that can be imported as external data in The 
Observer XT. Each data line in the file is a sample.
12 Export data from MindWare



Procedure

1. In BioLab, choose File > Open File. Select the MindWare data file 
(*.mw) and click OK.

2. Select the channels you want to export.

important  Make sure to include the channel with the 
synchronization signal!

3. Click the View button at the bottom of the window.

4. Click the Save All Text button. Select where to save the file, type in a 
file name and click OK.

5. Proceed with importing the MindWare export file into The Observer 
XT (see page 19).

export the mindware eda data

Aim

With the MindWare EDA Analysis application, you can calculate the 
number of significant peaks in the ElectroDermal Activity (or skin 
conductance) signal. These peaks can be exported as events and 
imported as observational data in The Observer XT.

Procedure

1. Start EDA Analysis. You need the MindWare dongle to do this. Select 
a MindWare file with EDA data (*.mw) and click OK.

2. In the window that appears, from the list next to the EDA/GSR 
Channel, select EDA, then click OK.
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3. In the EDA Setup window, in the Events and Modes tab, drag the 
Segment Time slider all the way to the right to analyze the complete 
file.

4. In the EDA Calibration Settings tab, set the value for uS Thresh to 
0.01.

5. Click the Additional Settings tab. Under Output Settings, select 
where to save the export file. 

By default, the file is written to a subfolder of the current folder: 
...\output data\[current date]. De-select Use Default Output Path 
Yes/No to specify another location. 

6. Make sure to turn on the Auto Analyze All Data Segments button.

7. Click the Analyze button or press Enter.

The EDA Analysis window displays the following Skin Conductance 
Response (SCR) Stats:
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SCR Type. This specifies whether a SCR is non-specific (NS) or event-
related (ER, in case you have scored events in the BioLab program 
during acquisition).

Event Time. If a SCR is event-related, this field shows the time of 
the related event.

Event Type. If the SCR is event-related, this field specifies the type 
of the related event.

Trough Time. This specifies the time of the trough associated with 
each SCR.

Peak Time. This specifies the time of the peak associated with each 
SCR.

HR Time. This specifies the half-recovery time associated with each 
SCR.

Trough SCL. This specifies the amplitude of the trough associated 
with each SCR.

Peak SCL. This specifies the amplitude of the peak associated with 
each SCR.

SCR. This specifies the total SCR associated with each SCR as 
derived from: (Peak SCL) – (Trough SCL).

8. Click the Write button in the Controls window. 

Next, click Create New.

9. Click Done to save the file.
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10.The Excel file opens on the background. Click the SCR Stats tab.

11. Choose File > Save As. Save this sheet to Text (tab-delimited).Close 
the Excel file.

12. Copy the text file to the The Observer XT computer. 

13. Proceed with importing this file into The Observer XT (see page 20).

export the mindware heart rate data

Aim

With the MindWare HRV Analysis application, you can use the 
ElectroCardioGraph (ECG or EKG) signal to calculate the Heart Rate (in 
beats per minute) and also the Heart Rate Variability. This data can be 
imported as external data in The Observer XT.

Procedure

1. Open HRV Analysis. You need a MindWare dongle to do this. Select 
a MindWare file (*.mw) with ECG data and click OK.

2. In the Map MindWare Channels to Channel Type window, from the 
list next to the ECG Channel, select ECG and click OK.
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3. Click the Events and Modes tab. Drag the Segment Time all the way 
to the right to analyze the complete file.

4. Click the HRV Calibration Settings tab. Set the Calculation Method 
to Interval, and the Interval Period to 1.00 second. This calculates 
the Heart Rate in 1-sec intervals from the ECG signal.

5. Click the Additional Settings tab. Under Output Settings, select 
where to save the export file. 

By default, the file is written to a subfolder of the current folder: 
...\output data\[current date]. De-select Use Default Output Path 
Yes/No to specify another location. 

6. Make sure to turn on the Auto Analyze All Data Segments button.

7. Click the Analyze (ENTER) button.

8. Click No when asked whether the ECG is inverted.

9. In the window that opens, select Create New.
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10. In the HRV analysis window, the HRV Stats table, shows the Mean 
HR (Heart Rate) and Mean IBI (Inter-Beat Interval) for each 1-sec 
interval you set in step 4.

11. The Excel sheet opens on the background.

12. Click the Write button in the Control window, then click Done to 
save the file.

13. In the Excel file, click the Interval Stats tab. This is the last tab in the 
workbook.

14. Choose File > Save As. Save this sheet to Text (tab-delimited). Close 
the Excel file.

15. Copy the export file to the The Observer XT computer. 

16. Proceed with importing the text file as external data into the 
corresponding observation in The Observer XT (see page 22).
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6 Import files into The Observer XT

import the biolab text file into the observer 
xt

In this section you find the instructions:

 To import the raw MindWare data as external data (see below).

For the export procedure, see export the mindware raw data on 
page 12.

 To import the pre-analyzed data:
- GSR peaks (see page 20)
- Heart rate data (see page 22).

For the export procedure, see export the mindware eda data on 
page 13 and export the mindware heart rate data on page 16.

import the raw mindware data

Aim

To import the raw data exported from BioLab (page 13).

Procedure

1. Start The Observer XT and open the project in which you want to 
import the MindWare physiological data. If you created EDF (*.edf) 
files, choose File > Import > European Data Format Files and select 
the file. Skip the rest of this paragraph. If you created text files, 
follow the procedure below.

2. Choose File > Import > External Data.

3. In the Import External Data window, select the MindWare BioLab 3.3 
(*.txt) pre-defined import profile from the Files of type list. 

4. Select the MindWare export text file and click the Manual import 
button.
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The window that opens shows all Channels / Data Sets that have 
been acquired, including the synchronization signal. The example 
below shows two Data Sets, skin conductance (GSR) and the 
synchronization signal (Sync).

5. Select all the data set names you want to import (press Ctrl to select 
multiple rows).

6. Drag the rows to the observation they belong to, in the Independent 
Variables window (this is open in the background).

7. Finish the import by clicking the Import button. 

The Link column in the Import External Data window shows the 
name of the observation linked with that data set.

 

import the mindware pre-analyzed gsr peak 
data

Aim

To import the GSR peak data exported from EDA Analysis Application 
(page 13).
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Procedure

1. In The Observer XT, open the observation in which you want to 
import the MindWare pre-analyzed data.

2. Click the Import Data button, then choose Import observational 
data.

3. From the Files of type list, select the pre-defined import profile 
MindWare GSR peaks (*.txt), select the MindWare export file and 
click Open.

4. When asked, click Yes, import new coding scheme elements.

Notes

 In the MindWare GSR Peaks import profile, the values for Peak SCL 
and SCR are imported as numerical modifiers in two groups, New 
numeric Modifier (1) (for Peak SCL) and New numeric Modifier (2) 
(for SCR). In the coding scheme, you can rename them to, for 
example, Peak SCL and SCR, respectively.

 In the coding scheme, behaviors are added that represent the 
column SCR type in the MindWare EDA Analysis export data file. A 
behavior is scored in the event log, at each sample time, together 
with the modifiers Peak SCL and SCR.

 The time stamps imported are from the column Trough time of the 
MindWare EDA analysis export data file.
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import the mindware pre-analyzed heart 
rate data

Aim

To import the heart rate data exported from HRV Analysis (page 16).

Procedure

1. In The Observer XT, open the observation in which you want to 
import the MindWare pre-analyzed data.

2. Choose File > Import > External Data.

3. From the Files of type list, select the pre-defined import profile 
MindWare Heart Rate (*.txt), select the MindWare export file and 
click Open.

Note

 The import profile MindWare Heart Rate makes it possible to 
import two columns of the HRV export file: Mean HR and Mean IBI.

 To create a new import profile or edit an existing one, in The 
Observer XT Help see External Data > Import external data, special 
cases.
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