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Welcome to UltraVox XT!
Main topics and tasks

 General information on UltraVox XT  8
 What's new in UltraVox XT  10
 The main workflow  13
 Important terms  14

How to use this Help

TIPS

 If you do not see the Table of Contents on the left, enlarge the Help window 
or zoom out the characters (Ctrl+mouse wheel).

 To search for two or more adjacent words, use quotes, for example “call 
statistics”.

 To go back to the search results after visiting one of the result pages, click 
the magnifying glass icon in the Search field.
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General information on UltraVox XT
What is UltraVox XT?
UltraVox XT is software for recording and analyzing sound, in particular ultrasonic 
vocalizations. 

In the UltraVox XT system, ultrasound vocalizations of a rodent or another animal 
are recorded from a full-sound spectrum microphone. UltraVox XT can record and 
analyze sound from up to four microphones.

NOTE  UltraVox XT can in principle work with standard microphones for human-
audible vocalizations. However, these are not thoroughly tested and supported. You 
can also import audio files of WAV formats in the audible range. See System 
requirements

See The main workflow

Working modes: Live and Offline
Live

Connect your microphones to your computer and record sound.

See Connect the microphones and Record sound

Offline

You can analyze pre-recorded audio files.

 Import sound files (WAV).
8



 Import an UltraVox XT recording (UVD). 
This way you can merge recordings of multiple UltraVox XT experiments, for 
example sound files recorded in different computers. 

You can work live and offline in the same experiment. You can also export your 
recordings to WAV files.
9



What's new in UltraVox XT
Below you find the main changes in UltraVox XT 4 relative to UltraVox XT 3.2.

General
 The program code has been entirely rewritten in C++. This has resulted in a 

significant improvement in performance.
 The UltraVox XT software license is no longer stored on a hardware key 

(also known as a dongle). You can activate a license by importing a file that 
you receive from Noldus after you have purchased the license. See License 
activation

Interface and usability
 The interface is instantly-responsive. 
 You can zoom in and out the spectrogram on both axes (time and 

frequency), using the mouse wheel. ‘
 The spectrogram can visualize up to 10 minutes intervals (previously that 

was 15 seconds).
 No need to re open the last experiment used: UltraVox does that for you (if 

you chose to do so).
 Spectrogram settings have been simplified and made more user-friendly. 

They are also available at File > Settings.
 Dynamic visualization settings: UltraVox XT 4 automatically optimizes 

spectrogram visualization settings based on the zoom level, ensuring great 
level of detail displayed efficiently. If you zoom in, the spectrogram 
becomes more detailed.

Recording sound
 The microphones of type Pettersson M500-384 shipped from March 2025 

are automatically recognized as sound devices with a unique ID. If you wish 
to re-program your microphones with and ID, let us know. See Technical 
support

 The maximum recording duration is: 
For Pettersson microphones (sample rate 384 kHz): 1 hour 33 minutes 5 
seconds.

For Dodotronic microphones (sample rate 250 kHz): 2 hours 23 minutes 11 
seconds.
10



For audible sound microphones (sample rate 44.1kHz): 13 hours 31 minutes 
35 seconds.

 The difference in recording duration between microphones is due to the 
maximum number of bytes allowed in sound files (4294967295). This value 
has to be divided by the sample rate of the microphone to obtin the 
maximum recording time.

 When you select to stop recording automatically, the maximum recording 
time is 90 minutes for all microphones.

Import of audio files
 You can now import audio files that come from other experiments, which 

include the calls already detected. This means that you can merge data 
from different experiments (e.g. large number of PhenoTypers or other 
home cage systems).

 The import functions accepts audio files of format UVD and WAV.

Sound analysis
 Call detection is now about 10 times faster.
 With parallel processing, calls across multiple recordings can be detected in 

parallel, drastically improving processing time and efficiency.
 You can follow the spectrogram while listening to the sound. In the Call 

Detection and Call Labeling screen, select Adjust speed to stretch the 
audio and listen to the sound at reduced frequency.

File management
 You can now save the data at crucial moments, for example before 

processing new recordings.
 An UltraVox XT 4 experiment contains the following file types: Experiment 

(.uvx), Recording (.uvd), Calls (.uvc).
The following file types were removed as they contained redundant or 
unnecessary information: .peak, .peakk, .uv1, .uv2. 

 You can export data to CSV, for easy import in R, Python, Matlab, etc.

What has been removed or simplified
 In the Spectrogram settings, Zero pad has been removed. Analysis is done 

the same as with Zero pad = 1 in UV 3.2.
11



 In the Experiment Settings, the ID column for microphones has been 
removed. For Noldus microphones, the ID is shown in the Microphone 
column (e.g. Pettersson-M500-384-1).

 The Spectrogram settings in the preview / acquisition screen have been 
removed.

 In the Preferences dialog, the Acquisition settings tab (File > Preferences > 
Acquisition Settings) has been removed.

 The Report (a PDF document with call data) has been removed.
 The following file types were removed as they contained redundant or 

unnecessary information: .peak, .peakk, .uv1, .uv2. 
12



The main workflow
What do you want to do?

 Create a new experiment
 Select the microphones
 Record sound
 Import sound files
 Define a call
 Search for calls
 Label the detected calls
 Calculate statistics

Learn about
 Important terms
 How to detect more calls
 UltraVox XT microphones
 Other options
13



Important terms
Call
In UltraVox XT, a call is any animal vocalization considered as a discrete unit. A call is 
either selected manually by drawing a rectangle around it or detected automatically 
based on a number of parameters, like the frequency minimum and maximum 
acceptable values.

Experiment
In UltraVox XT, an experiment is a container of one or multiple recordings. An 
experiment also contain microphone settings like the Gain used, and the analysis 
results. You can create as many experiments as you like. Normally an experiment 
contains recordings related to a specific experimental work.

Gain
A measure of the ability to increase the amplitude of the signal coming from the 
microphone. In UltraVox XT, there are two types of gain: that in the software itself 
and the microphone internal gain.

Independent variable
Any variable that is supposed not to vary during a recording, for example mouse 
strain, or day after treatment. You can use one independent variable to label 
recordings.

Recording
Uninterrupted record of audio in form of a digital audio file. In UltraVox XT, you can 
obtain a recording either from a microphone or by importing an audio file.

Sample rate
Also known as sampling frequency. This is the number of samples of a variable (in 
the case of sound, the signal coming from a microphone) collected in one second. 
The full-spectrum microphones provided with UltraVox XT have a sample rate of 
384 kHz.
14



Template
In UltraVox XT, a call template is a call definition stored in such a way it can be 
applied to different experiments.
15



Create a new experiment
To create a new experiment

1. Under New experiment, click New, or choose File > New.
2. In the New experiment window, enter the name for your experiment.
3. Click OK.

The new experiment (a file with extension *.uvx) is saved in a folder with the same 
name as the experiment. This folder is by default located in

C:\Users\Public\Documents\Noldus\UltraVox XT\Experiments

Notes
 If you want to save your future experiments in a different location:

Choose File > Settings > General. Under Experiments location, click the 
folder button and specify the new location. Then click OK. Next, create a 
new experiment. That new experiment will be saved in the new location.

 Select Open last experiment on startup if you want to have the last 
experiment already opened every time that you start the software.
16



Select the microphones
Aim
To choose the microphones for recording data in the current experiment.

TIP  Always plug the same microphone into the same USB port of the USB interface 
card or the USSB hub. See Connect the microphones

Prerequisites
 You have created or opened an experiment. See Create a new experiment

Procedure
1. Connect the microphones you want to use.
2. Choose Setup > Experiment Settings.
3. Click Refresh.
4. In the Microphone column, click <Select>.
5. The Select recording device window lists the microphones currently 

detected. Choose a microphone and click OK.
17



6. To add more microphones, repeat steps 4-5.
7. If you wish to modify the name of the microphones, click one of the cells 

under Microphone Name and enter a new name, e.g. Cage 1.

8. Next: Adjust the microphone gain in UltraVox XT.

Notes
 You cannot add a microphone that is already selected under Microphone.
18



 The Microphone column shows the Windows name of the microphone. For 
Noldus full-sound spectrum microphones, this is the friendly name of the 
USB device detected in the Windows manager. You cannot edit this name.

TIP  The 384-kHz microphones shipped from March 2025 have a unique ID, 
which makes them recognizable within the software even when connecting 
them to different USB ports. However, we recommend to connect each 
microphone to the same USB port on the USB interface card (for desktop 
PCs) or USB hub (for laptop PCs). Label microphones and USB ports, so you 
always know which microphone (and cage) is connected to which port.

 When the microphones are connected but you do not see them listed in the 
Select recording device window, click the Refresh button.

 The Status column indicates:

 Device is connected and ready to use.

 Device not found.

 Under Recordings you find the number of recordings made so far with that 
microphone in that experiment.

 The Sample rate (Hz) column shows the default sample rate: 
For Pettersson microphones: 384000.

For most Dodotronic microphones: 250000.

For non-ultrasonic microphones: 44100.

 The Settings column specifies the microphone Gain. See Adjust the 
microphone gain in UltraVox XT
19



Record sound
Aim
To record ultrasonic vocalizations to a data file which can be analyzed by UltraVox 
XT.

Prerequisites
 Microphones are connected and selected for use in the Experiment 

Settings.

Procedure
1. Choose Acquisition > Open Acquisition. or click Acquisition in the 

Experiment Explorer.

The Acquisition screen opens. 
20



2. Release the animals in their test environments.
3. Click the Start display button to visualize the input signal.

NOTE  The Start display function does not record data.

4. When ready, click the Start recording button.

5. To stop the recording, trigger UltraVox XT with the method specified in the 
trial control settings, or click the Stop recording button.
21



Notes
 You can record ultrasound for up to a specific time determined by the 

sample rate of your microphones. See Recording sound
 To stop recording after a specific time has elapsed, in the Trial Control 

Settings under Stop acquisition choose After ... minutes and select the 
duration required. See Trigger start/stop recording

 To start and stop recording at specific clock times, use UltraVox XT in 
combination with the Windows Task Scheduler. See Start and stop 
recording at specific times

 You can also start and stop recording from external software. See Trigger 
start/stop recording

 In step 3, check the signal amplitude. At this point the gain should have 
been already optimized. If not, see Adjust the microphone gain in UltraVox 
XT. If the signal is too noisy, the gain may be too high. If you do not see the 
animal’s vocalizations in the spectrogram, it may be that the gain is too low, 
or the microphone is too far from the animals, or that the animals do not 
emit vocalizations at all. See Factors affecting ultrasound recording and 
Eliciting vocalizations for test purposes

 Noise in the recording greatly affects the efficiency of call detection. It is 
very important that you minimize noise in your recording. See Experimental 
setup
22



Import sound files
Aim
To import audio files for analysis of vocalizations.

Prerequisites
 You have audio files of the following format: Windows PCM, 16 bits, Mono, 

with extension WAV, or audio files recorded in other UltraVox XT 
experiments, with extension UVD.

Procedure
1. Choose File > Import audio files.
2. In the Import audio files window, browse to the audio file you want to 

import.
To select multiple files, press and hold Ctrl down and select each file that 
you want to import.

3. Click Open. 
4. Click Recording List to view the recording currently present in the 

experiment.

Notes
 Other mono formats may work, but have not been tested.
 Stereo formats are not supported. Convert the audio file to mono, then 

import the resulting file.
23



Define a call
Aim
To create a call definition, which can be used to detect vocalizations automatically, 
based on frequency, amplitude and time parameters.

Prerequisites
 Choose Analysis > Call detection, or in the Experiment explorer choose 

Call Detection. Next, choose a recording from the list.

 Make sure that Spectrogram is selected in the View box.

To define a call
1. Filter the signal. If you want to analyze frequencies above a threshold, 

under View click the Filter button.
In the Filter window, enter this threshold in the Cut off frequency field, 
then click Apply.
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2. Click the step forward button until you find a suitable call spectrogram.
OPTIONAL  Adjust the Time interval to be visualized in the Spectrogram.

3. Drag the mouse around the call spectrogram. Make sure that all the 
frequencies you want to use to define the call are included.

The call is highlighted and labeled with a Call name indicating the 
frequency range.

4. If you drag the mouse around the call, the Edit Call Definition window 
appears. Adjust the parameters if needed, then click OK.

5. Adjust the parameters to improve call detection. See How to detect more 
calls

6. Let UltraVox XT Search for calls.

Notes
 There are other two ways to define a call: Add a call with specific 

parameters and Load a call template.
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 For a better view of the calls, Zoom in/out the spectrogram.
 The Spectrum shows the frequency range selected when you select a region 

of the spectrogram.

 In the Call Definition list, a new row appears with the current frequency, 
amplitude and time parameters of the call definition.

In the Spectrogram, the call is highlighted with a rectangle of the same 
color as that in the Call Definition list.

The width of the rectangle is the Minimum duration in the Call definition.

The height of the rectangle is the frequency range. You can adjust this 
range. See Adjust a call definition

 The call definition is given a default name based on the frequency range 
(for example, 52-65k).

 At the right side of the Detected Calls list, you find an enlarged 
spectrogram of the call.
26
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Search for calls
Aim
To have UltraVox search for signal events that correspond to one or more call 
definitions. The calls found are listed under Detected Calls.

Prerequisites
You have defined at least one call definition. See Define a call.

Procedure
Click Detect calls in this recording to find the calls in the current recording.

Alternatively, click Detect calls across all recordings if you want to apply the call 
definition(s) to all the recordings in the experiment.

 You are asked whether you want to overwrite previously-detected calls. 
Click Yes. If you click No, call detection is interrupted and the previous calls 
are kept.

 You are asked whether you want to save the experiment before starting the 
new call detection. Choose the action you require. 

All previously detected calls are removed and the new calls appear in the list. See 
Detected Calls list

Notes
 The Detect calls function applies to all the call definitions currently present 

for that recording. 
 See also How to detect more calls and Troubleshooting
 The Count column in the Call Definition list shows the number of detected 

calls.
 You can also save a call definition as a template, which you can use to 

detect calls in other recordings or experiments. See Save a call definition as 
a template
28



How to detect more calls
Keep the frequency range as narrow as possible
When you draw a rectangle around a call spectrogram, select the frequency range 
that covers that calls and also other neighboring calls, without selecting much 
empty space in the spectrogram. 

Example: If the frequency range of a call definition is too large, there may be two 
consequences: first, you may include noise in the call definition. Second, the 
“empty” space in the rectangle above the call lowers the Min Amp parameter that 
UltraVox XT calculates for this definition. In both cases applying this definition 
results no calls being detected.

Increase the Min Amplitude parameter
If Min Amplitude is too low, UltraVox XT finds large regions of the spectrogram 
with low amplitude that do not match the rest of the call definition, like the 
Maximum duration. This happens particularly when the signal is noisy. In that case 
you get fewer calls than expected.

However, at some point the Min Amplitude value could be too high. Calls that were 
previously detected are no longer found. Adjust Min Amplitude and click Detect 
calls in this recording until the number of detected calls is maximized.

In the example below, a call definition was made by dragging around the first call in 
the spectrogram. Clicking Detect calls in this recording did not result in detection 
of any vocalization (top).
29



After increasing Min Amplitude from 111 to 200, all subsequent calls were 
detected.

Get a feel of the amplitude in a call
Hover the mouse pointer over the spectrogram of a call that is not detected yet. 
Check the values of amplitude A near the hairlines. 

This way you get an idea of how the amplitude varies across the signal, and what 
the minimum amplitude would be required to detect similar calls.
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Example: Set Min Amplitude quite a bit lower (2 to 5 times) than the values you see 
next to A. Click Detect calls for this recording and check whether that call is 
detected. Repeat this procedure when necessary to detect more calls.

Reduce Min Duration
In general, a short Min Duration, say around 20 ms, works well for rodents.

Increase Max Duration
Keep Max duration high, unless you're specifically looking for calls shorter than a 
certain length.

In the following example, the second signal was not detected. The signal met the 
Amplitude and gap criteria, except for it was longer than the Maximum duration set 
to 200 ms. After increasing the Max duration, the signal was detected as a call.

Reduce noise
Example: In the following recording, continuous noise is present around 50 KHz.
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Make sure to minimize noise in your recordings; see Experimental setup.

Also check the Amplitude-time plot. If it looks like the following:

Before recording new data, adjust the microphone gain to make sure that there is a 
significant gap between the peaks of the signal and the margins of the plot, like 
here:
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Label the detected calls
Aim

 To group the calls detected based on, for example, the shape of the call 
spectrogram. You can label calls with pattern labels.

 To add a call manually when this was not detected automatically.
 To delete a call that you do not want to analyze, or sound that was wrongly 

detected as a call.

Prerequisites
 UltraVox XT has found calls using call definitions. 
 Choose Analysis > Call labeling or in the Experiment Explorer select Call 

Labeling. 

 Choose a recording from the list.

To label a call
1. Do one of the following:

In the Call list, click the row for the call that you want to label.

In the Spectrogram, click within the rectangle around that call.

2. To label the call, in the Pattern labels list, double-click the label you 
require.
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3. Results:
In the call list, the call is labeled and the cursor moves to the next row.

If the option Show pattern label is selected in the Spectrogram settings, 
the call is also labeled in the Spectrogram.

4. Repeat steps above to label the next calls.
5. To save the call labels, click the Save button.

Notes
 IMPORTANT Do not press Delete to delete a label just assigned! This will 

delete the whole call from your call list. 
Instead, Double-click the Pattern Label cell so that its content is 
highlighted in blue, then press Delete.

 To rename the labels available or add a label, see Labeling calls.
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Tips
 You can also label a call in the following way: In the call list, double-click the 

Pattern label cell, then type the first letters of the pattern you want to 
assign (for example: “F” for Flat). When the complete name of the label 
appears, press Enter to confirm.

 OPTIONAL  Under View, next to Spectrogram, click Settings and select the 
option Show pattern label if you want to view the pattern labels next to 
the call spectrogram.

 To navigate through calls, you can also use the arrow keys   or the 
Page Up/ Page Down keys.
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Calculate statistics
Aim

 To calculate statistics for entire recordings. For example, the mean duration 
of calls in each recording, grouped by pattern label.

 To calculate statistics of each call. For example, the duration of each call.

To calculate statistics of entire recordings
1. Choose Analysis > Call Statistics.
2. Click the Recording Statistics tab.
3. Under Call grouping, choose how to group calls. 

Choose All calls to calculate statistics of all calls together.
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4. Under Statistics, choose the statistics to calculate:
Count. The total number of calls for that group.

Mean duration. The mean duration of he calls (in ms).

SDEV duration. The standard deviation of the call duration (in ms).

Min duration. The minimum duration for that group (in ms).

Max duration. The maximum duration for that group (in ms).

Sum duration. The total duration for that group (in ms).

Mean dominant frequency. The average value of the frequency measured at 
the maximum amplitude for the calls in that group.

5. Choose the recordings to include in your table.

To calculate statistics of individual calls
1. Choose Analysis > Call Statistics.
2. Click the Call Statistics tab.
3. The result table is updated on your screen. Each row contains the results 

for one detected call.
4. Choose a recording from the Recording list.

5. In the Call Statistics table, each row contains the results for one detected 
call in the recording selected.

For information on the column headers, see Detected Calls list.

See also

 Export data and results
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Ultrasonic microphones supported with 
UltraVox XT
General information
UltraVox XT has been thoroughly tested with the full-spectrum microphone 
Pettersson M500-384, specifically designed for recording ultrasonic vocalizations.

This microphone has a sample rate 384 kHz and can record ultrasound up to 160 
kHz.

Connect the microphone
To connect multiple microphones to the PC, use a multi-port USB 3.0 interface card. 
See Install the USB 3.0 interface card

Alternatively, use a powered USB 3.0 hub. USB hubs that are not powered do not 
work with those microphones. 

IMPORTANT  When using 384-kHz microphones, we recommend to use a Windows 
11 computer. These microphones are not recognized in Windows 8.
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Notes
 The Dodotronic Ultramic 250 is not officially supported. However, short 

tests carried out with UltraVox XT 4 on Dell 3680 desktop with Windows 11 
version 24H2 did not reveal significant issues.

See also

 Connect multiple microphones with a USB hub
40



Experimental setup
Example
Home cages are placed in sound-attenuating chambers. Microphones are 
suspended over the home cages. Especially when not using such chambers, place 
the computer and monitor far from the animals because they produce ultrasound.

Factors affecting ultrasound recording
Before carrying out the actual data acquisition, make sure to run a test since several 
factors may affect detection of ultrasound and therefore the final result. For 
example:

 Fluorescent tubes.
 Computer hardware components, for example the monitor.
 Litter, such as nesting material.

Remember that all kinds of human activity produce ultrasound, and that smooth 
surfaces reflect ultrasound whereas “hairy” surfaces absorb it. 

Be aware that the amplitude of sound being recorded is likely to vary between 
microphones, and at different frequencies. Keep this in mind especially when using 
two or more microphones at the same time. The recorded amplitude may therefore 
differ between microphones. Also consider that microphones are often direction-
sensitive, meaning that different orientation relative to the animal introduces 
another source of variation in your results.
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Sound-attenuating chamber
To eliminate sound interference, place both the animal and the microphone in a 
sound-attenuating chamber. Contact Noldus for the solutions available.

Cage materials
 Plexiglas walls of home cages reflect ultrasound and result in much 

background noise.
 Whenever possible, use dampening material as inner walls of the cage. This 

reduces reflection of ultrasound against the walls.

Cables and electronic devices
Cables and electric/electronic devices produce ultrasound. Voltage changes may 
occur, resulting in a change in noise levels during recording, which is also difficult to 
deal with. Isolate all cables and devices as much as possible.

Sound in the room
Make sure to do all tests in a quiet room. When noise (also audible sound) is 
detected with very high amplitude, the amplitude scale of the spectrogram is 
adjusted, resulting in ultrasound calls being 'drowned' in the signal, and therefore 
hardly visible in the spectrogram.

See also

 Microphone position
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Connect the microphones
Connect microphones to the PC
When using 384-kHz microphones, we recommend to use a multi-port USB 3.0 
interface card. See Install the USB 3.0 interface card

Connect the microphones using the USB cables that come with the microphones.

 Type A plug goes to the USB 3 (recommended) port of your PC. USB 3.0 
connectors and ports can be recognized by their symbols, and often also by 
their blue color coding.

 Type Mini-B plug goes to the microphone.

IMPORTANT Always connect the same microphone to the same USB port. If you 
purchased a PC together with UltraVox XT, microphones and USB ports are labeled. 
Always make sure that microphones are plugged into the USB ports with the 
matching labels.
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See also Microphone position

Connect multiple microphones with a USB hub
When you work with UltraVox XT installed on a laptop, use a powered USB 3 hub.

NOTE  A powered, or active, USB hub is powered through a wall outlet to bring each 
hub port to the same energy level as an on-system port. Non-powered, or passive, 
USB hubs do not have an external power source and only pull power from the 
computer's USB port.

Maximum number of microphones
The number of microphones that you can use simultaneously depends on your 
UltraVox XT license. This is specified in the UltraVox XT license.

1. Choose Help > About UltraVox XT.
2. Click License Info.
3. Next to Number of microphones you see how many microphones you can 

use simultaneously.
See Activate your license
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Microphone position
Position the microphone in such a way that it receives sound optimally to minimize 
the effect of the position of the animal in the test environment. Here we report 
basic examples from the literature.

Test setups
Home cage observation

Microphones are positioned suspended 2 to 20 cm above the cage, pointing 
downward. Testing cages are generally placed in a sound-attenuating chamber. 

Separation test for rodent pups

Pups are placed into an empty container located inside a sound-attenuating 
chamber. The microphone is placed through a hole in the middle of the cover of the 
chamber, about 20 cm above the pup.

Self-administration chamber

Position the microphone outside the chamber behind a mesh screen, if possible 
between the response levers at approximately head-level of the animal.

Male-female interaction (rats)

The test cage is divided in two compartments, the lower one for the male, and the 
upper one for the female. The microphone is attached to the divider, pointing to the 
lower compartment. Holes are drilled into the dividing panel to allow odor to pass 
to the male chamber. The diameter of the holes is smaller than the 50-kHz 
vocalization wavelength to sufficiently attenuate female vocalizations (Ciucci et al., 
Behav Brain Res. 182: 284–289, 2007)

Male-male interaction (rats)

In this setup, a male rat is paired with another male and housed throughout the 
experiment period. Each pair is housed in a polycarbonate cage (26 cm width x 43 
cm depth x 20 cm height) in an environmentally controlled rearing system where 
temperature and humidity are kept constant and external sound and light sources 
are shut out. The microphones were suspended close to the lid of the cage 
(Takahashi et al., PLoS ONE 5(11): e14115, 2010. doi:10.1371/
journal.pone.00141152010)

Eliciting vocalizations for test purposes
For optimal gain adjustment, it is important that animals produce vocalizations. To 
trigger vocalizations:
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 For mother-pup interaction: separate the pups.
 For male-male interactions (mice): add bedding contaminated with urine of 

another male in the cage.
 For male-female interactions (mice): Wild-derived male mice increase the 

number and diversity of courtship vocalizations if they previously interacted 
with a female (Zala et al 2020). The exposure to a female partner or to the 
urine induces a clear USV response in adult male mice with previous 
reproductive experience (Holy and Guo 2005, Maggio et al. 1983; Nyby 
2001, Whitney and Nyby 1979).

 For prairie voles: put two individuals in the cage (e.g. same-sex siblings). The 
frequency of vocalizations is reduced when the animals are placed in 
separate, side-by-side cages. For single-individual recordings, optimal 
distance is about 15 cm (6 in) (Stewart A.M. PhD thesis, University of Illinois 
at Chicago, 2012).

Relevant literature
Browse to

https://www.noldus.com/ultravox-xt/resources

then under Products click UltraVox.

Animal care guidelines
http://www.animalethics.org.au/policies-and-guidelines/animal-care
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Adjust the microphone gain in UltraVox 
XT
Aim
With the Gain function you can adjust the amplification of the signal from the 
microphone.

NOTE  If adjusting the microphone gain in the software does not give the expected 
results, you can also Adjust the microphone internal gain.

Procedure
1. Place the microphones at the top of the cage, pointing down to the middle.
2. Click the name of the microphone you want to adjust, and then click the 

Settings icon.

3. In the Microphone settings window, click the Start monitoring button.

4. Results:
The Amplitude plot (top) and the Spectrogram plot (bottom) show the real-
time values.

5. Move the Gain slider in such a way that the peak of the waveforms (almost) 
never cross the red shaded area of the Amplitude plot.

6. In the spectrogram, the calls should be clearly visible, provided that the 
subject emits vocalizations. See Eliciting vocalizations for test purposes
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7. When ready, click the Stop monitoring button, then click OK.

8. The current value of gain is shown in the Gain column.

Repeat the steps above for the next microphone.

Note
UltraVox XT stores the gain settings based on the position of the microphone in the 
Experiment Settings. If you select a microphone in another position (for example, 
you select Microphone 2 in the first row under Microphone), UltraVox XT will 
assign the gain that was last saved for that row, and will show no error message.

 To prevent confusion, always label microphones and USB ports, so you 
always know which microphone goes to which port.

 Connect the microphones to the corresponding USB port and click Refresh 
in the Experiment Settings.
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About the microphone gain
Gain and signal offset
When the gain is high, an offset may appear in the Amplitude plot, that is, the 
average signal is higher than zero, and the maximum values are higher than 
unsigned minimum values. The offset is caused by the electronics of the 
microphone. Therefore, increasing the gain usually results in a higher offset. 
However this has generally no effect on your measurements. You can reduce the 
offset by lowering the gain.

When the offset is significantly high, it can reduce the dynamic range, that is, the 
range of amplitudes that can be described by a digital system. In the case of 
UltraVox XT where audio is sampled with a 16 bit resolution, the signal can range 
from -32767 to +32768. If the offset is, for example, 2500, then the positive side of 
the signal can be from 2500 to +32768, that is, leaving an actual range of 30268.

This limitation increases the probability that loud sound exceeds the maximum 
possible value, generating artifacts (see below).
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Gain and frequency artifacts
A high gain also produces additional high frequencies, which do not correspond to 
vocalizations. This occurs when the signal exceeds a lower or upper limit. The result 
is that the waveforms are cut off flat, or “clipped”. When sound is loud, clipping 
produces extra frequencies that you can see in the spectrogram. For example:

When setting the microphone gain, create conditions similar to those of the actual 
recordings. For example, put the mouse pups at the same distance from the 
microphone as when you carry out the real tests.

Microphone internal gain
If the vocalizations do not appear in the spectrogram, it may be that they are 
covered by overall noise. To further reduce noise, for 250-kHz microphones, you can 
then Adjust the microphone internal gain.
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Adjust the microphone internal gain
Aim
To adjust the gain of the 250-kHz microphone. Do this only when adjusting the gain 
in UltraVox XT does not give the expected results.

 For rough gain adjustments, adjust the microphone internal gain (see 
below).

 For fine-tuning the output, Adjust the microphone gain in UltraVox XT.
 See also Experimental setup and Microphone position

Procedure (250-kHz microphone)
1. Unscrew the microphone lid (connector side) and pull out the circuit board 

out of the aluminium cylinder.

2. Place the microphone at the top of the cage, pointing down to the middle 
of the cage.

3. Connect the microphone to the PC.
4. Start UltraVox XT, and choose Setup > Experiment Settings.
5. Click Settings for that microphone, then click the Start monitoring button.

6. In the software, set the Gain to a low value like 20. A low value is 
recommended because a high software gain increases noise more than the 
microphone’s internal gain.
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7. ‘Place the microphone over the subjects. Check the waveforms on the 
Amplitude plot and in the spectrogram.
The vocalizations should be visualized in the spectrogram. See Eliciting 
vocalizations for test purposes

8. Locate the trimmer on the board. This is a small box with a tiny screw on 
one side.

9. Gently turn the trimmer screw: counterclockwise If the waveforms are out of 
scale; clockwise if the call waveforms are too narrow.

10. Test the microphone with the actual sound source. There should always be 
a gap between signal peaks and the minimum and maximum values of the 
plot.

11. When finished, click the Stop monitoring button and then click OK.
12. Put the board back in place and close the microphone.
13. For fine tuning, adjust the Gain value in UltraVox XT.

Repeat the procedure for the other microphones.

Notes
 The Dodotronic Ultramic 250 is not officially supported. However, short 

tests carried out with UltraVox XT 4 on Dell 3680 desktop with Windows 11 
version 24H2 did not reveal significant issues.
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 For 384-kHz microphones, we recommend not to adjust the internal gain. 
The trimmer inside the microphone only allows changes in sensitivity 
significantly larger than microphone-to-microphone sensitivity variation.

 To produce ultrasound, move a key chain in front of the microphone, at a 
fixed distance. However, with this method you do not calibrate the 
microphone to the real animal’s vocalizations. See Eliciting vocalizations for 
test purposes

 Multiple microphones need not to have exactly the same optimal gain. For 
each microphone, try to find the gain that results in a clear spectrogram of 
calls.
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Technical specifications
Microphone with sampling frequency 384 kHz

Type Advanced electret

ADC resolution 16 bits

Max sampling 
frequency

384 kHz

Frequency range 10 - 160 kHz

Interface USB 2.0, full speed, OTG/host

Connection Mini-B USB

Anti-aliasing filter 8th order, 160 kHz

Dimensions 43 mm (1 11/16”) x 114 mm (4 31/64”) x 13 mm 
(33/64”)

Weight 60 g

Microphone with sampling frequency 250 kHz

ADC resolution 16 bits

Sensor MEMS high-sensitivity Surface Mount Wide-
band Ultrasonic Acoustic Sensor

Processor 32 bit 80 MHz integrated microcontroller

Digital signal 
processing

8th order anti-aliasing low-pass filter

Connection Mini-B USB

Max. sampling 
frequency

250 kHz

Frequency range 0 - 125 kHz

Dimensions Length 130 mm (5 1/8”) x Diam 20 mm (25/32”)

Weight 50 g
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Call definitions

Main topics and tasks
 Call definitions  56
 Add a call definition  58
 Adjust a call definition  59
 Load a call template  61
 Call templates  62
 Save a call definition as a template  63
 Detected Calls list  64
 How detected calls are sorted  67
 Explore the detected calls  68
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Call definitions
Background
Call definitions are used to detect calls in your recordings. See how to Add a call 
definition

The signal is detected as “call” when it fulfills the conditions set by the call definition 
parameters.

Call name

The name of the call definition. The same name will be given automatically to all 
calls detected based on that definition.

Call color

The color for this call definition (and the detected calls).

Parameters
Frequency low (Hz)

The lower frequency limit. Signals with frequency below that value are ignored.

Frequency high (Hz)

The higher frequency limit. Signals with frequency above that value are ignored.

Min amplitude

The value of amplitude below which the signal is not included in the call.

Min duration (ms)

The minimum duration of the call.

Max duration (ms)

The maximum duration of the call.
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Min gap (ms)

The shortest time allowed between the stop of one call and the start of the next 
one. If two events matching the other parameters are found at less then the 
minimum gap, they are considered as one call.

See also

 Adjust a call definition
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Add a call definition
There are three ways to define a call:

 Select a call in the spectrogram and Define a call
 In the Call Detection screen, click the Add button and enter the call 

parameters. See Adjust a call definition
 In the Call Detection screen, click Edit, then load a call template that was 

saved previously. See Load a call template
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Adjust a call definition
Aim
At least in some cases selecting a rectangle around a call in the spectrogram does 
not lead to detection of similar calls as expected. For example, calls in the 
spectrogram that are a bit shorter than the minimum duration estimated when 
drawing the rectangle around a call, will not be detected.

To adjust a call definition:
 For all parameters:

Click on a call definition in the Call Definition list, then click the Edit 
button. Make the necessary changes and click OK. 

Click Detect calls in this recording to detect the calls with the new 
definition. Note that clicking this button also updates the calls detected 
with other call definitions.

 For the call definition name:
Double-click the cell under Call Definition and rename the frequency range 
if necessary (that is important especially if you change the frequency limits).

 For the frequency range:
Drag the top or bottom side of the rectangle to select a higher or lower 
high frequency limit. 

NOTE  Changing the frequency limits by dragging the rectangle top/bottom 
sides does not result in changing the call definition name (frequency label 
on the spectrogram). You have to do that manually.

 For duration:
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Drag the left/right sides of the rectangle to change the minimum duration 
of the call definition.

Notes
 Editing the frequency limits does not result in changing the call definition 

name (frequency label on the spectrogram). You have to do that manually 
(see above).

 You can save the call definition as a template to use it to search for calls in 
other experiments. In the Save as template field, enter a name for your 
template and click Save.
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Load a call template
Aim
To apply a call definition to the current recording that was saved previously as a 
template, also in experiments other than that currently open.

Procedure
1. Under Recording, select the recording in which you want to detect calls 

based on an existing definition.
2. Click the Add button.

3. In the Edit Call Definition window, click the Load Call Template button.

4. Select a call template and click OK. 
5. The Add Call Definition window is updated with the values stored in the 

imported template.
6. Edit the call definition (optional), then click OK.
7. The new call definition is appended to the Call Definition list. 
8. Click Detect calls for this recording to detect the calls based on the call 

definition.
61



Call templates
Aim
You can use a call template to detect calls in one or multiple recordings based on 
information that you obtained from other recordings (or experiments).

Definition
A call template is a container of one call definition. A call template includes the 
following information:

 Template name
 Call name
 Color
 Frequency lower and higher limits
 Minimum amplitude
 Minimum duration (in ms)
 Maximum duration (in ms)
 Minimum gap (in ms)

What do you want to do?
 Load a call template
 Save a call definition as a template
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Save a call definition as a template
Aim
To save a call definition that can be used to detect calls in multiple experiments.

Procedure
1. Define a call. 
2. When necessary, Adjust a call definition.
3. Click the call definition name in the Call Definition List, and click the Edit 

button.

4. In the Edit Call Definition window, next to Save as template, enter a name 
for that call template.

5. Click Save.
6. Click OK.

Note
The call templates are saved in the call_defs.txt file located in 
C:\ProgramData\Noldus\UltraVox. Do not edit this file!
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Detected Calls list

Contents
Detected calls

The name of the call definition used to detect that call. See Call definitions

Color

The color of the call definition the call belongs to.

Duration (ms)

Duration of the detected call. This equals Stop time – Start time.

Start time (s)

The start time is back-calculated when a number of samples above the Min 
amplitude (set in the call definition) have been found that exceed the Min duration 
(set in the call definition). From this time (tm in the figure below) the Min duration is 
then subtracted to obtain the Start time.
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Stop time (s)

The stop time is back-calculated when a number of samples with low amplitude 
values (that is, below the Min amplitude in the call definition) have been found that 
exceed the Min gap time set in the call definition. From this time (tg in the figure 
below), the Min gap time is subtracted to obtain the Stop time.

The call is then fully defined with its Start time and Stop time:

Freq at Max Amp (Hz)

The frequency at which the amplitude is the highest in that call.

Mean Amplitude

The mean amplitude of a call is calculated as the sum of the amplitude of all points 
inside the call rectangle with an amplitude above the specified Min amplitude limit 
(in the call definition), divided by the number of points found.
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White background points in the spectrogram are generally not be included as they 
would reduce the mean amplitude to a meaningless low value. This means also that 
mean amplitude is always higher than (or equal to) the Min amplitude limit.

See also

 How detected calls are sorted
 Explore the detected calls
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How detected calls are sorted
In the Detected Calls List, calls are sorted first by the time interval chosen to 
visualize the signal, then by the call definition they originate from.

Example

The Time interval is 2 seconds. Within each 2-s interval, the calls obtained with the 
first call definition are listed first, then those obtained with the second call 
definition, etc. The orange rectangles below represent the time intervals.
67



Explore the detected calls
To view information on a detected call

1. Click within the rectangle around the call in the Spectrogram.
2. In the Detected Calls list, the row for the selected call is highlighted. 

To view the spectrogram of a detected call
1. Click a detected call in the Spectrogram or click a row in the Detected Calls 

list. The corresponding rectangle in the Spectrogram is highlighted. If the 
call is located in a time interval other than the current one, all plots are 
updated with the new interval.

2. A detailed spectrogram of that call appears at the bottom-right corner of 
the screen. 

3. To view details of the call, move the mouse over the plot and check the 
values at the bottom: t (time), f (frequency) and a (amplitude).

TIP  To navigate through calls, you can also use the arrow keys   or the Page 
Up/ Page Down keys.

See also

 The Spectrogram
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The Spectrogram

Main topics and tasks
 Explore the spectrogram  70
 Frequency scale  75
 Filter the recording  76
 Amplitude scale  77
 Spectrogram settings  73

Extras - Learn about
 The short-time Fourier transform  81
 Frequency resolution and time resolution  83
 Overlap  85

See also

 How do I report spectrogram parameters?
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Explore the spectrogram
Show the time, frequency, and amplitude at a specific point
Move the cursor over the Spectrogram and look at the values on the bottom line: t 
(time), f (frequency) and a (amplitude).

Locate the frequency at maximum amplitude
1. Click one of the rows in the Detected Calls list.
2. Take note of the Freq at Max Amp (Hz).
3. Enlarge the spectrogram at the bottom-right corner of the screen. 
4. Hover on the brightest (or darkest, depending on the color mapping 

chosen) pixel in the spectrogram. Observe the value of frequency (F). 
5. If you move the cursor just on the lower side of the brightest pixel, you’ll 

see the value of Freq at Max Amp (Hz) displayed in the Detected Calls list.
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Move between the detected calls
1. Click one of the detected calls either in the spectrogram or in the Detected 

Calls list.

2. To move through the entire recording you can also use the Up/Down 
arrow keys (to jump from call to call) 

3. If you press the Page Up/ Page Down keys you can make longer jumps, 
depending on how many calls the screen can contain.

Display the next time interval
1. Click the middle buttons under Step through all data. Adjust the length of 

the Time interval when necessary.
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Alternatively, press the Left/Right arrow keys to display the previous/next 
interval, respectively.

2. The interval is highlighted in yellow in the Entire recording plot. The 
waveform is displayed in detail in the Selected interval plot. See View 
options

Zoom in and out the axes
See Zoom in/out
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Spectrogram settings
Aim
To optimize the appearance of the spectrograms.

How to access these settings
 In the Call Detection screen or in the Call Labeling screen, under View, click 

Settings next to Spectrogram.

 Right-click anywhere on the spectrogram.

SFT length
UltraVox XT uses Short-time Fourier Transform (SFT) to create a spectrogram. In this 
process, digital data is broken in sliding frames containing a number of samples of 
the signal. Select here the frame length (minimum = 64, maximum = 2048).

A higher value of SFT length increases results in a higher frequency resolution and 
a less coarse image in the spectrogram; however, it reduces the time resolution, that 
is, the ability to discriminate between two events at two time points). That is 
because at a fixed sampling frequency, there is a trade-off between frequency 
resolution and time resolution (for details, see Frequency resolution and time 
resolution).

 The higher SFT length, the faster the processing time.
 Lower SFT length is good for wide-band spectrograms, while higher SFT 

length is good for narrow-band spectrograms.
 Choose a high SFT length when you are interested in an accurate 

measurement of the dominant frequency of vocalizations. Choose a low SFT 
length when you are more interested in the timing of vocalizations.

 Choose SFT length in such a way that waveform frequency resolution is 
smaller than the minimum spacing between the frequencies of interest.
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Overlap 
The Overlap setting determines which percentage of the frame of samples is re-
used for the next frame. 

Select the value you require (0 - 95%; default 50%). High Overlap percentages (90% 
and higher) result in the highest time resolution (that is, the ability to discriminate 
events at two different time points).

To speed up call detection, select a lower value. However, if you use two call 
definitions A and B that differ by a small range of frequencies, two calls of different 
type may be detected as both A or both B.

See also

 Overlap

Amplitude scale
See Amplitude scale

Frequency scale
See Frequency scale

Notes
 The Zero pad option has been removed in UltraVox XT 4. No zero padding 

is applied to the analysis frame, meaning that the length of the spectrum is 
equal to SFT length divided by 2. That is the same as Zero pad = 1 in 
UltraVox XT 3.

 Note that zero padding does not affect the waveform frequency resolution, 
which is the minimum spacing between two frequencies that can be 
distinguished. The waveform frequency resolution is always equal to R= 1/
T, where T is the length of the original (unpadded) signal (see Frequency 
resolution and time resolution). 
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Frequency scale
Aim
To specify the minimum and maximum values of frequency shown in the 
spectrogram.

Procedure
1. In the Call detection or Call labeling screen, select Spectrogram. Right-click 

somewhere on the large spectrogram or click the Settings button under 
View, or choose File > Settings > Spectrogram.

2. In the window that opens, under Frequency scale, deselect the auto check 
box and choose the values of Min frequency (bottom line of the 
spectrogram) and Max frequency (top of the spectrogram) that you want 
to view.

Notes
 You can quickly adjust the frequency range by zooming in and out the 

frequency axis. Press Ctrl and move the mouse wheel while pointing 
anywhere on the large spectrogram. 

 Adjusting the range of frequencies to be shown in the spectrogram does 
not filter your signals. To filter signals (for example, to remove audible 
vocalizations), see Filter the recording.
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Filter the recording
Aim
Filter the signal to display and analyze only frequencies above a specific threshold, 
and to eliminate noise in the audible range (up to 20 kHz).

Procedure
IMPORTANT When you filter a recording, all call definitions and calls are deleted. 
Make sure you apply a filter before you Define a call.

1. In the Call Detection or Call Labeling screen, under View click the Filter 
button.

2. Enter the value you require in the Cut off frequency field.
3. Click Apply.

Notes
 A copy of the unfiltered recording is kept in the Recording List. See The 

Recording List
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Amplitude scale
Aim
Define how you want to map the values of amplitude in the spectrogram over a 
range of colors.

Background information
The range of values of amplitude displayed in the spectrogram is based on the 
minimum and maximum values in the current interval. This means that when you 
visualize another interval, color are assigned based on the new amplitude range.

What you choose under Amplitude scale does not change the range on the y-axis 
of the spectrogram. This is by default 0 to 124776 for 250 Hz microphones, and 0 to 
191656 Hz for 384 kHz microphones. For non-ultrasound microphones, the range is 
0 to 22010 Hz.

Procedure
1. In the Call detection or Call labeling screen, select Spectrogram and click 

Settings, or right-click the spectrogram window.
2. Under Amplitude scale, choose the options that you require. 

Options
Linear

The option Linear maps the values of amplitude to color values using a linear 
function. In the linear scale color mapping, the minimum value of amplitude is given 
the “minimum” color (for example white; 0), and the maximum with the “maximum” 
color (dark blue; 255). The intermediate colors are calculated to vary linearly in the 
range [0, 255].
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The linear mapping may not be optimal in the following cases: 

 When the signal varies a lot in amplitude, because the color variability is 
limited by the values ranging from 0 to 255 a linear color mapping may not 
be able to discriminate between two events of different amplitude.

 When energy is concentrated in a narrow range of frequencies, there may 
be little variation in color within the call spectrogram, because relatively few 
colors are available for that narrow range. In that case some spectrogram’s 
details may be hidden.

Log

With the Log scale color mapping, you can represent a much wider amplitude span. 
However, the higher the log span, the more low amplitude (including noise) is 
represented with “higher” colors. The Log span determines the ratio between the 
maximum and minimum amplitude:

Ls 20 max
min
----------log=

For example when choosing a Log span of 45, we obtain

45 20 max
min
----------log=

Therefore

Select Log when the signal has a high variation in amplitude, and using Linear does 
not result in visible variation in color between two different values of amplitudes.If 
you choose Log, select the span (minimum 30, maximum 350 dB). The higher this 
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value, the more the sound of low amplitude is represented. As a result, noise will 
become more evident.

Gamma

With the Gamma scale, colors are calculated based on a power law relationship, 
where the exponent is called Gamma (y = x).

The Gamma option is similar to Log, but results in smoother spectrograms. If you 
choose Gamma, select the span (minimum 0.8, maximum 0.10). The value 0.8 gives 
results similar to linear mapping. The higher the span, the more the low amplitudes 
are represented. As a result, noise will become more evident.

Color map

Choose which color palette you want to use.

 Grayscale. From white (minimum amplitude) to black (maximum 
amplitude).

 Inverted grayscale. From black (minimum) to white (maximum).

 Blue. From white (Minimum) to dark blue (Maximum).

 Blue/Red. From white (minimum) to blue, to yellow, to red (maximum).
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 Inferno. From black (minimum) to purple, to orange, to yellow (maximum).

Notes
 A color palette has always 256 different scale values.
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The short-time Fourier transform
The Fourier Transform is a general method to represent data in the time domain as 
data in the frequency domain. With discrete data such as audio sampled at a certain 
frequency, the Short-Time Fourier Transform (SFT) is used, where a stream of sound 
data is split in blocks (also called frames) of fixed length (N samples). Each frame is 
analyzed separately to produce a spectrum.

The basic concept underlying the SFT has to do with taking an array of N time-
domain waveform samples (left) and processing those to produce a new array of 
frequency domain spectrum samples (right). The number of samples on the output 
is exactly the same as the number of samples on the input. 

The length of the SFT frame (time interval T, corresponding to N samples, and a 
sampling frequency fs =N/T) determines the spacing of the frequency bins df that 
can be represented in the spectrum (df = fs /N= 1/T). In reality, we can only use half 
of the bandwidth B to represent a frequency back in the time domain. The second 
half of the bandwidth is alias frequencies, that is frequencies of waveforms that, 
when sampled, would produce exactly the same samples as the sampled signal. For 
this reason, the actual frequency spectrum in UltraVox XT has a maximum frequency 
fmax equal to fs/2 (fmax is generally called the Nyquist frequency). Therefore, the 
spectrum itself is made of N/2 lines: 0, df, 2*df, ... up to (N/2)*df (see the figure 
below).
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From the SFT Fourier transform to a frequency spectrum, and the spectrogram in 
UltraVox XT. You can view each spectrum as a “slice” of the spectrogram, where the 
value chosen for SFT length is the width of one “pixel” of the spectrogram. Note 
that only the first half of the frequency array (compare this with the previous 
picture) is used to build the spectrum.

See also

 Frequency resolution and time resolution
 Overlap
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Frequency resolution and time resolution
UltraVox XT applies the Fast Fourier Transform algorithm applied to SFT, for this 
reason the frame length N is always a power of 2 (64, 128,..., 2048). The higher N, 
the smaller the frequency spacing df. 

If the SFT frame is 2048 samples long, the SFT analysis gives you 2048 equally-
spaced frequency bins from 0 Hz up to the sampling frequency divided by two. 
Increasing SFT length means to reduce the spacing of frequency bins according to 
the formula df = Sampling frequency/SFT length. This increases the waveform 
frequency resolution.

However, any timing resolution that occurs within a SFT frame is lost in the analysis, 
since all temporal changes are lumped together in a single frame. If SFT length is 
2048, the frame duration is, at a sampling frequency of 384 kHz, 2048/384000 = 
5.33 ms. This means that the first spectrum is created at t= 0, and the next spectrum 
is created at t=5.33 ms. Two subsequent events occurring within this time would not 
be distinguishable.

The following table shows the inverse relation between frequency resolution df 
(=sampling frequency / SFT length) and time resolution dt (=SFT length/sampling 
frequency), when sampling frequency is 384 kHz.

SFT length 
(samples)

df (=384000/SFT length) 
(Hz)

dt (=SFT length/
384000 (ms)

64 6000 0.17

128 3000 0.33

256 1500 0.67

512 750 1.33

1024 375 2.67

2048 187.5 5.33

The time resolution dt is the width of the spectrogram pixel, when Overlap = 0.

If you increase the SFT length, there will be more “pixels” along the frequency axis 
of the spectrogram, however they are now “wider”, since they represent a longer 
time interval; the higher the SFT, the longer this time. This relationship represents 
the trade-off between frequency resolution and time resolution.

See also

The following videos:

Short-time Fourier Transform and the Spectrogram
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http://www.youtube.com/watch?v=NA0TwPsECUQ 

FFT basic concepts

http://www.youtube.com/watch?v=z7X6jgFnB6Y
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Overlap
What is Overlap?
Overlap is a way of improving the time resolution of the spectrogram. From what 
described in Frequency resolution and time resolution, the time resolution dt is 
equal to N/fs, that is, the longer the SFT frame, the longer dt, the worse the time 
resolution. This means that events occurring within time t to time t+dt fall into one 
“column” in the spectrogram and cannot be distinguished from each other. 
Overlapping helps with this, like rewinding a bit and listening again.

Below: Difference between non-overlap and overlap processing of a signal 
transformed into Fourier transform frames. a) No overlap. b) 75% Overlap. Note 
that in b) four times as many Fourier transforms are performed, increasing the time 
resolution by a factor of 4. SFT means Short-Time Fourier Transform.

When Overlap is used, an event that does not even last as long as one SFT frame 
can be “seen” (even if at reduced amplitude) in many sets of spectra that are 
displayed adjacent to each other. This way visibility of very short temporal 
variations that occur in a signal is augmented.

The disadvantage of Overlap is that a higher value results in longer processing time 
when you let UltraVox detect calls.
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Effect of Overlap on your spectrogram
Overlap has an effect on the spectrogram. The width of the spectrogram pixel is:

 When Overlap (%)= 0, it is the time resolution dt according to the table 
which you can find in Frequency resolution and time resolution.

 When Overlap (%)= 50, it is 50% of the value in the table.
 When Overlap (%)= 90, it is 10% of the value in the table.

Below: Spectrogram resolution when Overlap (%)= 0 (left), 50 (middle), and 90 
(right). In this example, SFT length = 256, therefore dt=1.024 ms.
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Labeling calls

Main topics and tasks
 Pattern labels  88
 The Labels list  89
 Enter a pattern label that is not in the Labels list  90
 Label multiple calls  91
 Replace a pattern label for multiple calls  93
 Remove labels  94
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Pattern labels
Definition
A pattern label is a label that you can assign to multiple calls in order to analyze 
them as a group. 

A pattern label is often labeled according to the shape of the call spectrogram.

Procedure
1. Choose Analysis > Call Labeling, or click Call Labeling on the left pane.
2. Select one of the calls in the call list.
3. Observe the spectrogram of the call that is highlighted.
4. In the Labels list at the bottom-left corner of the screen, double-click the 

name of the pattern that you want to assign. 
5. The pattern name appears in the corresponding cell.

6. The cursor moves automatically to the next call. You can now label the 
following calls. See Label multiple calls

See also

 The Labels list
 Labeling calls
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The Labels list
The Labels list shows the names of the call pattern labels currently available.

NOTE  The Labels list is used for all your experiments. You cannot create different 
lists for different experiments.

Add a new pattern label
1. Right-click within the Labels list, and select Add label.
2. A new row is appended to the list. 

3. Enter the label you require, then press Enter.

Edit a pattern label
1. Select a pattern label in the Labels list, right-click and select Edit label.
2. The label name becomes editable. Make the necessary changes and press 

Enter. 

Delete a pattern label
In the Labels list, right-click the label and select Delete label.
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NOTE  When you delete a label, the labels of the same type assigned to calls are not 
deleted. If you want to delete those labels, see Remove labels

See also

 Labeling calls

Enter a pattern label that is not in the Labels list
You can label one or more calls with a pattern name that is not (yet) included in the 
Patterns list.

1. In the Call Labeling screen, click the row of the call you are interested in.
2. Type in a new pattern name in the Label cell for that call.

The label is not included automatically in the Pattern labels list. You can also add a 
pattern label to the list. See Add a new pattern label
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Label multiple calls
Aim
To quickly label a number of vocalizations of a specific pattern. To quickly label 
those calls, follow the steps below.

Procedure
1. Open the Call Labeling screen and select one recording.
2. For each call that you want to label with a specific pattern label, click the 

cell in the first column, so that it is marked with a check symbol .

3. In the Labels list, double-click the label that you want to assign. 
4. Click Yes on the message that appears.

5. Select the label you require and click OK.
6. The labels appear in the corresponding cells.
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Replace a pattern label for multiple calls
Aim
To re-assign a pattern label to multiple calls. This is especially handy in two 
situations:

 When you want to assign the same pattern label to all unlabeled calls.
 When you want to replace a specific label with another one.

To re-assign a pattern label to multiple calls
1. Click the button next to the Pattern Label column header.

2. In the Multi Pattern Label Editing window, under Rename pattern label, 
click the first button and in the Select pattern label window select the 
pattern label that you want to replace.
Leave this empty if you want to assign a label to unlabeled calls.

3. Click the second button and select the label you want to assign.

4. Click Apply.
5. The Pattern Label column is updated with the new pattern label. A 

message shows how many calls have been labeled.
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Remove labels
Aim
To remove the labels from the calls in your recordings.

Procedure (single call)
1. Double-click the Pattern Label cell so that its content is highlighted in blue.

2. Press Delete, or right-click the label name and select Delete. 

Procedure (multiple calls)
To remove the labels of a specific type, do the following:

1. Right-click anywhere in the call list and select Select by label.
2. In the second menu, select the label you want to delete.

NOTE  The second menu includes the labels that are scored in the current 
recording.

3. As a result, all the rows that include that label are selected with a check 
mark.
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4. Right-click again somewhere in the call list and select Remove label of [n] 
selected calls. The number [n] indicates how many calls in that recording 
are labeled with the label chosen.

5. The labels are removed.

See also

 Delete calls
 Replace a pattern label for multiple calls
 To edit the list of available pattern labels, see The Labels list
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Editing calls

Main topics and tasks
 Add a call manually  99
 Rename calls  101
 Adjust frequency and time boundaries in a call  104
 Delete calls  106
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Select multiple calls for editing
Aim
To select multiple calls for deletion, or call labeling.

Prerequisites
 Open the Call Labeling screen.

Procedure
 Simple manual selection. Click the check box next to each call that you want 

to select.
 Select by call name. Right-click anywhere in the call list and select Select by 

call name, then select one of the names available in the second menu.

 Select by label. Right-click anywhere in the call list and select Select by 
label, then select one of the labels available in the second menu.

Once selected, a call can be

 Labeled - See Label multiple calls
 Deleted - See Delete calls
 Renamed - See Rename calls 
 Assigned to a different pattern - See Replace a pattern label for multiple 

calls

Notes
To select or de-select all the calls in the Call Labeling screen, do one of the 
following:
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 Click the first check box of the list, near Call Name, to select all calls. To de-
select all calls, click that check box once again.

 Right-click somewhere in the call list and select Select all or Select none.
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Add a call manually
Aim
To add a call that was not detected automatically.

The call will be analyzed just as the calls detected automatically. If you want to have 
the new call analyzed in the same group as the other, automatically-detected calls, 
rename the new call with the name of those calls. See Rename calls

Procedure
1. In the Call Labeling screen, draw a box around the call spectrogram.

2. A new row is inserted. Under Call Name, the text Manual is entered 
automatically.

3. OPTIONAL  Double-click Manual under Call Name and enter the name you 
require.

4. OPTIONAL  Assign a Pattern Label. See Pattern labels
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Note
If you re-name a call with an existing call name (45-69k in the example above), the 
cell under Color is updated with the corresponding color.
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Rename calls
Aim
to provide meaningful names of the calls for a publication or to facilitate analysis of 
groups of calls across recordings and experiments.

What do you want to do?
 Rename a single call
 Rename multiple calls
 Rename the calls with a specific name
 Rename the calls with a specific label
 Rename all calls in a recording

Rename a single call
1. In the Call Labeling screen, double-click the Call Name cell for the call you 

want to rename.
2. Enter the new name for the call.

3. To confirm and stop editing, click anywhere in the call list. If you want to 
edit the next call name, just press Enter. 

Rename multiple calls
1. In the Call Labeling screen, for each call you want to rename, select the 

check box in the first column. Make sure that the calls selected have the 
same name.
TIP  If you only have one call name and you want to select all the calls, select 
the uppermost check box, at the left of Call Name.
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2. Enter the new name under Call Name for one of the calls selected, then 
press Enter.

3. In the message dialog that opens, click Yes to confirm.

Rename the calls with a specific name
1. In the Call labeling screen, right-click anywhere in the call list and select 

Select call by name, then choose the name that you want to modify.
2. The rows with the chosen name are selected. Double-click the Call Name 

for one of those rows and enter the new call name.
3. In the message dialog that opens, click Yes to confirm.

Rename the calls with a specific label
1. In the Call labeling screen, right-click anywhere in the call list and select 

Select call by label, then choose a label. 
2. As a result, calls with a specific label are selected.

3. Double-click one of those rows and enter the new name.
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4. In the message dialog that opens, click Yes to confirm.

Rename all calls in a recording
1. Select the uppermost check box, at the left of Call Name.

2. Enter the new name under Call Name for one of the calls selected, then 
press Enter.

3. In the message dialog that opens, click Yes to confirm.
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Adjust frequency and time boundaries in 
a call
Aim
To edit the frequency and time boundaries of a call if they do not match the call 
spectrogram.

Do this for example when the red rectangle around a detected call does not include 
some weak signal that you believe it is part of that call.

Procedure
Adjust the frequency boundaries

1. In the Spectrogram, hover the mouse cursor over the upper side (to adjust 
the High frequency boundary) or the lower side (to adjust the Low 
frequency boundary) of the rectangle around the call.

2. When the mouse cursor turns a double-headed arrow, drag the boundary 
up or down to the new position.

3. To save the changes, select File > Save or press Ctrl+S.

Adjust the time boundaries

1. In the Spectrogram, hover the mouse cursor over the one of the lateral 
sides of the rectangle around the call, depending on where you want to 
adjust the start boundary or the end boundary.
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2. When the mouse cursor turns a double-headed arrow, drag the boundary 
up or down to the new position.

3. To save the changes, select File > Save or press Ctrl+S.

Notes
 When you edit the frequency or time boundaries in a call, the values 

reported in the call list for the corresponding call are updated.
If you adjust the frequency boundaries, you’ll notice that the values Freq at 
Max Amp and/or Mean Amplitude will change. 

If you adjust the time boundaries, you’ll notice that one or more of the 
following values change: Duration, Start Time (or Stop Time), Freq at 
Max Amp and Mean Amplitude.

See also

 Adjust a call definition
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Delete calls
Aim
To remove calls that represent noise or calls that should not be analyzed.

What do you want to do?
 Delete a single call
 Delete a selection of calls
 Delete the calls with a specific name
 Delete the calls with a specific label (or no label)
 Delete all calls in a recording
 Restore a deleted call

Delete a single call
In the Call labeling screen, right-click the corresponding row in the call list, and 
press Delete Call.

The call is removed from the call list. The corresponding spectrogram is no longer 
highlighted with a rectangle.

Delete a selection of calls
1. For each call you want to delete, select the check box in the first column.

2. Right-click anywhere in the list ad select Delete [n] selected calls where [n] 
is the number of calls currently selected for deletion.
106



3. The calls are removed from the call list. The corresponding spectrograms 
are no longer highlighted with a rectangle.

To reset a selection of calls, select and then de-select the checkbox at the top of the 
list, at the left side of Call Name.

Delete the calls with a specific name
1. Right-click anywhere in the list ad select Select by call name, then select 

the name of the calls you want to delete.
2. As a results, the calls with that name are selected. 
3. Right-click anywhere in the call list and select Delete [n] selected calls 

where [n] is the number of calls currently selected for deletion.
4. The calls are removed from the call list. The corresponding spectrograms 

are no longer highlighted with a rectangle.

Delete the calls with a specific label (or no label)
1. Click the button next to the Pattern Label column header.

2. In the Multi Pattern Label Editing window, under Delete by label, click the 
button and select the label of the calls you want to delete.

Leave the field empty to delete all calls that currently have no label.

3. Click Apply.
4. The calls are deleted and a message informs you about how many calls 

have been removed.
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Delete all calls in a recording
1. Click the button at the top of the first column and select Tag all.
2. Click the same button once again and select Delete. Click Yes to confirm.

Restore a deleted call
If you deleted a call unintentionally, do the following:

1. In the Spectrogram, drag a rectangle around the call spectrogram.
2. The call list shows a new row, with the text Manual in the Call Name cell. 

Double-click Manual and enter the name you require.
3. OPTIONAL  Label the call. See Labeling calls

If you want to restore all the deleted calls, open the Call Detection screen and click 
the Detect calls in this recording button to restore the deleted calls according to 
the current definitions. This will not restore changes that you may have applied 
manually, nor will it restore the calls added manually.
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Recordings

Main topics and tasks
 The Recording List  110
 Independent variables  113
 Recording files  115
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The Recording List
How to access the Recording List
Choose Acquisition > Recording List.

Contents
Rec

The recording number. The number is assigned by sorting the recordings first by 
Microphone Name, then by import/recording date. 

Microphone Name

The name of the microphone used for the recording (that is specified under 
Microphone name in the Experiment Settings screen); or Imported if the recording 
is an imported WAV file.

Date

The date (year-month-day) and the time (HH:mm:ss) depend on the type of 
recordings:

 For microphone recordings, the date and time that the recording started.
 For imported audio files: the date and time that the file was imported. 

Size (MB) 

The recording file size in megabytes.
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Sample Rate (Hz)

The sample rate of the microphone used for that recording, or the sample rate of 
the imported audio file. Common values are 250000 for 250 kHz microphones and 
384000 for Noldus 384 kHz microphones.

Gain 

The value of gain of the microphone used for that recording.

Duration (m:s.ms)

The duration of the recording (minutes: seconds.milliseconds).

Calls Labeled/Detected

The number of calls currently labeled and detected, separated with a “/”.

Filtered 

This column shows Yes if the recording was filtered. The cell is left empty for the 
original, unfiltered recordings.

Independent Variable 

The value of the independent variable entered for that recording. See Independent 
variables

Delete

Click the symbol under Delete or click the Delete button to remove a specific 
recording from the experiment.

Options
Also show original for filtered recordings

You find this option at the bottom of the Recording List.
111



 Select this option to list recordings including the filtered copies.
 De-select this option to only include the filtered copies of the recordings.

Sort the Recording List

Click the column header you want to sort the list by.

Click once more to sort the Recording List in reverse order.

See also

 Independent variables
 Recording files
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Independent variables
Aim
To assign labels to recordings and facilitate group analysis. 

NOTE  UltraVox XT does not select or group your recordings based on the labels 
under Independent Variable. Instead, use the independent variables in the 
exported data to filter recordings or group recordings in other software such as 
Excel or R. 

Procedure
1. Choose Acquisition > Recording List. See The Recording List
2. Locate the Independent Variable column.

By default, the Independent Variables column is empty, unless you have imported 
the audio files; in that case the column shows the audio file name.

An independent variable is any variable that is supposed not to vary during a 
recording, and which you can use to label recordings.

For example, enter the value control or treated in each recording row.

Other examples:

 Phenotype (with possible values Young or Aged)
 Drug dose injected (with possible values 0.01, 0.05 mg/kg etc.).
 If you want to combine two or more independent variables, like Day and 

Treatment level, include the information on both variables in the single 
values. For example, assign a recording one of the values Control-d1, 
Control-d2, Treated-d1, Treated-d2 etc.
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Notes
 If you add text under Independent Variable, the name of the 

corresponding UVD file and that of the UVC file are updated automatically.
 When exporting the call statistics, that value is exported together with the 

statistics for the corresponding recording.
 If you imported an audio (UVD, WAV) file, the file name is automatically 

entered as independent variable for that recording. To edit this name, 
double-click the corresponding cell.
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Recording files
File location
Recordings are stored in the experiment folder:

C:\Users\Public\Documents\Noldus\ UltraVox XT\Experiments\ [experiment name]

To change the default experiment location, see Settings

File types
Recording (.uvd)

Each recording is saved as data file (*.uvd). The file name depends on how the 
recording was created.

For recordings made with a microphone in UltraVox XT:

[experiment name]_[Microphone name]_[independent variable value]_[Date 
(yymmdd)]_ [time (hhmmss)]_[time(ms)]_[Gnn]_ [N]_[flt].uvd

Where

 [Microphone name] is the name under Microphone name in the 
Experiment Settings.

 [Gnn] indicates the microphone gain (for example G52).
 [N] is always 1 in UltraVox XT.
 flt indicates a filtered copy of a recording.

For recordings imported from audio files (UVD or WAV):

[experiment name]_Imported_[audio file name]_[import date (yymmdd)]_[import 
time (hhmmss)]_ [import time(ms)]_G0_ [N]_[flt].uvd

Where

 G0 indicates that the gain used to record audio is unknown.
 [N] is always 1 in UltraVox XT.
 flt indicates a filtered copy of a recording.

Calls (.uvc)

A file with the same name as the recording file is created when at least one call is 
defined and saved. 
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Files of type .uvc contain the call definitions and the calls detected in a specific 
recording.

Notes
 If you add text in the Recording List under Independent Variable, the 

name of the corresponding UVD file and that of the UVC file are updated 
automatically.

 IMPORTANT Do not to try to open and edit any of the data files mentioned 
above. They may get corrupted and UltraVox XT may no longer be able to 
analyze them.

 You can also open and play back a uvd file with Windows Media Player and 
with Audacity.
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Other options

Main topics and tasks
 Experiment settings  118
 Trigger start/stop recording  119
 Start and stop recording at specific times  122
 Play back sound  125
 View options  126
 Zoom in/out  128
 Settings  131
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Experiment settings
To access the Experiments Settings
Choose Setup > Experiment Settings.

Experiment location

Where the experiment is saved depends on your Settings. Each experiment is saved 
in a separate folder, named as the experiment.

Created / Last modified

Date and time that the experiment was created and last modified, respectively.

Microphone list
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Trigger start/stop recording
To access the Trial Control Settings

1. Choose Setup > Trial Control Settings.

2. Choose one of the options below for Start acquisition and Stop acquisition.

Start acquisition
 Manually. To start acquisition when you click the Start recording button in 

the Acquisition screen.

 External program trigger. Choose this option to start acquisition when a 
file is detected in a specific location (default: 
C:\ProgramData\Noldus\UltraVox\XT 4\Synch).
To test the external program trigger option, see the note below. 

Choose this option to control UltraVox XT recording from EthoVision XT or 
The Observer XT.

Stop acquisition
 Manually. To stop acquisition when you click the Stop recording button in 

the Acquisition screen.

 External program trigger — To stop acquisition when a file is detected in 
a specific location (default: C:\ProgramData\Noldus\UltraVox\XT 4\Synch).
To test the external program trigger option, see the note below.

Choose this option to control UltraVox XT recording from EthoVision XT or 
The Observer XT.
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 After ... minutes — To stop acquisition after a fixed time has elapsed. 
Maximum recording time is 90 minutes. To record for longer time, stop 
manually or with an external pogram trigger. See Recording sound

Note
 To test the external program trigger, do the following:

Copy a text file named start.txt or stop.txt to the destination folder (default: 
C:\ProgramData\Noldus\UltraVox\XT 4\Synch). If you want to change this 
folder, click the [...] button and select the new folder path.

When the file is copied, a message appears:

In the case you copied the start.txt file:

When you copy the stop.txt file:

 TIP  To retrieve the current destination folder for the start/stop files. click 
the Copy button to copy the folder path to the clipboard.
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See also

 Control UltraVox XT from other software
 Trigger settings for EthoVision XT
 Trigger settings for The Observer XT
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Start and stop recording at specific times
Aim
To have UltraVox XT start and/or stop recording at specific clock times, without 
being in front of the computer.

Example: Start recording at 0:00 AM.

Prerequisites
 You have the UltraVox XT 4 installation package at hand.
 On your UltraVox XT computer, check that the following folder exist:

C:\ProgramData\Noldus\UltraVox\XT 4\Synch

If you do not see the Program Data folder, in the Windows File Explorer 
click View > Folder Options > On the View tab select Show hidden files, 
folders and drives.

Procedure
Step 1 - Copy and edit the batch file that triggers UltraVox XT

With the following steps you make a batch file that copies a file “Start.txt” to a 
specific folder of UltraVox XT./

1. On the UltraVox XT 4 installation package, browse to Extras. Copy the 
folder UltraVox XT 4 Control.

2. Paste the folder to a location on your computer.
3. Right-click the file SUV.bat and select Edit with > Notepad.

4. On the first line, enter the following:
@if exist "C:\ProgramData\Noldus\UltraVox\XT 4\Synch\start.txt" del 
"C:\ProgramData\Noldus\UltraVox\XT 4\Synch\start.txt"
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5. On the second line, enter the address of the “start.txt” file, which is located 
in the same folder as the SUV file. The second address is the same as that 
on the first line.
@copy "[location on your PC]\UltraVox XT 4 Control\start.txt" 
"C:\ProgramData\Noldus\UltraVox\XT 4\Synch" > nul

Step 2 - Program the Windows Task Scheduler

With the following steps you program the Windows Task Scheduler to start the 
batch file at the time required.

1. In the Control Panel, choose System and Security and under 
Administrative Tools click Schedule tasks. If you do not find this, in the 
Search field enter “schedule” and click Schedule tasks.

2. Click Create Task on the right panel.
3. On the General tab, give a name to the task.
4. Click the Triggers  tab. Select date and time required, and whether the task 

should be repeated, for example each night.
5. Click the Actions tab. Click New, next to Action select Start a program. 

Click Browse and select the SUV file.

6. Click OK.

Step 3 - Activate UltraVox

1. In UltraVox XT, click Trial Control, and under Start acquisition select 
External program trigger.

2. The UltraVox XT recording screen must be open the moment that the 
scheduled task is activated. Therefore, before leaving the lab, in UltraVox XT 
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choose Acquisition > Open Acquisition. You do not need to click the 
Start display button.

Note
 To stop recording at a specific time, make a separate task in Windows Task 

scheduler. In that task, select the file SUV.bat as defined above. In the Trial 
Control Settings, under Stop acquisition select External program trigger.

 To control UltraVox XT from EthoVision XT, see Control UltraVox XT from 
other software.

 The procedure outlined above is also valid when you work with multiple 
microphones.

See also

 Control UltraVox XT from other software
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Play back sound
Aim
To listen to recordings converted to audible frequencies.

Prerequisites
Make sure the computer has speakers enabled.

Procedure
1. In the Call Detection or Call Definition screen, under Playback choose the 

Pitch reduction value (1/1 to 1/20).

1/1: No change in pitch.

1/10: Pitch reduced 10 times (e.g. from 60 kHz to 6 kHz).

2. Choose Adjust speed to slow down playback, so you can perceive the 
changes in pitch for very short calls. If Adjust speed is not selected, the 
audio file is played at normal speed.

3. Play back audio. 
To play back a short section of the audio file, click anywhere within the 
Entire recording plot, to select an interval. Zoom in/out to adjust the length 
of the interval. Next, click the Play Interval button.

Alternatively, click a call in the call list, then click the Play Interval button.

To listen to the entire recording, click the Play Recording button.

See also

 How do I analyze audible sound?
125



View options

Select the plots you want to display.

Entire recording
Displays the Amplitude-time plot for the entire recording.

Selected interval
Displays the Amplitude-time plot for the time interval currently selected. See also 
Explore the spectrogram.

Spectrum
Displays the frequency spectrum for the time interval currently selected.
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NOTE  When you select one of the detected calls either in the Spectrogram or in the 
Detected calls list, part of the spectrum is highlighted in blue. This corresponds to 
the frequency range of the call definition that call was detected from, not the 
frequency range of the call itself.

Spectrogram
Displays the spectrogram for the time interval currently selected.

See also

 The Spectrogram
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Zoom in/out
Spectrum plot
To zoom in and out the horizontal (i.e. frequency) axis, place the mouse pointer over 
the spectrum and roll the mouse wheel. 

Selected interval plot
To zoom in and out the horizontal (i.e. time) axis of the Selected interval plot, do 
one of the following:

 Enter the length of the Time interval you require.
 Place the mouse pointer somewhere over the plot area (see the second plot 

in the figure below), then roll the mouse wheel. Note that the zoom is 
centered on the current position of the mouse pointer.
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Spectrogram

To zoom in/out the time axis:

 Adjust the value of Time interval at the top of the screen, or
 Place the mouse pointer somewhere over the spectrogram area (see the 

figure below), then roll the mouse wheel. Note that the zoom is centered 
on the current position of the mouse pointer.

To zoom in/out the frequency axis:

 Place the mouse pointer somewhere over the spectrogram area (see the 
figure below), then hold Ctrl down and roll the mouse wheel. Note that the 
zoom is centered on the current position of the mouse pointer.

 Alternatively, right-click the spectrogram area and under Frequency scale 
adjust the values Min frequency and Max frequency. Check the 
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spectrogram on the background. When you are happy with the zoom level, 
click OK. 
With the Auto options near Min frequency and Max frequency you return 
to the default range determined by the microphone sample rate.
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Settings
Aim
To access settings at the application level (default folder locations) and at the 
experiment level (e.g. the FFT settings).

Choose File > Settings, and click the page you require. 

NOTE the Spectrogram page is only available when an experiment is open.

General page

Experiments location

All new experiments are stored in the following location

C:\Users\Public\Documents\Noldus\UltraVox XT\Experiments

This folder is created at installation if you do not specify an alternative location.

When you create a new experiment, the software creates a sub-folder with the same 
name as the experiment. This folder contains all the files related to that experiment:

C:\Users\Public\Documents\Noldus\UltraVox XT\Experiments\[new experiment 
name]

Acquisition control location

This is the folder where a file is copied in order to trigger the start/stop of recording 
from an external application (for example, EthoVision XT).

Default location is C:\ProgramData\Noldus\UltraVox\XT 4\Synch.
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Spectrogram page
This page is only available after you have opened an experiment.

See The Spectrogram
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Export data and results

Main topics and tasks
 Export recording statistics  134
 Export call statistics  135
 Export the spectrogram  138
 Export the recording as WAV file  139
 Import call data in The Observer XT  140
 Import call data in EthoVision XT  142
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Export recording statistics
Aim
To export statistics of calls grouped according to name, or pattern label, or both. 
The statistics are saved to a CSV file.

Procedure
1. Choose Analysis > Recording Statistics.
2. Under Call grouping, select how you want the calls to be grouped in the 

table.
3. Under Statistics, choose which statistic to export.
4. Under Recordings, select the recordings you want to export and the way 

you want to group calls (for details see Calculate statistics).
5. Check the resulting table. When ready, click Export.

6. Specify the location and name of the file, and click Save.

Notes
 Under Call grouping, the option Name and label splits the data of a 

specific call name in different columns, each for a specific pattern label. The 
option Name only splits the data in columns based on the name of the 
calls, no matter what the call label is. The option Label only splits the data 
in multiple columns based on the label, no matter what the name of the 
calls is. Finally, the option All calls merge all calls in one group.

 The default name of the export file is:
[experiment name]_rec_stat_[date of export]_[time of export].csv.

 The default location of the export file is the Output folder within the 
experiment folder:
C:\Users\Public\Documents\Noldus\UltraVox XT\Experiments\[experiment 
name]\Output.

 If a recording does not contain detected calls, the value of Count is 0 and 
the other statistics are “- “.
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Export call statistics
Aim
To export statistics of each call.

Procedure
1. Choose Analysis > Call Statistics.
2. Click the Call Statistics tab.
3. Under Export, choose the export format (see below).
4. Under Export, choose the recording containing the calls you want to 

export. 
Choose one of the EthoVision XT options if you want to import the call data 
in EthoVision XT.

5. Click the Export button.

6. Repeat steps 3-5 to export more recordings.

Default file name
[experiment name]_[microphone name]_[independent variable value*]_[recording 
date]_[recording time (hhmmss)]_[recording time (ms)]_[Gnnn]_1_[flt].

 (*) present only if entered in the Recording List. For imported audio files, 
the file name is automatically added in the Independent Variable column 
of the Recording List.

 [Gnnn] is the gain used with that microphone.
 [flt] indicates that a filtered copy of the recording has been exported.
 For imported audio files, the microphone name is replaced by Imported.
 See Recording files for more details on file names.

Default export location
The Output folder of your experiment. If you did not change the default experiment 
location, you can find the export file in:
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C:\Users\Public\Documents\Noldus\UltraVox XT\Experiments\ [experiment 
name]\Output.

Export file formats
EthoVision XT

This format is compatible with EthoVision XT 11 or newer. Data is saved to a *.etx 
file and stored as a call list.

Headers:

 Application name and date of export.
 Experiment name.
 Call file name (UVC file). See File types > Calls (.uvc)
 Microphone name, or “Imported" for imported audio files.
 Recording Date.
 Recording Start Time.
 "Time (msec)"; [Call definition 1], [Call definition 2], etc. 

Data set

 The first column contains the time stamps of the start of each call, in ms.
 The second and next columns contain 0 (not a call start) or 1 (call start). 

Each column represents a call category (call name, or call name*pattern 
label). In the following example of an ETX file for EthoVision XT when 
opened in the Notepad, the call that started at 1.339 s is highlighted:
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NOTES 

 EthoVision XT does not import the values of amplitude and frequency of 
the single calls.

 Import of UltraVox XT data into EthoVision XT 10 or older is not supported.

The Observer XT

Data is saved to a *.odx file, containing the coding scheme, the call data in the form 
of an event log, and the link to the audio data.

NOTE  The Observer XT can also import UltraVox XT XT files as external data (*.etx). 
Select File > Import External Data and choose UltraVox XT 4 (*.etx) as file type.

HTML

Data is saved to a html file, containing one row for each call.

The call list opens automatically in your default internet browser.

Text (.csv)

This is the format compatible with most statistics applications, such as MatLab, 
SPSS, R, Python etc.
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Export the spectrogram
Aim
To copy the spectrogram to another program.

Procedure
1. Open the Call Detection screen, or the Call Labeling screen.
2. Adjust the spectrogram size and zoom level if necessary, to visualize the 

calls at the desired level of detail. See The Spectrogram
3. Under Options, click the Copy Spectrogram button.

4. In the other program, press Ctrl+V.
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Export the recording as WAV file
Aim
To export your recordings as sound files of WAV format. For example, to include 
them in a presentation or submit them to a journal as supplementary material.

Prerequisites
You have opened the Call detection or Call labeling screen.

To export a recording to a WAV file
1. Under Recording, select the recording you want to export.
2. Under Options, click the Export WAV button.

3. Specify a location and a name for the file.
4. Click Save. 

Note
For a collection of mouse vocalizations, see https://mousetube.pasteur.fr/
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Import call data in The Observer XT
To import the data
In The Observer XT, do one of the following:

 To import a recording as a separate observation: Choose File > Import > 
Observational Data.

 To import a recording into an existing observation: open that observation 
and click the Import data button. 

Next, follow the instructions on the screen.

Coding scheme
In The Observer XT coding scheme, calls are imported as discrete events, each 
consisting of a state event (call name) and a modifier (pattern label). 

 State events are listed in one Start-stop group named Calls. Call events with 
different names can be overlapping.

 If a call was labeled in UltraVox XT before exporting, the corresponding 
state event is attached to the modifier with the same name as the label. 
Modifiers are listed in a group named Pattern.
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Data in the event log
In the event log, calls are represented with two rows, one marking the call start time 
and one marking the stop time.

Data visualization
When visualizing the observation, calls are shown as colored segments on the 
timeline. Click the + sign next to the headers to view the calls with their pattern 
labels.

The audio data is displayed as a waveform. For more information, see The Observer 
XT Help.
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Import call data in EthoVision XT
To import call data

1. In EthoVision XT, open the Trial List.
2. Click the Import External Data button.
3. Under Files of type, select UltraVox XT [version number].

If you do not see this profile, install it from the UltraVox XT installation USB 
stick.

4. Select the *.etx files and click Open.
5. Drag the data lines from the Import External Data window to the trial you 

require.
6. When ready, click Import.

Data for each call name (or call name*pattern label) is imported and resampled as a 
separate dependent variable.

For more information on importing and analyzing external data, see the EthoVision 
XT Help.

Analysis profile
For each call type imported, the analysis profile shows two dependent variables, the 
continuous (resampled) and the state variable. This is a variable with discrete 
values 0 and 1 derived by the resampled variable.

For example, you exported calls of type 52-65 kHz (call name) labeled with 
“Chevron” (label name). To analyze those calls you have two options:

Click the button next the variable you want to analyze, and choose the type of 
upsampling/downsampling you require.

Integrated visualization
To visualize the original UltraVox call data, choose Show/Hide > Dependent 
Variables and select the [call name*pattern label] (original signal). 
142



When plotted against time, the data look like this:

Where 1 on the y-axis represent the onset of the call. The transition 1-0 represents 
the call end.

When visualized, the resampled variable look like this (second and third plot):
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Installation

Main topics and tasks
▪ Install UltraVox XT  146
▪ Install the USB 3.0 interface card  149
▪ License activation  155
▪ End-user license agreement  160
▪ Acknowledgments and copyright notices  161
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Install UltraVox XT
What do you want to do?

▪ Check the System requirements  146
▪ Install UltraVox XT  151
▪ Start UltraVox XT for the first time  153

See also

▪ License activation
▪ Installation
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System requirements
If you order a complete solution from Noldus Information Technology, you will 
obtain one of the computers listed below or their successors, with UltraVox XT 
installed and ready to use.

Operating system

▪ Shorter tests (no recording, only import of audio files) have been 
performed on Windows 10 Pro, 22H2, with no issues.

Computer

Dell Precision 3680 desktop

▪ Processor: Intel Core i7-14700, 20 CPU cores, 3.4 GHz.
▪ Internal memory: 32 GB DDR5.
▪ Hard disks: M.2 1TB PCIe NVMe SSD.
▪ Graphics card: NVIDIA T1000, 4 GB GDDR6.
▪ Operating system: Windows 11 Pro.

Dell 3591 mobile

▪ Processor: Intel Core Ultra 7 155H vPro Essentials, 16 cores, up to 4.8 GHz
▪ Internal memory: 16 GB DDR5.
▪ Hard-disks: M.2 2280 1 TB PCIe NVMe SSD.
▪ Graphics card: NVIDIA RTX 1000, 6 GB GDDR6.
▪ Operating system: Windows 11 Pro.

USB ports
With Noldus microphones, we recommend to use USB 3.0 ports.

▪ For USB 3.0: the PC must have as many ports as microphones.
▪ For USB 2.0: the PC must have as many controllers as microphones. To 

check how many USB2 controllers are present on your computer, in the 

▪ UltraVox XT 4 supports Windows 11 Pro and was tested on Windows 11 
Pro, version 23H2 and 24H2. 
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Control Panel choose System and Security > Device Manager. Under 
Universal Serial Bus Controllers check the items named “USB2”.

▪ When using 384 kHz microphones, each microphone must be connected to 
one USB controller. If you connect multiple microphones to USB ports 
which shares the same USB controller, Windows recognizes the devices but 
signals won’t be recorded. Therefore, when using multiple microphones of 
this type, we recommend to use a multi-port USB 3.0 interface card (see 
Install the USB 3.0 interface card). Alternatively, use a powered USB 3 hub, 
or add a USB 3.0 card to the PC for each microphone.
NOTE  A powered, or active, USB hub is powered through a wall outlet to 
bring each hub port to the same energy level as an on-system port.

TIP  USB 3.0 connectors and ports can be recognized by their symbols, and 
often also by their blue color coding.

USB 3.0 PCIe interface card

UltraVox XT has been tested with the Fresco Logic U3X4-PCIE4XE111 rev 1.1 PCIe 
interface card to connect multiple USB 3.0 microphones. See Install the USB 3.0 
interface card

Disk space

A 10-minute recording with one microphone requires:

▪ For 384-kHz microphones, approx. 400 MB.
▪ For 250-kHz microphones, approx. 300 MB.

The maximum file size, for all microphones, is about 4 GB per microphone. The 
maximum recording duration depends on the type of microphone.
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USB 3 hub

UltraVox XT has been tested with the following USB 3 hub:

▪ D-link 4-port DUB-1340, with bit rate 5 Gbps.
In all cases we recommend to use a USB hub compatible with USB 3.0.

Microphones
▪ For ultrasonic measurements, you must use the microphones that come 

with UltraVox XT.
▪ Maximum number of microphones: 4. However, when using 384-kHz 

microphones and a laptop computer (Dell 7510), we recommend to use up 
to three microphones.
NOTE  The maximum number of microphones also depends on your 
UltraVox XT license. See Request a license

▪ Standard microphones (for human audible vocalizations) have not been 
extensively tested with UltraVox XT. When using these microphones, the 
maximum sampling frequency is set to the standard 44100 Hz for human 
audible vocalizations. UltraVox XT will not record ultrasonic frequencies. 
NOTE  A third party microphone can only be used when it fully supports a 
44100 Hz sample rate.

▪ The maximum recording duration depends on the microphones being used. 
See Recording sound

Sound files
You can import sound stored in WAV files (*.wav), recorded in Windows PCM 
format, mono, with 16-bit depth. See Import sound files

TIP  If your audio files are stereo or with 32-bit depth, resample them in software 
like Audacity and export them as WAV files.

See also

▪ UltraVox XT microphones
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Install the USB 3.0 interface card
Aim
To install an interface card that receives data from up to four USB 3.0 microphones.

NOTE  If you ordered a computer from Noldus Information Technology when you 
purchased UltraVox XT and ultrasonic microphones, this card has already been 
installed and tested. If you bought your computer somewhere else, you will have to 
install the card yourself. Follow the instructions below.

IMPORTANT  UltraVox XT was tested with the following USB 3.0 interface card: Fresco 
Logic U3X4-PCIE4XE111 rev 1.1.

Procedure
1. Turn off your computer and all connected peripherals, such as the monitor 

and printer. Make sure that the computer is unplugged.
2. Remove the PC's case according to the instructions provided in the PC's 

user manual.
3. Select a free PCIe expansion slot, and remove the corresponding extension 

cover.
4. Unpack the USB 3.0 interface card, place it into the slot, and press it 

carefully into position. If the card does not fit into place easily, remove it 
and repeat the operation.

5. Connect the power connector on the board to one of the power supplies 
inside the PC. For this purpose, either use the Molex/IDE male 4-pin DC 
connector or the SATA male 15-pin connector that you find on the board.
Connector types vary between computers. Dell computers have a SATA 15-
pin power connector. Use an adapter cable with a 4-pin female Molex/IDE 
DC power connector or a SATA 15-pin power connector at one end, 
depending on the connector on the card you use (A), and a SATA 15-pin 
connector at the other end (B).
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6. Fix the card to the chassis and re-fit the computer's cover.
7. Connect each microphone to a USB port.

IMPORTANT  Make sure that you always connect a microphone to the same 
USB 3.0 port. Label microphones and USB ports if necessary.

See also

▪ Connect the microphones
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Install UltraVox XT
NOTE  UltraVox XT 4 only works with a software license, not with a hardware key as it 
was the case for UltraVox XT 3.x.

Procedure

Download UltraVox XT from my.noldus.com

1. Browse to https://my.noldus.com.
2. Log in or register using the registration code on your welcome letter. 
3. Click Downloads, then UltraVox XT. Under Versions, download the 

UltraVox XT 4 - Installation Package [version number].zip file.
Unzip the file and save the content to your PC. 

Install UltraVox XT

1. Double-click the setup file with extension exe. 
2. Under Installation type, select Standard.

UltraVox XT will be installed on C:\Program Files\Noldus\UltraVox XT 4. If 
you want to install UltraVox XT on another location, select Custom and 
specify there the new installation location. Note, however, that some links in 
the Help may not work if the software is installed in a folder other than the 
default one. 

3. Select I agree with the End-User License Agreement and click Install.
4. Click Close to complete installation.

Note
▪ Your license of UltraVox XT determines which setup is available to you. See 

License activation
▪ If you need to install a USB 3.0 interface card on the UltraVox XT computer, 

see Install the USB 3.0 interface card
▪ The experiments will be stored by default on 

C:\Users\Public\Documents\Noldus\UltraVox XT\Experiments.
If you wish to store the experiment in another folder or drive, specify the 
new location in UltraVox XT (File > Settings > General > Experiments 
location). 
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▪ To uninstall UltraVox XT, in the Windows Start menu choose Settings > 
Apps > Installed Apps, then select UltraVox XT and choose Uninstall 
from its menu.

See also

▪ System requirements
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Start UltraVox XT for the first time
Prerequisites
You need to have a license activation code to be able to run the full version of 
UltraVox XT.

Procedure
1. In the Apps screen, under Noldus, click the UltraVox XT icon.

2. Click Import License File. Select the UltraVox XT 4 license file (*.json) that 
you received from Noldus.

3. After that, the UltraVox XT start screen opens.

Next actions
▪ Create a new experiment
▪ Open an existing experiment (choose File > Open).
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Note
▪ The Select window only lists the experiments currently stored in the 

experiments location. You cannot open another location.
▪ Click Evaluate UltraVox XT to open the free evaluation version. With a free 

evaluation version, you can only open the sample experiment that is stored 
on C:\Users\Public\Documents\Noldus\UltraVox XT\Experiments. 

▪ Click Request a License to obtain a quotation for a UltraVox XT license.
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License activation
What do you want to do?

▪ Activate your license

Learn about
▪ Licensing options

See also

▪ End-user license agreement
▪ Acknowledgments and copyright notices
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Activate your license
Aim
To activate the license for a newer version of UltraVox XT.

If you have a previous version of UltraVox, the hardware key (also known as the 
dongle) associated with that version does not work with UltraVox XT 4. Please 
contact Noldus to purchase an upgrade to UltraVox XT 4.

Prerequisites
▪ You have downloaded and installed UltraVox XT from

my.noldus.com.

NOTE  You do not need to uninstall previous UltraVox XT versions.

Procedure

Request a license

If you already have a license file, go to the next section.

IMPORTANT  Request the license from the computer you intend to use with UltraVox 
XT. This is because the UltraVox XT license contains information about the machine 
that UltraVox XT is installed on.

If your computer is not connected to the internet or you can only request a license 
on a different computer, in step 3 take note of the AppID an send it to Noldus.

1. Make sure your computer is connected with the internet.
2. Start UltraVox XT.
3. Click the Request a License button.
4. Fill in the necessary data:

▪ Company/Organization.
▪ Name and email address of the main user.
▪ The Number of microphones you would like to use simultaneously.

5. Click Send Request. The request is sent to Noldus. After you have 
purchased the license, you receive a license file.

6. Activate your license (see below).
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Activate your license

1. Start UltraVox XT.
2. Click Import License File or choose Help > Import License File. 
3. Select the UltraVox XT 4 license file (*.json) that you received from Noldus.
4. Click Open.
5. A message informs you that the license has been successfully activated.

Activate an additional module

If you have UltraVox XT 4 and purchased an upgrade in order to use more 
microphones simultaneously, do the following:

1. Start UltraVox XT.
2. Do one of the following:

▪ Choose Help > Request License if you do not have yet a license file for 
that module. After you have received a license file, activate the license 
(see Activate your license).

▪ Choose Help > Import License File if you already have a license file 
for that module that you received from Noldus. Select that file and click 
Open.
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Licensing options

(1) Unregistered Trial Licenses only work with one specific audio file included in the 
installation package.

(2) Registration requires user name, organization and e-mail address.

(3) One Full License supports up to four microphones.

(4) Classroom licenses are free of charge for owners of a Full License with active 
NoldusCare. They are recommended for teaching courses, with max. 50 seats, for 30 
days. They come with a teaching package (installation instructions, background, 
manual, sample audio files, report template). They work with the bundled sample 
files only.

(5) Perpetual licenses are valid for the version purchased and remain in effect for an 
indefinite time. If you sign up for NoldusCare you can get major upgrades. You can 

Unregistered 
Trial License

Registered 
Trial License

Full License Classroom 
License

Registration needed No Yes(2) Yes No

Price Free(1) Free Paid Free(4)

Record audio No Yes Yes(3) No

License duration Perpetual 14 days Perpetual or 
Subscription(5)

30 days

Create new 
experiments

No Yes Yes Yes

Open existing 
experiments

Only sample 
experiment

Yes Yes Yes

Sample experiment Yes Yes Yes Yes

Import files Only sample files Yes Yes Only sample file

Call detection Yes Yes Yes Yes

Export results Yes Yes Yes Yes

Export calls to 
EthoVision XT

No Yes Yes Yes

Export calls to The 
Observer XT

No Yes Yes Yes
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also purchase upgrades separately without NoldusCare. With a Subscription license 
you can always download the latest version of UltraVox XT and stay up-to-date.

See also

▪ License activation
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End-user license agreement
Procedure
To open a PDF copy of the End-User License Agreement, do one of the following:

▪ Browse to the following file:
C:\Program Files\Noldus\UltraVox XT 4\Documentation\Legal\End-User 
License Agreement.pdf

▪ In UltraVox XT, choose Help > About UltraVox XT > License Info > End-
User License Agreement.

Notes
▪ If you installed UltraVox XT on a folder other than the default one, then 

browse to that folder, and open 
...\UltraVox XT 4\Documentation\Legal.

See also

▪ Acknowledgments and copyright notices
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Acknowledgments and copyright notices
UltraVox™ is a trademark of Noldus Information Technology BV. UltraVox XT would 
not be what it is without the use of third-party software. This page lists software 
libraries and other software products used in UltraVox XT and where you can find 
license and compliance information and/or acknowledgments for that product.

The PDF of the copyright notices are stored in

C:\Program Files\Noldus\UltraVox XT 4\Documentation\Legal\Acknowledgments.

Asio
Cross-platform C++ library for network and low-level I/O programming. Version 
1.32.0. Copyright © 2003-2024 Christopher M. Kohlhoff. Distributed under the 
Boost Software License, Version 1.0.

https://github.com/chriskohlhoff/asio/tree/master

https://github.com/chriskohlhoff/asio/blob/master/asio/LICENSE_1_0.txt

bb-audio

https://brain.builders/

bb-license

https://brain.builders/

ed25519
Public-key signature system used for verifying audio files and licenses. 

Copyright © 2015 Orson Peters. Distributed under the zlib license.

https://github.com/orlp/ed25519

https://github.com/orlp/ed25519/blob/master/license.txt

Library for recording, handling and analyzing audio files. Version 1.6.1. Copyright © 
2025 Brain Builders BV.

Library for handling license restrictions. Version 2.2.0. Copyright © 2025 Brain 
Builders BV.
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{fmt}
Open-source string formatting library for logging. Version 11.0.2.

Copyright © 2012 - present, Victor Zverovich and {fmt} contributors.

https://github.com/fmtlib/fmt

https://github.com/fmtlib/fmt/blob/master/LICENSE

GCC
Integrated distribution of compilers for several major programming languages.

https://www.fsf.org

https://www.gnu.org/licenses

muFFT
Library for performing the Fast Fourier Transform (FFT) in one or two dimensions.

Copyright © 2015 Hans-Kristian Arntzen.

https://github.com/Themaister/muFFT

https://github.com/Themaister/muFFT/blob/master/COPYING

nlohmann json
Class of JSON libraries used for reading license files. Version 3.11.3.

Copyright © 2013-2024 Niels Lohmann.

https://github.com/nlohmann/json

https://github.com/nlohmann/json/blob/develop/LICENSE.MIT

OpenSSL
Toolkit for general-purpose cryptography and secure communication. Version 3.4.0. 
OpenSSL is licensed under the Apache License 2.0. 

Copyright © 2025 OpenSSL.

https://openssl-library.org/

Copyright © 2023 The Free Software Foundation, Inc. This program is distributed 
under the GNU General Public License. Version 13.1.0. 
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https://github.com/openssl/openssl/blob/master/LICENSE.txt

PortAudio

https://github.com/PortAudio

https://portaudio.com/license.html

Qt
Qt is a cross-platform application development framework for creating graphical 
user interfaces. Version 6.7.3. Qt used in UltraVox XT development is licensed under 
a commercial license.

https://doc.qt.io/qt-6/licensing.html 

Simpleini
Simpleini is a cross-platform library that provides a simple API to read and write ini-
style configuration files. Version 4.20. Simpleini is licensed under the MIT License.

Copyright © 2006-2024 Brodie Thiesfield.

https://github.com/brofield/simpleini

https://github.com/brofield/simpleini/blob/master/LICENCE.txt

Spdlog
Spdlog is a C++ logging library. Version 1.15.0. Spdlog is licensed under the MIT 
License.

Copyright © 2016 Gabi Melman.  

https://github.com/gabime/spdlog

https://github.com/gabime/spdlog/blob/v1.x/LICENSE

Ultravox Library

https://brain.builders/

Software development kit for all UltraVox XT functionality. Version 1.1.1. Copyright 
© 2025 Brain Builders BV.

PortAudio is a cross-platform, open-source C language library for real-time audio 
input and output. Version 19.7.0. PortAudio is licensed under MIT license.
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Control UltraVox XT from 
other software

Aim
To start and stop recording in UltraVox XT from EthoVision XT or The Observer XT.

Example: You plan to video-track animals with EthoVision XT or record their 
behavior with The Observer XT and, at the same time, record ultrasound with 
UltraVox XT. For ease of use you want to start and stop recording with one click, in 
such a way the UltraVox data and the EthoVision XT/The Observer XT data are 
synchronized.

How it works
1. When proper communication is set between the two applications, you can 

start and stop recording in UltraVox XT by clicking the Start trial/Stop trial 
button in EthoVision XT.

2. You can then import call data into EthoVision XT for combined analysis of 
tracks and vocalizations. See Import call data in The Observer XT and 
Import call data in EthoVision XT.
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Main topics and tasks
 Computer setup  166
 Trigger settings for EthoVision XT  177
 Trigger settings for The Observer XT  179
 Co-acquisition of data  181
 Import profiles  182

See also

 Start and stop recording at specific times
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Computer setup
Computers
We advise to run UltraVox XT and EthoVision XT/The Observer XT on separate 
computers. On both computers, disable the firewall.

IMPORTANT  Running EthoVision XT/The Observer XT and UltraVox XT on the same 
computer is not recommended. The large data transfer may cause malfunctioning 
in either application. Test this solution thoroughly if you want to use it. For example, 
check that EthoVision XT does not miss samples, or that data streams from the two 
applications are in sync.

Network
The two computers should be connected to a dedicated network using a network 
switch. To avoid the risk of network communication delays, we recommend not to 
connect the computers to a larger network.

UltraVox XT computer (right) connected to an EthoVision XT or The Observer XT 
computer (left) through a network switch.

A typical EthoVision XT setup for one camera and one microphone would look like 
this:
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Procedure
 Specify the IP address of the UltraVox XT PC
 Share the UltraVox XT synchronization folder
 Make a virtual drive for the EthoVision XT / The Observer XT
 Copy the UltraVox XT Control folder to the EthoVision XT/The Observer XT 

PC
 Edit the StartUV/StopUV batch files
 Make UltraVox XT data import easier
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Specify the IP address of the UltraVox XT 
PC
Procedure
On the UltraVox XT computer, do the following:

1. In the Control Panel, choose Network and Internet > Network and 
Sharing Center.

2. Choose Change adapter settings.
3. Right-click the local network and choose Properties.
4. Select Internet Protocol Version 4 and click the Properties button.
5. Select Use the following IP address.
6. Enter the IP address that is in the batch file (suggested: 192.168.0.202; this 

address must also be specified in the batch file). 
Leave the Subnet mask and Default gateway unchanged.

Note
 We recommend to use one PC for EthoVision XT and one PC for UltraVox 

XT. Connect the two computers through a network switch and assign the IP 
addresses to enable communication. For example:
For example: 

Network switch: 192.168.0.239 (Netgear GS310TP)

EthoVision XT PC: 192.168.0.201

UltraVox XT PC: 192.168.0.202

 You can assign an IP address other than specified here. However, you must 
enter the same address in the batch file. This address must be different 
from that of the EthoVision XT/The Observer XT computer. See Edit the 
StartUV/StopUV batch files

Next

 Share the UltraVox XT synchronization folder
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Share the UltraVox XT synchronization 
folder
Procedure

1. With Windows Explorer, browse to C:\ProgramData\Noldus\UltraVox\XT 4\ 
Synch.

2. If you do not see this folder, it may be hidden. See the note below.
3. Right-click and select Properties, then click the Sharing tab.
4. Click Share and select Everyone. In the context menu choose Read/Write.
5. Click Share, then Done.

The Synch folder can now be “seen” by the EthoVision XT/The Observer XT 
computer.

Next: Make a virtual drive for the EthoVision XT / The Observer XT

Note
To view hidden folders:

1. In the Windows Control Panel, choose Appearance and Personalization, 
then under Folder Options click Show Hidden Files and Folders.

2. In the window that appears, under Hidden files and folders, select Show 
hidden files, folders and drives.
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Make a virtual drive for the EthoVision XT 
/ The Observer XT
Aim
To make data transfer from UltraVox XT and EthoVision XT easier. Once the 
procedure is completed, you can easily access the UltraVox XT data and import 
them in EthoVision XT/The Observer XT.

Procedure
1. On the EthoVision XT PC, with Windows Explorer, right-click This 

Computer and choose Map network drive.
2. Choose a drive letter.
3. Select the shared Synch folder from the UltraVox XT PC.
4. Click Finish.

Next: Copy the UltraVox XT Control folder to the EthoVision XT/The Observer XT PC
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Copy the UltraVox XT Control folder to 
the EthoVision XT/The Observer XT PC
Aim
To provide EthoVision XT or The Observer XT with the files necessary to 
communicate with UltraVox XT.

NOTE  The UltraVox XT Control folder is installed automatically with EthoVision XT. 
Therefore, if you have EthoVision XT you do not have to follow the procedure 
below. Skip this topic and go to Edit the StartUV/StopUV batch files

Procedure
1. Open the UltraVox XT 4 installation package and browse to Extras. 
2. Select the folder UltraVox XT 4 Control, and press Ctrl+C.
3. Open the following folder:

C:\Program Data\Noldus\Common\Tools

If the Tools folder is not present, create it.

4. Open the Tools folder and press Ctrl+V.
5. Open the folder just copied, and check that the two files SUV.bat and 

start.txt are present.
Next: Edit the StartUV/StopUV batch files
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Edit the StartUV/StopUV batch files
Aim
To make sure that the batch file triggers UltraVox XT when activated by Noldus 
software.

Background information
Once activated by Noldus software, a batch file StartUV*.bat or StopUV*.bat does 
the following:

1. It connects with the UltraVox XT computer, and deletes any file named 
start.txt from the folder C:\Program Data\Noldus\UltraVox\XT 4\Synch (if 
present). 

2. It copies the file start.txt (or stop.txt) to the folder C:\Program 
Data\Noldus\UltraVox\XT 4\Synch on the UltraVox XT computer. 

The files start.txt and stop.txt are empty text files. Their function is to trigger 
UltraVox XT, provided that this is set to “external program trigger” in the Trial 
Control Settings. See Trigger start/stop recording 

Procedure
1. Browse to C:\ProgramData\Noldus\Common\Tools\UltraVox XT 4 Control.

If this folder does not exist, see Copy the UltraVox XT Control folder to the 
EthoVision XT/The Observer XT PC.

2. Locate one of the *.bat batch files:
For EthoVision XT with one arena, or The Observer XT: choose StartUV - 2 
PCs or StopUV - 2 PCs.bat depending on which you want to use.

For EthoVision XT with two or more arenas, choose StartUV - 2 PCs 
multiple arenas.bat or StopUV - 2 PCs multiple arenas.bat

3. Right-click the batch file and select Edit with Notepad.
4. Insert the IP address that you assigned in step Specify the IP address of the 

UltraVox XT PC. See the instructions below depending on what file you are 
editing.

5. In all cases, make sure that the path of the file start.txt / stop.txt is
C:\ProgramData\Noldus\Common\Tools\UltraVox XT 4 Control.

6. Save and close the file.
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StartUV - 2 PCs.bat
Use this file in the external command for starting recording in UltraVox XT.

@if exist "\\IP address of UltraVox XT PC\Synch\start.txt" 
del "\\IP address of UltraVox XT PC\Synch\start.txt"

@copy "C:\ProgramData\Noldus\Common\Tools\UltraVox XT 4 
Control\start.txt" "\\IP address of UltraVox XT PC\Synch" > 
nul

Replace “IP address...” with the actual IP address of the UltraVox XT PC. Alternatively, 
enter the name of the PC that you find in Windows (e.g. DESKTOP-123ABC) instead 
of the IP address.

The batch file copies the file start.txt to the trigger folder of UltraVox XT. This starts 
recording in UltraVox XT.

StopUV - 2 PCs.bat
Use this file in the external command for stopping recording in UltraVox XT.

@if exist "\\IP address of UltraVox XT PC\Synch\stop.txt" del 
"\\IP address of UltraVox XT PC\Synch\stop.txt"

@copy "C:\ProgramData\Noldus\Common\Tools\UltraVox XT 4 
Control\stop.txt" "\\IP address of UltraVox XT PC\Synch" > 
nul

Replace “IP address...” with the actual IP address of the UltraVox XT PC. Alternatively, 
enter the name of the PC that you find in Windows (e.g. DESKTOP-123ABC) instead 
of the IP address.

The batch file copies the file stop.txt to the trigger folder of UltraVox XT. This stops 
recording in UltraVox XT.

StartUV - 2 PCs multiple arenas.bat
If you work with multiple arenas, use the batch file StartUV - 2 PC multiple 
arenas.bat to start recording in UltraVox XT. This way the file start.txt is sent out 
just one time, for Arena 1. If the arena has a different name, open the file with the 
Notepad and edit the name between the quotes.

@if exist "\\IP address of UltraVox XT PC\Synch\start.txt" 
del "\\IP address of UltraVox XT PC\Synch\start.txt"

@echo off
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echo %1

IF %1=="Arena 1" (

@copy "C:\ProgramData\Noldus\Common\Tools\UltraVox XT 4 
Control\start.txt" "\\IP address of UltraVox XT PC\Synch" > 
nul

)

Replace “IP address...” with the actual IP address of the UltraVox XT PC. Alternatively, 
enter the name of the PC that you find in Windows (e.g. DESKTOP-123ABC) instead 
of the IP address.

StopUV - 2 PCs multiple arenas.bat
If you work with multiple arenas, use the batch file StopUV - 2 PC multiple 
arenas.bat to stop recording in UltraVox XT. This way the file stop.txt is sent out just 
one time, for Arena 1. If the arena has a different name, open the file with the 
Notepad and edit the name between the quotes.

@if exist "\\IP address of UltraVox XT PC\Synch\stop.txt" del 
"\\IP address of UltraVox XT PC\Synch\stop.txt"

@echo off

echo %1

IF %1=="Arena 1" (

@copy "C:\ProgramData\Noldus\Common\Tools\UltraVox XT 4 
Control\stop.txt" "\\IP address of UltraVox XT PC\Synch" > 
nul

)

Replace “IP address...” with the actual IP address of the UltraVox XT PC. Alternatively, 
enter the name of the PC that you find in Windows (e.g. DESKTOP-123ABC) instead 
of the IP address.

Command line options
An important point when working with multiple arenas: in the Action boxes in the 
Trial Control Settings of EthoVision XT, specify the Command line options: “%an%”, 
quotes included. For more information, see the EthoVision XT 18 - Trial and 
Hardware Control - Reference Manual.
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Working with one PC
It is also possible to run EthoVision XT and UltraVox XT on the same PC. In this case 
use the batch files StartUV - 1 PC.bat and StopUV - 1 PC.bat. However, this 
solution is not supported as it may cause high workload on the memory and the 
processor, depending on your setup, the number of arenas and the method use for 
tracking. For example, Deep learning-based tracking is more demanding than 
Contour-based tracking. If you need install both applications on one PC, test your 
setup thoroughly and make sure that the proportion of missing samples in your 
tracks is acceptable.

Next: Make UltraVox XT data import easier
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Make UltraVox XT data import easier
Aim
When importing the call statistics files from UltraVox XT to EthoVision XT/The 
Observer XT, a shared folder may be handy that allows to import the files directly 
through the network.

Procedure
1. On the UltraVox XT computer, make a general folder where you are going 

to place all export (*.etx) files.
2. Share this folder (see a similar procedure in Share the UltraVox XT 

synchronization folder).
3. On the EthoVision XT/The Observer XT computer, create a virtual drive for 

this shared folder (see a similar procedure in Make a virtual drive for the 
EthoVision XT / The Observer XT).

Next: Follow the procedure that applies.

 Trigger settings for EthoVision XT
 Trigger settings for The Observer XT

See also

 Import call data in EthoVision XT
 Import call data in The Observer XT
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Trigger settings for EthoVision XT
In EthoVision XT

1. Choose Setup > Trial Control Setting > New.
2. Make a Trial Control Settings rule like in the following picture.

1 External command that runs one of the batch files StartUV*.bat. This copies the 
start.txt file to the trigger folder of UltraVox XT.

2 Time condition for waiting a fixed time (for example, 10 minutes). This determines 
the length of the EthoVision XT tracks and UltraVox XT recordings.

3 External command that runs one of the batch files StopUV*.bat. This copies the 
file stop.txt to the trigger folder of UltraVox XT.

See also Edit the StartUV/StopUV batch files

External command box (1 and 3):

1. In the Components pane, under Actions, choose External command. 
2. In the External Command Action window that appears, under Action to 

perform, click the button .

3. In the Open window, choose to view Batch Files (*.bat, *.cmd).

4. Select the file with extension .bat that you require.
5. IMPORTANT  When you work with multiple arenas, enter “%an%” under 

Command line options in both External command boxes. See Command 
line options
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6. OPTIONAL  Under Name, give a name to this action box (e.g. Start UltraVox 
recording for (1), Stop UltraVox recording for (3).

Time condition box (2)

1. Click the Settings button.
2. Enter the time required, i.e., the duration of the recording.

See also

 Trial Control in the EthoVision XT Help.

In UltraVox XT
1. Choose Setup > Trial Control Settings.
2. Under Start acquisition and Stop acquisition, select External program 

trigger.

See also

 Trigger start/stop recording
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Trigger settings for The Observer XT
Prerequisites 
In The Observer X, you have created a new project (File > New). Next, choose 
Setup > Project Setup.

In The Observer XT

1. Under Observation Source select Live.
2. In the Devices window that appears, click Add external program.
3. In the Add External Program window, under Name, enter a title (for 

example Control UltraVox XT).

4. Select Start Observation. Next, click and select the batch file StartUV 
- 2 PCs.bat.

5. Select Stop Observation. Next, click and select the batch file StopUV 
- 2 PCs.bat.
For how to edit the batch files, see Edit the StartUV/StopUV batch files.

6. Click OK.
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In UltraVox XT
1. Choose Setup > Trial Control Settings.
2. Under Start acquisition and Stop acquisition, select External program 

trigger.

See also

 Trigger start/stop recording
 Edit the StartUV/StopUV batch files
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Co-acquisition of data
Aim
To acquire UltraVox XT data together with EthoVision XT or The Observer XT data.

Procedure
Follow the instructions that apply to your software (EthoVision XT or The Observer 
XT).

1. In UltraVox XT, open the acquisition screen. 
In EthoVision XT, open the acquisition screen. In The Observer XT, create a 
new observation.

2. In EthoVision XT, start the trial and release the animal in the arena.
In The Observer XT, start the observation.

3. On the EthoVision XT/The Observer XT computer, the software activates the 
batch file. The file start.txt is sent to the Sync folder on the UltraVox XT 
computer. When this occurs, UltraVox XT detects the file and starts 
recording.

4. In EthoVision XT, after a fixed time, the trial stops automatically depending 
on the Time condition specified in the Trial Control rule (Trigger settings for 
EthoVision XT). In The Observer XT, stop the observation. 
In both cases, this stops recording in UltraVox XT.

5. In UltraVox XT, detect and label the calls.
6. In UltraVox XT, export the call data to EthoVision XT or The Observer XT. 

See Export call statistics
7. In EthoVision XT or The Observer XT, import the call data. 

See also

 Export call statistics
 Import call data in The Observer XT
 Import call data in EthoVision XT
 Import profiles
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Import profiles
EthoVision XT
To import UltraVox XT data into EthoVision XT, you must have the import profile 
UltraVox 3/4. 

The import profile is installed on C:\ProgramData\Noldus\Common\Profiles.

NOTE  If you do not see the C:\ProgramData folder, it may be hidden. To view hidden 
folders:

1. In the Windows Control Panel, choose Appearance and Personalization, 
then under Folder Options click Show Hidden Files and Folders.

2. In the window that appears, under Hidden files and folders, select Show 
hidden files, folders and drives.

For information on how to import UltraVox XT data, see the EthoVision XT Help.

The Observer XT
To import UltraVox XT data into The Observer XT, you do not need an import 
profile. Just export the call statistics in UltraVox XT in The Observer XT format 
(*.odx), and import the export file into The Observer XT.
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Troubleshooting

Microphones
 The microphones are not recognized after restarting the computer
 Error message “Device not found”
 The Microphone name has changed

Detecting calls
 I created a call definition, but UltraVox XT detects few or no calls
 I see no vocalizations in the spectrogram
 Reduced Min Amplitude in a call definition results in fewer calls detected
 Add a call that was not detected automatically
 A call is not detected even if its amplitude is above the threshold
 There is constant noise at a specific frequency
 Call detection is very slow

Call Statistics
 Call duration is not exactly the difference between Stop time and Start time

Other
 How do I make the recording screen darker?
 How do I copy recordings and experiments?
 How do I report spectrogram parameters?
 How do I analyze audible sound?
 How do I remove the microphones from my experiment?
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 The spectrogram is not aligned with the waveforms
 Error message “Unsupported WAV format”

Contact Technical Support
 Technical support
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The microphones are not recognized 
after restarting the computer
Problem
The computer went to sleep. After restarting, UltraVox XT does not recognize the 
microphones.

Solution
1. Disconnect and reconnect the USB cable of the hub to the same USB port 

of the UltraVox XT computer.
2. In UltraVox XT, open the Experiment Settings, and click the Refresh button.
3. If you see a cross symbol next to a microphone, click the button in the 

Microphone column and make sure to reselect the same microphone. The 
microphones will keep the same microphone name as before.

Back to Troubleshooting
185



Error message “Device not found”
Problem

After clicking the Settings button  for a microphone in the Experiment 
Settings, the following message appears:

Solution
1. Plug the microphone into the correct USB port of the PC.
2. In the Experiment Settings, click the Refresh button.

If the microphone was plugged in the correct port, the green symbol 
should appear under Status. 

Select the check box under Selected.

If the microphone is not recognized, it may be that it was plugged into a USB port 
different from that of the previous time. Follow the procedure in The Microphone 
name has changed

Back to Troubleshooting
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The Microphone name has changed
Problem
In the Experiment Settings, the name under Microphone has a number in front. For 
example, Pettersson M500-384-1 changed to 2-Pettersson M500-384-1.

Explanation/Solution
This happens when you plug the microphone into a USB port different from that 
used when you plugged the microphone for the first time. Close UltraVox XT and 
for the microphones with a name beginning with “2-“, swap the USB-A connectors 
that go to the USB card/hub. When re-opening the software, all the microphone 
names should be as before (without the “2-” in front). 

Even if the name under Microphone in the Experiment Settings changes, you can 
use that microphone. The name does not affect data recording. However, make sure 
that you know which microphone is associated with which cage. For example, label 
the microphones and the USB ports on your computer.

In all cases: 

1. Plug the microphone into the correct USB port, then click Refresh. 
2. Click the select button under Microphone.

3. Choose the microphone from the list, then click the Settings button to 
check the signal is received.
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I created a call definition, but UltraVox XT 
detects few or no calls
Problem
After creating a call definition and clicking Detect calls in this recording, UltraVox 
XT does not detect the calls that look like the one selected to create the call 
definition.

Solution
In the Call Detection screen, select the call definition and click Edit.

Try the following:

 Reduce the frequency range (Freq Low - Freq High). 
See Keep the frequency range as narrow as possible

 Increase Min Amplitude. Hover the mouse over the calls and take note of 
the amplitude values you see. Min Amplitude should stay below those 
values.
If calls that are not detected show weaker signal (lower amplitude), reduce 
Min Amplitude by steps of for example 30 or 50, and see if this improves 
detection.

See Increase the Min Amplitude parameter and Get a feel of the amplitude 
in a call

 Reduce the Min Duration value.
TIP  Draw a rectangle around a few calls, then in the resulting call definitions 
look at the Min Duration parameter and take note of the average value. 
When you define the true call definition, click Edit and enter half of the 
average value as a Min Duration. Do not forget to delete the call 
definitions made before.

See Reduce Min Duration

 Increase the Max Duration value.
See Increase Max Duration

 Reduce Min Gap.
Sometimes two calls are detected as one when Min Gap is too high.
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When calls have different frequency ranges, define two call definitions instead of 
one.

See also

 Call definitions
 Back to Troubleshooting
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I see no vocalizations in the spectrogram
One simple explanation is that the subject did not make vocalizations. However, it 
may be that the recording is so noisy that the calls do not emerge in the 
spectrogram.

The colors displayed in the spectrogram for one event also depend on the 
amplitude of the signal in the surrounding interval. The same call may appear or not 
(or appear less evident) if another, unwanted signal like strong noise (for example, a 
door being closed) or constant noise from electrical appliances occurs in the 
interval displayed. 

To find out whether there is constant noise in the signal
1. Under View, select Spectrum.
2. Look at peaks in the spectrum. If necessary, zoom in the spectrum. See 

Zoom in/out

Examples

With strong noise at 60 Hz, zoom in the left part of the spectrum.

In another example, after filtering at 20000 Hz, two peaks are visible at 32kHz and 
47 kHz.

See also

 The Spectrogram
 Factors affecting ultrasound recording
 Back to Troubleshooting
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Reduced Min Amplitude in a call 
definition results in fewer calls detected
This result may sound counterintuitive. One may expect to detect fewer calls after 
increasing the Min Amplitude parameter, that is, after applying more restrictive 
criteria. In fact, more calls are often detected after increasing Min Amplitude.

The reason is that when Min Amplitude is low, UltraVox XT captures large regions of 
the spectrogram that have amplitude higher than that value. But such large regions 
may not correspond to the other criteria in the call definition. For example, some 
regions may exceed Max Duration, and would not be considered as calls (figure 
below, top). When you increase Min Amplitude, it is more likely that (smaller) 
regions of the spectrogram will be found which correspond to all criteria in the call 
definition (bottom). This explains why when you increase Min Amplitude you begin 
to see more detected calls.

The figure below is an example of what could happen. 

Suppose 50 is used for Min Amplitude. Amplitudes just above 50 are found in 
large regions of the spectrogram, for example that indicated with the dashed 
rectangle. However, the rectangle does not satisfy the other criteria set in the call 
definition. For example, the rectangle could be longer than 100 milliseconds, which 
is in conflict with the Max Duration setting. Therefore, the call within that rectangle 
is not found.

After setting a higher value of Min Amplitude and clicking Detect calls in this 
recording, the software finds smaller regions of the spectrogram that are above 
that value. This time two regions are found that match the other settings of the call 
definition. Therefore, two calls are detected. 
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The third, slightly longer call indicated with the dashed rectangle is not yet found 
because it conflicts with the Max Duration setting. It is detected after increasing 
Max Duration to for example 200 ms and clicking Detect calls in this recording.

See also

 The Spectrogram
 Back to Troubleshooting
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Add a call that was not detected 
automatically
Problem
In the Spectrogram, I see vocalizations that were not detected. Further optimization 
of the Call definition did not help.

Solution
You can add a call manually.

1. Open the Call Labeling screen (Analysis > Call Labeling).
2. Draw a rectangle around the spectrogram of the call that was missed.

3. In the detected calls list, a new row appears. Double-click the Call Name 
cell for that row, and change its name from Manual to the one you require.

See also

 Add a call manually
 Back to Troubleshooting
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A call is not detected even if its amplitude 
is above the threshold
Problem
You applied a call definition and detected most calls. However, some calls that look 
very prominent are not detected.

Solution
In the example below, the second call is not detected even its amplitude is 
comparable with that other two. Some noise at the end of the call increases the 
time that the signal is above the Min Amplitude threshold, and this time is above 
the Max Duration threshold. In such cases UltraVox XT does not detect the call 
because the signal appears too long to match the criteria of the call definition.

You can solve this issue in two ways:

 Increase the Min Amplitude threshold, but check that the other calls are 
still detected.

 Increase the Max Duration threshold. If necessary, reduce the call duration 
in the Call Labeling screen. See Adjust frequency and time boundaries in a 
call

See also

 Back to Troubleshooting
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There is constant noise at a specific 
frequency
Problem
The spectrogram shows constant, narrow-band noise. In this example, at about 70 
kHz:

Constant noise could be due to an electronic device near the microphone, or to the 
microphone being defective.

NOTE  Cables and electric/electronic devices produce ultrasound. Voltage changes 
may occur, resulting in a change in noise levels during recording, which is also 
difficult to deal with. Isolate all cables and devices as much as possible.

Solution
1. First, try to know what amplitude is the noise signal. Draw a rectangle 

around the horizontal line, without including any call.
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2. A call definition is defined. Look at the spectrogram that appears at the 
bottom-right corner. Hover the mouse over the horizontal line and get a 
feel of the amplitude of that signal.
Take note of the maximum values you see.

3. Select the call definition and click the Remove button.
4. Draw a rectangle around a call.
5. Select the new call definition and click the Edit button. Set the Min-

Amplitude parameter to a value well above the values of the noise.
6. Click Detect the calls in this recording.
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Call detection is very slow
Problem
After clicking Detect the calls in this recording in the Call Detection screen, 
processing goes very slowly.

Solution
Right-click the spectrogram area and reduce the Overlap, for example to 50 % or 
lower.

See also

 Spectrogram settings
 Overlap
197



Call duration is not exactly the difference 
between Stop time and Start time
Problem
When examining the Call Statistics table, the value of Duration is not the same as 
one would obtain by calculating the difference between Stop time and Start time.

For example:

Solution
The value of Duration is obtained with the difference between Stop time and Start 
time. using six decimals, that is, more than those you see in the table (three for both 
Start time and Stop time). After that, the value is rounded to the milliseconds. This is 
the reason why you see a discrepancy between Duration and the value expected 
from Start time and Stop time in the table. The result is, however, very accurate.
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How do I make the recording screen 
darker?
If you want to reduce the brightness of the computer monitor in order to minimize 
the effect of light on the animals, you can run UltraVox XT in Windows dark mode.

1. Close UltraVox XT.
2. In Windows, click the Start button and choose Settings.
3. On the left panel, choose Personalization, then Themes.
4. Under Themes, choose Windows (dark).
5. Start UltraVox XT. 
6. To further reduce the brightness of the screen, in UltraVox XT, choose File > 

Settings > Spectrogram. Next to Color map, choose Inferno or Inverted 
grayscale.
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How do I copy recordings and 
experiments?
If you want to copy recordings to another PC or you want to send them to Noldus 
Support, copy the whole experiment folder. 

1. Locate the experiment folder. Each experiment is contained in a separate 
folder, named as the experiment itself.

2. Copy this folder and zip it.
3. Copy the zip file to another PC or send it to Noldus Support via a file 

transfer service.
4. On the other PC, unzip the file and copy the folder to the experiments 

folder.
If you want to copy recordings to another experiment, open that experiment and 
select File > Import audio files. The recordings are copied to the experiment’s 
folder, and have extension .UVD.

See also

 Default experiment location in Settings
 Recording files
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How do I report spectrogram 
parameters?
When writing a manuscript you may want to mention the spectrogram settings 
used in your analysis.

To access the current Spectrogram parameters, right-click the spectrogram area.

You can report the following parameters:

 SFT length. This is the length of the analysis window, in samples (e.g. 1024). 
It equals the Frame size, or Frame length, because the signal is not zero-
padded in UltraVox XT 4.

 In UltraVox XT 3, you could apply zero padding. In that case the frame size 
was 100% if zero padding was 1, 50% if zero padding was 2, etc.

 Window type = Hamming (not adjustable).
 Overlap (%). This is the Overlap between two subsequent analysis frames. 
 Hop length. This is not reported by UltraVox XT but may be required by 

reviewers. Hop length is related to overlap by the following formula:
Hop length = SFT length * (100-Overlap)/100

For example, if your SFT is 1024 and Overlap is 0%, each new analysis frame 
starts immediately after the previous one, with no overlap. So the hop 
length is the same as the SFT length, that is 1024. If the Overlap is 50%, the 
new analysis frame will be at halfway of the previous one. The hop length is 
therefore 1024 * 1/2 = 512.

See also

 The Spectrogram
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How do I analyze audible sound?
You can record and analyze audible sound (0-20 kHz) exactly like you would do with 
ultrasound. We recommend to connect a microphone that is appropriate for 
recording high-quality audible sound.
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How do I remove the microphones from 
my experiment?
If you want to reset the Microphones list, do the following:

1. Open the Experiment Settings
2. Under Microphone, click the first microphone name that you want to 

remove. 
3. In the window that appears, click Clear, then OK.
4. Repeat the steps 2-3 for the remaining microphones.

See also

 UltraVox XT microphones
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The spectrogram is not aligned with the 
waveforms

Explanation
This is an artifact of the FFT settings. When selecting a high value of the SFT length, 
frequency resolution increases, while time resolution decreases. This means that 
with high SFT length values the onset time of a vocalization is established with less 
precision.

Solution
1. Right-click the spectrogram area. 
2. Under Fourier transform settings, reduce the SFT length. See 

Spectrogram settings
3. Click Detect calls in this recording to update the position of the rectangle 

around the calls.
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Error message “Unsupported WAV 
format”
Problem
The following message appears after trying to import one or more audio files. For 
example:

Explanation
UltraVox XT accepts audio files of format PCM, encoded at 16 bits and with a Mono 
channel. 

Solution
If the audio file was recorded stereo, or encoded with 24 bit resolution, convert it to 
PCM WAV file format, mono, 16 bit, using an audio-editing application such as 
Audacity, available on the internet. Next, import the converted file in UltraVox XT.
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Technical support
Noldus Online
Choose Help > Noldus Online >

 UltraVox XT Home Page. With general information on UltraVox XT, 
including a list of selected scientific publications.

 MyNoldus Portal. Click this link to access the MyNoldus portal where you 
can contact Support and download software and documents.

 Noldus Academy. Check regularly the Noldus Academy web site for 
training courses and tutorials about UltraVox XT and other Noldus 
products.

 Get Updates and Support. This is a direct link to the Support section of 
MyNoldus.

 Check for Updates. This is a link to the page with the most recent version 
of UltraVox XT.

About UltraVox XT
Choose Help > About UltraVox XT for information on your UltraVox XT version, 
the registered user, the license number and the maximum number of microphones 
allowed. This information is needed when you contact Noldus Support.

FAQ and Knowledgebase
If you encounter a problem using UltraVox XT or any other Noldus system, you can 
search through hundreds of entries in a database of questions submitted by our 
customers to Noldus Support with answers by our support staff.

Choose Help > Noldus Online > FAQ and Knowledgebase, or browse to

 https://my.noldus.com/shared 

and enter the terms you want to find.

MyNoldus.com
If you have any problems, questions, remarks or comments, please let us know. You 
can contact us at our support page:

my.noldus.com

We offer 24 hour support in various time zones. 
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License information
Before you contact my.noldus, please have the following information available. To 
find this information, go to the Help menu and select About UltraVox XT:

▪ The version number of your copy of UltraVox XT.
▪ The name of the registered user of UltraVox XT (click License Info).
▪ If possible, a screenshot of the window that opens when clicking License 

Info.

UltraVox XT Log file
Our Technical Support department may request a log file when answering your 
support question. You can locate the file in:

C:\ProgramData\Noldus\UltraVox\XT 4\log\UltraVox.txt

The log file contains errors and warnings of the most recent run of the software. If 
UltraVox XT crashes, do not re-start it immediately. Instead, locate and copy the log 
file and send it to the Technical Support department. If you restart the software, the 
log file is deleted so you could lose important information.

NOTE  The ProgramData folder may be hidden on your computer. To view hidden 
folders:

1. in the Windows Control Panel, choose Appearance and Personalization, 
then under Folder Options click Show Hidden Files and Folders.

2.  In the window that appears, under Hidden files and folders section, select 
Show hidden files, folders and drives.

Make a PC report for Support
This section is needed if Noldus Support has asked you to send a PC report for the 
UltraVox XT computer. 

1. Download the SIW utility as indicated by Noldus Support and save it to the 
UltraVox XT computer.

2. Double-click on the file called siw64.exe.
3. Choose File > Create Report File > HTML Report.
4. Save the HTML file to your Desktop.
5. Send the HTML file as an e-mail attachment to Noldus Support.
207



NoldusCare
Your license of EthoVision XT comes with a standard service package of one year. 
This includes a one-year period of free technical support. With NoldusCare you 
make sure that you work with the latest version of your software, based on input 
from our worldwide customer base. Updates, upgrades and new releases are 
available for free. As well as update meetings, where you can discuss new features 
with a Noldus consultant.

For more information, see our web page

https://www.noldus.com/nolduscare

Other contact information
Browse to 

https://www.noldus.com/contact
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